#fedora-meeting-1: Server Working Group Weekly Meeting (2014-04-15)

Meeting started by adamw at 15:05:57 UTC (full logs).

Meeting summary

  1. roll call (adamw, 15:06:19)
    1. present: adamw, mizmo, tuanta, mitr, nirik, simo (adamw, 15:09:22)
    2. Agenda Item: Drafting a test plan (adamw, 15:09:56)
    3. Agenda Item: Should we have a default caching DNS server? (adamw, 15:10:15)
    4. Agenda item: Remote journal logging (adamw, 15:13:39)
    5. also present: davidstrauss (adamw, 15:13:44)

  2. Drafting a test plan (adamw, 15:14:05)
    1. adamw has volunteered himself to draft a broad initial test plan for the Server product, an attempt to define the required scope of test coverage to validate a Server release (adamw, 15:17:13)
    2. nirik suggests checking for already-existing upstream test plans (e.g. freeipa, postgresql) (adamw, 15:17:52)
    3. simo suggests simple deployment of domain controller role on server machine and domain join / user creation on a Workstation machine as a basic smoke test for domain controller role (adamw, 15:24:12)

  3. Should we have a default caching DNS server? (adamw, 15:28:57)
    1. davidstrauss and jsmith have found caching DNS very valuable in real-world deployments (adamw, 15:30:01)
    2. there is an effort underway to write a plugin for NetworkManager to integrate with unbound, which appears to be the WG's caching nameserver of choice, but it is on track for F22 not F21 (adamw, 15:38:18)
    3. ACTION: simo to work with virtualization and networking folks to make sure any caching DNS plans consider libvirt's use of dnsmasq (adamw, 15:40:55)
    4. AGREED: We would like the Server product to have DNS caching functionality by default, but we believe this can be done at a project-wide level as of Fedora 22 and do not intend to NIH it for the Server product only Fedora 21 (adamw, 15:44:26)
    5. simo will try to act as liaison to the folks working on NM/unbound integration (adamw, 15:45:54)

  4. Remote journal logging (adamw, 15:46:56)
    1. see devel@ thread "F21 Self Contained Change: Remote Journal Logging", https://lists.fedoraproject.org/pipermail/devel/2014-April/197980.html (adamw, 15:47:53)
    2. simo has concerns about the security of the proposed design (suggests kerberos as a better framework than https) (adamw, 15:49:29)
    3. it looks like we all have some reservations regarding the new proposed systemd remote logging functionality, and expect to stick with rsyslog for the foreseeable future for Server (adamw, 16:00:00)


Meeting ended at 16:02:49 UTC (full logs).

Action items

  1. simo to work with virtualization and networking folks to make sure any caching DNS plans consider libvirt's use of dnsmasq


Action items, by person

  1. simo
    1. simo to work with virtualization and networking folks to make sure any caching DNS plans consider libvirt's use of dnsmasq


People present (lines said)

  1. adamw (117)
  2. simo (108)
  3. nirik (26)
  4. mitr (25)
  5. davidstrauss (24)
  6. tuanta (9)
  7. zodbot (8)
  8. mizmo (7)
  9. jsmith (3)
  10. Evolution (0)
  11. sgallagh (0)


Generated by MeetBot 0.1.4.