15:33:29 <dgilmore> #startmeeting
15:33:29 <zodbot> Meeting started Mon May 12 15:33:29 2014 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:33:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:33:37 <dgilmore> #meetingname releng
15:33:37 <zodbot> The meeting name has been set to 'releng'
15:33:53 <dwa> woo, I'm not late! ;) ahoyhoy.
15:34:15 <dgilmore> #chair tyll_ nirik masta dwa sharkcz
15:34:15 <zodbot> Current chairs: dgilmore dwa masta nirik sharkcz tyll_
15:34:25 <dgilmore> #topic roll call
15:34:27 <nirik> morning
15:34:29 <dgilmore> who is here
15:34:48 <tyll_> Hey there
15:35:19 <dgilmore> lets get moving
15:35:27 <dgilmore> #topic tickets https://fedorahosted.org/rel-eng/report/10
15:35:44 <dgilmore> #topic https://fedorahosted.org/rel-eng/ticket/5854
15:35:47 <dgilmore> masta: ?
15:36:04 <dgilmore> we are not running the script at all. cant hurt to apply the patch
15:36:19 * nirik nods. Lets just apply and move on?
15:36:48 <dgilmore> yeah
15:38:41 <tyll_> sounds good
15:38:45 <dgilmore> applied
15:39:06 <dgilmore> #topic https://fedorahosted.org/rel-eng/ticket/5362
15:39:21 <dgilmore> okay , so pungi is updated
15:39:40 <dgilmore> need to update mash
15:40:08 <nirik> cool.
15:40:28 * nirik is looking forward to mash not keeping all those junk drpms in rawhide
15:40:49 <dgilmore> okay moving on
15:40:57 <dgilmore> #topic https://fedorahosted.org/rel-eng/ticket/5846
15:41:41 <dgilmore> not sure we have much to discuss here since bochecha is not here
15:41:42 <nirik> bochecha is traveling I think
15:42:25 <dgilmore> okay
15:42:32 <dgilmore> #topic https://fedorahosted.org/rel-eng/ticket/5870
15:42:38 <dgilmore> rawhide signing
15:42:40 <number80> bochecha is back in France (he should have arrived today
15:42:49 <nirik> number80: cool. ;)
15:43:03 <dgilmore> cool
15:43:07 <nirik> so, on rawhide signing, I think just signing part of them isn't going to be useful. We need to do all or nothing.
15:43:10 <dgilmore> thanks number80
15:43:23 <dgilmore> nirik: right
15:43:30 <nirik> so, then we could ask devel list or fesco if they would scream if we gated rawhide.
15:43:45 <nirik> and/or write up what we hope someone will implement for automated signing.
15:43:48 <dgilmore> anyway to make sure they are all signed will ad a delay for some packages getting out
15:44:16 <dgilmore> i suspect people will complain
15:44:42 <dgilmore> ive heard complaints that rawhide builds take too long to get out already
15:44:45 <nirik> yeah...
15:44:56 <nirik> but we could ask? or do you think it's just non starter?
15:45:03 <nirik> composes are down to around 5h now.
15:45:05 <dgilmore> we can ask
15:45:18 <nirik> I can open a thread on devel
15:45:38 <dgilmore> nirik: i would like to have nightly composes be full composes
15:45:49 <dgilmore> which ill likely make them take more time
15:45:53 <nirik> what all does that add on to it?
15:45:53 <dgilmore> and will be bigger
15:46:34 <nirik> I think the mash drpm thing might save some time...lots of less files to sling around
15:46:40 <dgilmore> yeah
15:47:19 <dgilmore> im thinking of making the steps that dont need to be arch specific run on x86
15:47:25 <nirik> now that storage is back to normal too, we could look at profiling things more.
15:47:36 <dgilmore> as the depsolving etc is quicker on x86 than arm
15:48:07 <nirik> mash in particular could use more logging of when it does particular steps.
15:48:30 <dgilmore> just run the steps to make the anaconda install bits on their target arches
15:48:39 <nirik> http://koji.fedoraproject.org/mash/rawhide-20140512/logs/buildrawhide.log
15:49:07 <nirik> see the 4.5 hours of mash mashing... would be nice to see when it did drpms, etc.
15:50:20 <dgilmore> yeah
15:50:41 <dgilmore> ill look at increasing its logging when I update it this week
15:51:16 <nirik> that would be great
15:52:24 <dgilmore> okay so
15:52:54 <dgilmore> #action nirik to raise with devel@ the idea of gating rawhide packages until signed.
15:53:07 <dgilmore> nirik: i honestly do not like the idea much
15:53:22 <nirik> yeah, it does mean more work for sure...
15:53:28 <nirik> and I'm not sure the gain is that great.
15:53:33 <dgilmore> nirik: because we shold do the same for secondaries and primary arches
15:53:48 <dgilmore> and its a lot of effort i am not sure i ant to commit people to
15:54:28 <dgilmore> we would probably want to disable rawhide on weekends
15:54:53 <nirik> yeah. perhaps we should drop the idea then...
15:55:06 <nirik> and work on writing up exactly what devel we need against sigul for automated.
15:55:12 <nirik> in hopes of someone stepping up to do it.
15:55:31 <dgilmore> not sure i really like automated signing either
15:56:14 <dgilmore> maybe we should get with the security folks and see if we can work out what we should do
15:56:37 <nirik> sounds like a nice idea. invite them to next weeks meeting?
15:56:48 <dgilmore> yeah
15:57:25 <dgilmore> #action dgilmore to get with the security folk and invite them to next weeks meeting
15:57:34 <dgilmore> okay lets move on
15:57:44 <dgilmore> #secondary arch updates
15:57:48 <dgilmore> #topic secondary arch updates
15:57:54 <dgilmore> #topic secondary arch updates - ppc
15:58:01 <dgilmore> dwa: you're up
15:58:09 <dwa> webkitgtk is gating a lot of packages on ppc :(
15:58:20 <nirik> I keep seeing it fail to build. ;(
15:58:24 <dgilmore> :( people working on it?
15:58:35 <dwa> yeah they are - karsten is working with the maintainer
15:58:55 <dgilmore> dwa: where is ppc64le? seems we have issues with you guys using older builds
15:59:10 <dgilmore> dwa: whats left to be built to merge into the main koji?
15:59:36 <dwa> that's... turning into a little bit of a can of worms
15:59:50 <dwa> IBM and I had/have differing ideas of timelines
15:59:52 <dgilmore> in what way?
16:00:10 <dgilmore> well it needs to be done sooner rather than later
16:00:23 <dwa> they want to maintain ppc64be stability first and foremost and wait to merge in ppc64le until packages don't need the LD override we're using right now
16:00:32 <dgilmore> as soon as you can get the builds caught up you should merge it in
16:00:56 <dwa> (LD override is a patch that's in the rawhide toolchain, tells the linker to always respond as if it's being asked about ppc64le for packages that bundle their own config.* )
16:01:16 <dwa> It probably needs a bigger discussion so I'll write stuff up for you today
16:01:24 <dgilmore> dwa: rpm replaces config.*
16:01:36 <dgilmore> well config.guess and config.sub
16:01:47 <dgilmore> dwa: so i suspect you do not need the hack now
16:01:48 <dwa> that's what I thought but they claim a lot of packages need manual editing
16:01:54 <nirik> btw, is it planned to do both ppc64be and ppc64le moving forward? or everything will move to le once it's ready?
16:02:08 <dgilmore> dwa: if so its a bug in the package and needs fixing
16:02:15 <dwa> nirik: the plan is to have both be & le simultaneously
16:02:28 <dgilmore> dwa: is there plans to drop 32 bit?
16:02:28 <nirik> ok
16:02:30 <dwa> nirik: I'm sure eventually they'll want to kill off be but that's not the plan today
16:02:53 <dwa> dgilmore: phil would really like to, and sent out a mail to the ppc list on friday proposing just that
16:03:11 <dgilmore> i think it makes sense to
16:03:17 <dgilmore> and just do 64 bit
16:03:31 * nirik wishes we could do that with x86 too. ;)
16:03:35 <dgilmore> dwa: so i suggest that we drop the hack
16:03:45 <dgilmore> fix the packages that need fixed
16:04:03 <dgilmore> and as soon as possible merge ppc64le into ppc.koji
16:04:26 <dwa> *nod*
16:04:41 <dwa> the 'hack' is actually something that the toolchain maintainers have accepted into rawhide
16:04:48 <dwa> so it's not a one-off thing only in ppc64le koji
16:04:53 <dgilmore> dwa: sure
16:05:07 <dgilmore> dwa: unlike glibc that seems to be anciet
16:05:08 <dwa> but it does need an environment variable being set to turn it on, so... I don't like the idea of using it in the main koji instance
16:05:10 <dgilmore> ancient
16:05:16 <dgilmore> dwa: whats the deal there
16:05:35 <dgilmore> why have you guys not been following things correctly?
16:05:58 <dwa> IBM has been focused on breadth of packages at the moment
16:06:13 <dwa> and we were planning on starting koji-shadow etc this week on le koji
16:06:13 <dgilmore> dwa: really not good enough or right
16:06:55 <dgilmore> dwa: how far behind is ppc64le?
16:07:12 <dwa> not sure. I tried to run koji-compare last week and it crashed. :P
16:07:26 * masta looks in
16:07:27 <dgilmore> okay
16:07:29 <dwa> we'll get it caught up this week.
16:07:33 <dgilmore> maybe it needs a patch
16:07:44 <dwa> the ppc64le systems are pretty dang fast
16:07:57 <dgilmore> cool
16:08:02 <dwa> (also helps we're only building one arch)
16:08:16 <dgilmore> anything else we need to discuss  for ppc?
16:08:59 <dwa> so in summary: 1) ppc64 is behind because of webkitgtk, people are working on it 2) We want to drop ppc32, discussion started on the mailing list, 3) ppc64le will get koji-shadow'd this week 4) you'll get an e-mail about ppc64le roadmap
16:09:20 <masta> yes, I'm supposed to be helping ppc le, officially... I think.
16:09:22 <dgilmore> #info ppc64 is behind because of webkitgtk, people are working on it
16:09:34 <dgilmore> #info We want to drop ppc32, discussion started on the mailing list
16:09:48 <dgilmore> #info ppc64le will get koji-shadow'd this week
16:09:50 <dwa> masta: yeah you'll get roped in on that e-mail too. sorry ;)
16:10:06 <dgilmore> #info e-mail about ppc64le roadmap on its way
16:10:33 <dgilmore> #topic secondary arch updates - s390
16:10:43 <dgilmore> no sharckcz
16:10:53 <dgilmore> #topic secondary arch updates - aarch64
16:10:59 <dgilmore> #topic secondary arch updates - arch
16:11:04 <dgilmore> #undo
16:11:04 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1762ab50>
16:11:05 <dgilmore> #undo
16:11:05 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1762af50>
16:11:09 <dgilmore> #topic secondary arch updates - arm
16:11:33 <dgilmore> so i caught up and pushed out f19 updates for 32 bit arm last week
16:11:46 <dgilmore> aarch64 is moving along pretty well
16:12:22 <masta> right now lmc can be used to produce aarch64 images
16:12:38 <dgilmore> lmc is not a tool we can use
16:12:48 <dgilmore> so we need to get tooling we can use
16:12:49 <masta> but I'm not sure all the bits are in place to actually produce a working image
16:13:17 <masta> dgilmore: I know, but for boot strapping purposes... perhaps it would be useful .. just throwing it out there
16:13:21 <dgilmore> masta: doesnt matter much since we cant use lmc
16:14:00 <masta> dgilmore: did you get your hardware?
16:14:04 <dgilmore> masta: not yet
16:14:15 <dgilmore> fedex has not updated today
16:14:53 <masta> so the aarch64 builders are up to nine hosts I believe, and Dennis and myself have been provisioned desktop hardware to get things moving...
16:15:09 <nirik> nice
16:15:21 <dgilmore> hopfully we can get some builders in phx2 so we can have a local platform for testing of composes
16:15:26 <dgilmore> making install trees
16:15:44 <masta> yes, the plan is to have them in phx2
16:16:07 * nirik is looking forward to them arriving as well.
16:16:27 <dgilmore> like ppc64le aarch64 is quite fast
16:17:06 <dgilmore> lets move on
16:17:12 <dgilmore> #topic open floor
16:17:27 <dgilmore> anyone want to discuss anything?
16:17:33 <nirik> I reinstalled all the builders this weekend.
16:17:41 <dgilmore> :) i saw cheers
16:17:52 <nirik> there's 3 arm socs that won't boot. Not sure why or how to fix them
16:18:10 <dgilmore> nirik: point me at them and i can take a look
16:18:19 <nirik> I also moved buildvm's from the old blades to the new blades...
16:18:26 <nirik> we can reinstall old blades as buildhw
16:18:30 <dgilmore> Im hoping to get a rawhide compose of everything done this week
16:18:31 <nirik> sure, can do
16:18:54 <nirik> so now buildvm's are on 3 new blades (9 per) and seem to be working pretty well.
16:19:10 <dgilmore> get an idea of what fedora.next will look like
16:19:20 <dgilmore> nirik: cool
16:19:32 <dgilmore> is there plans for more blades?
16:20:22 <nirik> well, we have 8 new blades... 3 are buildvmhosts (as above). the other 5 are bvirthosts. I was going to look at moving the existing bvirthost stuff over to them in the coming months.
16:20:40 <dgilmore> okay
16:21:41 <dgilmore> masta: fedex just pulled up
16:21:48 <dgilmore> anything else?
16:21:51 <masta> \0/
16:22:08 <masta> nope
16:22:16 <masta> we better wrap it up
16:22:59 * nirik has nothing else.
16:23:22 <masta> ok
16:23:51 <masta> I'm going to attempt to end it
16:23:59 <masta> #endmeeting