16:01:19 <spot> #startmeeting Fedora Packaging Committee
16:01:19 <zodbot> Meeting started Thu May 29 16:01:19 2014 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:24 <spot> #meetingname fpc
16:01:24 <zodbot> The meeting name has been set to 'fpc'
16:01:28 <spot> #topic Roll Call
16:01:56 * geppetto is here
16:02:00 <geppetto> hey spot!
16:02:02 <spot> #chair geppetto
16:02:02 <zodbot> Current chairs: geppetto spot
16:02:20 <spot> hey! sorry for being a perennial no-show. I've been super underwater lately.
16:03:05 * Rathann here
16:03:05 <geppetto> yeh
16:03:12 <spot> #chair Rathann
16:03:12 <zodbot> Current chairs: Rathann geppetto spot
16:03:30 <geppetto> I've been following your conferences on FB … almost traveling as much as sales guys :)
16:04:03 <spot> :)
16:04:31 * RemiFedora is here
16:04:36 <spot> #chair RemiFedora
16:04:36 <zodbot> Current chairs: Rathann RemiFedora geppetto spot
16:04:43 <tibbs|w> Howdy.
16:04:49 * spot is trying to run flock on top of all of that.
16:05:01 <spot> #chair tibbs|w
16:05:01 <zodbot> Current chairs: Rathann RemiFedora geppetto spot tibbs|w
16:05:15 <spot> i know abadger1999 and racor are going to be no-show today
16:05:34 <spot> ping SmootherFrOgZ
16:06:29 <spot> okay, we've just got quorum, lets start the fun. ;)
16:06:49 <geppetto> you really have been gone a while … you don't remember anything ! ;)
16:06:49 <spot> #topic Follow-up: Software Collections in Fedora - https://fedorahosted.org/fpc/ticket/339
16:07:06 * spot has no idea where we are on this... where are we on this? :)
16:07:15 <geppetto> abadger1999 is pretty much running this
16:07:25 <spot> okay, so we table until next week.
16:07:32 * geppetto nods
16:07:49 <spot> #action Table SC until next week when abadger1999 is around
16:08:14 <spot> #topic Follow-up: Go Packaging Guidelines Draft - https://fedorahosted.org/fpc/ticket/382
16:08:58 <spot> I see no update from 7 days ago with abadger1999's comment
16:09:00 <geppetto> looks like no response to abadger1999 last comment
16:09:01 <Rathann> hm, no comments from the submitter regarding the issues raised in the last meating
16:09:09 <geppetto> jinx
16:09:09 * spot guesses we're waiting for the submitter on that
16:09:11 <Rathann> *meeting
16:09:29 <spot> #action Waiting on submitter to reply to last week's comments
16:09:53 <spot> #topic Exception for bundled library FoX in exciting - https://fedorahosted.org/fpc/ticket/400
16:10:57 <spot> I don't know what the hold is here.
16:12:03 <spot> It seems like it would be worthwhile to have a conversation with FoX upstream about how they wish to handle format-pretty-print and shared libs
16:12:10 * SmootherFrOgZ here
16:12:17 <spot> #chair SmootherFrOgZ
16:12:17 <zodbot> Current chairs: Rathann RemiFedora SmootherFrOgZ geppetto spot tibbs|w
16:12:27 <geppetto> I think the general feeling was that we wouldn't bundle it without more reasoning of why it wasn't easier to just fix.
16:12:36 * geppetto nods
16:13:02 * Rathann has to go for a minute or two, brb
16:14:59 <spot> looking at https://groups.google.com/forum/#!topic/fox-discuss/g-Vx9ejuhF0, it seems like the upstream isn't likely to enable pretty-print by default, but may as some sort of option
16:16:24 <geppetto> yeh
16:17:02 <geppetto> also, I would guess/hope that pretty-print doesn't change the format of the output enough that it can't be read without it … thus. nullifying the main objection in the ticket.
16:17:13 <RemiFedora> looks like a good candidate for runtime option
16:17:34 <geppetto> yeh, most XML output things have a "normal" mode and a pretty print mode.
16:18:24 <spot> this library doesn't seem to.
16:18:47 <geppetto> yeh, just saying that they might take an option to add it … as it's a common extension
16:18:59 <spot> okay, so maybe libFoX.so and libFoXpp.so ?
16:19:05 <geppetto> it's not like it's an option to output in yaml or something weird :)
16:19:20 <spot> given that there is no real runtime for a lib
16:19:36 <geppetto> yeh, worst case we can fork it like that
16:19:48 <spot> not even a fork really, just compile options.
16:19:57 <spot> i'll try to make a package. would be a nice diversion.
16:20:02 <geppetto> cool
16:20:44 <spot> #action spot will try to make a FoX package that has both "normal" and "pretty-print" libraries
16:21:01 <spot> #topic ruby193 in SCL - https://fedorahosted.org/fpc/ticket/419
16:21:12 <spot> I'm guessing this is another "need abadger1999" item.
16:21:58 <spot> ?
16:22:31 <RemiFedora> mostly some disagrement on naming.
16:22:49 <spot> always fun.
16:23:05 <geppetto> yeh, basically needs to comply with the newer guildlines changes
16:23:11 <RemiFedora> We have talk a lot about this for SCL guidelines (don't rememebr any formal vote)
16:23:27 <spot> Okay, then I'll table it along with the other SCL item for next week.
16:23:48 <spot> #action Tabled to be addressed along with other SCL ticket with abadger1999 next week
16:24:18 <spot> #topic systemd or systemd-units should not be required if a spec file does a %systemd_post command - https://fedorahosted.org/fpc/ticket/425
16:26:01 <spot> soooooo
16:26:17 <geppetto> I believe this is basically fixed
16:26:25 <geppetto> they have a fakesystemd package, and are using it.
16:26:37 <spot> lemme ping mattdm to be sure.
16:26:40 <geppetto> They're also looking at minimalizing systemd itself
16:28:08 <spot> okay, lets do this
16:28:32 <spot> #action if mattdm confirms that they are working around this issue with a fakesystemd package, spot will close, otherwise, we will revisit.
16:28:56 <spot> look at us, blowing through tickets. ;)
16:29:15 <spot> #topic Bundling exception request for nodejs-weak-map - https://fedorahosted.org/fpc/ticket/424
16:30:36 <geppetto> seems fine to me
16:30:42 <spot> the request to bundle until Harmony standard is done seems reasonable to me. Impact is low, security risk is low.
16:30:48 <geppetto> yeh
16:31:18 <spot> Proposal: Approve bundling request until Harmony standard is done and available in Node.js core
16:31:21 <spot> +1
16:31:33 <RemiFedora> +1
16:31:34 <SmootherFrOgZ> meh...+1
16:31:54 <geppetto> +1
16:33:03 <spot> tibbs|w, Rathann ?
16:33:56 <Rathann> looks reasonable, +1
16:34:22 <spot> #action Bundling request approved (+1:5, 0:0, -1:0). Must be unbundled when Harmony standard is finalized and code is available in Node.js core.
16:35:12 <spot> #topic Need policy and macros for binfmt.d file handling - https://fedorahosted.org/fpc/ticket/426
16:36:04 <geppetto> seems fine … I'd be hapy to +1 if there was a written policy
16:36:17 <Rathann> regarding WeakMap, does that patch break other consumers of it?
16:36:33 <geppetto> Rathann: other consumers of Node.js?
16:36:48 <Rathann> no, other consumers of original WeakMap
16:37:34 <geppetto> I thought it was just integrating it into the Node.js API
16:38:37 <Rathann> on the surface, it seems it's just exporting 3 symbols that are not exported otherwise
16:38:54 <spot> The guideline draft seems straightforward here, something like: "Packages which contain binfmt.d configuration settings must place them in /lib/binfmt.d/ and mark them as %config(noreplace). /etc/binfmt.d is reserved for end-user specific configurations."
16:39:19 <spot> maybe s|end-user specific|local|
16:39:46 <Rathann> hm then why %config(noreplace)?
16:39:58 <Rathann> if they aren't supposed to be modified
16:40:12 <spot> ah, point.
16:40:15 <spot> scratch that part.
16:41:04 <spot> Packages which contain binfmt.d configuration settings must place them in /lib/binfmt.d/. Files in /etc/binfmt.d/ are reserved for the local administrator, and will override any files in /lib/binfmt.d/.
16:41:19 <Rathann> sounds good to me
16:41:21 <spot> Packages which contain binfmt.d configuration settings must place them in /lib/binfmt.d/. Files in /etc/binfmt.d/ are reserved for the local administrator, and will override any files with the same name in /lib/binfmt.d/.
16:41:23 <geppetto> sure, +1
16:41:27 <spot> minor technical nit. :)
16:41:37 <SmootherFrOgZ> +1 from me
16:42:30 <Rathann> +1
16:42:47 <Rathann> though I'm missing the information on how to add new formats on-the-fly
16:42:48 <RemiFedora> +1
16:42:51 <spot> hmm, i think we also need to try to restart systemd-binfmt.service
16:43:09 <spot> wine has a %post with "/bin/systemctl try-restart systemd-binfmt.service"
16:43:18 <Rathann> the systemd-binfmt.service manpage only says it's an early boot service
16:45:03 * Rathann pokes around the service
16:46:00 <Rathann> hm it looks like try-restart is a good pick
16:47:19 <spot> https://fedoraproject.org/wiki/User:Spot/binfmtd-draft
16:49:00 <spot> Proposal: https://fedoraproject.org/wiki/User:Spot/binfmtd-draft
16:49:00 <SmootherFrOgZ> +1 on draft
16:49:03 <spot> +1
16:49:26 <Rathann> +1
16:49:38 <geppetto> +1
16:49:53 <RemiFedora> +1
16:49:54 <geppetto> But does anyone know what the part of the ticket about register/unregister means?
16:50:08 <geppetto> Is that what the try-restart is doing?
16:50:14 <spot> geppetto: yessir.
16:50:22 <Rathann> yes
16:50:44 <spot> #action Spot's draft approved (+1:5, 0:0, -1:0)
16:50:47 <geppetto> I can kind of understand the desire to use macors there, then … but meh.
16:51:14 <spot> Not for 3 packages with one line scriptlets.
16:51:24 <spot> This isn't opensuse. ;)
16:51:37 <RemiFedora> :)
16:52:00 <spot> #topic Bundling exception requests for new julia package - https://fedorahosted.org/fpc/ticket/427
16:53:16 <SmootherFrOgZ> lot of bundled exception request, sweet!!!
16:53:27 <spot> hey, math copylibs, what could go wrong?
16:53:41 <tibbs|w> Sorry, folks; people at the door.
16:53:51 <spot> especially ones that version as often as this one does. :/
16:54:43 <spot> okay, lets do the easy bits first
16:54:49 <spot> 1) libuv
16:55:14 <spot> upstream is working on unbundling, is tracking upstream libuv
16:55:18 <RemiFedora> temporary, and upstream seems trying to fix it
16:55:28 <spot> I think a temporary exception is merited here.
16:55:36 <tibbs|w> +1
16:55:44 <RemiFedora> +1
16:55:44 <spot> Julia uses libyuv as soon as practical.
16:55:47 <spot> +1
16:55:48 <SmootherFrOgZ> +1 for lbuv I guess
16:55:52 <spot> err, libuv.
16:55:55 <SmootherFrOgZ> libuv*
16:56:05 <spot> libyuv is an altogether different kettle of fish. :)
16:56:30 <geppetto> maybe
16:56:37 <spot> I see +4 for libuv exception
16:56:45 <Rathann> +1 for temp libyuv exception
16:57:02 <Rathann> eh, libuv of course
16:57:30 <geppetto> it seems small enough, so I'm surprised they can't get them in easier … also no talking with the Fedora maintainer to get the patches in out libuv if they'll be accepted.
16:58:35 <spot> #action Temporary exception for libuv bundling in Julia granted, until system libuv is a practical option. (+1:5, 0:0, -1:0)
16:59:07 <geppetto> fair enough … +0 for me, fwiw
16:59:37 <spot> mmkay.
16:59:51 <geppetto> now … r-project … isn't that like a giant thing?
16:59:54 <spot> 2) Rmath
17:00:02 <spot> R is big, Rmath, not so much.
17:00:06 <geppetto> ahh
17:00:19 * spot is the maintainer of R
17:00:26 * geppetto nods
17:00:47 <geppetto> so what do you think?
17:00:49 <spot> I'm fine with the bundling of Rmath until it is no longer needed (0.4).
17:00:55 <geppetto> ok, +1 then
17:01:04 <spot> +1
17:01:08 <SmootherFrOgZ> +1
17:01:38 * spot honestly had no idea anyone was using Rmath, i don't think anything else in Fedora (aside from R) uses it.
17:01:56 <RemiFedora> +1 as temp.
17:02:45 <Rathann> +1
17:03:12 <tibbs|w> +1
17:03:26 <spot> #action Temporary bundling of Rmath is approved until it is no longer needed by Julia (0.4). (+1:6, 0:0, -1:0)
17:03:41 <spot> Now, to the fun one
17:03:48 <spot> 3) dSFmT
17:04:21 <spot> this code has updated 11 times since 2007.
17:04:24 <tibbs|w> Upstream views it as a copylib, I guess.
17:04:29 <SmootherFrOgZ> heh, no so fun. actually it's trivial to make a lib out of those files
17:04:47 * spot is pretty sure he's made a lib out of other math from this upstream
17:05:34 <spot> I'm inclined to ask them to make a shared lib version of dSFmT and use it in Fedora.
17:06:00 * geppetto nods … seems reasonable … math guys hate doing engineering work ;)
17:06:02 <spot> then again, we copylib md5.
17:06:26 * spot has no idea how widely dSFmT is in Fedora packages
17:06:35 <geppetto> that's mostly because it's super common, and never changes.
17:06:54 <geppetto> and we keep talking of one day having a simple library people can use instead.
17:07:15 <spot> true, but if we're being honest, dSFMT's changes since 2012 are opt and toolchain fix related.
17:07:25 * geppetto nods
17:08:08 <tibbs|w> Does Fedora support anything without SSE2?
17:08:23 * spot would sleep just fine with a bundled exception here (with a versioned Provides) matching the bundled dSFMT
17:08:37 <geppetto> I'm kind of +1 on letting one package bundle this … but I'd be less happy if more than one package wanted to do it.
17:08:47 <Rathann> tibbs: i686 builds shouldn't require SSE2
17:09:06 <spot> Pentium 3 and before don't have SSE2.
17:09:28 <spot> May the computing gods forgive those poor souls using such CPUs.
17:09:39 <Rathann> but on x86_64 it's part of the ABI
17:10:15 <Rathann> so it's probably ExclusiveArch: x86_64 ppc ppc64
17:10:25 <Rathann> or maybe even without ppc
17:10:50 <Rathann> I haven't looked at the code yet, though
17:10:57 <spot> Okay, here, lets do this:
17:12:23 <spot> Proposal: Bundling exception for dSFMT in Julia approved, as long as a versioned Provides: bundled(dSFMT) = #.#.# matching the bundled dSFMT is included. The FPC reserves the right to cancel this exception if other packages are shown to be bundling dSFMT (then, a trivial dSFMT shared lib package will be necessary).
17:12:49 <geppetto> +1
17:13:06 <spot> +1
17:13:08 <SmootherFrOgZ> -1.
17:13:24 <spot> SmootherFrOgZ: you want to make that package, i see. ;)
17:13:37 <SmootherFrOgZ> heh
17:13:50 <Rathann> hm it does have a plain C implementation, too
17:13:51 <spot> SmootherFrOgZ: if you go make that package, i'll review it, and we won't need this exception.
17:14:02 <SmootherFrOgZ> deal!
17:14:05 <Rathann> so it'll work on non-SSE2 and non-Altivec CPUs
17:14:12 <Rathann> too bad it's compile-time selectable
17:14:41 <Rathann> so  I guess for i686 you need to build it twice and put the sse2 version in /usr/lib/sse
17:14:50 <spot> #action SmootherFrOgZ will make a dSFMT package, and Julia can use that. :)
17:15:07 <Rathann> make that /usr/lib/sse2
17:15:22 * Rathann notices qt-webkit has a library there
17:16:08 <spot> #topic Exception for bundling css in infrastructure application - https://fedorahosted.org/fpc/ticket/428
17:17:51 <spot> I suppose question 1 is whether we consider CSS resources as code.
17:18:09 <spot> eh, maybe that's immaterial.
17:18:38 <spot> Proposal: Temporary bundling exception for bootstrap-fedora css resources until bootstrap-fedora is in Fedora.
17:18:50 <tibbs|w> +1
17:19:02 <SmootherFrOgZ> I do. +1
17:19:04 <Rathann> +1 as well
17:19:05 <spot> +1
17:19:15 <RemiFedora> +1
17:19:23 <geppetto> +1
17:19:37 <spot> #action Temporary bundling exception granted for bootstrap-fedora css resources until bootstrap-fedora is in Fedora. (+1:6, 0:0, -1:0)
17:20:18 <spot> #topic Bundling exception request for apitrace: libbacktrace - https://fedorahosted.org/fpc/ticket/429
17:20:59 <spot> There is tons of precedence here (gnulib springs to mind)
17:22:08 <spot> Proposal: Bundling exception for libbacktrace, use Provides: bundled(libbacktrace).
17:23:21 <geppetto> +1, I guess
17:24:29 <spot> +1
17:24:30 <geppetto> I am somewhat hesitant, given the tool chains history with having a giant pile of mud
17:24:47 <geppetto> but I'll give Jakub the benefit
17:25:21 <RemiFedora> not a lot of information why it is not possible... but well...
17:25:22 <RemiFedora> +1
17:25:27 <Rathann> meh
17:25:45 <spot> they're tracking upstream reasonably well, for a lib that is pretty much stagnant.
17:25:49 <SmootherFrOgZ> yeh, I really am curious why it can't be built as shared
17:26:21 <spot> SmootherFrOgZ: knowing jakub, it probably is "we don't really want you to use this or depend on it"
17:26:41 <Rathann> well, I'd like to let him state so first and give some justification
17:26:43 <SmootherFrOgZ> hmm
17:26:49 <Rathann> -1 from me without good reason
17:26:57 <spot> I can email jakub, he'll probably reply. :)
17:27:13 <SmootherFrOgZ> let
17:27:17 <SmootherFrOgZ> 's do that then
17:29:23 <spot> #action Tabled pending more info from Jakub Jelinek
17:30:47 <spot> #topic mod_cluster EPEL package conflict with product - https://fedorahosted.org/fpc/ticket/432
17:31:31 <tibbs|w> Not sure why this went to us.  Shouldn't have it gone to the EPEL committee?
17:31:43 <spot> I think they are trying to ask us how to resolve the issue.
17:32:29 <geppetto> I'm not sure what they mean by the last sentence
17:32:41 <Rathann> geppetto: it's about mirroring what's in EAP6 repo
17:32:44 <spot> It seems like one way would be for the mod_cluster package in EPEL to become a dummy package that simply Requires: mod_cluster-native
17:33:21 <geppetto> Rathann: I'm just not sure what they mean by "after the rename the issue will still be there"
17:33:26 <Rathann> and mod_cluster in EAP6 contains not the Apache module, but Java parts for JBoss
17:33:58 <Rathann> oh
17:34:08 <spot> I'm not sure why the issue would be there, if the package renamed, it should be possible to remove the old builds from EPEL to resolve the conflict.
17:34:12 <RemiFedora> geppetto: I think, the obsoletes, will affect the EAP6 package
17:34:36 <spot> just regen the metadata and the mirrors will pick it up (as long as they're still mirroring)
17:34:37 <geppetto> ahh … in that case the EAP package problably needs to bumpb it's epoch
17:35:10 <Rathann> I'd create a package that's almost identical to what's in EAP
17:35:22 <spot> anyone willing to take a crack at answering this with advice and closing the ticket?
17:35:23 <geppetto> I mean this entire thing feels like a giant java EAP snafu, and they want everyone else to magically fix the world
17:35:34 <Rathann> but mod_cluster in EPEL should require mod_cluster-native
17:35:42 <geppetto> I doubt I'd give advise anyone wants to hear
17:35:48 <Rathann> that's assuming that EAP6 package won't be fixed
17:35:49 <geppetto> advice too
17:35:59 <spot> Rathann: seems like you've got a handle on it, willing to take this ticket?
17:36:19 <Rathann> I'm not sure if everyone expects mod_foo to contain an Apache module called foo
17:36:25 <Rathann> but that's my gut feeling
17:36:32 <geppetto> yeh
17:36:33 <spot> basically, offer suggestions (as many as you'd like), then point them to EPEL and close it.
17:36:41 <Rathann> so I'd much rather this were fixed in EAP6
17:36:54 <geppetto> yeh, that's basically what I'd suggest too
17:37:06 <Rathann> spot: ok, though if I don't manage to do it tonight, it'll have to wait until next week
17:37:13 <geppetto> no problem
17:37:18 <spot> works for me.
17:37:29 <spot> #action Rathann will answer with suggestions and close ticket when he has time.
17:37:54 <spot> #topic Add %{python3_version} and %{python3_version_nodots} to Packaging:Python Macros section - https://fedorahosted.org/fpc/ticket/433
17:37:59 <geppetto> this seems really trivial … +1
17:38:01 <spot> EASYFIX: +1
17:38:12 <SmootherFrOgZ> +1
17:38:42 <tibbs|w> +1
17:38:47 * spot will add a note about python3_version_nodots being in 3.4 and later.
17:38:48 <Rathann> +1
17:39:00 <geppetto> I'm not sure _nodots is a good idea
17:39:11 <geppetto> but I don't have a problem listing it if people are using it
17:39:30 <spot> geppetto: what could go wrong, besides, we'll all be dead when Python 34.1 comes out. ;)
17:39:52 <geppetto> 640k should be enough for anyone, etc.
17:39:56 <spot> My kids can deal with that fun. :D
17:40:00 <geppetto> ha
17:40:28 <spot> #action new macros approved (+1:5, 0:0, -1:0)
17:40:28 <RemiFedora> +1
17:40:32 <spot> #action new macros approved (+1:6, 0:0, -1:0)
17:40:38 <SmootherFrOgZ> spot: depends if you get cryogenized ;)
17:40:54 <spot> SmootherFrOgZ: i plan on being uploaded into my lawnmower.
17:41:09 <SmootherFrOgZ> :)
17:41:14 <spot> #topic Open Floor
17:41:28 <spot> Nice work folks, we cleared through our entire agenda.
17:41:37 <tibbs|w> First time in a long time.
17:41:40 <RemiFedora> :)
17:41:42 * spot ignores the fact that we tabled SCLs... :D
17:41:59 <RemiFedora> spot: very easy, we just have to skip SCL stuff ;)
17:42:21 <spot> Assuming nothing else lands on my plate after FoX, I'll try to do writeups today.
17:43:06 <spot> Okay. 2 minute warning. If nothing else, I'm going to eat my late lunch.
17:44:06 <spot> hey
17:44:09 <spot> look, jakub reply
17:44:17 <spot> > We would like to know why it is not feasible for gcc to provide
17:44:17 <spot> > libbacktrace as a shared library?
17:44:17 <spot> Because the library is not meant to be a standalone project, it has no
17:44:17 <spot> upstream SONAME, no maintained ABI and e.g. in gcc sources is used
17:44:17 <spot> in 3 different places, in two places linked in as a convenience library,
17:44:17 <spot> in the last one built completely again with various redefines etc. to force
17:44:19 <spot> it to use different function, not use malloc at all etc.
17:44:23 <spot> It is pretty much the same thing as libiberty, which is also bundled
17:44:25 <spot> everywhere.
17:44:55 * spot notes that we have a bundled exception for libiberty.
17:45:04 <Rathann> ok, +1 in that case
17:45:12 <tibbs|w> +1
17:45:13 <geppetto> yeh, general toolchain … it's not meant to be shared with anything, apart from the 3 things using it in our giant tree … and oh look someone else wants to use it now too
17:45:15 <Rathann> thanks
17:45:17 <SmootherFrOgZ> +1 then
17:45:18 <spot> +1
17:45:23 <RemiFedora> +1
17:45:50 <SmootherFrOgZ> geppetto: excatly!
17:45:50 <geppetto> I already sigh +1'd … and will do so again.
17:45:55 <spot> #action Bundling exception for libbacktrace approved, Provides: bundled(libbacktrace). (+1:6, 0:0, -1:0)
17:46:28 <spot> And with that, my stomach leads me to lunch. Thanks everyone, see you in a week.
17:46:31 <spot> #endmeeting