15:00:58 <sgallagh> #startmeeting Server Working Group Weekly Meeting (2014-06-03)
15:00:58 <zodbot> Meeting started Tue Jun  3 15:00:58 2014 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:07 <sgallagh> #chair sgallagh mizmo nirik davidstrauss stefw adamw simo tuanta mitr
15:01:07 <zodbot> Current chairs: adamw davidstrauss mitr mizmo nirik sgallagh simo stefw tuanta
15:01:10 <sgallagh> #topic roll call
15:01:11 <mitr> Hello
15:01:23 <tuanta> .hellomynameis tuanta
15:01:23 <zodbot> tuanta: tuanta 'Truong Anh Tuan' <tuanta@iwayvietnam.com>
15:01:29 * nirik is sort of here.
15:02:31 <twoerner> hi
15:03:39 <twoerner> sgallagh: I have to leave a bit earlier today
15:03:57 <twoerner> sgallagh: about 10 minutes
15:04:15 <sgallagh> twoerner: We probably won't discuss the API today; that's seeing active discussion on the mailing list and should probably continue there
15:04:53 <twoerner> sgallagh: ok.. what we need to define for example are the states we want to support
15:04:55 <adamw> ahoyhoy
15:05:09 <adamw> .hellomynameis adamwill
15:05:10 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
15:05:15 <sgallagh> twoerner: Maybe it would be a good idea to start a fresh thread for that specific topic.
15:05:34 <twoerner> ehh...
15:05:34 <twoerner> yes
15:06:13 <sgallagh> We have quorum now
15:06:16 <sgallagh> #topic Agenda
15:06:37 <sgallagh> #info Agenda Topic: Branding and Design
15:06:46 <sgallagh> #info Agenda Topic: ARM support
15:07:16 <sgallagh> #info Agenda Topic: Scheduling
15:07:16 <simo> I am sorry I had not time to read the roles thread :/
15:07:31 * simo has been busy installing RHEL7.0 on his desktop the last few days :)
15:07:32 <sgallagh> simo: that's ok, we're going to keep that on the list for now.
15:08:42 <sgallagh> Anyone have other topics for the agenda?
15:08:50 <twoerner> sgallagh: I think it would be good to ask for more time for the Server Role API
15:08:50 * mizmo here now (sorry, cubing)
15:09:07 <sgallagh> #topic Scheduling
15:09:15 <sgallagh> This relates to twoerner, so let's cover it first.
15:09:30 <twoerner> sgallagh: I do not know if we need the time.. but it would be better to have some extra time just in case
15:09:34 <sgallagh> The deadline for "substantially testable" code in Fedora 21 is set for July 8th
15:09:45 <sgallagh> That's just over a month away.
15:10:17 <sgallagh> As above, twoerner is requesting that we have slightly more time than that.
15:10:35 <sgallagh> It's probably better for us to request it ahead of time rather than force a blocker delay at the end.
15:12:15 <twoerner> but this does not mean that we can move the work to the end of that period... :-)
15:12:25 <sgallagh> no, absolutely not
15:13:45 <nirik> how much time? or hard to say at this point?
15:13:47 <sgallagh> twoerner: How much time?
15:14:06 <sgallagh> If we asked for one extra week, is that enough? We're not going to get a month... :)
15:14:08 * nirik would suspect it might be better to warn/notify fesco about the possibility, but ask when it's known more whats needed?
15:14:37 <adamw> just as a note, Alpha TC1 usually lands two weeks prior to alpha freeze, so that would be around june 24 - just to keep that in mind
15:15:30 <danofsatx-work> I'm here
15:15:41 <twoerner> sgallagh: ohh.. maybe 2 weeks - if that is possible?
15:15:54 <twoerner> with an buffer...
15:16:12 <adamw> ask for two and maybe you'll get one? :)
15:16:48 <sgallagh> Proposal: request a two-week extension on Alpha Submission Freeze, noting that this is blocker-criteria functionality.
15:18:22 <mitr> twoerner: Would this extension include having an IPA role implementation, or would that be a dependency that needs additional time?
15:19:04 <twoerner> mitr: it would be good to have role definitions as soon as possible
15:19:14 <sgallagh> mitr: I'll be working on the IPA role implementation in parallel
15:19:25 <sgallagh> (Hopefully with help from simo)
15:19:26 <twoerner> to see if the Role API will match them and also if there are some things that needs to be tweaked
15:20:14 * mitr hopes that is the “include” variant
15:20:16 <twoerner> it would have been good to have them vbefore working on the API
15:20:56 <simo> sgallagh: if you pull me in as needed I will do my best (as usual I am short on time :)
15:20:59 <sgallagh> twoerner: Well, the Role implementation needs the plugin interface
15:21:06 <sgallagh> Once that's nailed down, we can implement.
15:21:14 <sgallagh> simo: understood.
15:21:28 <sgallagh> I expect to mainly use you as a knowledge resource and code-reviewer
15:22:20 <twoerner> sgallagh: yes, but to have at least some docs, what the specific roles need would help
15:23:42 <sgallagh> twoerner: We'll work that outside this meeting.
15:23:55 <twoerner> sgallagh: ok
15:23:56 <sgallagh> Votes on the schedule-extension proposal?
15:24:30 <adamw> +1, sure
15:24:35 <nirik> sure, we can ask.
15:24:41 <mitr> +1 if twoerner says it’s necessary who am I to contradict him?
15:24:49 <tuanta> +1, we should ask
15:25:45 <sgallagh> #agreed Request a two-week extension on Alpha Submission Freeze, noting that this is blocker-criteria functionality (+5, 0, -0)
15:26:00 <sgallagh> #topic Branding and Design
15:26:24 <sgallagh> mizmo: anything to report here? I know there have been several iterations on the logo designs
15:27:11 <mizmo> me and ryan are still iterating, we're getting close i think tho
15:27:56 <tuanta> mizmo, have you got an URL or Trac ticket?
15:28:14 <tuanta> to follow this
15:28:17 <mizmo> tuanta, theres a trac ticket for cloud, but not the others
15:28:23 <adamw> quite a few of the designs have gone up on her blog - http://blog.linuxgrrl.com/
15:29:01 <tuanta> thanks, I see
15:29:40 <sgallagh> mizmo: Is there anything you'd like from us to proceed here at this point?
15:29:41 * danofsatx-work likes D
15:30:03 <mizmo> sgallagh, not yet :)
15:30:14 <sgallagh> Ok, take it to the list when you do, please.
15:30:18 <mizmo> will do!
15:30:24 <sgallagh> #topic ARM Support
15:30:41 <sgallagh> adamw: Where are we and what do we need to rehash?
15:30:51 <simo> sgallagh: are we going to care only for 32bit ARM here ?
15:31:00 <sgallagh> simo: At this time, yes
15:31:15 <simo> it sounds like sort of a mess, but if there kernels/installersd already available who am I to say no ?
15:31:17 <sgallagh> 64-bit ARM is not yet sufficiently available
15:31:21 <adamw> sgallagh: OK, just to have the background on the record - we didn't really consider ARM arch requirements when deciding what deliverables we would have
15:31:32 <simo> except there are things that are stgarting to simply not work well on 32bit these days
15:31:39 <simo> (eg openldap with newer backend)
15:31:45 <sgallagh> #info ARM was overlooked when we defined our deliverable media
15:31:47 <adamw> through F20 ARM has primarily used disk image deliverables, not installer-based deployment
15:32:11 <simo> sgallagh: should we note that we will move to ARM 64 and abandon 32 once ARM 64 is ready
15:32:18 <adamw> I talked to the ARM team about how Server ought to handle this: https://lists.fedoraproject.org/pipermail/arm/2014-May/007779.html
15:32:20 <simo> is there any consensus on such a position even ?
15:32:49 <adamw> simo: what I heard is that 32-bit ARM and 64-bit ARM are essentially entirely different arches, or that's the best way to think of them. but best ask an expert.
15:32:55 <simo> I am not sure I want to be stuck in trying to support arm 32 for a long time, it just is less and less feasible going forward at least for server-like workloads
15:33:11 <adamw> dgilmore and pwhalen gave some useful replies: https://lists.fedoraproject.org/pipermail/arm/2014-May/007793.html and https://lists.fedoraproject.org/pipermail/arm/2014-May/007794.html
15:33:22 <simo> adamw: thwy are which is why I am not too happy wasting resources on arm 32
15:33:28 <sgallagh> adamw: Would you mind summarizing for the meeting?
15:33:55 <sgallagh> simo: Do you want to propose scrapping ARM32 support for F21?
15:34:07 <adamw> #info dgilmore has been working on changes to anaconda and uboot that will allow us to use installer-based deployment for ARM platforms in Fedora 21
15:34:08 <mitr> simo: If we made an arm32 release with a short schedule to dropping it again, I kinda feel we'd be doing our Server users more service by not publishing the 32-bit release in the first place, if Server is supposed to be suitable for longer-term stable deployments (OTOH, having more testers never hurts)
15:34:24 <nirik> simo: it is a primary arch... are the issues you are seeing filed as bugs, folks aware?
15:34:45 <sgallagh> so reading those replies...
15:34:46 <adamw> #info pwhalen has tested this on Wandboard and Cubietruck, but notes Beaglebones do not have sufficient RAM for installation
15:35:14 <sgallagh> It looks like dgilmore plans to have ARM32 be able to install via netinstall and anaconda for most platforms. Is that a fair assessment?
15:35:16 <adamw> i posted a reply trying to elucidate further info on the RAM issue, but haven't been successful yet. i think that, if anything, would be the stumbling block.
15:35:35 * sgallagh nods
15:35:35 <adamw> sgallagh: bar the RAM issue, yup.
15:35:52 <sgallagh> (Sorry, didn't see your first info there)
15:35:53 <adamw> I honestly don't know the current market/userbase prevalence of different RAM sizes
15:37:02 <sgallagh> I'm not sure we want to abandon ARM32 from the Fedora Server, particularly so soon after the ARM SIG finally got it promoted to primary arch
15:37:19 <sgallagh> Particularly with Workstation not supporting it, that relegates it to Fedora Cloud only
15:37:57 <simo> nirik: no it is more of a longer term thing
15:38:07 <simo> mitr: yes I asked myself thje same questrion
15:38:11 <simo> is it worth it ?
15:38:19 <danofsatx-work> I think we should still support an ARM32 release, with noted exceptions that will not run like FreeIPA.
15:38:25 <simo> given arm 32 doesn't even have the installer but needs to be released as images
15:38:25 <nirik> it's been working fine for us on builders, I haven't seen any specific arm32 issues in a while.
15:38:37 <sgallagh> simo: That last note is changing (as mentioned above)
15:38:40 <adamw> simo: the installer work is for arm32, aiui.
15:38:55 <simo> danofsatx-work: I think FreeIPA will run, but will require a beefy arm 32 ...
15:39:04 <mitr> I’m leaning towards 1) not dropping arm32 now, 2) not adding extra deliverables for it, and 3) having no answer WRT testing capacity of Server on arm32
15:39:09 <danofsatx-work> ok, I misunderstood the problem.
15:39:16 <sgallagh> Proposal: Fedora Server will provide support for those 32-bit ARM architectures that can be installed using anaconda.
15:39:34 <simo> nirik: it's not about building, but overall worthiness of running heavy server loads for infrastructure
15:39:40 <nirik> sgallagh: I'm ok with that...
15:40:01 <simo> I would assume people would rather run on arm64 but maybe I am too biased toward enterprise-like loads
15:40:10 <adamw> it seems like kind of a gross hack, but i can live with it
15:40:20 <sgallagh> (With the understanding that the ARM SIG is perfectly welcome to produce image-based Spins that aren't part of our blocking media set)
15:40:21 <nirik> simo: I think many small services could be a great fit for arm32 devices... nameserver and such.
15:40:30 <danofsatx-work> I'll admit I haven't done the research. Who is the current supplier of ARM servers? Are they successful/growing?
15:40:58 <simo> danofsatx-work: it is still a very young tumultuous market
15:41:20 <adamw> danofsatx-work: 'big iron' servers based on ARM are a very very new area and mainly going to be 64-bit ARM, I believe a few manufacturers have released initial hardware in like the last few weeks
15:41:21 <danofsatx-work> I know someone recently closed up shop, but my knowledge is very limited on the subject
15:41:33 <adamw> danofsatx-work: but it's certainly plausible to run 'small' services on ARM dev boards, as nirik suggests
15:41:33 <simo> danofsatx-work: but supposedly arm64 will be a real arch not a cpu instruction set with an ecosystem of incompatible platfroms around it
15:41:54 <adamw> danofsatx-work: and there's a reasonable reason for doing it: power consumption
15:41:57 <mitr> sgallagh: +1
15:42:07 <simo> adamw: right ok
15:42:13 <danofsatx-work> Well, I have a Pi at home running my SSH tunnel termination point and limited web server ;)
15:42:19 <simo> +1 to arm if supported by installer proposal
15:42:24 <simo> sgallagh: ^
15:42:42 <sgallagh> adamw: Was "I can live with it" a +1?
15:43:46 <sgallagh> nirik, mizmo, tuanta? Opinions?
15:44:05 * nirik was +1 already, sorry if I wasn't explicit
15:44:19 <adamw> sgallagh: sure
15:44:26 <mizmo> +1, i have plans and ideas for pi toys :)
15:44:28 <tuanta> +1 from me too
15:44:47 <sgallagh> #agreed Fedora Server will provide support for those 32-bit ARM architectures that can be installed using anaconda.
15:44:59 <sgallagh> #info The ARM SIG is perfectly welcome to produce image-based Spins that aren't part of our blocking media set
15:45:21 <sgallagh> #action sgallagh to update the PRD and Technical Specification
15:46:00 <sgallagh> #topic Open Floor
15:46:12 <sgallagh> Anyone have other topics today?
15:46:30 <mizmo> i have a minor topic
15:46:32 <mizmo> but it might eb premature
15:46:42 <mizmo> so on fedora magazine we're looking at doing different articles to highlight desktop apps
15:46:52 <mizmo> and thought maybe we should be highlighting - something - for server (and cloud)
15:47:13 <mizmo> would that be a useful exercise? to have a regular series in fedoramagazine for talking about server components offered in Fedora?
15:47:59 <simo> in general publicity is a good idea
15:48:02 <simo> so +1
15:48:21 <sgallagh> Yes, but I'm not sure what specifically to talk about.
15:48:33 <sgallagh> The Roles are obvious, but for F21 there are only likely to be two of them
15:48:51 <sgallagh> (Possibly three; I may knock out the memcached role as well, because it looks just this side of trivial)
15:51:05 <sgallagh> mizmo: Actually, what about setting up a series of interviews for Persona representatives and publishing those?
15:51:36 <sgallagh> either real or fictionalized (and labeled as such)
15:51:38 <mizmo> sgallagh, thats a great idea
15:51:58 <mizmo> ill propose that to the magazine team
15:51:59 <mizmo> thanks :)
15:52:02 <sgallagh> Sure :)
15:53:22 <sgallagh> Ok, any other topics?
15:53:38 <adamw> i was gonna ask if anyone had thoughts on release criteria
15:53:47 <sgallagh> "We should have some"
15:53:48 <adamw> beyond mostly going through the tech specs and covering the important bits
15:53:50 <adamw> =)
15:54:32 <sgallagh> Hopefully the Tech Spec should cover most of what we would really need to block on
15:55:08 <adamw> yeah, that's what I figured.
15:55:13 <sgallagh> And if it doesn't, we should fix the Tech Spec
15:55:20 <simo> +1
15:56:23 <sgallagh> adamw: Any specific questions or ambiguities?
15:56:29 <adamw> not yet
15:56:46 <sgallagh> ok, raise them on the list when they come up, please.
15:57:40 <adamw> sure
15:57:50 <sgallagh> Alright, I'll close the meeting out in one minute unless there are other topics.
15:58:53 <sgallagh> #endmeeting