#fedora-meeting-1: Server Working Group Weekly Meeting (2014-06-17)

Meeting started by sgallagh at 15:01:27 UTC (full logs).

Meeting summary

  1. roll call (sgallagh, 15:01:34)
  2. Agenda (sgallagh, 15:05:27)
    1. Agenda Topic: Release Criteria (sgallagh, 15:05:33)
    2. Agenda Topic: Server Role Daemon Naming (sgallagh, 15:05:37)

  3. Release Criteria (sgallagh, 15:07:46)
    1. https://fedoraproject.org/wiki/User:Adamwill/Draft_server_release_criteria (sgallagh, 15:08:09)
    2. ACTION: adamw to clarify "at install" phrasing to mean "running at the conclusion of the first boot-up after installation concludes" (sgallagh, 15:14:43)
    3. ACTION: adamw to reword "role deployment" criterion to be a bit vaguer (as part of install-time role deployment may happen during firstboot) (adamw, 15:24:42)
    4. ACTION: adamw to revise firewall criterion to allow port to be open for access to Cockpit web management console (adamw, 15:25:02)
    5. ACTION: adamw to write criterion requiring Cockpit web management console to be available OOTB (adamw, 15:25:28)
    6. Server Role API must *eventually* support blocking ports by network interface, but this feature is eligible for deferral in Fedora 21 (sgallagh, 15:27:39)
    7. http://www.iana.org/assignments/service-names-port-numbers/service-names-port-numbers.xhtml?search=10000 (tuanta, 15:39:35)
    8. ACTION: sgallagh to work with Cockpit team to find memorable port for reservation (sgallagh, 15:40:46)

  4. Server Role Daemon Naming (sgallagh, 15:57:38)
    1. Proposed Name: RoleD/roled (sgallagh, 15:57:38)
    2. Proposed Name: thespian (sgallagh, 15:57:39)
    3. Proposed Name: RoleKit (sgallagh, 15:57:39)
    4. Proposed Name: RoleMgr (sgallagh, 15:57:39)
    5. Proposed Name: RoleManager (sgallagh, 15:57:40)
    6. Proposed Name: Serverd (simo, 15:59:42)
    7. Proposed Name: RoleCtl (sgallagh, 16:07:07)
    8. AGREED: Project will be named 'rolekit', it's daemon will be 'roled' and its command-line interface will be 'rolectl' (sgallagh, 16:10:35)

  5. Open Floor (sgallagh, 16:10:41)
    1. ACTION: simo to chair next week's meeting (sgallagh, 16:14:46)


Meeting ended at 16:15:24 UTC (full logs).

Action items

  1. adamw to clarify "at install" phrasing to mean "running at the conclusion of the first boot-up after installation concludes"
  2. adamw to reword "role deployment" criterion to be a bit vaguer (as part of install-time role deployment may happen during firstboot)
  3. adamw to revise firewall criterion to allow port to be open for access to Cockpit web management console
  4. adamw to write criterion requiring Cockpit web management console to be available OOTB
  5. sgallagh to work with Cockpit team to find memorable port for reservation
  6. simo to chair next week's meeting


Action items, by person

  1. adamw
    1. adamw to clarify "at install" phrasing to mean "running at the conclusion of the first boot-up after installation concludes"
    2. adamw to reword "role deployment" criterion to be a bit vaguer (as part of install-time role deployment may happen during firstboot)
    3. adamw to revise firewall criterion to allow port to be open for access to Cockpit web management console
    4. adamw to write criterion requiring Cockpit web management console to be available OOTB
  2. sgallagh
    1. sgallagh to work with Cockpit team to find memorable port for reservation
  3. simo
    1. simo to chair next week's meeting


People present (lines said)

  1. sgallagh (116)
  2. adamw (64)
  3. simo (60)
  4. stefw (49)
  5. nirik (18)
  6. tuanta (11)
  7. twoerner (10)
  8. zodbot (9)
  9. mizmo (8)
  10. danofsatx-work (6)
  11. davidstrauss (6)
  12. jsmith (3)
  13. mitr (0)


Generated by MeetBot 0.1.4.