16:03:02 <spot> #startmeeting Fedora Packaging Committee
16:03:03 <zodbot> Meeting started Thu Jul 17 16:03:02 2014 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:03:08 <spot> #meetingname fpc
16:03:08 <zodbot> The meeting name has been set to 'fpc'
16:03:13 <spot> #topic Roll Call
16:03:35 * spot apologizes in advance, i am running from meeting to meeting today
16:03:40 * Rathann present
16:03:45 <spot> #chair Rathann
16:03:45 <zodbot> Current chairs: Rathann spot
16:03:47 * racor is here
16:03:49 <spot> #chair racor
16:03:49 <zodbot> Current chairs: Rathann racor spot
16:03:53 <tibbs|w> Howdy.
16:04:04 <spot> #chair tibbs|w
16:04:05 <zodbot> Current chairs: Rathann racor spot tibbs|w
16:04:42 * geppetto is here
16:05:28 <spot> #chair geppetto
16:05:28 <zodbot> Current chairs: Rathann geppetto racor spot tibbs|w
16:06:26 <spot> ping abadger1999 SmootherFrOgZ limburgher
16:07:00 <spot> brb, one min
16:07:41 * abadger1999 here
16:08:32 <abadger1999> Re: the scl meeting agenda, langdon said he wouldn't be able to attend this week so we could skip over that item.
16:08:47 <spot> #chair abadger1999
16:08:47 <zodbot> Current chairs: Rathann abadger1999 geppetto racor spot tibbs|w
16:08:49 <abadger1999> *agenda item
16:09:03 <spot> i think i'm going to start with the new items first, then we can circle through our long term items
16:09:13 * SmootherFrOgZ is around
16:09:18 <spot> #chair SmootherFrOgZ
16:09:18 <zodbot> Current chairs: Rathann SmootherFrOgZ abadger1999 geppetto racor spot tibbs|w
16:10:03 <spot> Alright. Lets go.
16:10:19 <spot> #topic Use of RPM macros for sysctl and binfmt activation - https://fedorahosted.org/fpc/ticket/441
16:11:04 <spot> This seems reasonably straightforward.
16:11:33 <spot> With the obvious exception of not knowing what those macros do...
16:11:34 <tibbs|w> Indeed, though I'm not sure I agree with the "please consider" bits.
16:11:39 <Rathann> what minimum Fedora version are the macros available in?
16:12:05 <tibbs|w> I mean, why not just make it a requirement, so that the behavior is consistent in not requiring a reboot?
16:12:23 <spot> http://cgit.freedesktop.org/systemd/systemd/plain/src/core/macros.systemd.in
16:12:23 * Rathann checks and finds they're not available on F20
16:12:26 <abadger1999> yeah, I'd change wording to MUST and expand the macros.
16:12:34 <spot> they're in git, so probably F21+
16:12:55 <abadger1999> The expansion is so that someone used to installing by hand can see what's going on.
16:13:18 <spot> not that i have any real insight into the workings of "systemd-sysctl" and "systemd-binfmt"
16:14:18 <spot> I'd say make it a MUST, expand the macros (even if it seems silly to have macros for oneliner items)
16:14:46 <geppetto> what do you mean by expand the macros?
16:14:53 <spot> expand them in the guideline text
16:15:02 <spot> basically show what they do
16:15:21 <spot> (this is what we normally do when we mandate macro use)
16:15:22 <geppetto> At that point I'd say why bother with the macros?
16:16:05 <abadger1999> geppetto: the macro means you don't have to modify $X packages if the implementation changes.
16:16:21 <tibbs|w> I guess two main reasons: Because it's shorter and more obvious for the packagers, and so that things can be updated without tweaking all packages.
16:16:23 <geppetto> abadger1999: sure, but you have to modify policy then
16:16:23 <abadger1999> Expanding the macro allows people to understand what the magic macros are doing.
16:16:25 <spot> abadger1999: that, and simplicity.
16:16:43 <abadger1999> geppetto: Yep.  But that's just one place instead fo $X spec files.
16:17:12 * geppetto shrugs … fine, +1
16:17:15 <spot> #proposal Lennart's macros, as a MUST, macros defined along with guideline
16:17:19 <abadger1999> +1
16:17:21 <tibbs|w> +1
16:17:22 <spot> +1
16:18:02 * spot counts +4 on the proposal
16:18:05 <SmootherFrOgZ> +1
16:18:11 <Rathann> +1
16:18:23 <abadger1999> geppetto: My thinking is that we want a sysadmin who is pretty new to packaging to see that they were running $cmd by hand before and now they're going to run $cmd in the %post of the package.  Just that it's encapsulated inside %macro
16:18:31 <racor> +1
16:19:04 <spot> #action Lennart's binfmt and sysctl macro usage, as a MUST, with macro definitions (+1:7, 0:0, -1:0)
16:19:47 <racor> Followup questions: Who is going to enforce this (walk through all packages)? How about backward compatibility (epel, fc <= 21)?
16:20:15 <spot> racor: FESCo is supposed to be "enforcement" body.
16:21:06 <spot> the other questions i have no answer for.
16:21:08 <racor> spot: More bluntly - I Lennart going through all packages and implement this into affected packages?
16:21:20 <racor> s/I/Is/
16:21:25 <spot> racor: i doubt it, but i suppose if he's provenpackager, he could.
16:21:46 <spot> i might see him filing bugs though.
16:21:52 <racor> spot: <no comment> ... something's got to change @RH
16:22:06 <spot> racor: not my department, not even a little bit.
16:23:00 <spot> #topic Use of sysusers.d to register system users - https://fedorahosted.org/fpc/ticket/442
16:23:08 <racor> spot: then communicate this to the appropriate people, pls.
16:23:24 <spot> racor: i'd like to say they'd listen to me, but the truth is, they would not.
16:24:08 * spot has no technical influence whatsoever on Red Hat's decisions around Fedora.
16:24:14 <racor> spot: ... I am quite sour at RH pushing contributors around. This is one such case.
16:24:15 <spot> not anymore.
16:24:39 <racor> Anyway, this is way off topic here, so EOT
16:25:20 <spot> I have 10,000 unread emails in my fedora-devel-list folder, so i'm not sure if lennart brought up this topic there or not
16:26:43 <Rathann> he did
16:26:49 <Rathann> about a week ago
16:27:08 <Rathann> actually Colin Walters started the thread
16:27:17 <Rathann> https://fedoraproject.org/wiki/Changes/SystemdSysusers
16:27:30 <abadger1999> I think we still need a lot of the UsersAndGroups page since that explains static vs dynamic ids.
16:27:42 <abadger1999> and soft static as well.
16:27:55 <abadger1999> we'll still need system wide registration.
16:28:04 * spot nods
16:28:14 <abadger1999> So it's pretty much just the scriptlets that are changing I take it.
16:28:27 <spot> the sysusers_create would replace the dynamic ids, i think
16:28:46 <abadger1999> I vaguely think that creating a group for every system user is a behaviour change.
16:29:18 <abadger1999> I'm not sure precisely how pressed for static gids but it's always worrisome.
16:30:27 <Rathann> as I understand, this means we'll move our static list from wiki page to /usr/lib/sysusers.d/fedora.conf or something like that
16:30:44 <abadger1999> spot: I havent looked at the macro, but the sysusers.d man page looks to be used for both uid and gid.
16:30:51 * spot nods
16:31:01 <abadger1999> Rathann: actually -- the canonical list is not in the wiki.
16:31:15 <spot> the macro is just:
16:31:16 <abadger1999> Rathann: It's i the setup package: /usr/share/doc/setup/uidgid
16:31:18 <spot> %sysusers_create() \
16:31:18 <spot> systemd-sysusers %{?*} >/dev/null 2>&1 || : \
16:31:18 <spot> %{nil}
16:31:23 <abadger1999> Rathann: And we'll still have to maintain that.
16:31:28 <Rathann> right
16:32:48 <abadger1999> Hmmm...
16:33:07 <racor> I do not see any advantage of this approach. All it does, to me reads as introducing yet another layer to uid/gid management
16:34:22 <spot> so i guess the question here is whether we want to replace the manual commands for user/group creation for these per-package user/groups with the systemd one-liner + 4 line config file
16:35:14 <tibbs|w> I'm always happy to make things simpler for the packager, but outside of that I'm not completely sure what this buys us.
16:35:29 <geppetto> This makes things simpler?
16:35:40 <spot> my instinct is to defer to fesco on this, if they support this methodology, we'll document its use in UsersAndGroups
16:35:51 <racor> spot: IMO, this actually consists of 2 questions: a) do we want macros for uid/gid creation  and b) do we want sysusers.d?
16:36:12 <Rathann> I'm not opposed to sysusers.d, it makes automated user creation simpler
16:36:18 <spot> racor: i suppose, although, if we are really hung up on macros, it is a one line command.
16:36:24 <abadger1999> Looking at the passwd and group file... I think it would be good to remove the Allocating a user automatically allocates a group mechanism.
16:36:41 <Rathann> and less clutter in spec files is always welcome
16:36:44 <geppetto> Rathann: it does … instead of running a command with the data you know, you create a config. file and run a command on that?
16:36:45 <abadger1999> But I'm with spot about documenting using this as opposed to useradd if it passes fesco.
16:37:05 <Rathann> geppetto: as I understand it, yes
16:37:14 <racor> spot: I feel this is yet another case of RH pushing Fedora around. Some anonymous director at RH has decided ... we are suppose to swallow ...
16:37:36 <spot> abadger1999: would an override option to create no group with "u" work?
16:37:57 * spot is just wondering what exactly we should propose to lennart there
16:38:09 <geppetto> racor: No director has decided this … if you want to blame a person, blame lennart … but I asssume he's spoken to someone about this, probably on the systemd MLs
16:38:56 <geppetto> The discussion I can find by Colin on f-d-l doesn't seem very related, and is very short.
16:39:23 <abadger1999> spot: Maybe -- I kinda think we want that to be the default and adding group to be a supplement... but more data could change my mind.
16:39:35 * abadger1999 checks i nthe uidgid file to see if that has more data.
16:39:43 <Rathann> also, before you start jumping to conclusions, this mechanism is meant for system users only
16:39:50 <spot> #proposal defer, waiting for FESCo decision on this methodology (use of sysusers.d for system user/group creation) && Ask Lennart to enable support for creating a system user without a matching group
16:40:19 <spot> abadger1999: does that wording make sense?
16:40:40 <Rathann> spot: which group would be primary for user without a matching group?
16:40:50 <abadger1999> spot: I think so yes.
16:41:34 <spot> Rathann: i think the scenario is packages that create a system user and put it into an existing group?
16:41:47 <spot> which seems to already be supported.
16:42:05 <spot> maybe abadger1999 has a better answer.
16:42:23 <Rathann> ah right I see what you mean
16:42:33 <racor> geppetto: So why are we discussing sysusers.d? From what I have read, I am far from being convinced about it. As said before, to me sysusers.d is just a wrapper around existing services.
16:42:35 <Rathann> yeah, that case definitely needs to be supported
16:42:51 <spot> i think if i'm reading the manpage right
16:43:00 <racor> geppetto: ... which is likely to cause confusions and breakages.
16:43:11 <spot> that if you set u spotd 500 "Spotd User" g input - -
16:43:26 <spot> it will not create a "spotd" group, but just put spotd into the input group
16:43:43 <tomprince> Declarative is nicer than imperative configuration.
16:43:44 <spot> but i might be wrong.
16:43:53 <abadger1999> So ... if you take a look at the uidgid file, you have things like:
16:43:56 <abadger1999> hacluster       189     -       /               /sbin/nologin   pacemaker
16:43:57 <abadger1999> haclient        -       189     -               -       pacemaker
16:43:59 <abadger1999> s
16:44:23 <abadger1999> Where there's a uid allocated without a gid and vice versa.
16:44:29 <spot> its not clear at all though, i could interpret the manpage either way
16:45:34 <spot> i do understand what we want to have supported though
16:46:04 * spot is +1 on the proposal to defer and ask for that to be supported
16:46:07 * limburgher is here, sorry I'm late. . .things. . .
16:46:54 <tibbs|w> +1 to defer, I guess.  It would be good to have clarification at least.
16:47:26 <abadger1999> <nod> +1 to defer. yeah, it seems like the example spot found could be what we need but not sure.
16:48:19 <racor> -1 on this proposal. It should be split into 2 questions, one on macros and the other on syssystemd, which should be deferred until somebody has decided to switch to sysusers.
16:48:36 <SmootherFrOgZ> yeah, defer.
16:49:02 <abadger1999> It would also be nice if lennart wrote up the draft as a change to the existing guidelines so that we could just copy and paste the new wiki page.
16:49:16 <Rathann> +1 to defer
16:49:51 <spot> I see +5 on the proposal (and a -1 from racor)
16:50:17 <spot> abadger1999: i think we will be waiting forever if we ask for drafts from lennart
16:50:23 <abadger1999> <nod>
16:50:29 <geppetto> sure, +1 … although I'd say that replacing the current copypasta for uid creation with a macro would get a +1 from me
16:50:40 <pingou> spot: could be made a requirement from accepting? :D
16:50:51 <spot> pingou: unlikely.
16:50:56 <geppetto> might also make it clearer how little this proposal is doing, while being incompatible
16:50:57 <racor> geppetto: I would also get a +1 from me :)
16:51:07 <spot> we tried that before, he just shrugged and went off to do something else
16:51:16 <pingou> :/
16:51:29 <spot> anyways, we're at +6 now
16:52:27 <spot> #action Defer 442, wait for FESCo to decide if they want to use the sysusers.d method for system user/group creation && Ask Lennart to enable support for creating a system user without a matching group (+1:6, 0:0, -1:1)
16:52:59 <spot> #topic Requesting bundling exception for Love - https://fedorahosted.org/fpc/ticket/443
16:53:07 * spot refrains from quoting beatles songs
16:54:22 <tibbs|w> I guess this is missing the usual answers to the stock questions.
16:54:23 <abadger1999> Think we need more info here.
16:55:09 <spot> what little info there is is here:
16:55:12 <spot> https://bitbucket.org/rude/love/issue/870/allow-for-shared-version-of-libraries
16:55:48 <tibbs|w> It sounds like this would qualify under our "too small to care" exception, but more info is definitely needed.
16:55:59 <spot> someone want to reply on that and ask for the usual details?
16:56:51 <tibbs|w> I have to run immediately after this meeting and don't know when I'll be back at a computer.
16:57:04 <tibbs|w> But I can do that much later.
16:57:14 <spot> tibbs|w: then much later will have to do
16:57:29 <tibbs|w> I mean, much later today.  Not next month or something.
16:57:29 <spot> #action tibbs|w will ask for necessary info on ticket 443
16:58:25 <spot> okay, old items
16:58:39 <spot> #topic AppData - https://fedorahosted.org/fpc/ticket/414
16:58:59 <spot> richard added the change to the verify tool to not parse licenses in relaxed mode
17:00:17 <tibbs|w> So what else were we waiting on?
17:00:19 <spot> I think that leaves us to consider his draft here: https://fedoraproject.org/wiki/User:Rhughes/DraftAppDataGuidelines
17:00:45 <abadger1999> So the two things needed for the draft:
17:00:56 <spot> (and i think we need to pass the proper option to run in "relaxed" mode on the appdata-validate call)
17:01:02 <abadger1999> switch from appdata-validate to whatever the mode is for relaxed
17:01:16 <abadger1999> and add a translation to the examples.
17:01:46 <abadger1999> neither are controversial, they just need to get done by someone who knows what the correct syntax is.
17:02:09 <spot> is there a translated appdata file already in fedora?
17:02:16 <spot> that might be the easiest thing to use
17:02:42 <spot> the relax flag is "-r"
17:02:48 <spot> or --relax
17:03:18 * abadger1999 edits the top section to say where appdata files are installed.
17:03:26 <spot> go ahead and add the -r too
17:03:35 * abadger1999 does so
17:05:39 <spot> EOG appdata has translations
17:06:09 <spot> its just an additional <p xml:lang="as"> </p> block
17:06:30 <spot> below each english <p>
17:06:44 <spot> where "as" is obviously the lang code
17:07:08 <abadger1999> spot: Is it the same for summary?
17:07:25 <abadger1999> <summary xml:lang="as"> </summary>
17:07:36 <spot> abadger1999: yes
17:08:27 <abadger1999> Cool.  So yeah, It'd be fine to me to switch the example to EOG.
17:08:28 <spot> abadger1999: if you want to just pass the comical strings through google translate for a lang like spanish, that should suffice.
17:08:35 <spot> EOG is missing a summary
17:08:37 <abadger1999> spot: okay.
17:09:34 <spot> abadger1999: let us know when to hit reload so we can review before a vote
17:09:39 * abadger1999 will use french so that remi can correct it if he wants.
17:09:43 <spot> :)
17:10:02 <SmootherFrOgZ> :)
17:10:21 * spot knows better than to try to write in french, i end up saying things like Cet ours a volé mon pantalon!
17:10:42 <SmootherFrOgZ> ah ah
17:11:59 <geppetto> damn bears
17:12:12 <abadger1999> Okay, hit reload
17:12:40 <abadger1999> hehe, Now SmootherFrOgZ can laugh at google translate.
17:13:07 <spot> abadger1999: you probably want to s/Comique/Comical
17:13:13 <SmootherFrOgZ> :D
17:14:06 <spot> Red Hat is not chapeau rouge in Paris, it is still "Red Hat"
17:14:11 <abadger1999> Refresh again
17:14:37 <spot> looks good. +1
17:14:41 <limburgher> +1
17:15:14 <SmootherFrOgZ> yeah, +1
17:15:18 <SmootherFrOgZ> spot: no way :P
17:15:25 <abadger1999> +1
17:15:57 <tibbs|w> +1
17:16:10 <spot> abadger1999: be sure to add <!-- Copyright 2014 Google --> for the translations. ;)
17:16:10 <geppetto> +1
17:16:16 * spot is kidding
17:16:25 <abadger1999> hee hee hee.
17:16:36 <abadger1999> Are you sure, some of google's translations are user contributed ;-)
17:17:03 <spot> abadger1999: we should open a ticket to track copyright ownership for attribution in an appdata file!
17:17:03 <SmootherFrOgZ> spot: i know ;)
17:17:07 <Rathann> +1
17:17:36 <spot> #action revised draft approved (+1:7, 0:0, -1:0)
17:17:58 <spot> #topic Open Floor
17:18:28 <tibbs|w> I have to split now.  Thanks and I'll follow up on 443 tonight.
17:20:28 <spot> if there are no other items aside from badly translated french jokes in... oh lets say 2 minutes, we'll close out.
17:21:56 <spot> Qu'est-ce que vous appelez une jolie femme en Angleterre?
17:22:04 <spot> Un touriste!
17:22:35 <spot> thanks everyone. :D
17:22:37 <spot> #endmeeting