15:00:17 <sgallagh> #startmeeting Server Working Group Weekly Meeting (2014-08-19)
15:00:17 <zodbot> Meeting started Tue Aug 19 15:00:17 2014 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:17 <sgallagh> #chair sgallagh mizmo nirik davidstrauss stefw adamw simo tuanta mitr
15:00:17 <sgallagh> #topic roll call
15:00:17 <zodbot> Current chairs: adamw davidstrauss mitr mizmo nirik sgallagh simo stefw tuanta
15:00:38 <nirik> hello
15:00:40 <mizmo> hey
15:00:40 <sgallagh> Who's around this week?
15:01:36 <mitr> Hello
15:03:15 * robyduck will listen, hello
15:03:19 <sgallagh> We're under quorum, but we don't have much on the agenda.
15:03:35 <sgallagh> #topic Agenda
15:03:36 <sgallagh> #info Agenda Item: Status of rolekit
15:03:36 <sgallagh> #info Agenda Item: Status of Cockpit
15:03:36 <sgallagh> #info Agenda Item: Open Floor
15:03:43 <danofsatx> I'm here, but I'm not a voting member
15:04:23 <sgallagh> #topic Status of rolekit
15:04:39 <tuanta> .hellomynameis tuanta
15:04:40 <zodbot> tuanta: tuanta 'Truong Anh Tuan' <tuanta@iwayvietnam.com>
15:04:55 <sgallagh> We're making decent progress on rolekit. I've successfully managed to deploy an example FreeIPA server using it.
15:05:23 <nirik> nice. ;)
15:05:30 <sgallagh> mitr and twoerner have been doing an outstanding job here, so thank you both very much.
15:05:40 <tuanta> really cool
15:05:43 <sgallagh> #info Major kudos to twoerner and mitr here
15:05:58 <twoerner> thank you :-)
15:06:16 <nirik> yeah, excellent work. ;)
15:06:24 <tuanta> +1 :)
15:06:27 <sgallagh> I've been in talks with some groups at Red Hat and there are now plans in Fedora 22 that will grab us some additional resources on this project.
15:07:07 <sgallagh> In particular, the FreeIPA upstream will be helping us flesh out a wider set of capabilities for the Domain Controller and Domain Controller Replica roles.
15:08:23 <sgallagh> I'm spending today (other than this meeting) working through the remaining code-reviews. I think we'll be in passable shape for the F21 Alpha (but there's plenty of clean-up and stabilizing to do by beta)
15:09:00 <sgallagh> #info rolekit in decent shape for F21 Alpha. Clean-up and stabilization work will happen for Beta.
15:09:11 <sgallagh> twoerner, mitr: Either of you have anything you'd like to call out?
15:10:00 <twoerner> sgallagh: nothing from my side so far
15:10:09 * nirik has not really done anything at all toward a database role. ;(
15:10:11 <mitr> sgallagh: no
15:10:30 <sgallagh> nirik: Oh, that's right. I meant to let you know, handsome_pirate has expressed interest in assisting with that.
15:10:47 <sgallagh> nirik: Would you mind syncing up with him on that?
15:11:05 <nirik> ok. I fear we may just not do it for f21... but it was secondary/optional too...
15:11:22 <tuanta> nice to hear that sgallagh
15:11:23 <nirik> sure, can try
15:11:24 <sgallagh> Yeah, but I suspect it's also going to turn out to be fairly easy to get *something*.
15:11:37 <tuanta> I will follow it to see if I can help anything
15:11:41 <sgallagh> tuanta: Thanks
15:12:02 <sgallagh> #action nirik, tuanta and handsome_pirate to look into the Database Server Role implementation
15:12:26 <tuanta> so, nirik et all, please keep it updated on the mailing list and IRC for all of us
15:13:03 <nirik> sure. Happy to let others take the lead on it too...
15:13:07 <sgallagh> tuanta, nirik: Please make sure to register an account on the ReviewBoard instance and preferably subscribe to the rolekit-commits mailing list (where we're sending the RB emails)
15:13:22 <sgallagh> #link http://reviewboard-fedoraserver.rhcloud.com/
15:13:40 <tuanta> thanks sgallagh
15:13:54 <sgallagh> #link https://lists.fedorahosted.org/mailman/listinfo/rolekit-commits
15:14:23 * simo late :(
15:14:24 <sgallagh> OK, that should cover rolekit for now. Let's move on.
15:14:39 <sgallagh> #topic Status of cockpit
15:14:46 <sgallagh> stefw: Are you around?
15:16:11 <sgallagh> puiterwijk: Mind giving a brief status report on Cockpit vis-a-vis Fedora 21?
15:16:45 <puiterwijk> sgallagh: well, I think we solved most of the blockers and we're just doing some code cleanups. butit's in the repos et all
15:17:49 <puiterwijk> sgallagh: on what exact parts do you want an update? as "status report on Cockpit" is quite boar
15:17:53 <puiterwijk> broad*
15:18:34 <sgallagh> puiterwijk: Is Cockpit upstream confident that it will be stable in time for Beta?
15:18:53 <sgallagh> (I'm assuming from your previous statement that it's sufficiently-ready for Alpha at this point)
15:19:27 <puiterwijk> sgallagh: ah, yes. I think we are stable in time. We're currently just fixing some easy shoot-yourself-in-the-foot things
15:20:01 <sgallagh> #info Cockpit upstream expects to be stable in time for Fedora 21 Beta. A testable version is available today for Fedora 21 Alpha
15:20:36 <sgallagh> puiterwijk: Any potential blockers (possibly from other projects) that might impede this?
15:20:56 <puiterwijk> sgallagh: not that I am aware of.
15:21:09 <sgallagh> Great!
15:21:09 <danofsatx> puiterwijk: are you saying the SElinux bug preventing cockpit from running is fixed?
15:21:17 * danofsatx hasn't checked the bz lately
15:21:43 <puiterwijk> danofsatx: we now ship cockpit-selinux, which is our own selinux policy, that works
15:21:49 <nirik> side note: I am seeing a broken dep in rawhide here with cockpit-selinux-policy.
15:21:51 <danofsatx> ok
15:22:08 <puiterwijk> nirik: hum, that should be working? isn't it?
15:22:35 <nirik> http://paste.fedoraproject.org/126727/84617421/
15:22:55 <nirik> needs updating for the newer cockpit ?
15:23:19 <puiterwijk> yeah, I think so. let me check into it
15:23:31 <nirik> no problem.
15:24:08 <sgallagh> puiterwijk: Looks like it's not being build in 0.18 or later
15:24:16 <sgallagh> Bad merge?
15:24:31 * sgallagh shrugs. We don't need to fix it here.
15:24:40 <sgallagh> puiterwijk: Thanks for the update. Keep up the good work.
15:24:52 <sgallagh> #topic Open Floor
15:24:55 <puiterwijk> sgallagh: will make sure that gets fixed
15:25:25 <sgallagh> Since we didn't meet last week, I'll just say a couple things about Flock
15:25:46 <sgallagh> I gave a talk on Fedora Server on the second day that was pretty well-attended.
15:26:09 <sgallagh> People were very excited about Cockpit and rolekit (and I even got some OpenLMI questions, which is encouraging)
15:26:31 <danofsatx> Is there any update to the server presets bug?
15:26:38 <danofsatx> .bug 1123845
15:26:41 <zodbot> danofsatx: Bug 1123845 Server presets not applied in systemd scriptlets - https://bugzilla.redhat.com/1123845
15:26:57 <danofsatx> last update in bz is 08/01
15:26:57 <sgallagh> mitr: You were looking into that, weren't you?
15:27:20 <sgallagh> danofsatx: Right before Flock, so it wouldn't surprise me if it fell off the radar
15:27:39 <danofsatx> understood...
15:28:08 <mitr> sgallagh: The patch is applied, but I haven’t reverified this.
15:28:17 <mitr> Can do that today easily enough.
15:28:22 <sgallagh> nirik: Do you know when we can expect a TC3 so I can verify it?
15:28:25 <sgallagh> Or mitr :)
15:28:39 <nirik> well, the mass rebuild just finished. Packages are being signed.
15:28:42 <sgallagh> Cool
15:28:48 <nirik> then we need them tagged in and a compose.
15:28:52 <nirik> so probibly tomorrow.
15:28:58 <sgallagh> Sounds good to me.
15:29:13 <nirik> which I don't know if it means we slip more or freeze. ;)
15:29:17 <mitr> I tested these things with a local compose, will try that today.  Then nirik can do the official one perhaps
15:29:29 <sgallagh> #info We expect a Fedora 21 Alpha TC3 build tomorrow.
15:29:43 <danofsatx> woot!
15:29:45 <sgallagh> #action mitr and/or sgallagh to test the server presets on Alpha TC3
15:30:02 <nirik> well, it should get composed as part of a test compose. ;) but we will see.
15:30:29 <sgallagh> mizmo: You were coordinating the website stuff. How is that going and do you need anything from us?
15:30:55 <sgallagh> (I realize you've been out of the office, so if the answer is "I'm out of the loop", that's acceptable)
15:32:55 <sgallagh> Ok, I guess mizmo must have dropped.
15:33:28 <sgallagh> mizmo: If you see this later, please let us know on the mailing list if you and/or the websites team need anything from us.
15:33:42 <sgallagh> Anyone else have something they'd like to bring up in Open Floor?
15:33:56 * danofsatx is done
15:34:38 * sgallagh waits 120s
15:35:47 <simo> nothing here
15:35:52 <simo> thanks for updates
15:35:53 * nirik has nothing
15:36:51 <sgallagh> #endmeeting