14:02:47 <tflink> #startmeeting qadevel
14:02:47 <zodbot> Meeting started Mon Oct  6 14:02:47 2014 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:57 <tflink> #meetingname qadevel
14:02:57 <zodbot> The meeting name has been set to 'qadevel'
14:03:03 <tflink> #topic welcome
14:03:41 <tflink> anyone here for the qadevel meeting?
14:03:48 * kparal is here
14:05:42 <kparal> mkrizek: welcome
14:05:47 * mkrizek joins
14:05:58 <kparal> I don't think jskladan will come
14:06:20 <tflink> kparal: any idea if there's a better time for him?
14:06:33 <tflink> I suppose I could just ask him directly :)
14:06:38 <kparal> I had a hard time reaching him today as well
14:06:54 <kparal> probably best to talk to him directly
14:07:02 <kparal> I can do that tomorrow
14:07:11 <tflink> hrm, no interns, either
14:08:04 <kparal> that's probably my fault, I didn't ask them to come explicitly
14:08:09 <tflink> like I said, it'll be short :)
14:08:18 <tflink> #topic iteration 6 status
14:08:37 <tflink> some of the bits have been done, but a lot of the tickets are still open
14:08:55 <tflink> https://phab.qadevel.cloud.fedoraproject.org/T322
14:10:11 <kparal> I have to admit I haven't followed the latest development and I didn't have time to work on any ticket lately
14:10:29 <tflink> no worries, I don't think you had any iteration6 tickets
14:10:50 <kparal> jsedlak said he had a patch for T338, was it not posted to Phab?
14:10:58 <tflink> the big missing pieces that I can think of are: bodhi retries, depcheck output and the backup tickets
14:11:03 <kparal> oh, it's linked there
14:11:40 <tflink> I think it's waiting on him
14:12:05 <kparal> yeah, just reading through it
14:12:33 <kparal> I think retrying just 5xx is good enough for the moment, but I don't mind either way
14:12:44 <kparal> but if we need to push it quickly, we can just take it as it is
14:12:56 <kparal> all the error I've seen from Bodhi are 5xx
14:14:03 <tflink> yeah, I can patch the use of 'i' as a variable
14:15:09 <kparal> btw, some return codes are not errors, like 3xx redirect, so we need to take that into account when catching anything except 200 ok
14:15:09 <tflink> I assume that he's gone for the day?
14:15:30 <kparal> I'm today at our local university, so I don't know whether he was in the office
14:15:35 <tflink> true, but a 3xx or a 200 shouldn't throw an error
14:15:43 <kparal> since he's not online, probably is not anymore
14:18:06 <tflink> I don't see john online either
14:18:17 <tflink> kparal: have you talked to him recently about the depcheck output?
14:18:35 <kparal> he asked some questions and advice
14:18:54 <kparal> he showed me some proof of concept new log output, I asked for some changes
14:19:02 <kparal> that was last week
14:19:07 <tflink> he was having some trouble with valid tap generation on friday but I've not heard back from him since then
14:19:10 <kparal> not sure when exactly
14:20:04 <tflink> how long do we want to wait on that?
14:20:05 <kparal> I have no further into than that
14:20:09 <kparal> *info
14:20:24 <tflink> eh, I'll chat with him if/when he shows up online later today
14:20:59 <kparal> maybe ask him to push his changes to some git branch, so we can pick it up if we're in a hurry and want to finish it ourselves
14:21:20 <tflink> yeah, will do
14:21:36 <tflink> I'd like to get everything deployed by tomorrow, if possible
14:21:56 <tflink> and switch off autoqa on friday
14:22:15 <tflink> that would give us until tuesday to back out of it, if needed
14:22:41 <tflink> if I'm remembering the schedule correctly, freeze starts on tuesday
14:22:58 <kparal> 2014-10-14
14:23:02 <kparal> right
14:23:33 <kparal> I'm quite certain people will be unhappy about the current depcheck output. so we should sort it out before then
14:23:42 <tflink> yeah, agreed
14:24:07 <kparal> I'll talk to Josef tomorrow and one of us will take it as a top priority task
14:24:18 * tflink is also wondering if making a few small resultsdb changes would be good to quell frustration
14:24:36 <kparal> just please make sure John pushes his stuff somewhere where we can find it
14:24:43 <tflink> will do
14:25:03 <tflink> #action tflink to get status update on depcheck enhancements from handsome_pirate
14:25:25 <kparal> the alternative is to delay taskotron production, which I guess you're not happy with
14:25:36 <tflink> I'd rather not do that, but we can
14:26:14 <kparal> if we deploy it shortly before freeze and then we find out serious problems during the freeze, what can we do about it?
14:26:14 <tflink> maybe syncing up on thursday or so would be wise - to make the final decision
14:26:36 <tflink> we can ask for freeze breaks
14:27:04 <kparal> ok
14:27:21 <tflink> I'm planning to keep autoqa in hibernation for a while
14:27:38 <tflink> ie - just turn it off instead of deleting anything
14:28:01 <kparal> sure, that's a good idea
14:28:07 <tflink> anything else for iteration6?
14:28:15 <mkrizek> yeah
14:28:23 <mkrizek> https://phab.qadevel.cloud.fedoraproject.org/T333
14:28:32 <mkrizek> this seems high priority to me
14:28:44 <mkrizek> just found out what it was earlier today
14:28:47 * tflink is thinking that we should just extend the iteration for another week since freeze is next week
14:29:06 <tflink> mkrizek: good find, your proposed fix sounds good to me
14:29:21 <mkrizek> cool
14:29:36 * mkrizek is fine with extending the iteration for another week
14:31:02 <tflink> #topic next iteration
14:31:47 <tflink> outside of the depcheck output ticket, anything else that should be done before freeze?
14:32:06 * tflink needs to file a ticket about blockerbugs spamming him relentlessly
14:32:39 <mkrizek> nothing I can't think of
14:32:42 <mkrizek> *can
14:32:53 <kparal> what about upgrading phab?
14:33:00 <kparal> is it affected by freeze?
14:33:02 <tflink> oh yeah, can do
14:33:08 <tflink> technically, no
14:33:22 <tflink> but there's no reason not to update it if your tests turned out well
14:33:27 <kparal> I tested the stg version
14:33:33 <tflink> #action tflink to update production phab
14:33:36 <kparal> there should be a ticket somewhere for you to upgrade it :)
14:34:06 <kparal> in infrastructure project
14:35:11 <tflink> any objections to just extending iteration6 instead of going through all the ticket churn of doing iteration 7?
14:35:35 <kparal> no objections
14:36:12 <tflink> #info will extend iteration 6 for 2 more weeks instead of closing it out - freeze starts next week and a new iteration would mean a lot of ticket churn
14:38:21 <tflink> any other topics that I've forgotten before moving to open floor?
14:39:02 <kparal> nothing here
14:39:11 <tflink> #topic open floor
14:39:17 <kparal> no further topic either
14:39:31 <tflink> any other things before we close out?
14:40:39 * tflink takes that as a no
14:40:47 <tflink> thanks for coming, everyone
14:40:53 * tflink will send out minutes shortly
14:40:56 <tflink> #endmeeting