15:01:34 <sgallagh> #startmeeting Server Working Group Weekly Meeting (2014-10-21)
15:01:34 <zodbot> Meeting started Tue Oct 28 15:01:34 2014 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:34 <sgallagh> #chair sgallagh mizmo nirik davidstrauss stefw adamw simo tuanta mitr
15:01:34 <sgallagh> #topic roll call
15:01:34 <zodbot> Current chairs: adamw davidstrauss mitr mizmo nirik sgallagh simo stefw tuanta
15:01:42 <nirik> .hello kevin
15:01:43 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
15:02:00 <sgallagh> .hello sgallagh
15:02:01 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:02:02 <adamw> .hello adamwill
15:02:05 <zodbot> adamw: adamwill 'Adam Williamson' <adamw+fedora@happyassassin.net>
15:03:30 <sgallagh> ... anyone else?
15:03:31 <stefw> .hello stefw
15:03:32 <zodbot> stefw: stefw 'Stef Walter' <stefw@redhat.com>
15:03:35 * junland here
15:04:05 <andreasn> .hello andreasn
15:04:06 <simo> .hello
15:04:06 <zodbot> simo: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
15:04:09 <zodbot> andreasn: andreasn 'Andreas Nilsson' <anilsson@redhat.com>
15:04:12 <simo> .hello simo
15:04:14 <zodbot> simo: simo 'Simo Sorce' <ssorce@redhat.com>
15:04:17 <simo> uff
15:04:20 <danofsatx> .hello dmossor
15:04:21 <zodbot> danofsatx: dmossor 'Dan Mossor' <danofsatx@gmail.com>
15:04:22 <junland> junland: junland 'John Unland' <opensourcejohn2112@gmail.com>
15:05:00 <sgallagh> OK
15:05:07 <sgallagh> #topic Agenda
15:05:11 <sgallagh> #info Agenda Item: Beta RC Validation Testing
15:05:15 <sgallagh> #info Agenda Item: Test Day Planning
15:05:25 <sgallagh> Any other important agenda topics this week?
15:06:25 <sgallagh> *crickets*
15:06:27 <tuanta> .hello tuanta
15:06:29 <zodbot> tuanta: tuanta 'Truong Anh Tuan' <tuanta@iwayvietnam.com>
15:06:30 <sgallagh> OK
15:06:38 <sgallagh> #topic Beta RC Validation Testing
15:06:39 <sgallagh> #link https://lists.fedoraproject.org/pipermail/server/2014-October/001536.html
15:06:59 <junland> .hello junland
15:07:00 <zodbot> junland: junland 'John Unland' <opensourcejohn2112@gmail.com>
15:07:20 <sgallagh> If you haven't seen it yet, I've put out a call to the Server SIG to assist QA in the RC2 validation that will HOPEFULLY be available within the next 10 hours.
15:07:41 <sgallagh> (And by "hopefully", I mean that adamw and I are cracking skulls to get this done)
15:07:42 <nirik> fingers crossed.
15:07:52 <adamw> all other things being equal we *should* be good from server side, sgallagh has tested with the latest fixes i believe (thanks)
15:08:15 <simo> is there further validation after RC2 ?
15:08:44 <sgallagh> simo: Hopefully not; we want RC2 to be the actual Beta
15:08:57 <simo> I ask because I know about bugs in FreeIPA 4.1, which we *should* get fixed for GA
15:09:02 <simo> but ..
15:09:03 <sgallagh> But we need to get the RC2 out ASAP so that if we find a showstopper, we can fix it before Go/No-Go
15:09:16 <adamw> validation stops once we have a release that passes all the tests...
15:09:16 <sgallagh> simo: We're only talking about Beta validation right now
15:09:23 <sgallagh> Final will have a separate validation cycle
15:09:37 <simo> sgallagh: ok so there is further validation, fine with that
15:10:42 <junland> Go/No-Go is on the 11/10/14?
15:11:13 <sgallagh> junland: Go/No-Go is 47 hours and 50 minutes from now
15:11:21 <junland> Roger.
15:12:02 <sgallagh> So I need volunteers. adamw is overseeing the wider F21 validation and I can only cover so much.
15:12:05 * adamw imagines sgallagh's lair, with giant countdown clock and white cat.
15:12:19 <sgallagh> adamw: Don't be ridiculous. The cat is black.
15:12:29 <adamw> hehe
15:12:58 * junland Can't do tests because of the load of homework / Open Source Presentations this week.
15:13:16 <sgallagh> nirik: Given that you have access to some ARM devices, I was hoping you might be able to split some of the load with pwhalen
15:13:41 <nirik> I can try... I have a beagleboneblack here at home and we have highbank stuff in phx2.
15:13:52 <sgallagh> Thank you
15:14:12 <sgallagh> #action nirik and pwhalen to perform ARM validation
15:14:22 <junland> Does it work on RPi?
15:14:28 <sgallagh> #action sgallagh to handle Active Directory-related validation
15:14:31 <junland> I have one laying around in my drawer?
15:14:40 <simo> junland: how much ram ?
15:14:40 <danofsatx> I'll do my best - my Openstack cluster is *almost* ready to receive guest OS's
15:14:46 <sgallagh> junland: No, there's a downstream Remix for RPi (Pidora)
15:14:54 <junland> It's a Model B 256
15:14:56 <simo> ah Rasp
15:14:58 <sgallagh> It needs non-upstreamed kernel patches
15:15:00 <junland> Got it.
15:15:24 <nirik> it's also an arch we don't support.
15:15:25 <sgallagh> danofsatx: Can you commit to covering some specific areas?
15:15:31 <sgallagh> Right, that too
15:15:40 <danofsatx> uhm, yes.
15:15:48 <sgallagh> danofsatx: Cockpit and firewall, perhaps? :)
15:16:19 <danofsatx> sure. that's easy.
15:16:41 <sgallagh> #action danofsatx to validate Cockpit and firewall test cases.
15:16:42 * danofsatx looks around to see if he saved any hardware for F21 testing
15:17:13 <sgallagh> danofsatx: The cockpit tests includes joining a FreeIPA or AD domain, so you may want to also do the role deployment one.
15:17:36 <danofsatx> awesome, I've got a non-efi optiplex 755, and an efi optiplex 3010 sitting under my desk right now ;)
15:17:40 <sgallagh> simo: Would you have time to handle some or all of the FreeIPA-based tests (including realmd enrollment)?
15:17:53 <danofsatx> roger, I hope to have my domain up by the end of today anyhow.
15:17:58 <sgallagh> ok
15:18:42 <adamw> for anyone who hates editing wiki pages to enter results but loves 1980s-style 'please select a number' TUIs, relval - https://www.happyassassin.net/wikitcms/ - might be useful for report submission.
15:19:11 <sgallagh> #link https://www.happyassassin.net/wikitcms/
15:19:27 <sgallagh> #info For anyone who hates editing wiki pages to enter results but loves 1980s-style 'please select a number' TUIs, try relval
15:20:22 <sgallagh> OK, I think that brings us to full coverage. Naturally, if you discover some spare time, please go ahead and test some of the others too
15:20:33 <sgallagh> Getting more than one set of results is a good thing
15:20:44 <adamw> right, multiple results for one test are OK and indeed encouraged
15:21:06 * junland will try to fit something in...But can't guarantee it.
15:21:09 <sgallagh> #info Anyone who wants to test should do so. Do not feel limited to your committed tests either.
15:21:23 <sgallagh> junland: Understood. We appreciate anything you can do
15:21:24 <adamw> thanks a lot for helping, folks. the announcement will be sent to server list when the compose is done, it will live at https://dl.fedoraproject.org/pub/alt/stage/21_Beta_RC2/Server
15:21:38 <sgallagh> #link https://dl.fedoraproject.org/pub/alt/stage/21_Beta_RC2/Server
15:21:42 <junland> spallagh: Thank, just doing my part :)
15:21:47 <junland> Thanks*
15:22:12 <sgallagh> OK, did I miss anything?
15:22:46 <sgallagh> #info Disregard the Database Role test, as that was always a "nice-to-have" and it didn't get implemented.
15:22:58 <sgallagh> It is not release-blocking
15:23:12 <adamw> i put it in the matrix as it at least seemed to exist in the rolekit package
15:23:17 <adamw> i didn't try it
15:23:27 <sgallagh> Yeah, there's a skeleton for it, but it's nonfunctional.
15:23:40 <sgallagh> I thought we purged it from the Fedora builds, but we must have forgotten.
15:23:42 <sgallagh> I'll do that before Fina
15:23:46 <sgallagh> *Final
15:24:01 <sgallagh> #action sgallagh to make sure that non-functional Roles don't show up in rolekit for Final.
15:24:32 <simo> sgallagh: I am in a pinch today
15:24:42 <sgallagh> simo: Hmm?
15:24:46 <adamw> ok, i can drop it from the matrix if it's known broken.
15:24:47 <simo> (working on a security fix)
15:24:55 <sgallagh> adamw: Please do, thank you
15:25:20 <simo> sgallagh: are FreeIPA-based tests due today ?
15:25:20 <sgallagh> simo: The compose will take about 8 hours from when it starts. So most likely, validation will be tomorrow.
15:25:26 <simo> ah ok
15:25:31 <simo> then I might be able to
15:25:56 <simo> sgallagh: if you ping me tomorrow when you start I can work side by side on #fedora-server
15:25:58 <sgallagh> Thank you. If you can't, please let me know by tomorrow morning and I'll make arrangements
15:26:35 <sgallagh> #action simo to try to handle the FreeIPA-based validation. May have a conflict.
15:27:14 <sgallagh> OK, let's move on to the Test Day
15:27:19 <sgallagh> #topic Test Day Planning
15:27:24 * junland is ready
15:27:45 <stefw> sgallagh, i imagine the Test Day is only to find blockers given that it's pretty late?
15:28:18 <sgallagh> stefw: Well, finding blockers would be great, but there's still value in getting testing and feature requests.
15:28:19 <simo> sgallagh: today is 28th btw (all the topics use 21 in the date)
15:28:23 <sgallagh> We don't have to FIX them for Final
15:28:35 <adamw> stefw: test days are generally pretty open. there is still a period between beta and final freeze when non-blocker/FE changes can be landed, and of course there are post-release updates.
15:28:37 <sgallagh> ah, crud. I forgot to change that when I copied the template from last week
15:28:55 <stefw> makes sense
15:29:42 <sgallagh> I'm thinking that junland's suggestion of starting with the Validation tests and then moving on to free-form playing around trying to break it might be sensible.
15:29:50 * nirik nods
15:30:06 <junland> Yes, let's just copy the TC's and they it's free-for all for everyone.
15:30:28 <junland> Let's not kill ourselves over this.
15:30:34 * sgallagh nods
15:30:56 <sgallagh> adamw: Do we have anything in particular that we're going to add to Final validation that isn't in Beta?
15:31:05 <sgallagh> We should probably discuss that prior to the Test Day
15:31:30 <junland> Now about the ticket issue. Does someone have admin privileges to get a QA ticket?
15:31:31 <danofsatx> that would be good.
15:31:35 <adamw> junland: we already have a large set of realmd and freeipa test cases available to refer to, btw.
15:31:55 <adamw> junland: eh? where do you need admin privileges?
15:31:57 <sgallagh> adamw: Mind linking them for the meeting notes?
15:32:00 <junland> adamw, could you provide links?
15:32:14 <adamw> https://fedoraproject.org/wiki/Category:FreeIPA_Test_Cases and https://fedoraproject.org/wiki/Category:Realmd_Test_Cases
15:32:15 <sgallagh> adamw: He reported that he was denied creating a ticket for lack of the CREATE_TICKET privilege
15:32:25 <adamw> they're from older freeipa and realmd test days
15:32:26 <sgallagh> #link https://fedoraproject.org/wiki/Category:FreeIPA_Test_Cases
15:32:26 <sgallagh> #link https://fedoraproject.org/wiki/Category:Realmd_Test_Cases
15:32:27 * junland nods
15:32:31 <adamw> where? QA trac?
15:32:34 <adamw> were you logged in?
15:32:41 <junland> Yes I was.
15:33:07 * junland tries to find link.
15:33:29 <nirik> make double sure you are logged in before trying to create the ticket.
15:33:31 <adamw> are you sure?
15:33:44 <adamw> trac permissions has TICKET_CREATE set to 'authenticated'.
15:33:50 <simo> sgallagh: we should test with freeipa 4.0.4, right ?
15:33:53 <adamw> i.e., any signed-in user should be able to create a ticket.
15:34:16 <sgallagh> simo: 4.0.3 is what's in stable. However, rolekit will automatically pull from updates-testing by default.
15:34:27 <junland> Okay, well I'll try again later today....
15:34:27 <adamw> you can disable updates-testing before running tests'
15:34:33 <sgallagh> For validation, I noted how to disable updates-testing
15:34:33 <adamw> we're still kind of feeling out the logic of that
15:34:36 <sgallagh> In the testcase
15:34:46 <simo> sgallagh: we do not want 4.1 it has serious stability issues
15:34:50 <simo> 4.0.3 will do
15:34:52 <sgallagh> ok
15:34:53 <adamw> things get a bit fuzzy when we have validation tests that inherently pull from repos
15:35:00 * sgallagh nods
15:35:09 <simo> however those 29 tests will take days, not just tomorrow
15:35:12 <sgallagh> #info Test with stable packages where possible, please
15:35:14 <simo> I think we'll have to skip some
15:35:28 <sgallagh> simo: The test cases above aren't part of validation
15:35:34 <sgallagh> Those are proposed for the Test Day
15:35:38 <simo> ah
15:35:42 <sgallagh> Different level of urgency :)
15:36:02 <sgallagh> Only the ones at https://www.happyassassin.net/testcase_stats/21/Server.html are blockers
15:36:07 <simo> do we have a checklist for validation ? sorry f I missed it earlier
15:36:20 <simo> ok
15:36:21 <sgallagh> simo: One line above :)
15:36:51 <junland> Also would we like to get have Test Day's running all next week?
15:37:22 <sgallagh> No, we want a single coordinated event, IMHO
15:37:32 <sgallagh> It's best if we know when we need to be around to answer questions and help
15:37:59 * junland was able to login.
15:38:06 <junland> Okay I'm in.
15:38:27 <junland> So what day would that be so I can create a ticket?
15:39:07 <sgallagh> Is Nov 7 still open?
15:39:15 <junland> For me yes.
15:39:49 <junland> Don't know about anyone else.
15:39:57 <sgallagh> junland: I mean, is there an available slot
15:40:03 <sgallagh> https://apps.fedoraproject.org/calendar/list/QA/?subject=Test+Day
15:40:39 <adamw> should be.
15:40:47 <adamw> roshi's been mainly looking after test days this cycle, though.
15:40:52 <junland> Yup it's open.
15:41:08 <sgallagh> I can attend.
15:41:26 <junland> Same here. It's on a Friday so no classes.
15:42:38 <sgallagh> I can attend.
15:42:39 <sgallagh> Does anyone have a real problem with that date?
15:43:13 <junland> I'm guessing everyone is checking there calendars?
15:43:25 <simo> I don't immidiately see a problem with Nov 7th
15:43:46 <sgallagh> OK, let's assume it works for now
15:43:49 * nirik has no issues with it off hand either.
15:44:00 <sgallagh> #info Fedora Server Test Day on November 7, 2014
15:44:08 <danofsatx> yay
15:44:10 <sgallagh> #action junland to set it up
15:44:12 <junland> I can go ahead and make a ticket later today. Then start making a wiki page.
15:44:19 <sgallagh> junland: Thank you
15:44:32 <junland> spallagh: No problem.
15:44:50 <sgallagh> #topic Open Floor
15:45:06 <sgallagh> Anything for Open Floor?
15:46:21 <sgallagh> OK, I'll set the fuse for 120s
15:47:45 <danofsatx> just wanted to note that Openstack Juno is not recommended for F21 at this time.
15:47:58 <danofsatx> as a host, anyhow....
15:48:24 <sgallagh> Noted
15:48:36 <sgallagh> OK, thanks for coming, everyone
15:48:42 <sgallagh> #endmeeting