19:01:05 <kushal> #startmeeting Fedora Cloud SIG
19:01:05 <zodbot> Meeting started Wed Jan  7 19:01:05 2015 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:19 <kushal> #meetingname Fedora Cloud SIG
19:01:19 <zodbot> The meeting name has been set to 'fedora_cloud_sig'
19:01:27 <kushal> #topic Roll Call
19:01:29 <jsmith> .hellomynameis jsmith
19:01:29 <roshi> .hello roshi
19:01:29 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
19:01:32 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:01:35 <oddshocks> .hellomynameis oddshocks
19:01:35 <kushal> .hellomynameis kushal
19:01:35 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
19:01:38 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:01:47 <lsm5> .hellomynameis lsm5
19:01:48 <zodbot> lsm5: lsm5 'Lokesh Mandvekar' <lsm5@redhat.com>
19:01:54 <langdon> .hellomynameis langdon
19:01:55 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
19:01:57 <kushal> scollier, hello
19:02:03 <soumyaC> .hellomynameis soumya
19:02:04 <scollier> hey kushal
19:02:05 <zodbot> soumyaC: soumya 'Soumya Kanti Chakraborty' <soumya@dgplug.org>
19:02:10 <dustymabe> .hellomynameis dustymabe
19:02:11 <scollier> .hellomynameis scollier
19:02:11 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
19:02:17 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
19:02:22 <roshi> quite the turnout today :)
19:02:32 <kushal> roshi, Yeah, almost full house.
19:02:34 <jzb> .hellomynameis jzb
19:02:35 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
19:02:55 <kushal> Happy new year everyone :)
19:03:04 <dustymabe> kushal: happy new year
19:03:11 <roshi> happy new year!
19:03:29 * roshi is glad to note that we seem to have survived another calendar year. Hoping to keep that tradition up :p
19:03:52 <kushal> roshi, haha
19:04:11 <kushal> #topic Action items from last meeting
19:04:14 * langdon says on the internet no one knows if you are an autonomous computer /cc roshi
19:04:27 <kushal> * jzb work on Ticket 87 (Fedora Magazine Post on Dockerfiles)
19:04:27 <kushal> * jzb create ticket for defining dockerfile collaboration
19:04:29 <roshi> shh, can't have people finding out
19:04:34 <jzb> langdon: isn't that what captchas are for?
19:04:40 <kushal> langdon, #reboot
19:04:46 <roshi> I Am The Captcha
19:04:50 <rtnpro> .fas rtnpro
19:04:51 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
19:04:53 <kushal> It seems the command failed.
19:05:00 <kushal> langdon, :)
19:05:01 <jzb> kushal: nothing new to report on my end since holidays.
19:05:17 <kushal> jzb, I hope you had good holidays :)
19:05:28 <jzb> kushal: I moved from STL to RDU... so, mostly unpacking.
19:05:38 <kushal> jzb, Ah, nice to know that.
19:06:00 <langdon> kushal, :)
19:06:13 <roshi> STL?
19:06:18 * roshi doesn't know airport codes
19:06:21 <langdon> roshi, st louis
19:06:33 <roshi> ah
19:07:08 <kushal> #topic Regular topics
19:07:12 <kushal> From https://fedorahosted.org/cloud/report/9
19:07:34 <kushal> #topic support HVM instances in EC2 (#68)
19:08:01 <kushal> oddshocks, Anything you can add on that ^^
19:08:04 <kushal> ?
19:08:08 <oddshocks> sure can
19:08:38 <oddshocks> Was talking in #fedora-cloud about this last night. I'm moving around some bits as we speak that should accomplish this
19:08:51 <oddshocks> Just making sure the tests run on both virtualization types as well
19:09:04 <roshi> sweet
19:09:14 <oddshocks> I can update the ticket when I've got something to test, maybe later today?
19:09:28 <kushal> oddshocks, cool, thanks :)
19:09:54 <kushal> #action oddshocks will update #68 when he has something to test.
19:09:56 <oddshocks> I'll see if it works with the x86_64 fedora 21 base image. That is, see if the same image boots fine with Fedimg making it available in HVM and pv-grub
19:10:03 <oddshocks> cool :)
19:11:14 <kushal> #topic publicize fedora-dockerfiles (#84)
19:11:36 <langdon> i wrote a blog post :)
19:11:52 <kushal> langdon, Yes, thanks for that :D
19:12:13 <dustymabe> langdon.. link?
19:12:24 * langdon digs
19:12:26 <dustymabe> I want to add you to my reader
19:12:51 <langdon> ha
19:12:54 <langdon> http://fedoramagazine.org/fedora-dockerfiles-ready-to-go-recipes-for-easy-app-deployment/
19:12:54 <kushal> dustymabe, http://fedoramagazine.org/fedora-dockerfiles-ready-to-go-recipes-for-easy-app-deployment/
19:12:55 <jzb> langdon: are you on Planet Fedora?
19:13:03 <kushal> jzb, This was on magazine.
19:13:07 <dustymabe> :) - ok cool
19:13:13 <dustymabe> I thought maybe you had a personal blog
19:13:21 <langdon> i rarely publish on my own channel.. fed-mag and rhel-dev mostly.. which should really change.. but i stink
19:14:20 <kushal> We have two more tickets which are in the same line of this one, Fedora Magazine Post: How to Use Dockerfiles and Social Media for Dockerfiles. jzb Can we discuss these here now?
19:14:51 <kushal> One of my personal goal is to write more, I will surely do posts on these too.
19:15:17 <kushal> soumyaC, rtnpro, may be you want to write some posts on the same topic.
19:15:19 <jzb> kushal: I think we've discussed previously - it's just a matter of doing, unless there's questions.
19:15:25 <jzb> kushal: just no movement over the holidays.
19:15:42 <jzb> I should commit to knocking one out by next week
19:15:43 <rtnpro> kushal, ok
19:15:49 <kushal> jzb, Yes, just want to get that noted during this topic once again. Thanks :)
19:15:52 <langdon> does anyone have a list of proposed topics/headlines? that often makes it easier for somoene to write something
19:16:09 <langdon> like tighter than "fed-dockerfiles"
19:16:11 <jzb> #action jzb write "how to use dockerfiles" by next Cloud SIG meeting
19:16:35 <roshi> good point langdon
19:16:45 <kushal> langdon, we don't but we should.
19:17:05 <soumyaC> kushal, will add it to my "things to do".
19:17:09 <scollier> langdon, 1. fedora images on docker hub, 2. how to contribute - what's needed?
19:17:15 <langdon> personally i think a "how to contribute a fed-dockerfile" would be nice
19:17:18 * rtnpro will draft and share article on Docker on Fedora for review
19:17:23 <kushal> jzb, langdon Personally I would love to see more posts on Fedora atomic image at the same time.
19:17:35 * langdon yeah.. what he (scollier) said
19:18:32 <jzb> any other headline/post suggestions?
19:18:41 <langdon> scollier, i think having "quality information" would be nice.. like "how to indicate if 1) WIP 2) done but not terribly tested 3) solid" but that could be in 'how to contribute"
19:18:43 <jzb> do we have any Dockerfiles that we specifically want to highlight?
19:19:02 <langdon> another head: how to write a dependent dockerfile for fed-dockerfiles?
19:19:26 <jzb> langdon: We might need to explain dependent Dockerfiles...
19:19:33 <kushal> "What can I do with these dockerfiles?"
19:19:37 <jzb> so... "What is a Dependent Dockerfile?"
19:19:42 <scollier> langdon, we have a needs work directory, but i was thinking about nuking that and just shifting to a PR process
19:19:48 <scollier> langdon, the "WIP", is a PR..
19:20:55 <scollier> langdon, then, and maybe this is off topic, but, being "solid" between one version of docker and another is... eh... not solid.
19:20:58 <langdon> scollier, yeah.. ok.. still think it needs "2" though.. this stuff is so new a lot of people wont be confident that their stuff is prod ready or how to prove that it is
19:21:08 <langdon> scollier, lol
19:21:40 <scollier> langdon, and not only versions of docker, but package updates can ruin a docker image too.
19:21:58 <scollier> langdon, so, i gues what i'm saying is, we either need some sort of CI process to keep these things in check, or it's def a YMMV.
19:22:01 <langdon> scollier, well.. that is why you shouldn't use dockerfiles ;)
19:22:12 <langdon> scollier, +1
19:22:27 <langdon> i think that is another blog post
19:22:37 <scollier> ok
19:22:47 <langdon> like "why fed-dockerfiles are reference only, and yours are too, unless you do this CI thing"
19:23:19 <roshi> not a bad idea
19:23:26 * roshi hasn't touched the dockerfile due to lack of time
19:23:35 <roshi> I have every intent to though :P
19:23:50 <jzb> langdon: we're saying "hey, use these, but don't use these"?
19:23:59 <langdon> roshi, pretend easy to use, widely distributed custom kickstarter files... that everyone expects to work perfectly :)
19:24:13 <scollier> jzb, i think we are saying, use these as an educational tool, not in prod.  but, doesn't that go without saying?
19:24:31 <roshi> few things go without saying
19:24:34 <jzb> scollier: actually, if we're promoting them, it might need saying
19:24:53 <langdon> well not nec. not in prod, but ymmv .. and oyu better test it first.. this bs about docker being a panacea is the problem
19:24:53 <scollier> agree.
19:24:53 <kushal> scollier, we have to make that clear.
19:24:59 <scollier> kushal, got it.
19:25:24 <jzb> how about...
19:25:42 <jzb> "How to Go from Fedora Reference Dockerfiles to Production Containers"?
19:25:45 <scollier> kushal, where would we start with fedora based CI inclusion?
19:25:47 <langdon> not to further tout my own writing but : http://www.drdobbs.com/architecture-and-design/containers-for-development/240168801 ;)
19:25:56 <jzb> or something like that that basically says how to use them as a starting point
19:25:59 <jzb> ?
19:26:10 <jzb> langdon: ah, Dr. Dobbs. We miss you.
19:26:36 <langdon> scollier, i think the proposal is on the table with a docker build service from copr/scl.o or something similar...
19:26:40 <scollier> i see this: http://jenkins.cloud.fedoraproject.org/   maybe that, maybe not?
19:26:55 <scollier> langdon, hmm
19:26:57 <kushal> scollier, I think that is the starting point.
19:27:07 <kushal> scollier, I will pass you more details this week.
19:27:12 <scollier> kushal, ok
19:27:21 <kushal> #action Kushal will send CI details to scollier
19:27:39 <langdon> kushal, i would like to get plugged in to that as well.. I also think this needs coordination with envs&stacks
19:27:46 <scollier> kushal, in summary, what i would like to see, is when a change is made to a dockerfile, or a new dockerfile is submitted, that the image is built, and that it responds in and expected manner, automagically.
19:28:07 <kushal> langdon, Understood.
19:28:10 <kushal> #undo
19:28:10 <zodbot> Removing item from minutes: ACTION by kushal at 19:27:21 : Kushal will send CI details to scollier
19:28:16 <kushal> #action Kushal will send CI details to scollier  and langdon
19:28:47 <jzb> added a few suggested headlines to the ticket:
19:28:49 <jzb> https://fedorahosted.org/cloud/ticket/84#comment:8
19:28:54 <langdon> scollier, we talked about doing it as a fedmsg msg.. 1)dockerfile change 2) fedmsg "please build" 3) build 4) msg "built"
19:28:54 <jzb> feel free to add more
19:28:58 <kushal> jzb, Thanks :)
19:29:11 <scollier> langdon, 5) tested
19:29:16 <langdon> pshaw
19:29:20 <scollier> haha
19:29:22 <scollier> cmon now
19:29:44 <langdon> 4 should not be complete without test being complete :)
19:29:59 <scollier> langdon, no, you have to build before you can test it
19:30:22 <scollier> langdon, for example, the apache image must respond to a request on port 80
19:30:35 <scollier> so that requires a docker run
19:30:36 <langdon> scollier, yes... no..
19:30:54 <langdon> i meant the "build service step should not be complete until the tests are complete"
19:31:11 <langdon> as in "we should not tell the user it is cooked until the tests have all been run"
19:31:22 <scollier> langdon, understand.
19:32:28 <kushal> Can we move on to the next points?
19:32:34 <kushal> s/points/tickets
19:32:36 <scollier> sure
19:33:23 <kushal> #topic Update Timezone for the docker images (#91)
19:33:47 <kushal> I have received a patch from lsm5 for the same, I will apply locally and test it out.
19:34:06 <kushal> #action Kushal to test the patch from lsm5 on docker image timezone.
19:34:12 <jzb> kushal: is that going to cause any problems for people using the image currently?
19:34:24 <jzb> if the image suddenly updates and switches time zones?
19:34:49 <kushal> jzb, None as I can imagine.
19:35:30 <kushal> jzb, in case people are changing the timezone, they will do that anyway.
19:35:50 <lsm5> scollier: also, about the .profile thing you mentioned earlier ... that's something that should go into the f21 image too
19:35:59 <lsm5> kushal: ^
19:36:12 <jzb> ok
19:36:22 <scollier> lsm5, sure.  kushal, i noticed at least 1 inconsistency between the fedora:20 image and fedora:latest image
19:36:24 <scollier> from docker hub.
19:36:37 <scollier> the fedora:20 image has a /root/.bashrc, fedora:latest does not.
19:36:39 <kushal> lsm5, Okay, can you please create another ticket for the same?
19:36:52 <scollier> kushal, we would like that in all images
19:37:22 <kushal> scollier, fedora:latest is the build from koji
19:37:28 <kushal> scollier, 20 is from lsm5 iirc.
19:37:36 <lsm5> kushal: yes
19:37:45 <scollier> kushal, can koji modify that?
19:38:33 <kushal> scollier, I guess that was added in the way lsm5 was building the image, the imagefactory builds do not contain that file.
19:38:47 <kushal> lsm5, Am I correct in the assumption?
19:39:20 <lsm5> kushal: i've no idea where .bashrc came from, i'll blame it on appliance-creator /cc scollier
19:39:27 <kushal> Yeah
19:39:37 <scollier> kushal, rootfiles package
19:40:09 <kushal> scollier, Okay, we will have to look into this one then.
19:40:15 <kushal> scollier, Can you please file a ticket?
19:40:15 <lsm5> kushal: perhaps we could just have the kickstart include rootfiles
19:40:21 <kushal> lsm5, Yes.
19:40:21 <scollier> kushal, sure.
19:40:25 <scollier> lsm5, that's what i was thinking
19:40:33 <kushal> Having a ticket means we will not forget that.
19:41:59 <lsm5> ack
19:42:15 <kushal> Moving on then.
19:42:22 <kushal> #topic Decide whether to update cloud image to not include ruby (#90)
19:42:40 <kushal> I tried to boot the lastest nightly build on an openstack, did not boot.
19:42:54 <kushal> I will dig more tomorrow.
19:43:57 <kushal> Any comments on the topic?
19:44:34 <jzb> kushal: I commented on the ticket
19:44:36 <jzb> nothing to add
19:45:35 <scollier> kushal, ticket created for rootfiles
19:45:53 <kushal> scollier, Thanks :)
19:46:06 <kushal> #topic Open Floor
19:46:16 <kushal> dustymabe, any update from DO?
19:46:22 <dustymabe> kushal: yep
19:46:29 <dustymabe> roshi and I tested a bit
19:46:38 <dustymabe> seems like we are pretty close to releasing F21
19:46:52 <roshi> yeah
19:46:55 <dustymabe> I actually just spoke with some of them and they may release as early as friday
19:47:08 <dustymabe> jzb: we want a fedora magazine post correct?
19:47:08 <roshi> it was working for me, passed all the basic tests we usually run
19:47:13 <jzb> dustymabe: yeppers
19:47:22 <dustymabe> they sent me this https://www.digitalocean.com/company/logos-and-badges/
19:47:28 <dustymabe> if we want to use their logo in the post
19:47:49 <jzb> dustymabe: I'd use it as the "featured image" in the post
19:48:14 <dustymabe> ok good
19:48:38 <kushal> dustymabe, awesome :)
19:48:49 <dustymabe> I can try to write something up.. I might try to find an old post to mimic or something :)
19:49:23 <jzb> dustymabe: lemme know if you need help drafting something
19:49:37 <jzb> dustymabe: doesn't need to be great prose, just "hey - look what's going on here!"
19:49:58 <dustymabe> jzb: ok cool
19:50:04 <dustymabe> thanks
19:50:06 <kushal> One important point.
19:50:18 <kushal> Please start filing feature proposals for Fedora 22
19:50:34 <kushal> I think January 20 is the last date (I may be wrong).
19:50:45 <jzb> kushal: we should probably blast that to the list
19:50:50 <jzb> (and confirm the date)
19:51:13 <kushal> jzb, yes.
19:52:20 <kushal> I am planning to work on a separate test system for nightly and other cloud image builds from koji, I will use testCloud from roshi in it.
19:52:40 <kushal> This will be a complete automated system.
19:52:53 * jzb reminds roshi that he was going to file testCloud as a feature for F22/package it.
19:53:52 <kushal> jzb, :)
19:54:22 <roshi> was I?
19:54:33 <roshi> I was going to package it, but does it need a feature request?
19:55:05 <jzb> hmmm
19:55:06 <jzb> maybe not?
19:55:07 * roshi isn't too familiar with the feature proposal process
19:55:15 <jzb> I guess a regular package no
19:55:21 <roshi> I mean, if we want it included on workstation or something, then we would
19:55:25 <roshi> aiui
19:55:46 <kushal> roshi, Yes
19:55:57 <kushal> roshi, It is a very good feature to have.
19:56:07 <roshi> is that a thing people would want on WS?
19:56:21 <kushal> roshi, It is a feature for the cloud people.
19:56:40 <kushal> roshi, and WS may want to include it.
19:56:45 <langdon> roshi, can you point me at a link for what testcloud is?
19:57:18 <jzb> langdon: https://github.com/Rorosha/testCloud
19:57:28 <langdon> jzb, thanks
19:57:34 <jzb> roshi: note that testCloud is not terribly google-able.
19:57:38 <roshi> we can ask
19:57:42 <jzb> roshi: you might want to rename it something unique
19:57:42 <roshi> I hadn't thought of that
19:57:54 <roshi> and is it a "feature" for cloud?
19:57:55 <jzb> roshi: "SharkCat" :-)
19:58:06 <roshi> I mean, I thought a feature was something on the cloud image itself
19:58:10 <roshi> but I could just be confused
19:58:24 <kushal> roshi, It cloud be anything related to Fedora 22.
19:58:27 <jzb> mmmm, maybe not
19:58:28 <kushal> oops
19:58:28 <roshi> yeah, jzb - guess I should look at a name or something
19:58:31 <kushal> could
19:58:34 <langdon> roshi, have you looked at the similar concept in ubuntu land? or should this be an offline discussion?
19:58:42 <roshi> it can be offline
19:58:48 <roshi> I hadn't
19:58:57 <jzb> langdon: which in Ubuntu?
19:59:02 <roshi> I wrote this to scratch an itch I had, but it turns out others have the same itch :p
19:59:18 <jzb> they have an ointment for that.
19:59:19 <roshi> I honestly didn't think people would use it
19:59:23 * langdon digs, notes it doesnt support fed, and this is a pain point for me too
19:59:26 <roshi> python oil?
19:59:46 <kushal> roshi, I am heavily dependent on it.
19:59:57 * jzb has to run to another meeting
19:59:58 <kushal> It is almost time to finish.
20:00:10 <kushal> Thank you everyone for coming down.
20:00:20 <roshi> I'm glad it's useful :) I just didn't expect it to be :)
20:00:20 <kushal> Going to close this meeting in 5
20:00:21 <kushal> 4
20:00:22 <kushal> 3
20:00:24 <kushal> 2
20:00:25 <kushal> 1
20:00:30 <kushal> #endmeeting