17:01:24 <geppetto> #startmeeting fpc
17:01:24 <zodbot> Meeting started Thu Jan  8 17:01:24 2015 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:25 <geppetto> #meetingname fpc
17:01:25 <zodbot> The meeting name has been set to 'fpc'
17:01:25 <geppetto> #topic Roll Call
17:01:38 <orionp> morning
17:01:44 <tibbs|w> Hello everyone.
17:01:48 <geppetto> #chair orionp
17:01:48 <zodbot> Current chairs: geppetto orionp
17:01:54 <geppetto> #chair tibbs|w
17:01:54 <zodbot> Current chairs: geppetto orionp tibbs|w
17:01:58 <Rathann> hi
17:01:59 * tomspur is here, but might need to leave earlier... :/
17:02:02 <tibbs|w> Sorry for spamming your mailboxes with FPC ticket updates over the last month.
17:02:03 <geppetto> #chair Rathann
17:02:03 <zodbot> Current chairs: Rathann geppetto orionp tibbs|w
17:02:06 <geppetto> #chair tomspur
17:02:06 <zodbot> Current chairs: Rathann geppetto orionp tibbs|w tomspur
17:02:32 <tomspur> tibbs|w: where can I subscribe to all fpc ticket updates?
17:02:39 <geppetto> tibbs|w: ha, no need to appologize for doing a bunch of the ticket work
17:02:50 * tomspur looks them by hand right now...
17:02:54 <tibbs|w> tomspur: You don't get them?  We must have screwed up.
17:03:15 <tibbs|w> Let me dig into trac.
17:03:51 <tibbs|w> You have trac_admin, so you can add yourself to ticket CC if you like.
17:05:08 * limburgher hi
17:05:11 <tomspur> tibbs|w: you mean in the permissions tab in trac?
17:05:14 <geppetto> #chair limburgher
17:05:14 <zodbot> Current chairs: Rathann geppetto limburgher orionp tibbs|w tomspur
17:05:52 <geppetto> #topic #484 	Minor PHP Guidelines update (for PSR-4)
17:05:52 <geppetto> .fpc 484
17:05:52 <geppetto> https://fedorahosted.org/fpc/ticket/484
17:06:10 <geppetto> RemiFedora: you are up :)
17:06:46 <RemiFedora> any question, seems very minor trivial
17:07:05 <tibbs|w> This is fine with me, as far as I actually understand the underlying issue.
17:07:09 <RemiFedora> just because the question have raised duriung a recent review
17:07:12 <geppetto> I don't really understand this, but it looks trivial to +1
17:07:20 <limburgher> Agreed.
17:07:20 <tibbs|w> By the way, why the backslashes in Foo\Bar?
17:07:36 <RemiFedora> the \ is the PHP namespce separator
17:07:52 <tibbs|w> Ah, it's a namespace thing.  I thought it was the windows directory convention.
17:08:02 * racor is here
17:08:07 <geppetto> #chair racor
17:08:07 <zodbot> Current chairs: Rathann geppetto limburgher orionp racor tibbs|w tomspur
17:08:11 <tibbs|w> Anyway, +1.
17:08:28 <geppetto> RemiFedora: Do you know where you want to add that block?
17:08:51 <RemiFedora> geppetto, juste after the PSR-0 one
17:09:00 <limburgher> +1
17:09:05 <geppetto> ok, +1
17:09:35 <Rathann> +1 from me as well
17:09:47 <RemiFedora> notice, guidelines already applied for some package when upstream move from psr-0 to psr-4 sources (to keep the update consistent = same content)
17:10:23 <racor> +1
17:10:28 <geppetto> vote: Rathann tomspur orionp ?
17:10:42 <Rathann> geppetto: I did, +1
17:10:57 <geppetto> you're right, who did I miss then
17:11:15 <orionp> seems fine +1 - just wondering if the language could be made less technical - I've packaged a few php libs at times and don't understand "PSR-0" "PSR-4"
17:11:21 <tomspur> Honestly speaking, I don't quite get it, so I'd +0 here...
17:11:41 <RemiFedora> orionp, there is a link to the standard definition at the end of the page
17:12:35 <geppetto> #action Minor PHP Guidelines update, for PSR-4 (+1:6, 0:1, -1:0)
17:12:36 <tibbs|w> To clarify, this goes in the File Placement section, and the link goes at the very end?
17:12:44 <tibbs|w> I'll write it up now if so.
17:12:49 <RemiFedora> tibbs|w, yes
17:12:59 <geppetto> tibbs|w: cool, thanks
17:13:08 <geppetto> #topic #486 	help2man
17:13:08 <geppetto> .fpc 486
17:13:08 <geppetto> https://fedorahosted.org/fpc/ticket/486
17:13:18 <tibbs|w> I'm not struggling as much with the wiki these days, so I'll try to just take care of these.
17:13:41 <tibbs|w> For 486, I didn't think it was worth including help2man instructions at all.
17:14:00 <tibbs|w> But I don't see the harm in mentioning it, I guess.   Honestly I'm not sure how useful it is.
17:14:16 <tomspur> Your counterproposal seems fine
17:14:35 <geppetto> yeh, +1 on tibbs proposal
17:14:38 <racor> I don't think this is useful.
17:14:56 <limburgher> +1 for tibbs
17:15:00 <geppetto> racor: I would say that I didn't know about this before … so it's probably useful to mention it
17:15:06 <racor> Whether and how to provide man-pages should remain subject to upstreams.
17:15:28 <racor> geppetto: I am the help2man maintainer :)
17:15:33 <geppetto> :)
17:16:08 <geppetto> I think we provide a bunch of manual pages that aren't upstream, right?
17:16:21 <geppetto> even if most of them have been lifted from Debian :)
17:16:56 <Rathann> +1 for tibbs' counterproposal
17:17:01 <geppetto> eh … I'm still +1, but don't care if it doesn't pass :)
17:17:24 <tibbs|w> Yes, we do.  The guidelines do suggest a way to get additional manpages from !upstream, so I figured adding another wouldn't hurt.  Alternately we could remove mention of where to get additional manpages.
17:17:31 <tibbs|w> But +1 to my thing, obviously.
17:17:38 <orionp> Seems like there could be lots of man page generating software one could mention, why only this?
17:17:47 <orionp> or so, why any?
17:17:53 <racor> geppetto: I am not opposed to maintainers adding Debian or help2man man-pages, I just want to avoid these flamewars on "missing man-pages" which occasional hit Debian
17:18:32 * geppetto nods … I'd assume (hope?) that the change is small enough that it wouldn't generate any flamewars that wouldn't happen anyway
17:19:13 <geppetto> orionp: I think most other software actually generate complete man pages though … like perl2man/texinfo/etc.
17:20:56 <tibbs|w> orionp: If there are others which would be useful, we could add them.  We're just addressing what was proposed to it.
17:21:02 <tibbs|w> s/it/us/
17:21:18 <tibbs|w> I don't think this is worth spending any more time on, though.
17:24:17 <geppetto> So we are +1:3, 0:1, -1:1 ?
17:24:35 <tibbs|w> +4, I think.
17:24:40 * tomspur was already +1
17:25:00 * limburgher was too
17:25:04 <geppetto> ahh, +5 I think then
17:25:08 <racor> tibbs|w: I think the question behind this is: Do we want to encourage packagers to add non-upstream man pages.
17:25:12 <tibbs|w> Then +5. geppetto, limb, Rathan, me, tomspur
17:25:16 <tibbs|w> racor: We already do.
17:25:17 * geppetto nods
17:25:46 <tibbs|w> The guidelines say all executables _should_ have manpages.
17:25:55 <tibbs|w> https://fedoraproject.org/wiki/Packaging:Guidelines#Manpages
17:26:13 <racor> tibbs|w: I don't consider this useful. They tend to rot and to be incomplete, not worth mentioning incomplete i18n
17:26:35 <geppetto> Well, often something is better than nothing
17:26:41 <geppetto> esp. when you include things like man -k
17:26:50 <tibbs|w> Well, I suppose file a ticket to remove that?  It's been in the guidelines forever, we're just mentioning an alternate source for them besides Debian.
17:26:56 * SmootherFrOgZ is here/late
17:27:03 <geppetto> #chair SmootherFrOgZ
17:27:03 <zodbot> Current chairs: Rathann SmootherFrOgZ geppetto limburgher orionp racor tibbs|w tomspur
17:27:05 <tibbs|w> But that's off-topic for tiscussion of #486.
17:27:08 <racor> geppetto: You don't often read man-pages in other languages, don't ya?
17:27:18 <geppetto> racor: that is true
17:27:55 <tomspur> racor: Where are the custom man pages translated? Doesn't that only happen to upstream man pages?
17:28:06 <geppetto> racor: maybe change the wording to only imply that english man pages should be added?
17:28:38 <geppetto> SmootherFrOgZ: You've probably got time to read 486 and vote, even though it's passed … if you want
17:28:55 <tibbs|w> Don't see why; if someone wants to supply only a German or Chinese manpage, great.  It's still better than no manpage.
17:29:13 <tibbs|w> I'm pretty sure manpages have some i18n mechanism.
17:29:14 * SmootherFrOgZ nods
17:29:21 <racor> tomspur: I've seen Fedora-adoptend Debian man-pages suffer from this fate. Once translated cleanly, then having been rotten over time ...
17:29:26 <tibbs|w> But really, is this worth any more time?
17:29:59 <tibbs|w> Submit a ticket to remove that bit of the manpages guideline if you want everyone to consider it, and we can talk about it in another meeting.
17:29:59 <SmootherFrOgZ> +1 for the record.
17:30:14 <geppetto> #action Including help2man reference (+1:6, 0:1, -1:1)
17:30:20 <geppetto> ok, let's move on :)
17:30:28 <geppetto> #topic #488 	[RFC] Please update Python_Eggs packaging guidelines
17:30:28 <geppetto> .fpc 488
17:30:29 <geppetto> https://fedorahosted.org/fpc/ticket/488
17:31:21 <limburgher> +1 JUSTDOIT
17:31:52 <tomspur> +1 obviously
17:31:55 <geppetto> yeh, looks like a +1 tibbs just do it one :)
17:31:59 <SmootherFrOgZ> +1
17:32:06 <racor> +1
17:32:27 <tibbs|w> I'll do that too.
17:32:33 <Rathann> +1
17:34:04 <geppetto> orionp: vote ?
17:34:29 <orionp> sorry - distracted with work crisis - seems okay +1
17:34:36 <geppetto> #action Please update Python_Eggs packaging guidelines (+1:8, 0:0, -1:0)
17:34:46 <geppetto> #topic #489 	Ruby guidelines: Updates for Minitest 5
17:34:46 <geppetto> .fpc 489
17:34:46 <geppetto> https://fedorahosted.org/fpc/ticket/489
17:35:36 <geppetto> wow, this is ugly
17:36:02 <tibbs|w> I think that's in line with most of the ruby stuff.
17:36:06 <geppetto> :)
17:36:12 <limburgher> <headdesk>
17:36:21 <limburgher> I can actually understand it so I'm leaning +1
17:36:38 <tibbs|w> It seems to have gathered cruft in a way similar to Perl, but then Perl got way better like a decade ago and ruby.... hasn't.
17:36:45 <orionp> why not a macro?
17:36:52 <geppetto> yeh, I don't think we can do much apart from +1 … but it does feel like a giant step backwards for ruby
17:37:10 <tomspur> I don't know if it is worth to change it. Why not just remove it and leave it up to the packager to call whatever works to run the tests?
17:37:32 <geppetto> orionp: given all the quoting I'm not sure how much I'd trust a macro
17:37:36 <tibbs|w> I don't see a problem mentioning what most packages have to do.
17:37:48 <tibbs|w> Plus maybe this differs enough between packages that a macro isn't worth it.
17:37:48 <SmootherFrOgZ> +1 (with a push to make it as macro)
17:37:49 <Rathann> ugh, this looked much better before
17:38:19 <tibbs|w> geppetto: One smart person could get a macro right and save every packager from having to get it right.
17:38:35 <geppetto> Do you know any sufficiently smart people?
17:38:37 <orionp> Actually, reading does sound like one needs to tweak it so...
17:38:38 <tibbs|w> But +1, certainly, if it's not possible to macro-ize this.
17:38:47 <tomspur> I don't _guess_ ./test/ is a requirement, so if the test*rb files are in tests a macro doesn't work anymore
17:39:04 <tibbs|w> geppetto: I don't, but if they can figure out ruby, they should be able to figure out RPM macros to talk to ruby.
17:39:09 <tomspur> At least python people have sometimes "test" sometimes "tests"
17:39:21 <geppetto> tibbs|w: that is not my experience with ruby developers
17:39:51 <Rathann> reluctant +1 from me, we shouldn't have non-working examples in FPG
17:39:52 <tibbs|w> I mean the ruby team, assuming there is such a thing, in Fedora/Red Hat.
17:40:10 <racor> My knowledge on ruby is NULL, but I guess this change needs to be restricted to certain fedora releases.
17:40:16 <tibbs|w> But definitely we can't leave things as they are regardless,
17:40:40 <tibbs|w> Actually this should work everywhere; testrb is simply going away.  Even older releases can still call the tests manually.
17:40:48 <geppetto> #action Would be nice if one of the main ruby packagers for Fedora could make a macro for this.
17:41:21 <tibbs|w> But I think we should write this up anyway, so the guidelines are at least correct.
17:41:21 <tomspur> +1 for adding it, it at least serves as an example to run the tests
17:41:26 <racor> repoquery tells me f21 has it, so it's not going away from at least fedora <= 21
17:41:58 <tibbs|w> They're going to be making this change anyway as testrb disappears; the guidelines might as well reflect reality.
17:42:45 <tibbs|w> I think we're at +5.
17:42:53 <geppetto> I think it's +7
17:43:06 <geppetto> not sure if orionp wanted a 0, if macro couldn't be done
17:43:10 <geppetto> or a +1
17:43:15 <orionp> I'm +1
17:43:19 <orionp> with or without
17:43:23 <racor> -1 - The guidelines need to refer to fedora > 21, because testrb can not be removed from earlier versions
17:43:31 <tibbs|w> Lots of "leaning" and "reluctant", too, but there's not much else we can do.
17:43:40 <geppetto> racor: I'm assuming that the ruby call works on all versions
17:43:46 <tibbs|w> It does.
17:45:30 <geppetto> #action  Ruby guidelines: Update guidelines due to lack of testrb (+1:7, 0:0, -1:1)
17:45:47 <geppetto> ok, that's it for the newer new ones … going back in time now
17:45:54 <geppetto> #topic #443 	Requesting Bundling exception for Love (liblove sub package)
17:45:55 <geppetto> .fpc 443
17:45:55 <geppetto> https://fedorahosted.org/fpc/ticket/443
17:46:52 <geppetto> this feels like "just another crappy fork"
17:47:28 * Rathann afk for a few min
17:47:37 <limburgher> I've tried and failed to get another package to with with system Box2D before, it's. . .nightmarish.
17:47:52 <geppetto> ahh
17:48:09 <geppetto> so it's more like box2d is a horrible shared library?
17:48:45 <limburgher> Yes.  I hate when devs say "oh, just copy this into your project" instead of doing something wild like a solib.
17:48:56 * geppetto nods
17:49:34 <limburgher> That's when we get all these bizarre modifications that upstream won't take, and the downstream software decides the changes simply "must" go into the copied lib and not their own code. . .
17:50:09 <limburgher> I could go on. . .but I don't think anyone wants that.
17:50:56 <geppetto> what about enet … that seems like it might be sharable?
17:51:37 <limburgher> I think so.  I've not looked at this case but I've unbundled it before, I forget where ATM.
17:52:30 <limburgher> I'm hoping they're not asking to bundle all of them just because of box2d.  I'd like to see specifics about how big the changes are to each lib.
17:52:31 <geppetto> dito luasocket?
17:52:37 <limburgher> No idea.
17:53:11 <geppetto> from what I can see that is on github and is meant to be a library
17:53:32 <geppetto> so I'm +1 on box2d … but need more info. on the other two
17:53:41 <SmootherFrOgZ> limburgher: yeah. I think that the approach to have there
17:53:53 <limburgher> It's like people have forgotten how to C.
17:54:01 <geppetto> indeed
17:54:02 <tibbs|w> Or never knew.
17:54:08 <SmootherFrOgZ> heh
17:54:28 <geppetto> the shortest line between two points is to take a copy of both the points with you
17:54:28 * limburgher Gestures at nose, points at tibbs|w, back at nose.
17:54:46 <geppetto> :)
17:54:55 <limburgher> Making a big ball of wibbly-wobbly, codey-wodey. . .stuff.
17:55:44 <geppetto> Indeed, there are more explosions in a random episode of dr. who than I'd want in Fedora :)
17:55:56 <tibbs|w> So....
17:56:01 <tomspur> Do we really want to grant an exception for "not wanting/knowing" to unbundle?
17:56:22 <tibbs|w> Not really.
17:56:37 <tibbs|w> This ticket doesn't really have all of the info we ask for, either.
17:56:45 <geppetto> no, I'm +1 on them bundling box2d … but if they want to bundle the other two, need a bunch more info.
17:57:30 <geppetto> anyone else?
17:57:46 <limburgher> I'd really like more on all 3, though I fully expect to go blind and possibly mad reading the box2d piece.
17:58:01 <geppetto> ok, that's fair too :)
17:58:30 <SmootherFrOgZ> what limburgher said
17:59:57 <geppetto> #action Need more information on all 3 bundle requests, how much custom code is there, how much work would it take to unbundle etc.
18:00:10 <geppetto> #topic #209 	Please define policy regarding instantiated application
18:00:10 <geppetto> services
18:00:10 <geppetto> .fpc 209
18:00:10 <geppetto> https://fedorahosted.org/fpc/ticket/209
18:00:28 <geppetto> this one is _really_ old
18:00:58 <geppetto> I think the main problem here, and with the next one is that the request is basically "someone else please write the policy"
18:01:04 <tibbs|w> Yeah, sorry, I dug up a bunch of ancient ones.  And I'm probably not even half done.
18:01:33 <tibbs|w> Sounds good to me.  Say that, mark as needinfo, close after a month if nobody responds?
18:01:51 <geppetto> I'm more than happy to needinfo => feel free to write the policy, and/or try to work with someone on the FPC to help you
18:01:53 <limburgher> ucarp and openvpn already do this. . .it's not in the guidelines, but. . .
18:02:02 * geppetto nods
18:02:10 <geppetto> #topic #208 	Please add policy regarding socket activated services
18:02:10 <geppetto> .fpc 208
18:02:10 <geppetto> https://fedorahosted.org/fpc/ticket/208
18:02:13 <geppetto> Dito. this one?
18:02:36 <limburgher> Yeah.  I remember this one. . .
18:03:00 <Rathann> regarding #209, the httpd vhost example is really neat
18:03:02 <Rathann> :)
18:03:18 <tibbs|w> Yes, same thing.  I certainly don't feel qualified to understand systemd enough to write a draft, that's for sure.
18:03:23 <geppetto> #action Someone needs to write the policy, feel free to try to work with someone experienced with writing policy to help you
18:03:34 <tibbs|w> Plus given the rate of change, I'm not sure how much of what's in those tickets is still relevant.
18:03:39 <geppetto> yeh
18:03:41 <tibbs|w> And yes, that vhost thing is quite cool.
18:03:45 <limburgher> It is, but I've been able to achieve so much just be configuring httpd in it's configs that I'm not sure I'd ever use it.
18:04:03 <geppetto> #topic #478 	Proposal: Package Guidelines: DevAssistant Assistant packages (DAP)
18:04:03 <geppetto> .fpc 478
18:04:03 <geppetto> https://fedorahosted.org/fpc/ticket/478
18:04:19 <geppetto> orionp: Anyone speak to you about this?
18:04:31 <orionp> nope
18:04:46 <tibbs|w> Wherre is that ticket on the report?  Or are you going from a different list?
18:04:54 <Rathann> I'm +1 to #208 in general, though I don't have time to do a write-up on my own at the moment
18:04:59 <geppetto> tibbs|w: at the top
18:05:26 <geppetto> tibbs|w: we did new, the new ones that are really old … now doing followup tickets
18:05:56 <tibbs|w> OK, you're not just working from report 13.  Just trying to keep track.
18:06:10 <geppetto> Yeh, I work from the schedule: https://lists.fedoraproject.org/pipermail/packaging/2015-January/010422.html
18:06:39 <geppetto> 480 doesn't seem to have changed either
18:06:41 <geppetto> so …
18:06:43 <geppetto> #topic #481 	static uids systemd-network, systemd-timesync, systemd-resolve
18:06:43 <geppetto> .fpc 481
18:06:43 <geppetto> https://fedorahosted.org/fpc/ticket/481
18:08:24 <limburgher> I don't love the idea because I just generally don't love static UID/GID if remotely avoidable but it looks like a semi-reasonable +1
18:09:19 <tibbs|w> What about walters's comment at the end with a workaround?
18:09:29 <geppetto> yeh, that seems resonable
18:09:33 <tibbs|w> That seems to qualify as "remotely avoidable".
18:09:43 <geppetto> I'm also wondering how much actual data is in the initramfs
18:10:09 <tibbs|w> Well, it's in RAM, so running a chown wouldn't take very long in any case.
18:10:22 <geppetto> yeh
18:10:42 <geppetto> it might be a tad annoying to do the chown at the right time, I guess
18:10:45 <tibbs|w> I would like to see if they balk at that possible fix.  Because, really, wouldn't they _want_ to make this work in the future without having to go through us?
18:10:53 <tibbs|w> At least tell us why that won't work.
18:11:19 <limburgher> Right.  I mean, they should know when all the files are there and can then chown really fast and be done with it.
18:11:26 <geppetto> yeh, I'd kind of reluctantly just give them a +1 if I _knew_ they'd never ask for more
18:11:37 <tibbs|w> Impossible to tell the future....
18:11:43 <geppetto> but it feels a lot like a slippery slope
18:12:05 <SmootherFrOgZ> tibbs|w: you don't have a personal time-machine. how lame.
18:12:08 <geppetto> and betting against feature creep in systemd is not something I'm goign to do
18:12:59 <geppetto> so I'm happy to ask for more info again
18:13:04 <tibbs|w> Now that's sig-worthy.
18:13:13 <limburgher> +1
18:13:24 <limburgher> to tibbs|w, not the ticket. :)
18:13:29 <tibbs|w> Definitely ask why it won\'t work.
18:13:33 * geppetto nods
18:16:33 <geppetto> #action zbyszek Can you answer: Why can't you chown in the initramfs? What kind of state/data is in the initramsfs, or is it just the uid security? Why do they need to be started before the system has booted?
18:17:11 <geppetto> Ok, how is everyone on time?
18:17:18 <geppetto> Next ticket would be 412
18:17:32 <geppetto> which is in the "really old, and a followup" section
18:19:10 <geppetto> #topic #412 	Please change the packaging guidelines to include packaging
18:19:10 <geppetto> policy regarding systemd timer units
18:19:10 <geppetto> .fpc 412
18:19:10 <geppetto> https://fedorahosted.org/fpc/ticket/412
18:19:38 <racor> geppetto: Sorry, was distracted for the last 20min+ and will have to leave soon.
18:20:51 <geppetto> racor: Ok, this will prob. be the last ticket anyway as tomspur needs to leave soon too, I think
18:21:00 <geppetto> And I"m not sure what there is to do here
18:21:06 <tomspur> yes
18:21:13 <geppetto> AIUI we sovled the issue, and then there was a lot of shouting from johan
18:21:24 * geppetto shrugs
18:21:36 <tibbs|w> We should be used to the shouting.
18:21:46 <tibbs|w> The question I had was whether I should just write up what we have.
18:21:58 <geppetto> I … think so
18:22:04 <tibbs|w> Plus there was a proposal from notting which we supposedly voted on.
18:22:20 <tibbs|w> Really I just want to know what I'm supposed to write up, but I'm kind of lost in all of the arguing.
18:24:33 <geppetto> I think you just write the policy in the description of the ticket
18:24:50 <geppetto> I don't see anything else apart from shouting about random stuff
18:25:21 * geppetto shrugs
18:26:35 <geppetto> #action follow vote from 9 months ago, writeup policy in description
18:26:45 <geppetto> There … it's my fault now, if I'm wrong :)
18:26:52 <tibbs|w> That was https://fedoraproject.org/wiki/User:Notting/timer, right?
18:27:00 <racor> i need to hurry ... bye
18:27:04 <Rathann> ok guys I need to leave now, but for the record, I wouldn't recommend migrating cron jobs over to systemd timers
18:27:05 <geppetto> #topic Open Floor
18:27:19 <Rathann> bye
18:27:27 <geppetto> tibbs|w: just the bit under proposed poliucy in 412 … I think
18:27:30 <geppetto> Rathann: see ya
18:27:38 * tomspur needs to leave too...
18:27:43 <tibbs|w> Folks, just assume that I'll take care of writeups until I say I'm not going to be able to take care of it.
18:27:45 <tomspur> See you next week, bye
18:27:46 <geppetto> tibbs: I think the notting proposal was for a different ticket
18:27:58 <geppetto> tibbs: But I wouldn't bet a lot of money that I'm right
18:28:07 <geppetto> tomspur: see ya
18:28:22 <tibbs|w> OK, I'll write up what I see in the ticket.
18:28:32 * geppetto nods
18:28:39 <geppetto> Anyone else have anything else?
18:28:50 * SmootherFrOgZ has nothing
18:28:54 <tibbs|w> Any thoughts about the gcc in buildroot thing?
18:29:04 <tibbs|w> https://fedorahosted.org/fpc/ticket/490
18:29:11 <tibbs|w> I know it's new.
18:29:13 <geppetto> yeh, I saw that appear just before the meeting
18:29:46 <tibbs|w> Personally I'm on board, even though I used to force people to get rid of them in reviews.
18:29:49 <geppetto> the benefit is what … a smaller buildroot for ruby?
18:30:04 <tibbs|w> Smaller buildroot for pretty much everything noarch, which is a lot of stuff.
18:30:13 <tibbs|w> And completely specified dependencies for bootstrapping.
18:30:24 <tibbs|w> Not that you can do much bootstrapping without gcc anyway.
18:30:27 * geppetto nods
18:30:43 <geppetto> but it also means that the caching mock does won't be that useful anymore, right?
18:30:53 <tibbs|w> That depends, I guess.
18:31:26 <tibbs|w> Our buildsys doesn't do caching mock.  I think infrastructure might be marginally happer about this because mass rebuilds would go measurably faster, but that's just handwaving.
18:31:46 <geppetto> It might be nice if we could have a buildroot and a buildroot-noarch … where the second doesn't include gcc
18:31:49 <tibbs|w> But really I think this should be a distro-wide feature.
18:32:08 <SmootherFrOgZ> geppetto: sound like a good idea
18:32:11 <tibbs|w> Because most packages will need to change.
18:32:22 <tibbs|w> But for the record, I would +1 this if it came to us.
18:32:38 <geppetto> yeh, that's my worry … we'll need to change 1000s of arch packages to specify gcc as a dep.
18:32:54 <geppetto> which seems like a big price
18:33:02 <orionp> Will help find unmaintained packages :)
18:33:38 <geppetto> I'm not against it … but I don't want to just +1 it and go "lol, all you packagers will find out when nothing builds anymore"
18:34:17 <geppetto> so if a couple of proven packager people are happy to run with helping everyone migrate, I'm much happier to just do it
18:34:30 <tibbs|w> Now, we can change the guidelines to get rid of that whole "you don't have to include this possibly changing set of packages in BuildRequires:" without anyone else changing anything.
18:35:23 <geppetto> Yeh, I've always thought it was a little weird … but again, change is hard :)
18:35:25 <tibbs|w> And someone can do a side build occasionally to say what's still broken.  And then not actually change the builders for two or three releases.  It's definitely possible to do such a thing.
18:35:41 * geppetto nods
18:35:51 <tibbs|w> But I think we should really consider just nuking that section entirely.
18:36:26 <tibbs|w> Where on earth is that section, anyway?
18:36:49 <tibbs|w> https://fedoraproject.org/wiki/Packaging:Guidelines#BuildRequires_2
18:37:04 <tibbs|w> There are two Buildrequires sections.  Fun.
18:37:28 <tibbs|w> Does that rpmdev-rpmdevelrpms thing even still exist/work?
18:38:01 <geppetto> no idea
18:38:10 <tibbs|w> And that guideline still mentions mach.
18:38:29 <geppetto> I'm also wondering how up to date that exceptions section is :)
18:38:39 <tibbs|w> Honestly I think the "There are two suggested ways" paragraph should just go aw well.
18:39:25 <tibbs|w> So, here's a proposal.  Nuke everything between "There are two sugested" and "BuildRequires and %{_isa}".
18:39:57 <geppetto> searching for "there are two" gets a lot of hits on that page :) :)
18:40:17 <tibbs|w> Third paragraph in https://fedoraproject.org/wiki/Packaging:Guidelines#BuildRequires_2
18:40:20 <geppetto> but, yeh, I think I'm +1 to your proposal tibbs
18:40:30 <tibbs|w> I'll just add it in the ticket so we can vote.
18:40:49 <geppetto> but again … I'd want to be sure it's not just a silent change
18:41:07 <tibbs|w> At some point, if your package builds people are going to be happy.
18:41:19 <tibbs|w> And some stuff is always going to be in the buildroot.
18:41:26 * geppetto nods
18:41:29 <tibbs|w> I just don't think it should be our business to try and keep track of that.
18:41:46 <tibbs|w> We say you have to put everything in there, and if people don't, they get to cry when the buildroot actually changes.
18:43:37 <tibbs|w> Anyway, there was one other thing but I think everyone has wandered off, and it should probably wait until we've dealt with our backlog anyway.
18:43:49 <tibbs|w> And that's the horrible random ordering to the main guidelines page.
18:44:01 <tibbs|w> I mean, how does anyone actually find anything in there?
18:44:07 <geppetto> Control-f
18:44:07 <limburgher> Ctrl+F.
18:44:10 <limburgher> jinx
18:44:12 * geppetto hi5s
18:44:22 <tibbs|w> You have to know what you're looking for to search, though.
18:44:22 * limburgher fistbump
18:44:55 <geppetto> probably easiest to just reorder/split/whatever and submit a ticket
18:45:03 <tibbs|w> Sometimes I think if it's longer than three paragraphs, it should be in its own page, but then Ctrl-F doesn't work any longer.
18:45:22 <geppetto> I'd probably just +1 any split/reorder you proposed *hints* :)
18:45:43 <tibbs|w> I don't want to put the guidelines in publican, either, but that would at least give you the "one document" and the "split for reading" option.
18:46:09 <tibbs|w> And the thing is, I can't think of any good organization.
18:46:22 * geppetto nods, there's that too
18:46:34 <geppetto> maybe can ping one of the doc. experts?
18:46:48 <tibbs|w> Really important stuff at the top, then stuff dealing with organization and syntax of the spec file, and then stuff dealing with how the actual software works.
18:47:04 <geppetto> maybe
18:47:08 <tibbs|w> But the latter section is still nebulous.  The recent security policy thing would go there, for instance.
18:47:38 <tibbs|w> Anyway, I'll try.  Doing too much with the wiki is always going to be painful but swapping a couple of sections around at a time isn't going to kill anyone.
18:48:08 * geppetto nods
18:48:14 <limburgher> tibbs|w: Bet you'll feel like a total jerk if you edit the wiki and it *does*.  Just sayin'
18:48:33 <tibbs|w> I am devoid of normal human emotions.
18:48:36 <geppetto> haha
18:48:58 <tibbs|w> But I'm trying to ride this recent wave of motivation to work on this stuff as far as it will take me.
18:49:03 <limburgher> If I can pass the Turing test, so can you.
18:49:17 <tibbs|w> I'll handle the wiki and trac as long as someone else keeps running the meetings.
18:49:46 <geppetto> ok, do you want me to keep posting the summary sections to the tickets after the meetings too?
18:50:08 <tibbs|w> If you can.
18:50:20 <tibbs|w> But if that takes too much time, let me know.
18:50:32 <geppetto> yeh, if only because it makes it much easier to see what happened historically when looking at old tickets
18:50:56 <geppetto> And the ticket owners 100% get notified too, which is a good bonus
18:51:03 <tibbs|w> Yes.
18:51:28 <tibbs|w> But I'll go through tickets we _didn't_ get to and let them know when the next meeting will be.
18:53:37 <tibbs|w> Anyway, I'm out.
18:53:44 <tibbs|w> Well, out of stuff to talk about, at least.
18:53:45 <geppetto> that's a bunch of tickets
18:53:45 * limburgher waves
18:54:05 <geppetto> and they are all really old ones … and/or waiting on info. anyway
18:54:22 <geppetto> I'm not against pinging them every week … but not sure they'll aprecciate it
18:54:50 <geppetto> but, yeh, see ya all next week … I'll close in a min. if nobody says anything :)
18:55:09 <tibbs|w> I would probably only ping the recent ones.
18:55:18 <limburgher> dammit tibbs|w. . .
18:55:24 <tibbs|w> Someone filed a ticket this week but we didn't have time to get to it, for example.
18:55:29 <tibbs|w> Anyway, I'll mute myself.
18:55:32 <limburgher> :)
18:58:59 <geppetto> that's just 490 right?
18:59:19 <geppetto> The only reason I didn't get to it was because it was opened after I posted the schedule
18:59:38 <geppetto> but cool, I'll close now :)
18:59:46 <geppetto> #endmeeting