19:02:25 <kushal> #startmeeting Fedora Cloud SIG
19:02:25 <zodbot> Meeting started Wed Jan 14 19:02:25 2015 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:02:45 <jzb> .hellomynameis jzb
19:02:49 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
19:02:49 <roshi> .hello roshi
19:02:50 <kushal> #meetingname Fedora Cloud SIG
19:02:50 <zodbot> The meeting name has been set to 'fedora_cloud_sig'
19:02:52 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:02:57 <kushal> #topic roll call
19:03:02 <kushal> .hellomynameis kushal
19:03:03 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:03:08 <number80> .hellomynameis hguemar
19:03:09 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
19:03:09 <lsm5> .hellomynameis lsm5
19:03:12 <zodbot> lsm5: lsm5 'Lokesh Mandvekar' <lsm5@redhat.com>
19:03:14 <scollier> .hellomynameis scollier
19:03:15 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
19:03:26 <langdon> .hellomynameis langdon
19:03:30 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
19:03:47 * langdon needs to step away for 10 mins.. but will be back
19:04:07 <kushal> Anyone else?
19:04:19 <kushal> rtnpro, jsmith ?
19:04:30 <jsmith> .hellomynameis jsmith
19:04:31 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
19:04:36 <jsmith> Sorry I'm late...
19:04:40 <jsmith> ... busy day today :-(
19:04:47 <kushal> jsmith, not started fully yet :)
19:05:00 <kushal> dustymabe, yay, you are here.
19:05:09 <dustymabe> kushal: only in spirit :)
19:05:10 <kushal> even though you said you will not be :p
19:05:20 * gholms takes a seat in the bleachers
19:05:22 <dustymabe> I probably won't be engaged much
19:05:24 <kushal> gholms, :D
19:06:03 <kushal> #topic Action items from last week's meeting
19:06:12 <kushal> * oddshocks will update #68 when he has something to test.
19:06:12 <kushal> * jzb write "how to use dockerfiles" by next Cloud SIG meeting
19:06:12 <kushal> * Kushal will send CI details to scollier  and langdon
19:06:12 <kushal> * Kushal to test the patch from lsm5 on docker image timezone.
19:06:16 <kushal> I will go first.
19:06:40 <kushal> About CI whatever I found, I sent it to both scollier and langdon.
19:06:53 * kushal and lsm5 are working on the timezone patch.
19:06:53 <jzb> kushal: still in progress
19:07:06 <scollier> kushal, i got it.  Thanks.
19:07:10 <kushal> oddshocks, you there?
19:07:21 <lsm5> kushal: would be great to have scratch builds going on real koji if possible
19:07:37 <kushal> lsm5, yeah, I just wish.
19:08:11 <kushal> lsm5, build is successful btw :)
19:08:28 <lsm5> kushal: ooh nice ..
19:08:31 <kushal> lsm5, I will pass you the details after the meeting.
19:08:37 <lsm5> kushal: wonder what's messed up on my system
19:08:39 <lsm5> kushal: thanks
19:09:38 <kushal> Moving to current items.
19:09:49 <kushal> #topic support HVM instances in EC2 (#68)
19:09:59 <kushal> It is on oddshocks.
19:10:38 <kushal> According to the ticket the image is out.
19:11:21 <kushal> next
19:11:31 <kushal> #topic publicize fedora-dockerfiles (#84)
19:11:40 <kushal> jzb, already informed worked is going on.
19:11:46 <kushal> s/worked/work
19:12:28 <kushal> jzb, feel free to add an action item :)
19:12:40 <jzb> kushal: still in progress from last week
19:12:53 <jzb> kushal: so we'll hold pat on that one.
19:13:40 * langdon back
19:14:00 <kushal> jzb, Okay.
19:14:03 <scollier> kushal, just as FYI, we should prob publicize the images on docker hub as well
19:14:15 <scollier> kushal, to date, not including the base image, we have ~ 30k downloads.
19:14:25 <kushal> scollier, cool.
19:14:52 <kushal> scollier, I never managed to write anything on them yet, can you please write some posts too? we all can share them.
19:15:38 <scollier> kushal, sure.  also, i posted: http://www.colliernotes.com/2015/01/flannel-and-docker-on-fedora-getting.html  which is flannel on fedora, but should be  a quick start for folks evaluating the tech.
19:15:59 <scollier> kushal, that was posted yesterday
19:16:37 <kushal> scollier, ah, I read that post, but never read who wrote it. Stupid me :(
19:16:44 <kushal> #link http://www.colliernotes.com/2015/01/flannel-and-docker-on-fedora-getting.html
19:17:11 <jzb> scollier: why not on Fedora Magazine? :-)
19:17:41 <scollier> jzb, good question.  i should do that more often.  sry.
19:18:22 <kushal> jzb, do we have a wiki page which explains how one can start writing on Fedora magazine?
19:18:49 <jzb> kushal: most likely
19:19:13 <scollier> kushal, jzb: http://fedoraproject.org/wiki/Magazine/Howtopost
19:19:26 <jzb> yeah, that
19:19:32 <jzb> scollier beat me to it
19:19:42 <number80> http://fedoraproject.org/wiki/Magazine/Howtopost
19:19:43 <kushal> scollier, jzb Thanks :)
19:19:51 <dustymabe> jzb: we should have a magazine post that tells users about that page :)
19:19:54 <number80> (so its get added to the minutes)
19:21:05 <jzb> dustymabe: I am pretty sure there has been one.
19:21:16 <jzb> dustymabe: aren't you not here?
19:21:27 * dustymabe vanishes
19:22:34 <kushal> moving nect
19:22:37 <kushal> * next
19:22:57 <kushal> #topic Update Timezone for the docker images (#91)
19:23:29 <kushal> I just now tested a patch which will update the timezone to UTC, I will commit it after the meeting.
19:23:33 <kushal> lsm5, thanks for the help.l
19:23:41 <kushal> oops, too many typos tonight.
19:23:44 <lsm5> kushal: np :)
19:23:57 <kushal> After that I will update the ticket.
19:23:57 <lsm5> kushal: so it works??
19:24:04 <kushal> lsm5, as it seems.
19:24:08 <lsm5> \m/
19:24:17 <kushal> anaconda showed that while installation.
19:25:01 <kushal> jzb, should we repaste the dockerfile related tickets here? we already discussed them.
19:26:19 <kushal> I guess we can skip them as already discussed.
19:26:49 <jzb> sorry
19:26:57 <kushal> Fedora Magazine Post: How to Use Dockerfiles (#87) and Social Media for Dockerfiles (#88)
19:26:58 <jzb> kushal: I don't think so
19:27:07 <kushal> jzb, okay :)
19:27:08 * oddshocks late
19:27:23 <kushal> oddshocks, thanks for the HVM images :D
19:27:41 <kushal> #topic Decide whether to update cloud image to not include ruby (#90)
19:27:54 <oddshocks> Sure thing, hope there haven't been any issues :)
19:28:07 <number80> less is better here
19:28:09 <kushal> I just updated the ticket that we do not have ruby in the  nightly cloud  base builds anymore.
19:28:25 <kushal> number80, yeah, it got automatically removed.
19:29:09 <kushal> # Open floor
19:29:14 <kushal> #topic Open floor
19:29:33 <kushal> The deadline for the feature proposal coming, 20th of this month.
19:29:42 <langdon> jzb, kushal i would like to propose that fedora-cloud build an "official" vagrant box
19:29:53 <jzb> langdon: +1
19:29:54 <kushal> langdon, Please go ahead.
19:29:56 <langdon> jzb, not sure if you filed a ticket
19:30:11 <jzb> langdon: you mean feature request/proposal/whatever?
19:30:24 <jzb> langdon: I haven't yet, I can take that I guess
19:30:29 <langdon> jzb, honestly.. no clue.. what do i do to propose it?
19:30:36 <jzb> langdon: I'll take it and add you
19:30:38 <langdon> i can do it if i know where/how
19:30:41 <langdon> ahh ok
19:30:46 <kushal> langdon, I am going to drop a mail to the list about that in few minutes.
19:30:47 <jzb> #action jzb propose the Vagrant feature for F22
19:30:50 <number80> langdon: does that require that we get chef in packages repo ?
19:30:59 <langdon> number80, no
19:31:23 <langdon> number80, not proposing we "ship" vagrant (although that is in the works) this is just an "iso" for use in vagrant
19:31:55 <number80> langdon: we already ship vagrant (with kvm plugin) but vagrant image used to require chef installed in the image
19:32:06 <number80> and we don't have chef in our repositories
19:32:10 <langdon> from an effort perspective, ian mcleod has written an image factory plugin for it that should be consumable by koji
19:32:32 <scollier> number80, i don't think that's still required
19:32:37 <roshi> there's that "S" word :p
19:32:42 <jzb> we also really need to get our **** together and actually ship vagrant
19:32:45 <number80> scollier: if that's the case, then it's ok
19:32:51 <kushal> langdon, http://fedoraproject.org/wiki/Features/Policy
19:33:00 <langdon> jzb, jstribny is working on it.. along with vondruch...
19:33:11 <scollier> number80, i just looked at a fedora box running on fedora with vagrant / libvirt, the fedora box doesn't have chef
19:33:16 * number80 more worried about providing good experience with an official vagrant image
19:33:18 <scollier> i think that's what you are referring to
19:33:23 <langdon> number80, im confused.. so fedora ships a vagrant box somewhere?
19:33:38 <number80> langdon: no, I meant we ship the vagrant software
19:33:46 <langdon> number80, ahhh.. ok
19:34:15 <langdon> coprs for f20 and f21 exist.. working on unbundling to get in fedora main.. or thinking playground..
19:34:43 <langdon> vagrant ships bundling ruby.. so .. not chef .. but ruby instead :)
19:35:10 <langdon> kushal, so.. i wasn't sure if this was a "feature" or a fed-cloud ticket
19:35:21 <kushal> langdon, put it as feature
19:35:26 <number80> at some point, it used chef for provisionning inside the virtual machine
19:35:27 <kushal> fesco can decide more :)
19:35:47 <kushal> roshi, you will also file a proposal
19:35:52 <roshi> so are we pushing the Features bit for getting mentions in release notes and whatnot?
19:35:59 <langdon> number80, yeah.. chef is now an option but not default.. (i believe).. it just uses shell/ssh by default now..
19:36:00 <kushal> roshi, Yes.
19:36:05 <kushal> roshi, we will do that.
19:36:06 <roshi> http://fedoraproject.org/wiki/Features/Policy/Definitions
19:36:25 <roshi> for testcloud, I'm still not convinced it meets the criteria
19:36:42 <langdon> so, jzb, you will file feature?
19:36:44 <kushal> roshi, It does.
19:36:55 <roshi> under which bit of the checklist?
19:37:20 <roshi> just the publicity one?
19:37:22 <kushal> roshi, I personally think so for developersl.
19:37:27 <kushal> eeee
19:37:34 <kushal> roshi, developers.
19:37:48 <kushal> i.e. users.
19:38:12 <langdon> kushal, roshi arguably.. testcloud and vagrant boxes are being shipped by cloud but consumed by workstation... so it should really appear in their notes as well
19:38:23 <kushal> langdon, Yeah.
19:38:57 <roshi> hrm
19:39:00 <jzb> langdon: yes
19:39:08 <langdon> jzb, cool, thanks
19:39:25 <jzb> roshi: what's the worst that could happen? ;-)
19:39:37 <jzb> roshi: if you file as a feature and they say "not needed" no biggie.
19:40:01 <jzb> roshi: though if you file as a feature and it makes the list it will also help us remember to put it into marketing materials.
19:40:07 <roshi> but if they say "Yeah, looks good." then there's another meeting and stuff I have to track :p
19:40:34 <kushal> roshi, lol
19:40:56 <roshi> tbh though, I have no idea what "attending feature status meetings" looks like
19:41:31 * langdon guesses it probably isn't an excuse for more beer
19:41:39 <kushal> jzb, what about Bare metal installer for Atomic?
19:41:46 <jzb> langdon: you need an excuse?
19:41:47 <kushal> lsm5, you should file one on rocket?
19:41:51 <jzb> kushal: that's on my list
19:42:26 <kushal> jzb, who is going to do the feature on Flannel?
19:43:11 <kushal> also "Overlay packages for rpm-ostree"
19:43:25 <jzb> kushal: is one needed?
19:43:31 <jzb> kushal: flannel is already packaged for F212
19:43:33 <jzb> er, F21
19:43:43 <jzb> presumably it'll be in F212 if we get that far.
19:43:48 <kushal> jzb, I got that from your reply to the thread.
19:43:57 <kushal> jzb, haha
19:44:11 <jzb> kushal: Yeah, I thought it hadn't made it - but it did.
19:44:24 <kushal> jzb, and the os-tree one?
19:44:46 <jzb> kushal: I'll check in with Colin on that to make sure it's something he (still) feels good about.
19:44:57 <kushal> jzb, Okay, thanks.
19:45:02 <lsm5> kushal: sorry got distracted ...
19:45:26 <lsm5> kushal: file ticket you mean?
19:45:41 <kushal> lsm5, not ticket but a feature proposal
19:45:51 <kushal> lsm5, http://fedoraproject.org/wiki/Features/Policy
19:47:13 <lsm5> kushal: i'll take a look at this (haven't filed such a thing before)
19:47:42 <kushal> lsm5, if you need help then you can ping us.
19:48:19 <lsm5> kushal: sure thing
19:48:24 <kushal> lsm5, :)
19:48:36 <kushal> Anything else for the open floor?
19:49:16 <langdon> just, jzb, feature for vagrant-fedora-cloud and vagrant-fedora-atomic, right?
19:50:02 <jzb> langdon: right
19:50:08 <langdon> cool
19:52:45 <kushal> anything else?
19:52:52 <kushal> or we can close this meeting.
19:53:33 * roshi doesn't have anything
19:53:39 <kushal> #endmeeting