16:34:12 <dgilmore> #startmeeting RELENG (2015-01-26)
16:34:12 <zodbot> Meeting started Mon Jan 26 16:34:12 2015 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:34:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:34:20 <dgilmore> #meetingname releng
16:34:20 <zodbot> The meeting name has been set to 'releng'
16:34:20 <dgilmore> #chair dgilmore nirik tyll sharkcz bochecha masta pbrobinson
16:34:20 <zodbot> Current chairs: bochecha dgilmore masta nirik pbrobinson sharkcz tyll
16:34:21 <dgilmore> #topic init process
16:34:51 * sharkcz is here
16:34:58 <tyll_> Hi there
16:35:26 <masta> hello
16:35:28 <bochecha> hi everyone
16:35:28 * masta is here
16:35:30 <nirik> morning
16:37:23 <Corey84> .fas corey84
16:37:24 <zodbot> Corey84: corey84 'Corey84' <sheldon.corey@gmail.com>
16:37:38 <Corey84> (passively learning )
16:37:49 <dgilmore> #topic #5931 [Proposal] Move new branch and unretire requests to pkgdb2
16:37:57 <dgilmore> https://fedorahosted.org/rel-eng/ticket/5931
16:39:21 <nirik> I think pingou has worked more on this some... and things are coming along.
16:40:07 <pingou> apparently #fedora-meeting-1 != #fedoram-meeting-1
16:40:11 <pingou> hi all :)
16:40:24 <nirik> hey pingou.
16:40:26 <pingou> so basically: * Mon Jan 26 2015 Pierre-Yves Chibon <pingou@pingoured.fr> - 1.23.99-1
16:40:28 <pingou> - Update to 1.23.99 (pre-release for 1.24)
16:40:30 <pingou> - New processes to request a new package or a new branch of a package directly
16:40:41 <pingou> not exactly what I wanted to paste but it works :)
16:40:55 <pingou> https://admin.stg.fedoraproject.org/pkgdb/ stg now runs the latest release (changelog above)
16:41:02 <nirik> cool. so whats left to do?
16:41:11 <pingou> during the review one question popped-up: https://fedorahosted.org/rel-eng/ticket/5931#comment:13
16:41:16 <pingou> for which I would like more input
16:41:55 <pingou> as for what is left: new pkgdb-cli release, testing of both, adjust doc and announcing
16:42:20 <pingou> I'm thinking we may want to announce it already so that we can fix things before they hit prod
16:42:25 <nirik> I'd also like to try and get a few packages to use it before we announce to shake out issues.
16:42:31 <pingou> +1
16:43:08 <pingou> the one 'big' thing remaining is the automation from pkgdb to git
16:43:19 <nirik> and I'm fine with the 1 week wait re: comment 13... but not sure if we should run that by fesco as it's a change from current...
16:43:22 <pingou> the code is ready but basically relies on the new version of pkgs
16:43:43 <pingou> I'm ok with asking fesco
16:43:45 <nirik> oh? so we need to wait for new pkgs to roll this out?
16:44:25 <pingou> well, we can roll it out sooner, but then the admin processing the request will have to adjust the git in a different call/tool
16:44:49 <nirik> hum, ok.
16:44:55 <pingou> technically, I *think* we could roll out the fedmsg trigger git sync sooner, but I've to check the mkbranch script
16:45:04 * pingou puts bochecha on the list to help :-p
16:46:43 <nirik> ok, so roll this to prod sometime this week, then see where we are next week and also talk to fesco about process/changes?
16:47:03 <pingou> sounds good
16:47:39 <tyll_> #info  nirik> ok, so roll this to prod sometime this week, then see where we are next week and also talk to fesco about process/changes?
16:47:55 <tyll_> #info < nirik> and I'm fine with the 1 week wait re: comment 13... but not sure if we should run that by fesco as it's a change from current...
16:49:43 <dgilmore> pingou: I know that pbacina is working on setting a roadmap for features for distgit
16:49:53 <dgilmore> including an api for branching etx
16:50:04 <pingou> interesting
16:50:21 <pingou> dgilmore: is it documented somewhere?
16:50:40 <dgilmore> pingou: not yet that I know of
16:50:42 <nirik> mostly our changes are just rhel7, gitolite3, ansible... we didn't make too many other changes really yet that I can think of.
16:50:46 <dgilmore> but it needs to be
16:50:52 <nirik> just wanted to get it on modern setup
16:50:53 <dgilmore> nirik: right
16:51:08 <nirik> so any changes after that could be good to work on once it's updated.
16:51:09 <dgilmore> but there is going to be active development on distgit
16:51:31 <pingou> sounds nice
16:51:33 <dgilmore> internally at Red Hat they forked what Fedora had and did what they needed.
16:51:56 <dgilmore> he is planning to unify both and do active development and maintainence on it as a open project
16:51:57 <nirik> it would be great to converge.
16:52:02 <nirik> excellent.
16:52:38 <pingou> dgilmore: any ETA?
16:52:44 <dgilmore> so while we will have something that makes branching work for now
16:52:58 <dgilmore> down the road we can and should do it in a new way
16:53:05 <dgilmore> pingou: afaik its just getting underway
16:53:06 * nirik looks at schedule
16:53:15 <pingou> dgilmore: open from the start?
16:53:38 <dgilmore> pingou: well its pulling in what exists in Fedora and Red Hat
16:53:47 <dgilmore> but that is the idea
16:53:58 <pingou> looking forward then :)
16:54:13 <nirik> pingou / bochecha: do you think we can move pkgs01 production to new setup before f22 mass branch?
16:54:17 <nirik> (ie, next week sometime)
16:54:37 <bochecha> nirik, it's not ready yet
16:54:49 <bochecha> nirik, we're still trying to figuring out lookaside and cgit
16:54:51 <pingou> we have a final bug on the upload
16:54:54 <pingou> cgit is happy
16:54:59 <nirik> ok, fair enough... we can play it by ear then.
16:55:04 <bochecha> pingou, well, it's happy with selinux disabled :)
16:55:12 <pingou> bochecha: which is what we had before
16:55:19 <bochecha> it's disabled in prod ? o_O
16:55:25 <pingou> on pkgs01 yes
16:55:28 <bochecha> huh
16:55:44 <pingou> nirik: if we were to deploy next week, we should do it on Monday as we'll be traveling on Thursday to DevConf
16:56:05 <nirik> we want to fix selinux.
16:56:23 <nirik> pingou: yeah, might be tight... so perhaps after is better
16:56:24 <pingou> sure, but required for moving to prod?
16:56:33 <nirik> if we don't... we never will.
16:56:40 <bochecha> agreed with nirik here
16:56:59 <pingou> if we can pull tyll or puiterwijk on it, "they know" :)
16:57:32 <pingou> something to check tomorrow
16:58:11 <tyll> I am not really an selinux expert :-/
16:58:39 <nirik> I suspect we can get it working without too much hassle.
16:58:42 * dgilmore flys to fosdem thusday and then devconf monday/tuesday
16:58:55 * nirik notes we have spent a lot of time on this ticket... move on to some others? or is there more here?
16:59:02 <pingou> +1 to move
16:59:05 <dgilmore> yeah lets move on
16:59:15 * dgilmore needs to run in 10 minutes
17:00:06 <dgilmore> #topic #6047 handle packages that are retired only in Branched but not Rawhide
17:00:18 <dgilmore> tyll: so this is kinda ugly
17:00:53 <dgilmore> https://fedorahosted.org/rel-eng/ticket/6047
17:00:55 <tyll> I believe we already discussed it but I did not get to update the script
17:01:01 <dgilmore> okay
17:01:29 <dgilmore> #info already discussed
17:01:58 <dgilmore> #topic #5870 rawhide signing
17:02:03 <dgilmore> https://fedorahosted.org/rel-eng/ticket/5870
17:02:08 <dgilmore> anything left here?
17:02:18 <dgilmore> we do not have gating etc yet
17:02:26 <dgilmore> and I think we should do so
17:02:29 <nirik> I'd like to try and get this finished. ;)
17:02:52 <dgilmore> so we need to get sigul dev time
17:02:52 <tyll> I am currently waiting for someone to be able to restart sigul so running it does not that much disturb others/works more often
17:02:53 <nirik> we might manually sign with f23 after branching, then enable it?
17:03:07 <nirik> because we will have to resign everything right?
17:03:19 <tyll> the last time it ran, there were only complains because sigul was not working too often
17:03:41 <pingou> maybe something to discuss IRL at fosdem or devconf
17:03:44 <nirik> yeah, there were some hangs...
17:04:02 <tyll> also it usually was not able to sign anything about 1/3 of the day after sigul died when dgilmore/nirik were not available anymore
17:04:20 <nirik> they seem to happen when multiple people sign at the same time... it gets confused and locks up
17:04:56 <dgilmore> tyll: I need to talk to mitr about the risks with giving more people the shared nss password on the boxes
17:05:22 <dgilmore> tyll: at least on the bridge I feel that there is nothing in the nss db that actually needs the password
17:05:36 * nirik notes pingou offered and I would be happy to have him have it... but sure, do check risks
17:05:52 <dgilmore> the nss db on the bridge has a copy of the fedora ca cert and the key and cert for the bride user
17:06:06 <nirik> usually it's the bridge that locks up/dies...
17:06:15 <tyll> sounds good
17:06:21 <dgilmore> the same cert and key is stored unencrypted on the bridge box to allow koji to import the signed rpms
17:06:59 <dgilmore> so I feel that we could remove the password on the nss db and we will not be any less secure
17:07:16 <nirik> alright.
17:07:17 <dgilmore> then we could allow a few people to restart the bridge
17:07:28 <masta> that would be nice
17:07:29 <nirik> so, talk with mitr at devconf and revisit?
17:07:57 <tyll> if no password is required, maybe we can implement a watchdog that just restarts the bridge if it hangs
17:08:10 <dgilmore> the thing having the password on the nss db gives us is making sure a authorized person starts sigul_bridge
17:08:14 <dgilmore> tyll: right
17:08:25 <dgilmore> which is not ideal
17:08:35 <dgilmore> but better than it being down
17:08:51 <dgilmore> nirik: yeah I will talk with mitr
17:09:26 <dgilmore> if he agrees we do not lose anything by removing the password i will just do it and let pingou know
17:09:36 <nirik> ok
17:09:51 <dgilmore> if he thinks we really need it I will talk to him about the risks of more people knowing it
17:10:01 <pingou> wfm
17:10:17 * dgilmore needs to run to the eye specialist
17:10:29 <dgilmore> can someone please continue on
17:10:34 <tyll> #action dgilmore discuss adding more people to be able to restart sigul bridge with mitr
17:10:35 <masta> see ya later dgilmore, bye
17:10:58 <tyll> bye
17:11:04 <nirik> safe travels dgilmore
17:11:14 * nirik doesn't know what else was on the agenda...
17:11:53 <sharkcz> secondary arches status is, if there are no more tickets
17:12:01 <nirik> not much else in meeting tickets...
17:12:10 <nirik> sure, lets do secondaries.
17:12:15 <tyll> https://fedorahosted.org/rel-eng/ticket/5886 is something that is currently stalling but important
17:12:26 <nirik> #topic secondary arch status - s390
17:12:39 <nirik> tyll: yeah, we need to gather stakeholders and figure things out...
17:13:02 <nirik> I guess I can see if I can find someone to organize a meeting on it...
17:13:15 <sharkcz> s390 looks good, we are quite on par with primary, fixing stuff as they come
17:13:39 <nirik> excellent.
17:13:44 <nirik> #topic secondary arch status - ppc
17:13:45 <sharkcz> with ~100 builds missing due broken buildroots in the past, but it can fixed easily
17:14:03 <nirik> sharkcz: oh? what broke them?
17:14:38 <sharkcz> nirik: it's koji shadow issue with packages like perl dual life modules
17:14:46 <nirik> ah, ok.
17:15:27 <sharkcz> ppc also made progress, don't have the numbers but they should be ~week behind
17:15:53 <nirik> ok, fair enough.
17:16:23 <nirik> sharkcz: side note: how practical might it be to move our 2 ppc builders (which we use for epel builds) to fedora ? (they are rhel6 now)
17:17:26 <sharkcz> it should work, we use f20 based builders, question is what hw is it and how easy we can get fedora there
17:17:46 <nirik> Smooge would know.. can find out.
17:17:57 <nirik> #topic secondary arch status - aarch64
17:18:04 <sharkcz> because I hear about troubles with power6 blades, but power5 hw work and power7 and up
17:18:24 <nirik> sharkcz: we might also be getting new stuff, not sure... it would be great to do kvm + fedora.
17:18:39 <sharkcz> yeah new hw is in the queue
17:19:39 <sharkcz> and IBM is interested in EPEL, so there might be a EPEL dedicated box
17:19:50 <nirik> would be nice to have the builders the same as the others...
17:19:58 <nirik> anyhow... any aarch64 news
17:20:35 * sharkcz isn't informed about aarch64 :-) maybe masta is?
17:21:16 <nirik> yeah, masta or pbrobinson...
17:21:44 <masta> uh... I haven't been paying much attention to the aarch64 lately, sry
17:21:52 <nirik> no worries.
17:22:05 <nirik> Any other tickets to discuss, or shall we move on to open floor?
17:22:38 <nirik> #topic Open Floor
17:22:44 <nirik> I had one item...
17:23:09 <nirik> about https://fedorahosted.org/rel-eng/ticket/6091
17:23:23 <nirik> I can set the 'ipa' component to be not open for new bugs...
17:23:30 <nirik> does anyone see an issue with that?
17:23:55 <pingou> can we drop it entirely?
17:23:59 <sharkcz> nope, go for it
17:24:15 <nirik> pingou: well, it has closed bugs... what happens to them?
17:24:21 <pingou> I've had the question coming up for pkgdb: https://github.com/fedora-infra/pkgdb2/issues/59
17:24:33 <nirik> I dislike removing history
17:24:36 <pingou> nirik: good question, no idea :/
17:25:05 <nirik> so, yeah, I think disable is the right thing to do.
17:25:07 <sharkcz> not sure bz would allow you to physically remove the history
17:25:20 <sharkcz> so yes, disable it
17:25:42 <nirik> there is a 'delete' button, but not sure what happens when I press it. ;) I guess I could try in partner-bugzilla.
17:26:39 <sharkcz> sounds as a dangerous button :-)
17:26:47 <nirik> yeah.
17:26:54 <nirik> anyhow, will look more at it.
17:27:01 <nirik> Anything else for open floor before we close?
17:28:09 <nirik> alright. Thanks for coming everyone!
17:28:12 <tyll> is the new meeting time is now official?
17:28:12 <nirik> #endmeeting