19:17:28 <roshi> #startmeeting Fedora Cloud SIG
19:17:28 <zodbot> Meeting started Wed Feb  4 19:17:28 2015 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:17:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:17:38 <roshi> #meetingname Cloud SIG
19:17:38 <zodbot> The meeting name has been set to 'cloud_sig'
19:17:49 <roshi> #topic Roll Call
19:17:54 <roshi> .hello roshi
19:18:15 <roshi> who's still around for some cloud discussions?
19:18:29 <roshi> thanks for the help with zodbot, nirik  :)
19:18:33 <dustymabe> .hellomynameis dustymabe
19:18:59 <oddshocks> .hellomynameis oddshocks
19:19:50 <dustymabe> hmmm zodbot?
19:20:06 <nirik> it's likely still joining things. it will catch up.
19:20:14 <roshi> yeah
19:20:38 <roshi> number80: jsmith
19:20:53 <roshi> agrimm
19:21:03 <roshi> ^^ ping for meeting :)
19:21:08 <agrimm> .hellomynameis arg
19:21:47 <roshi> kushal won't be making it today - he's sick with some kind of respritory thing
19:22:18 <dustymabe> bummer.. sounds serious
19:22:21 <roshi> #topic Previous meeting follow-up
19:22:44 <roshi> yeah, not sure how long he'll be recovering
19:23:27 <roshi> me, dustymabe and Corey84 were the only ones here last meeting
19:23:45 <roshi> the previous previous meeting follow up items were all done by then
19:23:53 <roshi> and nothing from last meeting to follow up on
19:24:08 <roshi> #info nothing to follow up on
19:24:16 <roshi> #topic Agenda Items
19:24:18 * larsks is lurking, just out of interest.
19:24:28 <roshi> #link https://fedorahosted.org/cloud/report/9
19:24:38 <roshi> larsks: you don't have to just lurk, speak up if you want :)
19:25:22 <roshi> #topic HVM Instances (#68)
19:25:24 <roshi> #link https://fedorahosted.org/cloud/ticket/68
19:25:34 <roshi> this one we're just waiting on the website to get updated
19:26:14 <roshi> there's a thread on the list discussing it
19:26:16 <roshi> https://lists.fedoraproject.org/pipermail/cloud/2015-February/004900.html
19:26:23 <roshi> anyone have anything else for this?
19:26:30 <roshi> oddshocks?
19:26:34 <dustymabe> nope.. thanks for tracking roshi
19:26:44 <roshi> np :) It's what I do :p
19:27:00 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:27:09 <roshi> there it is :)
19:27:23 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
19:27:40 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
19:27:41 <oddshocks> hey, sorry :P
19:28:04 <roshi> #topic Publicize docker-files (#84)
19:28:05 <oddshocks> yeah, so those are good HVM images AFAIK,
19:28:07 <roshi> #link https://fedorahosted.org/cloud/ticket/84
19:28:13 <oddshocks> minus the message added by mattdm
19:28:34 <oddshocks> but that's something actually in the image itself, not with the AMI, so IDK what's up with that
19:28:37 <roshi> what are you sorry for oddshocks ?
19:28:46 <zodbot> agrimm: arg 'Andy Grimm' <agrimm@redhat.com>
19:28:49 <oddshocks> zoned out there :P
19:28:57 <roshi> haha, no worries
19:29:15 <oddshocks> anyway, this libvirt issue (was gonna bring it up in open floor anyway): https://lists.fedoraproject.org/pipermail/cloud/2015-February/004905.html
19:29:16 <roshi> ball is still rolling on this one?
19:29:47 <oddshocks> That thread was sort of my "are these good to go to the web team / can I publish a blog post" type thing
19:30:12 <roshi> yeah, that's what I thought it was
19:30:23 <oddshocks> So, I guess if they're ready to go depends on 1) if dustymabe's question is answered and there's nothing to do left on that 2) if this libvirt thing is something I want to wait to be resolved
19:30:51 <oddshocks> but either way, the older AMIs that ARE up there right now have the problem as well, so IMO might as well upload the list I sent, since it includes some benefits
19:31:02 * gholms appears
19:31:03 <dustymabe> oddshocks: sorry I didn't respond to the email
19:31:08 <oddshocks> Of course, like I said, I don't know much about the image itself, or the libvirt issue
19:31:24 <dustymabe> yes. my question was answered. I wanted to make sure these images didn't have updates
19:31:33 <roshi> makes sense to me oddshocks
19:32:04 <oddshocks> dustymabe: oh no that's no problem, I just sent it like yesterday :P just wanted to make sure everything made sense
19:32:04 <oddshocks> and cool
19:32:05 <dustymabe> oddshocks: my 2nd question may not have been answered though
19:32:29 <oddshocks> yeah to clear up: I have not created any AMIs with any images dating past those Dec 3rd (?) images we used for the official release that are on the download page
19:32:30 <dustymabe> the ami id that shows up in the pop up doesn't match what is linked
19:32:42 <roshi> #topic AMI updates
19:32:46 <oddshocks> Fedimg hasn't either, since I don't see any recent createImage tasks in koji that succeeded
19:32:52 <roshi> since that's what we're talking about :)
19:33:02 <oddshocks> dustymabe: the pop up on the website?
19:33:08 <dustymabe> oddshocks: yeah
19:33:12 <roshi> should we get some website folks in here to discuss?
19:33:13 <oddshocks> dustymabe: that's the pop up that needs to be changed, that's why I sent out the email
19:33:22 <roshi> who would that be, ryanlerch?
19:33:25 <oddshocks> robyduck, maybe?
19:33:35 <oddshocks> I know he's updated the AMIs for me in the past
19:33:39 <dustymabe> oddshocks: ok well lets make sure when they do update it the text matches the link
19:33:39 <roshi> kk
19:33:50 <dustymabe> currently it doesn't
19:34:00 <dustymabe> at least for N Virginia
19:34:31 <oddshocks> I would have sent in a patch myself, but there needs to be a new button/control/something added to choose between PV and HVM, and soon we'll need choices for even more volume type options... so I figured I'd leave that to the web team to decide on
19:34:46 <oddshocks> dustymabe: hm, I didn't know that, but also, I've never updated them myself :P
19:34:46 <roshi> probably a good call
19:35:05 <oddshocks> on the website that is
19:35:07 <roshi> but then again, if you copy what they have, it might be good enough for them
19:35:11 <dustymabe> ok let's spot check it when it does get updated
19:35:19 <oddshocks> dustymabe: sounds good
19:35:27 <dustymabe> ok.. moving on to the current topic
19:35:38 <roshi> #topic Publicize docker-files (#84)
19:35:54 <roshi> jzb: ^^ you have any update on this one?
19:36:06 <roshi> or anyone else for that matter?
19:36:16 * roshi hasn't done anything with dockerfiles at all
19:36:50 <dustymabe> roshi: I have some stuff planned but nothing done
19:37:19 <roshi> what kinds of stuff?
19:37:33 <roshi> and could you update the ticket?
19:38:34 <dustymabe> well. just basically need to update the dockerfiles I own to use fedora 21
19:38:45 <dustymabe> and I want to rework the busybox container one
19:39:01 <dustymabe> I can add to the ticket that I want to post about it once the busybox one is done.
19:39:32 <roshi> sweet, that'd be great
19:40:17 <roshi> anyone have anything else on this? or can we move on?
19:40:18 * robyduck here
19:40:25 <roshi> hey robyduck :)
19:40:32 <robyduck> hi roshi
19:40:47 <roshi> #action dustymabe to update the ticket with his dockerfile plans
19:40:53 <roshi> #topic Website
19:41:09 <roshi> robyduck, we had a question with updating the AMI ids on the website
19:41:19 <robyduck> yes sure
19:41:23 <roshi> is that something you can help us with, or point us to where we need to go?
19:41:52 <robyduck> I can help, fo you have updated IDs?
19:41:59 <robyduck> s/fo/do
19:42:11 <dustymabe> oddshocks ^^
19:42:19 <oddshocks> robyduck: we do! on the cloud list
19:42:21 * oddshocks gets link
19:42:35 <oddshocks> robyduck: this thread: https://lists.fedoraproject.org/pipermail/cloud/2015-February/004900.html
19:42:43 <robyduck> want me to update them?
19:42:59 <roshi> +1 to update them
19:43:11 <oddshocks> robyduck: that'd be swell. you might need a new button/column/something though, because now there are both HVM and PV AMIs for the base image :)
19:43:22 <oddshocks> +1 from me
19:43:39 * robyduck looks on the webpage
19:44:08 <roshi> thanks robyduck :)
19:44:23 <robyduck> oddshocks: roshi: so you have new images or just updated images?
19:44:45 <robyduck> We have base cloud EC2 and Atomic EC2 AMI IDs there
19:45:12 <roshi> oddshocks can speak better to that than me
19:45:15 <oddshocks> robyduck: those AMIs are built from the same official images provides on the cloud download page. But these AMIs have smaller volume sizes, are on the *official* Fedora AWS account, and a few other benefits
19:45:38 <oddshocks> s/provides/we provide/
19:46:24 <oddshocks> robyduck: the list in that email still has base and Atomic AMIs. It's just that now, there are 2 types of base image
19:46:29 <oddshocks> for a total of 3 AMI IDs per region
19:46:46 <robyduck> hmm, the cloud webpage is *your* page, so just tell me which images you want to have there. I don't know if there are other links to them for example, or is the AWS link the same
19:46:54 <oddshocks> and that number will expand by a few more in the future (encrypted EBS will be added, and instance store... AIUI)
19:47:26 <robyduck> ok, yes I knew there will be more public cloud images soon
19:47:27 <oddshocks> robyduck: do you have access to the attached list from the cloud email, or can I just email it to you directly?
19:47:37 <oddshocks> it's got all the IDs in a signed text file
19:47:51 <robyduck> we could add them for now there and when we have other services, make a separate public cloud page
19:48:28 <oddshocks> Alright, cool. We'll tackle that when we get there.
19:48:43 <roshi> robyduck is this the best way to handle this kind of issue? Get a list of AMIs and ping you?
19:48:45 <robyduck> oddshocks: if you could mail me would be nice ;)
19:48:46 <oddshocks> I think we're set on the AMIs/website then, unless someone has something else regarding the updated AMIs
19:48:50 <oddshocks> roshi: good question
19:49:17 <robyduck> yes, the best would be to check the link and just list the IDs, I need to change our script a bit but that's all
19:49:30 <roshi> I don't know if we'd be allowed commit access to the /cloud/ page, but I think we'd be fine with updating them ourselves if it's easier
19:49:43 <robyduck> will need also to add a third button with the third AMI IDs, (if I understood right)
19:49:44 * oddshocks nods
19:50:03 <oddshocks> robyduck: that, or a second column to the pop-up
19:50:07 <roshi> since the plan is to have more updates as time progresses, so this won't be a one-off thing
19:50:25 <robyduck> well I can't grant commit access to just a part of a website, only to the whole websites repo
19:51:12 <roshi> ah
19:51:13 <robyduck> but if you have updates you can mail me or just open a ticket with the updated links
19:51:17 <robyduck> links=IDs
19:51:17 <roshi> I wasn't sure how it was split up
19:51:27 <oddshocks> Alright, sounds good. I'll probably open a ticket then, to keep things open :)
19:51:32 * roshi thought maybe subprojects that got pulled in when the site was built
19:51:39 <roshi> good call oddshocks
19:51:52 <roshi> thanks robyduck, that's what we'll do from now on
19:52:14 <robyduck> oddshocks: roshi: as you prefer, you can also ping us in -websites, if I'm not around there is someone else (hopefully) :D
19:52:21 <robyduck> ok cool
19:52:23 <roshi> good to know
19:52:34 <roshi> we can release you now :p
19:52:48 <roshi> onto the next topic?
19:53:00 <oddshocks> robyduck: thanks! :)
19:53:14 <robyduck> eheh, thanks, if you need anything else, just ping me again ;)
19:53:17 <robyduck> YW
19:53:29 <roshi> #topic Image checksums (#93)
19:53:35 <roshi> #link https://fedorahosted.org/cloud/ticket/93
19:54:02 <roshi> who's tracking this/wants to track it?
19:55:27 <roshi> what does systemd have to do with checking images?
19:55:54 <roshi> at first glance I thought this was meant to be like the checksums we publish for all our other images
19:56:08 <roshi> can someone fill me in on what systemd has to do with it?
19:56:09 <dustymabe> hmm
19:56:19 <dustymabe> roshi: I don't think anything
19:56:29 <dustymabe> I guess lennart was just an interested party?
19:56:52 <dustymabe> or maybe that want to index images by checksum or something?
19:56:55 <dustymabe> no idea
19:56:58 <roshi> could just be a typo in the description
19:57:07 <dustymabe> either way we already have the sums don't we?
19:57:13 <roshi> but that and lennart being on the ticket makes me wonder
19:57:20 <roshi> I can't imagine we don't
19:57:33 <roshi> maybe not on a standard path, though
19:58:23 <dustymabe> http://fedora.mirror.lstn.net/releases/21/Cloud/Images/x86_64/Fedora-Cloud-Images-x86_64-21-CHECKSUM
19:58:35 <dustymabe> I think we just need to put them somewhere where people can find the links..
19:58:35 <roshi> well, without kushal here, it's hard to know what he's getting at
19:58:46 <dustymabe> maybe robyduck can help us with that to
19:58:53 <dustymabe> s/to/too
19:59:07 <roshi> I can see wanting it at https://fp.o/cloud/sums or something like that
19:59:14 <roshi> instead of from a mirror
20:00:11 <robyduck> uh?
20:00:14 <robyduck> Reading
20:00:29 <roshi> thought you had escaped, eh?
20:00:36 <robyduck> eheh, yeah
20:00:42 <dustymabe> roshi: do you agree the sums should be linked off of the page where you can download the images?
20:00:59 <roshi> I would say so, if not on the pages themselves
20:01:39 <robyduck> mmh, the checksums you mean?
20:01:48 <robyduck> they are linked in the download splash
20:02:02 <roshi> yeah, the checksums themselves
20:02:08 <roshi> that'd be my thought, at least
20:02:09 <robyduck> with a JS script, or if it doesn't work there is a direct link
20:02:45 <robyduck> roshi: when you click on "download" you will get to the download splash
20:02:49 <roshi> ah, yeah - it's there
20:03:00 <roshi> yep, no idea what's going on with this ticket
20:03:03 <robyduck> "validate" will give you the checksum of the image you are downloading
20:03:11 <roshi> yeah, I see it now :)
20:03:23 <robyduck> or if not, click on "follow these instructions"
20:03:32 <dustymabe> hmm
20:03:36 <roshi> I propose we punt this one until kushal gets back
20:03:38 <dustymabe> are you guys looking at this page?
20:03:41 <dustymabe> https://getfedora.org/en/cloud/download/
20:03:51 <roshi> https://getfedora.org/en/cloud/download/download-cloud-splash?file=http://download.fedoraproject.org/pub/fedora/linux/releases/21/Cloud/Images/x86_64/Fedora-Cloud-Base-20141203-21.x86_64.raw.xz
20:03:52 <robyduck> yes
20:04:00 <robyduck> dustymabe: click on a download link
20:04:07 <roshi> that's the link you get taken to if you click download
20:04:13 <dustymabe> robyduck: ahhh
20:04:18 <dustymabe> hmmm
20:04:36 <dustymabe> so let me try to explain how I use it
20:04:45 <robyduck> our thought was, people are not interested in checksums until they download an image
20:04:49 <dustymabe> I usually right click and copy link address
20:04:55 <dustymabe> and then wget that somewhere else
20:05:01 <roshi> same here, actually
20:05:05 <robyduck> while you download you can see and read the page and get it
20:05:08 <dustymabe> so I never see the "validate"
20:05:20 <robyduck> aha ok
20:05:27 <robyduck> well that's a special usecase
20:05:29 <roshi> I do the same thing
20:05:41 <robyduck> interesting
20:05:57 <roshi> my testCloud tool uses those links as well
20:05:58 <dustymabe> yeah most of the time the machine I am on is not the one I want to download the image to
20:06:07 <roshi> which means that you don't see the validate bits at all
20:06:12 <dustymabe> anywho I wonder if lennart uses it the same way
20:06:21 * roshi realizes he should do checksum checking in testcloud
20:06:24 <dustymabe> and he thinks we don't have sums posted for cloud images
20:06:53 <dustymabe> robyduck: thanks for helping us
20:07:04 <robyduck> dustymabe: YW
20:07:05 <dustymabe> maybe in the future we can include a validate link on the base page
20:07:20 <robyduck> yes, we could think about adding it, yes
20:07:37 <robyduck> pages are new, so they need to be improved for sure
20:08:05 <dustymabe> roshi: i'll update the ticket to point to the existing checksums and see what lennart comes back with
20:08:07 <roshi> I updated the ticket with a link to the checksums if that's what they're looking for
20:08:12 <roshi> already done :)
20:08:12 <dustymabe> :) nvm
20:08:33 <roshi> onto the next ticket then?
20:08:40 <roshi> got three more, then open floor
20:08:55 <roshi> do people have time?
20:09:29 <roshi> #topic OpenShift Commons (#83)
20:09:33 <roshi> #link https://fedorahosted.org/cloud/ticket/83
20:10:08 <dustymabe> i think we are putting this off for now
20:10:16 <dustymabe> at least until we have some bigger players like jzb around
20:10:19 <roshi> yeah, that's my thought as well
20:10:33 * roshi proposes we move on
20:10:46 <dustymabe> +1
20:11:08 <roshi> #info Skipping #83 until we have more people around to discuss
20:11:22 <roshi> #topic Dockerfiles Howto (#87)
20:11:29 <roshi> #link https://fedorahosted.org/cloud/ticket/87
20:11:50 <roshi> dustymabe: perhaps your dockerfile plans could include this, if you have time to write it?
20:12:17 <roshi> or we could start a draft on the wiki and write it communally
20:12:39 <dustymabe> roshi: I think my stuff will initially be a bit too complicated for a "how to"
20:12:50 <roshi> k, wasn't sure
20:12:52 <dustymabe> but I could do a how to for the owncloud one
20:13:01 <dustymabe> i'll leave that one at a "maybe"
20:13:03 <dustymabe> for now
20:13:28 <roshi> well, your name is mabe, so that means, you're taking it, right? :p
20:14:02 * roshi probably read mabe as maybe for a least a couple months
20:14:44 <roshi> #info Ticket 87 will need someone to write a draft howto and submit it to the list
20:15:24 <roshi> #topic Updated image policy (#94)
20:15:27 <roshi> #link https://fedorahosted.org/cloud/ticket/94
20:15:40 <roshi> dustymabe: any movement on this?
20:15:58 <dustymabe> roshi: not right now. I guess we need to know the right people to talk to
20:16:13 <roshi> probably dgilmore and releng
20:16:17 <dustymabe> and also get releng involved.. oddshocks may be able to help
20:16:36 <dustymabe> one other thing is the libvirt issue.. so I guess this is blocked on that as well
20:16:51 <roshi> oddshocks: you want to run point on figuring out the details on what releng needs in order to produce the updated images?
20:17:18 <oddshocks> Sure
20:17:25 <oddshocks> any other details I should know?
20:17:35 <roshi> nothing comes to mind
20:17:47 <roshi> I mean, we want to create updated images throughout a release
20:17:53 <roshi> so:
20:17:55 <oddshocks> So basically we need to find out why the image builds aren't passing?
20:17:58 <roshi> - cadence
20:18:03 <oddshocks> or just in general, what do they need
20:18:06 <roshi> - website updates with new IDs
20:18:30 <roshi> - what packages we'd allow in an update (or just a complete update of all available packages?)
20:19:01 <roshi> first, we need to find out what they need - and if we can even produce updated images
20:19:23 <dustymabe> roshi good questions. can you add these to the ticket?
20:19:37 <roshi> figuring out why the builds are failing needs to happen too, but not for this ticket, just in general
20:19:39 <oddshocks> Alright, should I shoot an email over to their list?
20:19:40 <roshi> sure
20:19:43 * oddshocks nods
20:19:45 <oddshocks> cool
20:19:47 <roshi> yeah, that'd be good
20:19:50 <dustymabe> oddshocks: thanks!
20:19:52 <roshi> I'll update the ticket right now
20:19:58 <oddshocks> sure thing
20:21:47 <roshi> oddshocks: can I assign this ticket to you while you commune with releng?
20:23:08 <oddshocks> sure thing.
20:23:10 <oddshocks> :)
20:23:12 <roshi> sweet
20:23:51 <roshi> #action oddshocks to get with releng about updated images
20:23:57 <roshi> #topic Open Floor
20:24:04 <roshi> dustymabe had something for this, as did I
20:24:14 <roshi> if people have time
20:24:19 <roshi> I can also just email the list
20:24:43 <dustymabe> roshi: you referring to what I told you last week?
20:24:52 <roshi> uh
20:25:04 <roshi> I think I was talking about the libvirt issues
20:25:13 <roshi> is that what you told me last week?
20:25:14 <roshi> lol
20:25:34 <dustymabe> haha no. libvirt issues? the ones that mattdm found?
20:25:45 <dustymabe> for the builder hosts
20:25:52 * roshi has been neck deep in yum/dnf exploration so his brain is a bit fuzzy
20:25:57 <roshi> yeah, those
20:26:13 <roshi> I thought you said at the beginning of the meeting you wanted to talk about that during open floor
20:26:14 <dustymabe> yeah I don't have any more information than what he reported
20:26:26 * dustymabe looks
20:26:53 <roshi> meh
20:26:59 <roshi> my memory is failed
20:27:03 <roshi> it was oddshocks
20:27:32 <dustymabe> :)
20:28:24 <roshi> oddshocks: ^^ what did you want to bring up?
20:29:30 <dustymabe> we may have lost him
20:29:39 <roshi> could be
20:29:47 <roshi> lunch time probably
20:29:55 * roshi needs to eat something sometime soon
20:30:16 <roshi> I'll email the list, but my thing is related to the release criteria
20:30:19 <roshi> we have http://fedoraproject.org/wiki/Fedora_22_Beta_Release_Criteria
20:30:23 <dustymabe> ok
20:30:26 <roshi> under Cloud-init
20:30:43 <roshi> we should really specify which bits of it we need to have working
20:31:01 <dustymabe> roshi: ok
20:31:01 <oddshocks> sorry, phone call
20:31:07 <roshi> np
20:31:23 <oddshocks> yeah, mattdm just pointed out some libvirt issue
20:31:27 <oddshocks> with it not running or something
20:31:29 <oddshocks> in the AMI list thread
20:31:36 <oddshocks> that's all.
20:31:39 <roshi> ah
20:32:45 <roshi> does anyone have any idea about dnf support for cloud-init?
20:32:56 <dustymabe> roshi: no idea right now
20:33:03 <roshi> I seem to remember seeing that there was a patch sent upstream, but I can't find it
20:33:10 <dustymabe> is dnf all there is going to be in F22
20:33:16 <roshi> that's the plan
20:33:17 <roshi> that'
20:33:32 <roshi> s what I'm looking into now, for QA, to figure out what all we need to test
20:33:41 <roshi> it's a non-trivial change :p
20:33:47 <dustymabe> ok. yeah I don't know. hoping to be able to  devote more time to cloud in the future
20:34:17 <roshi> sweet :)
20:35:04 <roshi> it's something we have to figure out
20:35:13 <roshi> and find ways to test it
20:35:55 <roshi> that's all I had
20:36:06 <roshi> anyone else have anything? or should I set the fuse?
20:37:22 * oddshocks is good
20:37:57 * roshi sets the fuse
20:37:59 <roshi> 3...
20:38:06 <roshi> thanks for coming!
20:38:17 <dustymabe> roshi: thanks!@
20:38:41 <roshi> np!
20:38:43 <roshi> 2...
20:38:56 <roshi> 1...
20:39:00 <roshi> #endmeeting