#fedora-meeting-1: fpc

Meeting started by geppetto at 17:00:46 UTC (full logs).

Meeting summary

  1. Roll Call (geppetto, 17:00:46)
  2. Schedule (geppetto, 17:04:19)
    1. https://lists.fedoraproject.org/pipermail/packaging/2015-February/010471.html (geppetto, 17:04:21)

  3. #492 Reverse weak dependencies (geppetto, 17:04:37)
    1. https://fedorahosted.org/fpc/ticket/492 (geppetto, 17:04:43)
    2. ACTION: Create a real policy in the ticket, probably as a new page that is linked to, using the information provided by the dnf maintainer. Include examples for packagers, and how to change the dnf settings. (geppetto, 17:21:33)
    3. ACTION: Also include "normal" weak deps., so we can at least make sure they both line up correctly. Although we'll probably vote on them separately. (geppetto, 17:22:25)

  4. #493 Bundling exception: python-execnet bundles python-apipkg (geppetto, 17:23:12)
    1. https://fedorahosted.org/fpc/ticket/493 (geppetto, 17:23:35)
    2. ACTION: apipkg is in rawhide, check back if you need anything else. If we don't hear anything we'll close the ticket in a few weeks. (geppetto, 17:32:17)

  5. #495 Proposal: Package Guidelines: PreupgradeAssistant contents packages (geppetto, 17:32:26)
    1. https://fedorahosted.org/fpc/ticket/495 (geppetto, 17:32:30)
    2. ACTION: PreupgradeAssistant contents packages (+1:6, 0:0, -1:0) (geppetto, 17:57:49)
    3. https://github.com/phracek/preupgrade-assistant (tibbs|w, 17:57:55)

  6. #497 Clean up BuildRequires section; don't try to define the minimal build env (geppetto, 18:01:03)
    1. https://fedorahosted.org/fpc/ticket/497 (geppetto, 18:01:09)
    2. ACTION: tibbs Tweak email with feedback and post again, will look at voting on something next week. (geppetto, 18:13:45)

  7. #498 Seeking guidance: Apps using default Python in Fedora vs. EPEL (geppetto, 18:14:02)
    1. https://fedorahosted.org/fpc/ticket/498 (geppetto, 18:14:08)
    2. https://fedoraproject.org/wiki/User:Tomspur/Unversioned_Python_Macros#Bytecompiling_with_the_correct_python_version (tibbs|w, 18:26:51)
    3. ACTION: Apps using default Python in Fedora vs. EPEL (+1:6, 0:0, -1:0) (geppetto, 18:28:12)

  8. Open Floor (geppetto, 18:28:35)
    1. https://lists.fedoraproject.org/pipermail/packaging/2015-February/010471.html … we've got 7 anchient tickets (geppetto, 18:29:52)
    2. https://fedorahosted.org/fpc/ticket/221 (tibbs|w, 18:30:36)

  9. #221 Bundling exception request: numptyphysics and Box2D (geppetto, 18:31:02)
    1. https://fedorahosted.org/fpc/ticket/221 (geppetto, 18:31:10)
    2. ACTION: retiring package, so doesn't matter. (geppetto, 18:33:54)

  10. Open Floor (geppetto, 18:34:44)


Meeting ended at 18:45:42 UTC (full logs).

Action items

  1. Create a real policy in the ticket, probably as a new page that is linked to, using the information provided by the dnf maintainer. Include examples for packagers, and how to change the dnf settings.
  2. Also include "normal" weak deps., so we can at least make sure they both line up correctly. Although we'll probably vote on them separately.
  3. apipkg is in rawhide, check back if you need anything else. If we don't hear anything we'll close the ticket in a few weeks.
  4. PreupgradeAssistant contents packages (+1:6, 0:0, -1:0)
  5. tibbs Tweak email with feedback and post again, will look at voting on something next week.
  6. Apps using default Python in Fedora vs. EPEL (+1:6, 0:0, -1:0)
  7. retiring package, so doesn't matter.


People present (lines said)

  1. geppetto (121)
  2. tibbs|w (113)
  3. tomspur (34)
  4. mbooth (19)
  5. limburgher (19)
  6. orionp (10)
  7. zodbot (8)
  8. hhorak (2)
  9. tomspur_ (1)


Generated by MeetBot 0.1.4.