19:04:31 <kushal> #startmeeting Fedora Cloud SIG
19:04:31 <zodbot> Meeting started Wed Feb 25 19:04:31 2015 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:04:43 <kushal> #meetingname Fedora Cloud SIG
19:04:43 <zodbot> The meeting name has been set to 'fedora_cloud_sig'
19:04:51 <kushal> #topic Roll call
19:04:53 <roshi> .hello roshi
19:04:54 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:04:57 <kushal> .hellomynameis kushal
19:04:59 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:05:08 <jzb> .hellomynameis jzb
19:05:09 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
19:05:43 <rtnpro> .fas rtnpro
19:05:45 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
19:07:08 <kushal> oddshocks, number80 ?
19:07:26 <kushal> #chair rtnpro jzb roshi
19:07:26 <zodbot> Current chairs: jzb kushal roshi rtnpro
19:07:54 <kushal> I am with a huge lag
19:08:20 <roshi> it's alright, we don't notice :p
19:08:34 <jzb> I just assumed you were slow typing
19:08:41 <kushal> haha
19:08:58 <kushal> #topic Action items from last meeting
19:09:08 <kushal> There is none I guess.
19:09:22 <jzb> let's give somebody an action item to have an action item this week
19:09:26 <roshi> yeah, there wasn't any
19:10:22 <kushal> moving on
19:11:08 <kushal> #topic dockerfiles #84
19:12:00 <kushal> any update on this one?
19:12:26 * jzb is looking for the ticket
19:13:00 <roshi> I played with docker files over the weekend
19:13:06 <roshi> might do a write up on my blog
19:13:20 <kushal> roshi, please go ahead, we can tweet/retweet :)
19:13:20 <roshi> trying to containerize chrome to manage it's memory usage
19:14:11 <kushal> roshi, ah, that would be painful :)
19:14:11 <jzb> roshi: ask Jim Perrin
19:14:18 <jzb> roshi: he's managed to containerize Wine/IE
19:14:24 <jzb> it's ... well, sort of evil
19:14:43 <jzb> I have an article done for Fedora Magazine that I need to polish and publish
19:14:48 <jzb> I'll do that tomorrow
19:15:48 <scollier> hey kushal
19:15:51 <scollier> sorry for delay.
19:15:53 <kushal> scollier, welcome :)
19:16:02 <kushal> scollier, no problem, we are just starting.
19:16:05 <jzb> EOF for me on that topic.
19:16:37 <kushal> scollier, any pointers for publicizing Fedora dockerfiles?
19:17:40 <scollier> kushal, aside from the typical social media, not really.  Each time a dockerfile gets modified or added, I generally tweet about it.  at one time i wrote a blog post for each dockerfile, but i don't do that anymore.
19:17:50 <kushal> scollier, okay.
19:17:52 <scollier> kushal, i think an entry in the fedora-magizne
19:18:05 <scollier> with regards to, where we need help, and encouraging contributions would be nice.
19:18:09 <kushal> scollier, that would be nice, roshi is doing a blog post in the coming days.
19:18:49 <scollier> kushal, i think having the basic dockerfiles are nice
19:18:52 <scollier> at some point
19:19:06 <kushal> scollier, yup, they give ideas on how to start.
19:19:07 <scollier> i'd like to see some folks actually putting together multi-container apps.
19:19:10 <jzb> scollier: I can send you what I have
19:19:15 <scollier> and even orchestrating with k8s.
19:19:30 <scollier> that would show some real value.  IMO.
19:19:30 <jzb> scollier: see if there's room to expand the "where we need help" part
19:19:35 <scollier> jzb, ack
19:19:55 <kushal> Moving to next topic then
19:20:01 <kushal> #topic Getting sha256sum published for the cloud images #93
19:20:06 <jzb> do we have any tools for Fedora packagers?
19:20:14 <jzb> (containerized)?
19:20:21 <jzb> kushal: soorry
19:20:23 <jzb> er, sorry
19:20:24 <kushal> jzb, not that I remember.
19:20:28 <jzb> K
19:20:32 <scollier> jzb, now that's a GREAT suggestion.
19:20:33 <kushal> jzb, my bad, please go ahead.
19:20:33 * jzb makes a note that might be a good start
19:20:50 <scollier> for folks who are packaging rpms, maybe create containers as well :)
19:20:55 <jzb> scollier: charity begins at home, right?
19:20:58 <scollier> where it makes sense.
19:21:02 <kushal> scollier, jzb :)
19:21:03 * dustyaway is late
19:21:30 <kushal> dustymabe, welcome ;)
19:21:39 <dustymabe> kushal: thanks!
19:21:53 <jzb> dustymabe: howdy
19:22:08 <dustymabe> jzb: :)
19:22:20 <kushal> So for #93, systemd wants in the way  Ubuntu does, we have a different style for the last 10 years already.
19:22:38 <kushal> Wondering how to put that nicely on the ticket, can anyone help me on that part?
19:23:10 <jzb> kushal: I'm not sure I followed that
19:23:34 <kushal> jzb, so we have these checksum files https://getfedora.org/en/static/checksums/Fedora-Cloud-Images-x86_64-21-CHECKSUM
19:23:38 <kushal> for a long time.
19:24:14 <kushal> jzb, systemd wants them to be renamed as sha256sums and they want the gpg sig to be in a different file
19:24:48 <kushal> jzb, that will break the way we do release engineering for the last 10 years or so, also someone has to fix many scripts (i guess).
19:25:10 <jzb> kushal: this only applies to cloud images, or...?
19:25:13 <kushal> jzb, because this is the standard way for creating checksums in other parts of the release
19:25:19 <kushal> jzb, he only wants for cloud
19:25:41 <dustymabe> kushal: yeah. I don't know why they can't just parse out the sig to verify signature and parse out the sum to verify the download file
19:26:02 <kushal> dustymabe, can you please ask that in the ticket? :)
19:26:08 <dustymabe> sure
19:26:12 <kushal> dustymabe, thanks :)
19:26:15 <jzb> kushal: I think this would be classified as a system-wide change and something that would probably need to be held to F23
19:26:35 <kushal> jzb, yup, that is also true.
19:26:36 <dustymabe> I understand he is going for a standard thing to download but it would be better if his tool was more accomodating
19:26:53 <jzb> I don't disagree that we should have a standard name
19:27:28 <jzb> it'd be a lot easier to have a script that checks things if the name is always sha256sums than somethign-something-CHECKSUMS
19:27:43 <dustymabe> jzb: I agree
19:27:49 <jzb> but really - the tooling would come from infrastructure, or rel-eng, not us?
19:27:52 <kushal> jzb, yup, I am okay with the first part, but not sure about keeping sig in a different file.
19:28:01 <kushal> jzb, Yes.
19:28:03 <jzb> so the ask is really to them.
19:28:03 <dustymabe> jzb: but we could have both
19:28:08 <jzb> dustymabe: sure
19:28:26 <dustymabe> we could have Fedora-Cloud-Images-x86_64-21-CHECKSUM
19:28:43 <dustymabe> and then also SHA256SUMS that is a symlink or something
19:29:02 <jzb> dustymabe: look at you being all problem solving and stuff
19:29:11 <kushal> :)
19:29:14 <dustymabe> :)
19:29:19 <kushal> Can we move to next topic?
19:29:24 <dustymabe> kushal: sure
19:29:32 <jzb> yep
19:29:33 <kushal> #topic Fedora Magazine Post: How to Use Dockerfiles #87
19:29:49 <kushal> I guess we already discussed this part.
19:29:51 <jzb> done, I just need to polish and add a few lines
19:30:33 <jzb> EOF
19:30:59 <kushal> Okay.
19:31:03 <kushal> Moving to next then.
19:31:23 <kushal> #topic Producing Updated Cloud/Atomic Images #94
19:31:49 <kushal> just wondering why the primary connection went just at the time of the meeting :(
19:32:07 * rtnpro have been working on testing project atomic image for Fedora 22
19:32:15 <kushal> oddshocks, any updates on this?
19:32:22 <kushal> rtnpro, you can wait till the open floor :)
19:33:08 <kushal> We need the updated images.
19:33:15 <rtnpro> pl
19:33:21 <rtnpro> s/pl/ok
19:33:40 <kushal> roshi, jzb any comments?
19:34:52 <jzb> kushal: just a sec
19:35:26 <roshi> sorry, had to handle something IRL
19:35:31 * roshi reads backscroll
19:35:46 <jzb> I think/thought we'd largely decided the cadence, etc. We still need to decide who file tickets, etc
19:35:54 <jzb> so the question really is - who's going to own this?
19:35:59 <jzb> I think that's the question, anyway
19:36:12 <kushal> jzb, ideally rel-eng
19:36:30 <jzb> kushal: well, there's also updating the Web site, etc
19:36:36 <jzb> does rel-eng need to do that as well?
19:36:45 <jzb> I guess oddshocks volunteered
19:36:49 <dustymabe> I think oddshocks has been working with the website people quite a bit
19:36:55 <roshi> also, who's going to own the tooling to get it done
19:36:59 <dustymabe> to get new AMIs published etc..
19:37:08 <roshi> aiui, there's technical limits to getting the updated images as well
19:37:26 <kushal> jzb, yup.
19:39:13 <dustymabe> do we know what those are?
19:42:14 <roshi> I don't
19:42:18 * oddshocks pops in
19:42:36 <kushal> I also don't.
19:42:38 <kushal> oddshocks, hi
19:42:40 <oddshocks> Hey! So, I spoke with dennis briefly
19:43:00 <oddshocks> apparently they're still figuring out the process that will be used, but he did summarize... I think I posted on the ticket?
19:43:15 <oddshocks> I haven't heard anything since I asked rel-eng list and updated the ticket
19:43:17 <oddshocks> (heard nothing on rel-eng list)
19:43:40 <oddshocks> but dennis said basically we'd poke rel-eng, then they'd produce something, then QA would eventually release
19:45:05 <dustymabe> ok.. so looks like it is in-progress
19:45:16 <kushal> Okay, good news :)
19:45:22 <dustymabe> oddshocks: let us know if there is anything we can help with as far as technical limitations go
19:45:34 <oddshocks> Yeah. Out of my hands on the rel-eng process. But they're definitely aware we're hoping to set up a good process to release updates
19:45:53 <oddshocks> Dennis said he'd update us when they know :)
19:46:18 <dustymabe> :)
19:46:27 <oddshocks> dustymabe: cool. I haven't gotten any details yet on technical stuff. But will definitely keep everyone in the loop, and update the ticket.
19:47:17 <dustymabe> ok cool.. what's next?
19:47:36 <kushal> open floor
19:47:41 <kushal> #topic Open Floor
19:47:48 <kushal> I have a few points.
19:47:58 <kushal> 1. What about the F22 features we proposed?
19:48:06 <kushal> Tunir is ready and under review.
19:48:16 <kushal> roshi, what is the status for testCloud?
19:48:44 <rtnpro> I was trying out the test matrix for atomic image: file:///home/rtnpro/ISOS/Fedora-Cloud-Atomic-20150207-rawhide.x86_64.raw.xz available at https://fedoraproject.org/wiki/Test_Results:Fedora_22_Branched_20150221_Cloud?rd=Test_Results:Current_Cloud_Test
19:48:47 <oddshocks> I guess I was gonna dumbly ask if we need AMIs for any recent F22 test candidates. Can produce any needed immediately (now with both standard and gp2 volume types!)
19:49:44 <rtnpro> I could not relate with the first two test cases: a) Testcase_base_initial_setup, b) Testcase_base_startup
19:50:01 <kushal> rtnpro, is networking working in that image?
19:50:09 <rtnpro> kushal, yeah :)
19:50:29 <kushal> 07 is old though.
19:51:05 <kushal> rtnpro, I can see http://koji.fedoraproject.org/koji/taskinfo?taskID=9001537
19:51:09 <kushal> TC3
19:52:17 <kushal> oddshocks, I am not sure if we have people who wants to use TC* as AMI
19:52:30 <kushal> oddshocks, but may be I am completely wrong
19:52:39 <rtnpro> I will pull the latest build and try running the test cases again
19:53:08 <oddshocks> kushal: Yeah, I mostly meant if anyone wants 'em for testing
19:53:14 <jzb> kushal: it's good to have for testing...
19:53:14 <oddshocks> mostly cloud folks
19:53:15 <roshi> kushal: I haven't done much with it since we talked last about it
19:53:18 <kushal> oddshocks, Okay.
19:53:32 <kushal> roshi, Okay, update the wiki when you find time.
19:53:50 <roshi> will do, I updated the bug for the feature
19:53:53 <dustymabe> rtnpro: I don't if an initial setup utility is going to run for atomic
19:53:54 <rtnpro> 'tail /var/log/secure' failed for https://fedoraproject.org/wiki/QA:Testcase_base_system_logging
19:54:13 <dustymabe> roshi: does that apply to atomic?
19:54:31 <roshi> which?
19:54:49 <kushal> jzb, what about the other feature proposals from our side?
19:54:53 <rtnpro> seems like /var/log/secure file is missing by default in the atomic image
19:55:15 <dustymabe> roshi: https://fedoraproject.org/wiki/QA:Testcase_base_initial_setup
19:55:15 <rtnpro> also, disabling, stoping sshd.service does not work
19:55:25 <jzb> kushal: what about them? :-)
19:55:41 <kushal> jzb, I mean what is the status, etc :)
19:55:44 <jzb> https://bugzilla.redhat.com/show_bug.cgi?id=1191525
19:55:50 <jzb> https://bugzilla.redhat.com/show_bug.cgi?id=1194589
19:55:57 <jzb> https://bugzilla.redhat.com/show_bug.cgi?id=1194590
19:55:58 <rtnpro> Testcase_Services_start and Testcase_base_selinux are working fine
19:56:06 <jzb> Most recent updates from walters
19:56:35 <jzb> basically all are in MODIFIED state atm.
19:56:40 <kushal> jzb, thanks :)
19:56:44 <jzb> I have been out all week so I don't really have much else on that status
19:56:50 <jzb> I do have one additional bug/question to look at
19:56:59 <jzb> https://bugzilla.redhat.com/show_bug.cgi?id=1194623
19:57:01 <kushal> jzb, go ahead.
19:57:25 <jzb> basically they're asking if we can default to networkd instead of network-scripts
19:57:29 <jzb> any objections?
19:57:59 <dustymabe> jzb: that might affect cloud-init
19:58:38 <dustymabe> does networkd read the /etc/sysconfig/network-scripts files too?
19:58:39 <kushal> jzb, also we have to find what all will be affected.
19:59:04 <dustymabe> I think it doesn.. but not sure right off the top
19:59:13 <dustymabe> s/doesn/does/
19:59:25 <roshi> I'll take a look, it might not
19:59:31 <roshi> dustymabe: ^^
19:59:35 <roshi> (sorry, phone call)
19:59:56 <dustymabe> roshi: thanks.. since rtnpro is consuming these it would be good if we have him scoped right :)
20:00:02 <jzb> dustymabe: do you want to look into this?
20:00:17 <roshi> aren't all the atomic testcases optional anyways?
20:00:18 <dustymabe> jzb: networkd and init scripts?
20:00:25 <jzb> dustymabe: yeah
20:00:27 <kushal> I will also have a look tomorrow moring.
20:00:30 <kushal> * morning
20:00:47 <dustymabe> jzb: let me take a look at the bug real quick
20:00:59 <jzb> dustymabe: soitenly
20:01:02 <jzb> dustymabe: thanks
20:01:07 <rtnpro> kushal, I will sync up with you tomorrow morning then :)
20:01:29 <kushal> rtnpro, find out if the latest images have networking or not.
20:01:37 <rtnpro> kushal, ok
20:01:46 <roshi> hopefully they do
20:01:50 <kushal> :)
20:01:57 * roshi didn't get to filing the bug for that
20:02:01 <roshi> has anyone else?
20:02:06 <jzb> eh, what do we need networking for in the cloud
20:02:07 <jzb> ?
20:02:08 * roshi hasn't looked into it
20:02:20 <dustymabe> jzb: yeah I can look into that.
20:02:22 <roshi> it needs to be proposed as a blocker as well
20:02:22 <kushal> jzb, I mean the images were not getting any IP.
20:02:27 <kushal> roshi, yup.
20:02:41 <jzb> dustymabe: awesome
20:02:59 <jzb> #action dustymabe to look at bug 1194623
20:03:13 <jzb> kushal: it's more secure that way
20:03:14 <kushal> jzb, finally, an action :)
20:03:19 <kushal> jzb, yup :)
20:03:42 <kushal> jzb, just have to create a buzzword for the same.
20:04:03 <jzb> "Super-secure cloud: Totally impervious to network attacks"
20:04:17 <kushal> jzb, sounds good :)
20:04:22 <roshi> it's a feature!
20:04:42 <roshi> Fedora Bottled Cloud
20:04:47 <kushal> haha
20:04:48 <jzb> nice
20:04:50 <roshi> nothing gets in, nothing gets out
20:04:55 <kushal> I guess we can close the meeting now.
20:05:01 <jzb> +1
20:05:02 <kushal> roshi, that is a superb feature.
20:05:03 <jzb> kushal: thanks
20:05:07 <kushal> #endmeeting