19:01:10 <kushal> #startmeeting Fedora Cloud SIG
19:01:10 <zodbot> Meeting started Wed Mar  4 19:01:10 2015 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:21 <kushal> #meetingname Fedora Cloud SIG
19:01:21 <zodbot> The meeting name has been set to 'fedora_cloud_sig'
19:01:27 <kushal> #rollcall
19:01:33 <kushal> #topic rollcall
19:01:40 <kushal> .hellomynameis kushal
19:01:41 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:01:56 <roshi> .hello roshi
19:01:56 <dustymabe> .hellomynameis dustymabe
19:01:57 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:01:59 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
19:02:06 <rtnpro> .hellomynameis rtnpro
19:02:07 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
19:02:17 <jzb> .hellomynameis jzb
19:02:18 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
19:02:26 <dustymabe> rtnpro: welcome!
19:02:30 <kushal> Anyone else?
19:02:43 <oddshocks> yep
19:02:47 <oddshocks> .hellomynnameis oddshocks
19:02:51 <kushal> oddshocks, :)
19:02:52 <oddshocks> butts
19:02:55 <oddshocks> .hellomynameis oddshocks
19:02:56 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
19:03:01 <kushal> oddshocks, hahaha
19:03:29 <kushal> #topic Action item from last meeting
19:03:32 <kushal> * dustymabe to look at bug 1194623
19:03:40 <dustymabe> kushal: :)
19:03:52 <dustymabe> jzb: I took a look at systemd-networkd
19:04:07 <dustymabe> it isn't compatible with the old style network scripts
19:04:16 <dustymabe> so cloud-init would need to be updated if we adopted this as the default
19:04:43 <kushal> dustymabe, means more work.
19:04:45 <jzb> dustymabe: yeah - I saw the update, thanks - so, how invasive / troublesome is the update?
19:04:45 <dustymabe> this is a change in behavior too so would probably need to be proposed etc...
19:05:00 * rtnpro needs to speak with dustymabe about systemd-networkd
19:05:09 <dustymabe> rtnpro: noted
19:05:55 <dustymabe> jzb: well the update probably wouldn't be too bad for cloud-init (especially if that guy writes a tool to do the conversion)
19:06:02 <kushal> dustymabe, jzb so we will have to inform this to the cloud-init devels?
19:06:05 <dustymabe> the problem is the change in behavior
19:06:06 <kushal> gholms, welcome :)
19:06:34 <dustymabe> what people expect to happen.. Should we vet this and possibly do it for the next round of Fedora?
19:07:03 <dustymabe> static networking is a small use case so maybe it's not that big of a deal
19:07:06 <jzb> dustymabe: I think that's probably the best plan.
19:07:13 <kushal> dustymabe, +1
19:07:17 <roshi> +1 to that
19:07:28 <dustymabe> ok should we make a ticket anyways?
19:07:34 <kushal> dustymabe, make one
19:07:37 <dustymabe> is there a way to mark tickets for later releases?
19:07:40 <jzb> dustymabe: we may ask on atomic-devel whether anyone is using static networking.
19:07:41 * gholms goes to find the channel logs for context
19:07:41 <roshi> I don't imagine it would be easy to get a change like that pushed through for F22 this late in the game
19:07:50 <kushal> that way we will be able track things.
19:07:53 <kushal> dustymabe, yes
19:08:10 <dustymabe> ok.. I'll make a ticket
19:08:16 <jzb> roshi: well
19:08:18 <oddshocks> sounds like the thing to do
19:08:26 <jzb> hmmm
19:08:28 <kushal> #action dustymabe will create a track ticket about systemd-networkd
19:08:34 <kushal> dustymabe, is this okay ^^?
19:08:37 <jzb> the idea is that this will solve another issue
19:08:40 <dustymabe> kushal: yep
19:08:42 <jzb> that we're currently having, though - right?
19:08:48 <dustymabe> jzb: correct
19:08:53 <jzb> e.g. problems bringing up networking with the current Atomic/Cloud image?
19:08:54 <dustymabe> supposedly networking is racy?
19:09:14 <dustymabe> jzb: just atomic or cloud base and atomic?
19:09:14 <jzb> so - if we hold off to F23 are we saddling ourselves with this bug through the entire release?
19:09:35 <jzb> dustymabe: initial bug says cloud image
19:10:00 <kushal> dustymabe, There is a milestone called Future for that kind of tickets.
19:10:10 <dustymabe> well I think for most of us the issue with networking in the early TCs for F22
19:10:18 <dustymabe> was that dhcp-client rpm wasn't in the image
19:10:23 * gholms nods
19:10:26 <dustymabe> so no dhcp networking would ever work at all
19:10:27 <kushal> dustymabe, yes, and that is solved for now.
19:10:32 <jzb> dustymabe: ah. that would be a bad thing :-)
19:10:34 <dustymabe> current TCs don't have that problem
19:10:40 <jzb> OK
19:10:46 <gholms> This seems like a good thing to do first in rawhide.
19:10:47 <kushal> dustymabe, there was a change made in comps.
19:10:49 <dustymabe> and networking seems to be working fine (at least for me :))
19:10:51 <roshi> bottom line, will we be able to fix networking in F22 without trying to push the change through?
19:11:04 <jzb> if this isn't related to widespread problems, I'm OK with defering.
19:11:24 <dustymabe> roshi: I think networking has been "fixed" for the majority
19:11:28 <kushal> gholms, someone forgot to update the comps.
19:11:33 <dustymabe> only side cases of racy conditions exist
19:11:35 <roshi> ok, good
19:11:54 <kushal> dustymabe, +1 on "fixed"
19:11:59 <dustymabe> roshi: we can request the bug reporter to test though
19:12:02 <gholms> kushal: For systemd-networkd?
19:12:07 * gholms is still catching up
19:12:15 <kushal> gholms, nope, normal f22 cloud image
19:12:29 <gholms> Oh.  Yep.
19:14:43 <gholms> [Frost gathers on the windows]
19:15:02 <dustymabe> ok done with that topic?
19:15:09 <jzb> I believe so.
19:15:10 <kushal> seems so.
19:15:14 <kushal> I was waiting.
19:15:21 <kushal> next topic
19:15:38 <kushal> #topic Text for Alpha Release Announcement #95
19:16:16 <kushal> So should we update those bullet points?
19:16:26 <kushal> #link https://fedoraproject.org/wiki/F22_Alpha_release_announcement
19:16:36 <kushal> ^^ that is the current draft
19:16:39 <roshi> yeah, as I'm sure I forgot something or didn't represent something correctly
19:17:07 <jzb> note this is the alpha, so - the final release will highlight different things
19:17:18 <jzb> what's our messaging for this release, though?
19:17:28 <roshi> "Test, Test, Test!"
19:17:31 <jzb> heh
19:17:37 <kushal> roshi, +1000
19:17:43 <roshi> I just went through the changeset for F22 and added bullets for cloudy things
19:17:46 <jzb> I do feel like this is a release where we're honing what we have rather than introducing new things.
19:17:59 <roshi> most alpha's are
19:18:00 <jzb> do we want to highlight Docker?
19:18:02 <dustymabe> jzb: not a bad thing?
19:18:02 <oddshocks> "Only _you_ can prevent cloud image bugs"
19:18:07 <jzb> roshi: I mean F22 altogether
19:18:16 <dustymabe> since F21 was so different..
19:18:17 <jzb> roshi: sorry - when I say "this release" I mean F22
19:18:29 <kushal> oddshocks, I want to print that on a tshirt :)
19:18:37 <jzb> when all's done and said, what are we trying to achieve mostly with F22 Cloud Edition?
19:18:40 <roshi> my though was: Changes have to be testable by alpha, we should announce all changes early to get them tested
19:18:49 * gholms points at oddshocks's message  :)
19:18:50 <jzb> btw - we're shying away from "product" and using "edition"
19:19:06 <sgallagh> oddshocks: Can we get that written with Beefy Miracle pointing out of a shirt?
19:19:06 <roshi> Atomic host, and vagrant boxes, I would think
19:19:12 <oddshocks> jzb: Good question, and also I prefer "edition" to "product" as well
19:19:22 <roshi> as long as it has a laser gun and a radioactive panda
19:19:25 <jzb> the release notes are generally what get read and turned into article fodder
19:19:29 <kushal> roshi, haha
19:19:30 <oddshocks> sgallagh: I should ask mizmo ;)
19:19:49 <jzb> so the real audience here is people outside the normal Fedora circles and press.
19:20:07 <kushal> roshi, what is the status with testCloud?
19:20:08 * gholms chuckles at the product vs. edition snafu
19:20:09 <roshi> makes sense
19:20:18 <roshi> I have a lot of work to do with it kushal
19:20:31 <roshi> I pushed it off to F23 to ensure I have time to get it working right
19:20:37 <kushal> roshi, oh okay.
19:20:46 <roshi> and waiting on an official name from legal
19:21:03 <kushal> I will publish the cloud test cases for tunir. So that anyone can use that to test our cloud images.
19:21:29 <kushal> #action Kushal has to publish the test cases to be used with Fedora Cloud for Tunir.
19:21:33 <jzb> roshi: Tunir - have we got any "how to" to point to?
19:21:43 <kushal> jzb, tunir.rtfd.org
19:21:49 <roshi> yeah
19:21:53 <jzb> OK
19:22:06 <roshi> and tunir is kushal's baby - I just built a piece he used is all
19:22:20 <jzb> ah..
19:22:23 <kushal> roshi, tunir is all on your code :)
19:23:05 <roshi> lol
19:23:25 <kushal> jzb, btw, please tell me how can I improve that documentation? :)
19:23:31 <jzb> kushal: ok
19:24:23 <kushal> moving to next ticket?
19:24:35 <roshi> sure
19:24:42 <jzb> kushal: full speed ahead
19:24:50 <kushal> #topic publicize fedora-dockerfiles #84
19:25:09 <roshi> article looks good jzb :)
19:25:57 <jzb> roshi: thanks!@
19:26:00 <jzb> er, no @ there
19:26:11 * jzb curses fat fingers
19:26:19 <kushal> :)
19:27:35 <kushal> Moving ahead?
19:27:41 <jzb> Basically we need to flog the heck out of the article
19:27:41 <roshi> yup
19:27:44 <jzb> and keep writing more
19:27:44 <jzb> :-)
19:27:48 <roshi> for sure
19:27:55 <jzb> EOF
19:28:10 * roshi is working to get chrome working in a container - but not sure we want to do an article about non-free software
19:28:23 <roshi> I just want to constrain chromes memory usage...
19:28:24 <kushal> roshi, may be not.
19:28:33 <kushal> roshi, but publish it in your blog
19:28:40 <kushal> roshi, we can tweet that.
19:28:51 <roshi> that was my thought
19:28:52 <gholms> You'd probably have better luck with firefox.
19:28:53 <dustymabe> roshi: I'm surprised someone hasn't already done that
19:29:00 <jzb> roshi: talk to jperrin he's done WINE/IE
19:29:11 <jzb> I'm pretty sure Chrome has been done.
19:29:15 <roshi> I only want chrome for the flash support
19:29:18 <roshi> it has, in ubuntu
19:29:33 <roshi> selinux issues for using fedora as the base container image though
19:29:34 <jzb> roshi: I mean on Fedora. It may have been jperrin
19:29:37 <roshi> at least for me
19:29:40 <roshi> ah
19:29:44 <jzb> roshi: even using a privileged container?
19:29:46 <roshi> I'll look into it
19:29:48 <gholms> Nice
19:29:57 <roshi> I dunno - still kind of a docker luddite
19:30:04 <dustymabe> jzb: maybe get jperrin to donate dockerfile to fedora-dockerfiles?
19:30:09 <roshi> using this as a means to learn docker better
19:30:20 <jzb> dustymabe: there's some additional foo, I believe
19:30:29 <jzb> dustymabe: though this may be a test case for /usr/bin/atomic
19:30:38 <dustymabe> jzb: you may be right since its not free software
19:31:42 <roshi> sorry, I derailed things :( we can talk about this in #fedora-cloud later and move on with the meeting
19:31:50 <kushal> Okay :)
19:32:54 <kushal> #topic Getting sha256sum published for the cloud images #93
19:33:08 <kushal> dustymabe, updated that ticket but no reply yet.
19:33:34 <kushal> I am going to meet LP  next week during FOSSASIA in Singapore, I will bring this topic up there.
19:34:03 <dustymabe> kushal: thanks!
19:34:06 <roshi> sweet
19:34:18 <jzb> kushal: might also be something for the new Fedora Engineering Lead or whatever to help with.
19:34:21 <dustymabe> I never knew there were so many conferences
19:34:31 <kushal> jzb, Engineering lead?
19:34:40 <jzb> dustymabe: oooh, so many
19:34:52 <jzb> kushal: might have been publicized as an Atomic lead or something
19:35:13 <dustymabe> jzb: I saw a job posting.. did someone get hired?
19:35:22 <jzb> kushal: anyway - a new person who will be herding cats to make sure all the wonderful things happen w/r/t images, etc.
19:35:29 <kushal> We should talk this after meeting.
19:35:34 <kushal> jzb, yup.
19:35:52 <jzb> dustymabe: we haven't announced a hire yet, but I know that we have the position
19:36:15 <dustymabe> cool
19:36:36 <kushal> Moving to next ticket.
19:36:37 <kushal> #topic Producing Updated Cloud/Atomic Images #94
19:36:44 <kushal> oddshocks, ^^
19:37:13 <jzb> dustymabe: http://paul.frields.org/2015/02/03/fedora-release-infrastructure-job-opening/
19:37:25 <oddshocks> Unless someone's spoken to one of you, I haven't heard anything.
19:37:40 <oddshocks> Well, scratch that. I haven't heard anything regardless ;)
19:37:52 <oddshocks> Is this something maybe to re-ping about?
19:37:59 <kushal> oddshocks, I hope this new infra guy will help writing the new tools first.
19:38:34 <oddshocks> Ahh nice yeah stickster and I were chatting about the new person that could help us tackle some of this releng stuff
19:38:46 <oddshocks> Also, there's that FAD coming up, at some point
19:39:10 <oddshocks> And I think dgilmore is trying to come too https://fedoraproject.org/wiki/FAD_Release_Tools_and_Infrastructure_2015#Potential_Attendees
19:39:12 <kushal> oddshocks, Yes, in May.
19:39:22 <oddshocks> Ah yeah that's a bit of a ways off
19:39:55 <oddshocks> Do you think there's somewhere else I should ping, or just wait a bit?
19:40:06 <oddshocks> AIUI they're working on it
19:40:20 <kushal> oddshocks, may be just a gentle hello and ask about the progress.
19:40:36 * roshi wonders if we'll ever have a cloud FAD sometime in the future
19:40:50 <oddshocks> kushal: will do, and will report back
19:41:11 <kushal> oddshocks, Thanks :)
19:41:18 <kushal> That ends all the tickets.
19:41:29 <kushal> #topic Open Floor
19:41:44 * roshi has nothing
19:42:04 <dustymabe> nothing here
19:42:18 <oddshocks> When Alpha is released, are we gonna wanna put the AMIs on the webpage?
19:42:21 <jzb> nada
19:42:30 <oddshocks> or not until RC or final
19:42:38 <jzb> oddshocks: which webpage?
19:42:50 <roshi> I'd say to put them on the pre-prelease page
19:42:58 <jzb> right
19:43:02 <roshi> since we do that with the other editions, why shouldn't cloud get some love?
19:43:06 <kushal> roshi, +1 or else people will start using that and complain
19:43:39 <oddshocks> Okay, cool!
19:43:45 * oddshocks notes that as well
19:44:06 <roshi> do we have TCs up on EC2 as of late?
19:44:57 <oddshocks> I could send out a list to the cloud list after the meeting?
19:45:02 <oddshocks> So people can poke at em
19:45:07 <roshi> great
19:45:15 * oddshocks STILL has to add fedimg stuff to the release dashboard
19:45:31 * oddshocks remembers looking at the mass of javascript and not being sure what to do
19:45:50 <oddshocks> but if anyone is really familiar with how that app works, it'd be incredibly easy to just add a fedimg section
19:46:09 <kushal> rtnpro, ^^ chance to write more code.
19:46:20 <roshi> threebean would be the person to ping about it
19:46:31 <roshi> I bet he could at least do the review and accept the patch
19:46:39 <oddshocks> there are fedmsgs sent out for each upload, region, type, etc. Then the AMIs would be just THERE every time, and no one would have to look at the fedmsg data in datanommer
19:47:05 <oddshocks> Yeah, I've let that one fall by the wayside. I'll tackle it this week. It's lame to not have that up there
19:47:47 <rtnpro> oddshocks, I can help
19:48:01 <oddshocks> rtnpro: awesome :)
19:48:08 <oddshocks> That's all from me, then
19:48:37 <kushal> Okay, then we can end the meeting
19:48:42 <jzb> +1
19:48:46 <roshi> +1
19:48:49 <dustymabe> +1
19:48:50 <kushal> #endmeeting