17:01:20 <geppetto> #startmeeting fpc
17:01:20 <zodbot> Meeting started Thu Mar 19 17:01:20 2015 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:20 <geppetto> #meetingname fpc
17:01:20 <zodbot> The meeting name has been set to 'fpc'
17:01:20 <geppetto> #topic Roll Call
17:01:27 <geppetto> pretty sure we are going to have 4 again
17:01:49 <geppetto> #chair mbooth
17:01:49 <zodbot> Current chairs: geppetto mbooth
17:02:03 <geppetto> orionp: tibbs: ping
17:02:28 <orionp> hello - FYI Rathann can't make it
17:02:34 <geppetto> yeh, I saw
17:02:38 <geppetto> #chair orionp
17:02:38 <zodbot> Current chairs: geppetto mbooth orionp
17:02:44 <tibbs|w> OK, I'm around.
17:02:48 <geppetto> why I assume we'll only have have 4 again :(
17:02:52 <geppetto> #chair tibbs
17:02:52 <zodbot> Current chairs: geppetto mbooth orionp tibbs
17:03:21 <geppetto> limburgher racor Rathann SmootherFr0gZ spot tomspur: FPC ping
17:03:24 <tibbs|w> Sorry about being out earlier.  Wasn't planning on being pulled into a meeting.
17:03:33 <geppetto> yeh, no problem … happens to us all
17:03:46 <tibbs|w> Was Rathann here earlier?
17:03:56 <geppetto> no, had same thing … emergency at work
17:03:59 * SmootherFrOgZ here
17:03:59 <tibbs|w> Would hate to think I was the one that broke quorum.
17:04:08 <geppetto> #chair SmootherFrOgZ
17:04:08 <zodbot> Current chairs: SmootherFrOgZ geppetto mbooth orionp tibbs
17:04:17 <geppetto> cool, we made it anyway :)
17:04:45 <geppetto> #topic Schedule
17:04:47 <geppetto> https://lists.fedoraproject.org/pipermail/packaging/2015-March/010506.html
17:05:01 <geppetto> #topic #511 	Change request: Package Guidelines: DevAssistant
17:05:07 <geppetto> https://fedorahosted.org/fpc/ticket/511
17:05:28 <tibbs|w> Got my +1 already.
17:06:14 <geppetto> https://fedoraproject.org/w/index.php?title=User%3ATradej%2FDraft%3APackaging%3ADAP&diff=406424&oldid=401659 … is the diff
17:06:33 <mbooth> Looks sensible enough to me
17:06:55 <geppetto> yeh, +1
17:06:56 <tibbs|w> I think it's nice of them to accommodate.
17:07:15 <SmootherFrOgZ> +1 with changes
17:07:25 <mbooth> +1
17:07:29 <orionp> +1
17:08:07 <geppetto> #action DevAssistant change for license files (+1:5, 0:0, -1:0)
17:08:09 * orionp wonders about java maven packaging...
17:08:21 <geppetto> #topic #512 	Java guidelines change
17:08:25 <geppetto> orionp: That this one?
17:08:30 <geppetto> https://fedorahosted.org/fpc/ticket/512
17:08:45 <geppetto> Or related to dev assistant in some way?
17:08:56 <orionp> no, wondering about license files
17:09:02 <geppetto> Diff: ​https://fedoraproject.org/w/index.php?title=User%3AMsrb%2FJavaPackagingDraft&diff=406064&oldid=406063
17:09:08 <orionp> but I think that's handled normally
17:09:54 <orionp> java folks were pretty solidly behind this change
17:10:06 <tibbs|w> Also already has my +1.
17:10:22 <mbooth> Yep -- this list is out-of-date and no-one maintains it -- +1 to removal
17:10:23 <geppetto> ok, rm'ing stuff seems like a no brainer +1 … even though I've not much idea what it's about :)
17:10:29 <orionp> +1
17:11:31 <geppetto> SmootherFrOgZ: vote?
17:11:38 <SmootherFrOgZ> yup, +1
17:11:41 <geppetto> #action Java guidelines remove using EE APIs section (+1:5, 0:0, -1:0)
17:11:52 <geppetto> #topic #513 	Use python -Es in shbang
17:11:57 <geppetto> https://fedorahosted.org/fpc/ticket/513
17:12:39 <orionp> So, it seems like there are more technical discussions to work out
17:13:01 <tibbs|w> Yeah.
17:13:09 <orionp> In the end I guess I'd like a %py_build macro that Does The Right Thing (tm)
17:13:15 <tibbs|w> Indeed.
17:13:20 <tibbs|w> Which is part of that other stalled ticket.
17:13:28 <orionp> right
17:13:34 <orionp> thanks for finding that
17:13:36 <tibbs|w> If someone wants to revive just that part of it, we could probably move forward.
17:13:51 <geppetto> orionp: Well I think there is general agreement that having -s added would be a good thing to do
17:14:12 <orionp> yes, that is for sure
17:14:12 <tibbs|w> Yes, +1 to -s from me.
17:14:39 <tibbs|w> Honestly I'm leaning towards -E as well, and -I for python 3, but I'm not enough of an expert to advocate for them.
17:15:12 <geppetto> The main questions are: How does -s get added to the she-bang … and do we want -E or -I there too?
17:15:15 <tibbs|w> I think the absolutely trivial workaround of just sticking "python" or "python3" on the command line before the name of the script kind of overrides any "you broke my workflow" complaints.
17:15:35 <tibbs|w> geppetto: Without macro-izing the setup.py call, we'd just tell people to do it manually.
17:15:44 <geppetto> yeh
17:15:48 <tibbs|w> But whipping up a macro for that should take 20 seconds.
17:16:18 <tibbs|w> See https://bugzilla.redhat.com/attachment.cgi?id=739290
17:16:40 <geppetto> Yeh, it just be cool if there could be two macros and then packagers don't have to do anything if/when we change this again
17:17:34 <tibbs|w> I think all of the necessary macros are in that attachment, though it needs minor tweaks to add -s/-sE/-I/whatever.
17:17:47 * geppetto nods
17:18:17 <tibbs|w> Not that I actually understand the nested expansion in py_rt_build and py_rt_install.
17:18:24 <geppetto> :)
17:18:42 <tibbs|w> Never worked with parameterized macros in RPM.
17:19:13 <geppetto> I feel like everytime I look at them I have to learn them again
17:19:42 <orionp> FWIW - not too much more feedback from python-dev
17:19:45 <geppetto> mbooth: SmootherFrOgZ: You read/understand enough to vote on making -s mandatory?
17:20:23 <SmootherFrOgZ> yeah, was reading comments. So I'm also +1 to -s only
17:23:28 <geppetto> mbooth: ?
17:23:42 <orionp> -E / -I may be desired for daemons and other security sensitive apps
17:23:50 <mbooth> Sorry it must have been written slowly because I was reading it slowly :-p
17:24:35 <mbooth> +1 -- it makes "sense" to me, but I am a long way from being a python expert
17:24:50 <mbooth> I trust all y'all
17:26:28 <geppetto> #action Mandatory use of -s in she-bang of python programs (+1:5, 0:0, -1:0)
17:26:37 <orionp> So: a %py_build macro that defaults to --executable "%{__python} -s", but can be changed by defining something like %py_executable
17:27:21 <geppetto> We really need a py_build and py_build3 … unless someone is backporting -I to py-2.7
17:27:51 <orionp> and mentioning it in the guildlines incase people don't use the macro
17:27:51 <geppetto> Also do we want to vote on that, or ask/wait for the py packager to propose it?
17:27:59 * geppetto nods
17:28:23 <tibbs|w> Vote on the macros?
17:29:03 <tibbs|w> I'm +1 in general.
17:29:35 <geppetto> I'm +1 on the macros, but it'd be good to have a concrete proposal
17:29:40 <tibbs|w> Yes.
17:29:58 <tibbs|w> Let me see if I can figure out how to tweak them for -s and further args we want to add.
17:30:12 <tibbs|w> And then run them by the python folks before next week.
17:30:25 <orionp> that would be great, thanks tibbs
17:30:34 <tibbs|w> I should be able to find the time for that.
17:30:51 <tibbs|w> And python packaging needs all the help it can get.
17:31:53 <tibbs|w> I really want to push an additional macros package to EPEL to get rid of some of the conditionals needed for EPEL support.
17:31:57 <SmootherFrOgZ> +1 on macros
17:32:11 <orionp> tibbs|w - what bug did that attachment come from?
17:32:22 <geppetto> #action tibbs Will work on macros to vote on next week.
17:32:32 <tibbs|w> Digging...
17:32:42 <tibbs|w> https://bugzilla.redhat.com/show_bug.cgi?id=953704
17:33:05 <tibbs|w> I will also leave the filtering stuff out for now.
17:33:56 <geppetto> ok, cool
17:34:05 <geppetto> Anyone want to say anything else about this?
17:34:57 <geppetto> #topic #325 	Temporary bundling exception of yajl library
17:34:59 <geppetto> https://fedorahosted.org/fpc/ticket/325
17:36:23 <tibbs|w> It was a temporary request.  Not sure how temporary, though.
17:36:26 <tibbs|w> The whole thing is a mess.
17:36:27 <geppetto> "Other option could be to package yajl1 compat package, but this is overkill" … my feeling here is "yes, no"
17:36:48 <geppetto> I don't think it's temporary ganymore given the responses
17:39:44 <mbooth> Wow, and silence from brianmario (of yajl-ruby fame) for 2 years on that PR
17:39:49 <tibbs|w> I don't know what to do.
17:39:59 <tibbs|w> Honestly I'd say just fork the damn thing.
17:40:15 <geppetto> tibbs: Can you see any downside to just -1 bundling, but +1 on creating a compat-yajl1 package?
17:41:01 * geppetto nods … I'm not even bothered if they call it just yajl1 or whatever
17:41:22 <mbooth> tibbs|w: The "forks" graph in github has kinda exploded in the last year -- looks like it is no longer maintained
17:41:48 <tibbs|w> It isn't maintained, except for all of the people who forked it, I guess.
17:41:49 <SmootherFrOgZ> :/
17:42:08 <tibbs|w> "maintained" has become kind of a nebulous concept with the existence of social coding.
17:42:23 <tibbs|w> But, sore, I don't see why we don't have the compat package, even if it's patched.
17:42:39 <tibbs|w> Would be nice if someone just said "I'm maintaining it now" but whatever.
17:42:41 <tibbs|w> "sure".
17:43:02 <tibbs|w> I guess the downside is forcing someone to do more work.
17:45:26 <geppetto> #action No bundling exception of yajl library, someone just create a compat-yajil1 or even yajil1 fork/whatever package.
17:45:59 <geppetto> #info Or become the upstream maintainer :)
17:46:22 <geppetto> sgallagh: I assume you want to skip 506 for another week?
17:46:23 <mbooth> Compat pkg sounds fine to me -- once created it should be low maintenence
17:46:37 * geppetto nods
17:46:49 <geppetto> #topic Open Floor
17:47:10 <geppetto> Well, that's it … first meeting under an hour this year I think :)
17:47:37 <tibbs|w> Yep,  Which is good because I have to leave in 20 minutes.
17:47:41 <geppetto> :)
17:47:52 <geppetto> Anyone have anything to discuss for 25 minutes ?;)
17:48:18 <tibbs|w> Will probably drop some  more needinfo tickets soon.
17:48:22 <sgallagh> geppetto: 506 is under active discussion in the ticket and script package review, so yes. Let's keep it there for now.
17:48:36 <geppetto> sgallagh: yeh, cool.
17:49:11 <geppetto> Ok, well I'll close in a couple of minutes then unless someone shouts.
17:51:24 <geppetto> #endmeeting