19:01:21 <kushal> #startmeeting Fedora Cloud SIG
19:01:21 <zodbot> Meeting started Wed Mar 25 19:01:21 2015 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:26 <kushal> #topic Roll Call
19:01:36 <kushal> .hellomynameis kushal
19:01:37 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:01:37 <dustymabe> .hellomynameis slimshady
19:01:40 <zodbot> dustymabe: Sorry, but you don't exist
19:01:41 <rtnpro> .hellomynameis rtnpro
19:01:42 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
19:01:48 <dustymabe> .hellomynameis dustymabe
19:01:49 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
19:01:49 <kushal> dustymabe, :)
19:02:19 <oddshocks> .hello oddshocks
19:02:22 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
19:02:31 <roshi> .hello roshi
19:02:34 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:03:15 <kushal> Anyone else?
19:03:46 * jsmith is here
19:04:29 <roshi> don't think so
19:04:35 <kushal> #topic Last meeting's action items
19:04:48 <kushal> * jzb help find scollier additional maintainer for dockerfiles
19:04:49 <kushal> * jzb (and others) update dockerfiles for dnf
19:04:49 <kushal> * kushal wil ask Lennart for more specific use case and details  for #93
19:04:49 <kushal> * create proposal page on wiki for Atomic spin for f23 forward, call for
19:04:49 <kushal> vote on mailing list.
19:04:49 <kushal> * jzb create proposal page on wiki for Atomic spin for f23 forward, call
19:04:51 <kushal> for vote on mailing list.
19:05:34 <kushal> jzb, Any updates?
19:05:44 <Corey84> .fas  corey84
19:05:45 <zodbot> Corey84: corey84 'Corey84' <sheldon.corey@gmail.com>
19:05:49 <Corey84> (a bit late)
19:06:06 <kushal> I am yet to ask Lennart was he was traveling to Indonesia and on leave till 29th.
19:06:41 <kushal> Rest of them are on jzb
19:07:25 <kushal> I think we can move to the tickets
19:07:35 <kushal> #topic Maintaining Fedora docker images for f22 https://fedorahosted.org/cloud/ticket/97
19:07:44 <kushal> Anyone else has update for this?
19:07:54 <roshi> I'm going to do some helping of scollier with the docker files
19:08:04 <roshi> haven't gotten to it yet - but it's on the radar at least
19:08:27 <roshi> we talked a bit about it after the last meeting - and checks jzbs first item from last meeting
19:08:35 <kushal> roshi, can you please add an action item then?
19:08:57 <dustymabe> kushal I think for this ticket someone was going to go to server WG and try to see if "cloud" could own Docker image?
19:09:06 <roshi> what do you mean kushal ?
19:09:22 <dustymabe> kushal: from the ticket looks like it was JZB
19:09:26 <kushal> roshi, meeting action item :)
19:09:31 <kushal> dustymabe, yup.
19:09:37 <kushal> dustymabe, and he is not here today.
19:09:45 <dustymabe> :(
19:10:02 <dustymabe> Maybe post in the ticket to ask for status update?
19:10:11 <kushal> dustymabe, can you please do that?
19:10:17 <roshi> I guess I mean what for? For me helping with it?
19:10:25 <kushal> roshi, yeah :)
19:10:50 <roshi> did you give char to anyone yet?
19:10:57 <roshi> I think you have to do it since you're chair
19:11:36 <kushal> roshi, ah
19:11:42 <kushal> roshi, this should work anyway
19:11:57 <kushal> #chair roshi dustymabe Corey84 rtnpro oddshocks
19:11:57 <zodbot> Current chairs: Corey84 dustymabe kushal oddshocks roshi rtnpro
19:12:07 <kushal> roshi, sorry, I missed that
19:12:31 <roshi> no worries :)
19:13:33 <kushal> Moving to next ticket then.
19:13:34 <roshi> #action roshi to help with docker files
19:13:44 <dustymabe> kushal: I updated the ticket
19:13:48 <kushal> dustymabe, thanks :)
19:14:03 <kushal> #topic Care and Feeding, Fedora Dockerfiles https://fedorahosted.org/cloud/ticket/84
19:14:19 <scollier> hi kushal, i must say, I'm very, very distracted in meetings ATM.
19:14:21 <scollier> sorry.
19:14:31 <kushal> scollier, no problem.
19:15:10 <kushal> Moving to next.
19:15:25 <kushal> #topic Getting sha256sum published for the cloud images https://fedorahosted.org/cloud/ticket/93
19:15:32 <kushal> No updates for this too.
19:15:42 <kushal> Lennart is on holiday till 29th of this month.
19:16:33 <kushal> I think we will have a lot more time for open floor today :)
19:16:43 <kushal> #topic Atomic as separate spin (or, going the other way, main cloud edition)? https://fedorahosted.org/cloud/ticket/96
19:17:25 <kushal> jzb, is supposed to create the proposal page for the same.
19:17:34 <kushal> For Fedora 23 onwards.
19:17:43 <dustymabe> he sent an email to the list with some proposal
19:17:45 <dustymabe> was that it?
19:18:17 <kushal> dustymabe, ah, just now saw that email
19:18:22 <kushal> https://fedoraproject.org/wiki/Cloud/Atomic-2-Week-Proposal
19:18:58 <kushal> dustymabe, thanks :)
19:19:02 <dustymabe> np
19:20:33 <kushal> Moving to next.
19:20:34 <kushal> #topic Producing Updated Cloud/Atomic Images https://fedorahosted.org/cloud/ticket/94
19:20:41 <kushal> oddshocks, any updates on this one?
19:21:15 <oddshocks> Haven't heard from dgilmore or releng on this
19:21:39 <dustymabe> looks like this is probably not going to happen til at least F22?
19:21:45 <oddshocks> what's on the ticket is all I know
19:21:48 <oddshocks> dustymabe: probably
19:23:08 <kushal> rel-eng created new images.
19:23:13 <kushal> I did the initial testing.
19:23:25 <kushal> There was the issue of missing eth0 sometime.
19:23:33 <kushal> I think I dropped a mail to the list.
19:23:46 <kushal> I have more to say during open floor.
19:24:26 <oddshocks> Yeah, I know there have been updates. But I don't think there's been a whole system set up for how it'll happen between us/them/qa yet
19:25:52 <kushal> oddshocks, Okay.
19:26:24 <kushal> I think we can move to Open Floor now.
19:26:56 <kushal> oddshocks, btw, can you poke rel-eng once?
19:27:06 <kushal> I mean over email / track
19:28:32 <oddshocks> kushal: yeah
19:28:37 <kushal> thanks
19:28:40 <oddshocks> I have before, sent out an email. No replies.
19:28:43 <oddshocks> I'll send another
19:28:53 <kushal> #topic Open Floor
19:28:54 <oddshocks> Just to ask about the status of the whole collaborative process?
19:29:01 <kushal> oddshocks, yup.
19:29:03 <oddshocks> cool
19:29:17 <kushal> I have few points for open floor.
19:29:51 <kushal> I was trying out the kickstart with the hack for languages related to https://bugzilla.redhat.com/show_bug.cgi?id=156477
19:29:54 <kushal> https://bugzilla.redhat.com/show_bug.cgi?id=156477
19:30:28 <kushal> x86_64 rawhide is 264 MB in my local box without the hack, and 240MB with the hack.
19:30:36 <kushal> Means there is difference.
19:31:08 <kushal> But as my imagefactory setup happily fails to reboot the image, it actually declares it a complete fail.
19:31:19 <kushal> I will have to mount the image manually, and test it.
19:31:23 <kushal> Images rather.
19:31:53 <kushal> On the other hand, yesterday I wrote a blog post on Tunir.
19:32:02 <kushal> http://kushaldas.in/posts/tunir-a-simple-ci-with-less-pain.html
19:32:23 <kushal> I also ported the cloud tests using python unittest for tunir.
19:32:33 <kushal> https://github.com/kushaldas/tunirtests
19:32:38 <rtnpro> kushal, +1
19:32:47 <dustymabe> kushal: sounds great
19:32:50 <kushal> Feel free to test the system and add new tests.
19:33:08 <kushal> It already found few existing issues in the current images.
19:33:38 <kushal> I am planning to add extra tests for atomic image.
19:33:54 <kushal> Things like checking if docker actually works or not.
19:34:32 <kushal> roshi, Do you have anything on mind for new testcases?
19:35:03 <kushal> For the normal cloud image, I am already testing installation of a package (pss in this case).
19:35:11 <roshi> not really, but we should really get stuff integrated into taskotron - so we're running tests in one place and not multiple
19:35:41 <roshi> taskotron is going to be the place for tests to be ran - and then we won't have to maintain the infro for it or ask someone else to do it
19:35:44 <kushal> roshi, taskotron can just reuse my unittests, they are simple python unittests.
19:35:57 <roshi> we'd just have to maintain my tasks
19:36:15 <roshi> you just have to get them into the task format that taskotron can consume
19:36:21 <kushal> Okay.
19:36:31 <roshi> I'm working on bits for the disposable clients for them to be able to run the tests on
19:36:48 <roshi> so if you could help with that effort (cloud tests in taskotron), it'd be great
19:37:00 <roshi> and tunir already has some bits in it that can be used, I'd imagine
19:37:07 <kushal> roshi, Okay, I will look into that.
19:37:24 <roshi> I'm not totally familiar with the taskotron internals - but that's been a goal for a long time
19:37:40 <roshi> perhaps get with tflink and find out what he has to say about what's needed to get some more movement on that
19:37:40 <rtnpro> can I share updates from my end?
19:38:03 <roshi> but that's all I had - because then we can get new testcases into that system once the system is working
19:38:16 <roshi> sure thing rtnpro  - that's EOL for me
19:39:10 <rtnpro> I started working on creating a framework on top of datagrepper to empower widgets and dashboards needed by various fedora apps
19:39:12 <rtnpro> https://github.com/rtnpro/fedwidgets
19:39:37 <rtnpro> I got my initial prototype validated by threebean
19:39:41 * roshi is excited about this bit
19:40:05 <rtnpro> the concept is pretty simple
19:40:29 <rtnpro> have a denormalized data layer on top of datagrepper for faster data retrieval
19:41:16 <rtnpro> people write widgets in Python to listen to fedmsg and save denormalized data in proper format
19:41:38 <rtnpro> and widgets also render data (JSON) through an API
19:42:08 <rtnpro> people can use JS to render this data as needed
19:42:52 <rtnpro> I could not work on this idea last week and this week as I was in between finalizing job change
19:43:03 <rtnpro> it's almost done now
19:43:14 <rtnpro> so, I will resume work on it ASAP
19:43:25 <rtnpro> I will keep you folks posted :)
19:43:41 <dustymabe> rtnpro: thanks
19:44:19 <rtnpro> EOL
19:44:33 <kushal> Any other update for open floor?
19:45:37 <dustymabe> nothing here
19:45:39 <oddshocks> Yeah
19:45:42 <oddshocks> First, AMI lifetimes
19:46:06 <oddshocks> I sent out a summary to the list of how people seemed to feel about them https://lists.fedoraproject.org/pipermail/cloud/2015-March/005148.html
19:46:41 <kushal> https://lists.fedoraproject.org/pipermail/cloud/2015-March/005148.html
19:46:54 <oddshocks> I don't want to take up too much time here, but I propose a vote, and also to immediately (without a vote, besides now), delete all alpha, beta, TC, and RC AMIs from before the F21 release
19:47:09 <oddshocks> sorry, that first part was confusing
19:47:28 <oddshocks> the first vote i mentioned was for the lifetime of final release AMIs, or if we keep them forever
19:47:51 <oddshocks> and I'm just asking for +1s now to get rid of the non-final F21 amis people tested with
19:47:59 <oddshocks> I already got one +1 on the list
19:48:03 <kushal> oddshocks, +1 from me on that.
19:48:34 <dustymabe> oddshocks: +1 on getting rid of non-final AMIs
19:48:45 <oddshocks> Cool, if no objections, will do today
19:48:59 <dustymabe> I think we should send a follow up email to the list
19:49:13 <kushal> dustymabe, +1
19:49:14 <oddshocks> dustymabe: as in, "we're about to do this because we have +1s, any objections?"
19:49:18 <dustymabe> and state what we have decided along with a time and date that the action will be performed
19:49:21 <kushal> oddshocks, yup.
19:49:37 <dustymabe> this gives people a chance to come out of the woodwork to enlighten us on possible issues.
19:49:50 <dustymabe> but also gives us a course of action
19:50:13 <oddshocks> cool
19:50:14 <oddshocks> will do
19:50:34 <oddshocks> I have one other thing for open floor. Did anyone see that thread about enhanced networking in our AMIs?
19:51:00 <oddshocks> We're running out of time here and I don't want to leave anyone else without time, but if people wanna check that out and give any input, that'd be cool
19:51:38 <kushal> oddshocks, I saw, but have to read it again to understand it properly.
19:52:06 <dgilmore> oddshocks: I am waiting on an okay that things are right, or a no they are not we have the fixes in and please do a new tree
19:52:10 <oddshocks> Basically, "are there any problems with doing this" or whatever. The guy wants us to toggle the flag on to enable enhanced networking (kernel mod I think) for our AMIs
19:52:12 <dgilmore> oddshocks: I have gotten neither
19:52:22 <oddshocks> thanks, dgilmore :)
19:52:38 <dgilmore> oddshocks: at this point everything is in the CloudWG's hands
19:52:48 <kushal> dgilmore, Okay, understood.
19:52:55 <dgilmore> as it has been for a few weeks now
19:53:59 <oddshocks> okay, I must have misunderstood
19:54:03 <oddshocks> anyway, that's all from me
19:54:36 <dustymabe> ok all of that was a bit confusing
19:54:41 <dustymabe> was dg talking about sriov?
19:54:53 <kushal> dgilmore, we will test out the networking changes as suggested by in the bugzilla, and then will ask you to create a new tree.
19:55:15 <kushal> Okay, that line is confusing due to missing words :(
19:56:08 <oddshocks> dennis was talking about cloud image updates with releng
19:56:26 <oddshocks> I was talking about enhanced networking kernel mod in our AMIs
19:56:32 <oddshocks> all good now
19:57:16 <kushal> We have 3 minutes left.
19:58:41 <kushal> I am close this meeting then.
19:58:48 <dustymabe> +1
19:58:50 <kushal> If no one has anything to say.
19:58:55 <kushal> 3
19:58:56 <kushal> 2
19:58:58 <kushal> 1
19:59:01 <kushal> #endmeeting