19:04:33 <roshi> #startmeeting Cloud WG
19:04:33 <zodbot> Meeting started Wed Apr  1 19:04:33 2015 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:04:42 <roshi> #meetingname Cloud WG
19:04:42 <zodbot> The meeting name has been set to 'cloud_wg'
19:04:48 <roshi> #topic Roll Call
19:04:52 <roshi> who's around?
19:04:56 <roshi> .hello roshi
19:04:57 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:05:01 <jzb> .hellomynameis jzb
19:05:02 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
19:05:04 <oddshocks> .hello oddshocks
19:05:08 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
19:06:16 <roshi> #topic Previous Meeting Follow-up
19:06:27 <roshi> * roshi to help with docker files
19:06:38 <roshi> nothing new here - but it's on my docket
19:06:43 <roshi> anybody have anything else?
19:08:45 <roshi> guess not
19:09:24 <roshi> #topic (#97) Maintaining Docker images
19:09:28 <roshi> #link https://fedorahosted.org/cloud/ticket/97
19:10:16 <jzb> that's me, but I have nothing new to report ATM
19:10:41 <roshi> ok
19:10:45 <roshi> moving on then :)
19:10:47 <jzb> I was in all-day meetings all last week and PTO Monday & Tuesday
19:10:49 <jzb> sorry
19:10:59 <oddshocks> shame on you for taking time off
19:11:03 <roshi> no worries - it happens :)
19:11:24 <roshi> easy there oddshocks, I'm about to take a chunk of PTO as well
19:11:35 <roshi> 12 days from now :p
19:11:54 <oddshocks> I just announced that I'll be absent Thu and Fri ;)
19:11:59 <roshi> #topic (#84) Dockerfile Husbandry
19:12:00 <oddshocks> we're all gonna burn for this, I'm certain
19:12:06 <roshi> #link https://fedorahosted.org/cloud/ticket/84
19:12:09 <roshi> lol
19:12:57 <jzb> "husbandry"?
19:13:21 <roshi> the care and feeding of animals
19:13:28 * roshi was trying to be funny
19:13:32 <jzb> I'd say this is in progress, we're trying to get people to care for the Dockerfiles and "port" them to dnf
19:13:48 <jzb> but, as above, nothing new really to report this week
19:13:57 <roshi> yeah, and that's what my previous action item was for as well
19:14:12 <roshi> I'll try to get some work done on that this week
19:15:04 <roshi> moving on then
19:16:08 <roshi> #topic (#93) sha256sums
19:16:14 <roshi> #link https://fedorahosted.org/cloud/ticket/93
19:17:43 <jzb> roshi: can we set that for F23?
19:17:52 <jzb> I think the milestone is moved
19:17:56 <roshi> I'm fine with that
19:18:21 <roshi> moved it to "Future" since we don't have a F23
19:18:55 <roshi> that work?
19:20:11 <jzb> roshi: sure.
19:20:21 <oddshocks> +1
19:20:22 <jzb> roshi: we need a way for things to come up like every *other* meeting :-)
19:20:22 <roshi> kk, moving on
19:20:31 <roshi> yeah, that'd be nice
19:21:03 <roshi> #topic (#94) Atomic Spin
19:21:16 <roshi> #undo
19:21:16 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x31998590>
19:21:22 <roshi> #topic (#96) Atomic Spin
19:21:27 <roshi> #link https://fedorahosted.org/cloud/ticket/96
19:21:52 * dustymabe is late
19:22:05 <roshi> welcome dustymabe - we've reassigned all the things to you
19:22:10 <roshi> just fyi
19:22:11 <roshi> :p
19:22:16 <dustymabe> april fools!!
19:22:18 <dustymabe> :)
19:22:31 <jzb> dustymabe: nope, he's serious. ;-)
19:22:48 <jzb> So - I sent that out for discussion
19:23:14 <jzb> other than mattdm raising the question about the specialness of the "regular" cloud edition
19:23:23 <jzb> I didn't seen any real objection to the proposal.
19:23:42 <roshi> to make it a spin, right?
19:24:01 <jzb> https://fedoraproject.org/wiki/Cloud/Atomic-2-Week-Proposal
19:24:04 <jzb> ^^ proposal
19:24:19 <jzb> roshi: spin/remix yes, demote from blocker for now.
19:24:38 <roshi> ...
19:24:43 <roshi> it's never been a blocker
19:24:52 <roshi> atomic was never a blocker, iirc
19:24:54 <jzb> roshi: you sure? I thought Atomic is/was a blocker now
19:25:06 * oddshocks didn't think so
19:25:11 <jzb> hrm.
19:25:16 <roshi> pretty sure - as QA hasn't spent any time testing it
19:25:19 <oddshocks> Don't base things on me though :P
19:25:31 <jzb> roshi: I stand by my "hrm"
19:25:32 <jzb> :-)
19:25:36 <roshi> I've poked at it - but just to get it some testing, not thinking it was a blocker
19:25:46 <roshi> it's listed as optional in the testing matrix
19:25:50 <dustymabe> either way.. spin means that atomic will have more freedom to adopt it's own special release schedule?
19:25:51 <jzb> but at any rate
19:25:55 <jzb> dustymabe: yes
19:25:56 <roshi> yeah
19:26:43 <roshi> if it was decided to be a blocker, no one notified QA :)
19:27:37 <jzb> anyway - do we need to do a formal vote on this or do we accept the proposal since nobody's objected?
19:27:47 <roshi> I think we just accept it
19:27:56 <roshi> but then again, I don't know what all goes into making a spin
19:28:04 <dustymabe> there is a ticket for it right?
19:28:06 <roshi> surely other groups have to be involved?
19:28:59 <jzb> roshi: https://fedoraproject.org/wiki/Spins_Process#Creating_a_Spin
19:29:11 <dustymabe> jzb: so basically what we (the cloud group) are proposing to do is spin off atomic..
19:29:24 <dustymabe> should we get some sort of commitment on who is going to foster the spin?
19:29:32 <jzb> dustymabe: more or less. I'm saying it's moving too quickly to be a main edition
19:29:45 <roshi> yeah, that makes sense
19:29:59 <jzb> and we should bake it a bit before re-introducing it as an edition in two or three cycles.
19:30:24 <dustymabe> "two or three cycles" meaning two or three fedora releases?
19:30:28 <jzb> dustymabe: yeah
19:30:43 <dustymabe> ahh. I think I see what you are saying
19:30:52 <roshi> it makes sense to me
19:30:56 <dustymabe> make it a spin for now and then possibly re-introduce it as not a spin later
19:30:59 <roshi> who's taking it to the spin sig?
19:31:13 <jzb> well, dustymabe was late, so...
19:31:19 <jzb> er, probably me
19:31:35 <jzb> unless we have any other victim^H^H^H^H volunteers.
19:31:56 <roshi> hehe
19:32:06 <roshi> I don't know enough about atomic or spins to be much help
19:33:25 <roshi> anything else to discuss for this one? or can we close it and let you run with it jzb ?
19:33:31 <jzb> roshi: I'll run w/it
19:33:40 <roshi> I don't imagine you're going to forget about Atomic w/o a ticket
19:33:45 <roshi> sgtm
19:33:50 <dustymabe> i know we talked about voting.. should we include our decision in the ticket?
19:33:59 <dustymabe> in a ticket
19:34:08 <roshi> #action jzb to take the Atomic Spin idea to the Spin SIG
19:34:14 <roshi> we can vote in ticket
19:34:18 <oddshocks> +1
19:34:19 <jzb> dustymabe: yeah, we can update it with "lazy consensus"
19:34:28 <roshi> then close it out next meeting to give people who aren't here time to vote
19:34:42 <jzb> roshi: eh, they've had a week or so
19:34:54 <roshi> kk
19:35:11 <roshi> then you want to close it asserting lazy consensus?
19:35:16 <jzb> roshi: yep
19:36:14 <roshi> sweet
19:36:17 <roshi> moving on then
19:36:56 <roshi> #topic (#94) Updated cloud images
19:37:01 <roshi> #link https://fedorahosted.org/cloud/ticket/94
19:37:09 <oddshocks> This one's in our court now, as per the comment I posted
19:37:28 <jzb> yeah
19:37:39 <oddshocks> https://fedorahosted.org/cloud/ticket/94#comment:7
19:38:12 <dustymabe> so one question here
19:38:18 <dustymabe> we have established a process
19:38:22 <dustymabe> but it is late in F21
19:38:29 <dustymabe> should we wait til F22 to start doing this?
19:38:35 <roshi> that would be my guess
19:38:40 <dustymabe> just so it's not confusing
19:39:02 <oddshocks> Yeah, I think we're just ad-hocing it for now
19:39:04 <roshi> is it trivial to know the build tree that was used for a nightly? or will we decide fast enough that things can be rolled before another nightly kicks off?
19:40:51 <dustymabe> oddshocks: ?
19:40:57 <dustymabe> i really don't know
19:41:10 <oddshocks> I think that's trivial
19:41:18 <roshi> that's something we'd need to be able to track in order to pull it off, right?
19:41:19 <dustymabe> either way.. I'll update the ticket to state we'll start this officially in F22
19:41:25 <roshi> sweet
19:41:26 <oddshocks> That process I listed is basically what kushal has been doing
19:41:36 <dustymabe> one small other thing.
19:41:36 <oddshocks> nothing more, nothing less. I don't think we have to specifically wait for another nightly
19:41:37 <roshi> it woul d be good to take some practice runs during F21 though
19:41:47 <roshi> just not advertise it as updated cloud images, if that makes sense
19:41:56 <dustymabe> rather than putting out updated images for possibly two releases at a time
19:42:06 * jzb is on a call, distracted, sorry
19:42:22 <dustymabe> we should decide now how to deprecate releasing images for older release
19:42:38 <dustymabe> roshi: I agree about practicing now
19:42:40 <roshi> I meant that more as "if testing takes longer, will a new nightly break our ability to build yesterdays 'being tested' image if a new nightly lands
19:42:43 <roshi> that's what I meant
19:42:47 <roshi> hard to word that
19:43:43 <dustymabe> roshi: i think that may be something we learn as we go
19:43:51 <dustymabe> like you said.. practicing will help
19:43:57 <roshi> sgtm
19:44:01 <roshi> anything else for this?
19:44:08 <oddshocks> not from me
19:44:26 <dustymabe> well
19:44:29 <roshi> #action dustymabe to update the ticket saying this will land in F22
19:44:53 <dustymabe> did you read my statements above about deciding when to "stop" doing this for a release?
19:45:10 <dustymabe> One option is to not release images for multiple releases ever
19:45:22 <dustymabe> which means as soon as F23 is out we would stop releasing updated F22
19:45:42 <dustymabe> I think that is easiest as far as amount of work
19:45:51 <dustymabe> less to keep up with/test
19:46:10 <roshi> true
19:46:26 <roshi> do we have *any* idea what the typical lifespan of a cloud instance is?
19:46:50 <oddshocks> Like, how long people typically run a cloud instance for? I have no idea how we'd ever know that
19:46:57 <dustymabe> not really. I'm sure some people leave them up forever and some kill them every day
19:46:58 <roshi> ie, are there any F9 cloud images out in the wild?
19:47:20 <oddshocks> roshi: if anyone is running F9 on a cloud instance, I don't care ;)
19:47:21 <roshi> I'm fine for one release
19:47:29 <dustymabe> if they leave them up forever then it is their responsibility to update them too
19:47:32 <dustymabe> ok
19:47:35 <roshi> if you're spinning up a new image, you'll get the new stuff
19:47:36 <oddshocks> +1
19:47:41 <dustymabe> we'll start with that as a proposal
19:47:46 <roshi> if you have an old image, it'll still get package updates normally
19:47:49 <dustymabe> and we can change it if we find we need to
19:47:57 <roshi> +1 from me
19:48:03 <dustymabe> i'll update the ticket with this information
19:48:35 <roshi> sweet
19:48:42 * jzb is back
19:48:48 <roshi> anything else?
19:49:07 <jzb> dustymabe: sorry - you mean atomic or regular flavor cloud?
19:50:19 <dustymabe> jzb: regular cloud
19:50:34 <dustymabe> well initially the proposal was for both
19:50:53 <jzb> OK - I think we probably do need to update original flavor cloud
19:50:56 <dustymabe> but since atomic is changing to be a spin (in F23) I'm not as concerned with having atomic be a part of this process
19:51:15 <jzb> dustymabe: right, the spin won't get updates. You use Fedora Atomic, you'll be along for the ride. :-)
19:51:21 <dustymabe> jzb: yep
19:51:43 <roshi> makes sense
19:51:48 <roshi> fine to move on? running out of time
19:51:53 <jzb> roshi: +1
19:51:54 <dustymabe> roshi: yep
19:52:03 <roshi> #topic (#100) Broken build
19:52:07 <roshi> #link https://fedorahosted.org/cloud/ticket/100
19:52:31 * roshi hasn't tracked this at all
19:52:55 <dustymabe> neither have I
19:53:14 <dustymabe> roshi.. you wanted to learn more about atomic :)
19:53:46 <jzb> hmmm
19:53:49 <roshi> man, if I had a sheet of paper for all the stuff I want to learn more about - it'd rival an encyclopedia in thickness :p
19:53:52 <jzb> are the TC's building?
19:54:16 <dustymabe> I tested out stuff a while ago.. for alpha
19:54:19 <roshi> s/encyclopedia/multi-volume encyclopedia/
19:54:41 <jzb> well, I'm curious whether this is a case of "my env is borked" or "everything is borked"
19:54:52 <dustymabe> guess we should probably check in on this. I'll ping the original poster in the ticket to see if he has any resolution yet
19:55:02 <dustymabe> sound good?
19:55:04 <jzb> dustymabe: thanks
19:56:11 <roshi> sgtm
19:56:18 <dustymabe> we'll see what he says in the ticket
19:56:28 * roshi moves to open floor
19:56:32 <dustymabe> unfortunately I am travelling this week and won't have much time to look at the TCs
19:56:39 <roshi> #topic Open Floor
19:56:43 <dustymabe> so maybe if someone could give them a spot check that would be nice
19:56:44 <jzb> dustymabe: are you in the RDUs?
19:56:46 <oddshocks> Haven't gotten any thoughts or member votes on https://fedorahosted.org/cloud/ticket/99 yet
19:57:02 <randomuser> !
19:57:05 <dustymabe> jzb: yeah I'm in NC but out in the country right now
19:57:12 <dustymabe> hoping to be in RHT tomorrow
19:57:18 <jzb> dustymabe: sweet
19:57:26 <jzb> dustymabe: pls put something on my calendar for when you are available.
19:57:52 <randomuser> we could use some help covering Cloud for the release notes, https://fedoraproject.org/wiki/Documentation_Cloud_Specific_Content_Beat https://fedoraproject.org/wiki/Documentation_Cloud_Beat
19:58:00 <dustymabe> jzb: I will as soon as I know for sure I am coming
19:58:08 <dustymabe> oddshocks: sorry about that. will vote now
19:58:28 <oddshocks> dustymabe: no worries :) just keeping it on folks' radar
19:58:46 <roshi> I'll vote too
19:58:52 <roshi> not sure what I think, to be honest
19:58:58 <jzb> oddshocks: voted
19:59:12 <jzb> roshi: in that case, just agree with me. ;-)
19:59:39 <oddshocks> thanks guys
19:59:41 <roshi> hehe
19:59:43 <oddshocks> that's all from me
20:00:43 <jzb> let's call it?
20:00:45 <roshi> same here
20:00:49 * roshi sets the fuse
20:00:52 <jsmith> WORKSFORME
20:00:58 <dustymabe> +1
20:01:07 <roshi> ...3
20:01:10 <roshi> 2...
20:01:12 <roshi> ...1
20:01:15 <roshi> BOOM
20:01:22 <roshi> thanks for coming folks!
20:01:25 <roshi> #endmeeting