16:10:26 <tibbs|w> #startmeeting
16:10:26 <zodbot> Meeting started Thu Apr  9 16:10:26 2015 UTC.  The chair is tibbs|w. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:10:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:10:28 <tibbs|w> #meetingname FPC
16:10:28 <zodbot> The meeting name has been set to 'fpc'
16:10:29 <tibbs|w> #meetingtopic Packaging Committee meeting
16:11:42 <tibbs|w> Howdy, folks.
16:11:51 <mbooth> Hi
16:11:52 <tibbs|w> My office is clear now.
16:12:19 <tibbs|w> Who's around?  I see orionp and racor.
16:12:28 <orionp> Hello
16:12:39 <racor> hi
16:12:48 <tibbs|w> And SmootherFrOgZ would make 5.
16:13:14 <SmootherFrOgZ> yup
16:13:23 <tibbs|w> Well, cool.
16:13:35 <tibbs|w> I suck and didn't send an agenda, but we have only one piece of new business.
16:13:49 <tibbs|w> And I think sgallagh is here about his ticket.
16:14:02 <tibbs|w> #topic #522  Should -static packages require -devel
16:14:04 <tibbs|w> .fpc 522
16:14:16 <tibbs|w> https://fedorahosted.org/fpc/ticket/522
16:14:27 <tibbs|w> Guess zodbot isn't listening.
16:14:34 <tibbs|w> In any case, orionp, this was yours.
16:15:13 <orionp> Yeah.  I just think that it should be made explicit that if -static won't work without -devel, it should require it.
16:15:13 <tibbs|w> I'm not sure I care either way, really.  To me it appears to do do nothing other than save a line in a few spec files.
16:15:34 <tibbs|w> Anyone else have an opinion?
16:15:37 <mbooth> Maybe you have to #chair yourself to #topic
16:15:53 <tibbs|w> Argh.
16:16:32 <tibbs|w> No, that's good.  It's just zodbot that didn't listen to .fpc for whatever reason.
16:16:38 <tibbs|w> #chair mbooth
16:16:38 <zodbot> Current chairs: mbooth tibbs|w
16:16:45 <tibbs|w> #chair orionp
16:16:45 <zodbot> Current chairs: mbooth orionp tibbs|w
16:16:48 <tibbs|w> #chair racor
16:16:48 <zodbot> Current chairs: mbooth orionp racor tibbs|w
16:16:52 <tibbs|w> #chair SmootherFrOgZ
16:16:52 <zodbot> Current chairs: SmootherFrOgZ mbooth orionp racor tibbs|w
16:16:56 <tibbs|w> That should be everyone.
16:17:15 <mbooth> If it makes sense to require the -devel package in the majority (99%?) of cases then sure
16:17:52 <mbooth> What are the use cases for having the static lib without the headers?
16:18:10 <tibbs|w> Honestly I don't see how you could ever use a static package without the headers.  But some packages have them all together and there it doesn't matter.
16:18:39 <orionp> There are some fortran libraries that don't have headers :)
16:18:54 <racor> IIRC, we didn't mandate *-static to R: *-devel, because at the time when this section was written, there was some confusion over packages providing "*-static" only and the naming "*-devel-static"
16:19:21 <racor> I think these arguments are mood, today.
16:19:22 <tibbs|w> Honestly, though, we're talking about a very small number of packages that even use static libs (given that their use is strongly discouraged).
16:20:04 <tibbs|w> So, what -static packages don't require -devel now?  How did this even come up?
16:20:11 <tibbs|w> We can't be talking about more than five or ten packages.
16:20:13 <nirik> FYI, there was no 'fpc' alias setup in zodbot. I added one for you now though.
16:20:24 <tibbs|w> nirik: Hmm, it used to work.
16:20:29 <tibbs|w> But thanks.
16:20:32 <orionp> https://bugzilla.redhat.com/show_bug.cgi?id=1067475
16:20:50 <tibbs|w> Of course that's in the ticket, doh.
16:21:15 <mbooth> Okay, I am +1 to amending the guidelines as orionp suggests
16:21:27 <SmootherFrOgZ> yup, +1 as well
16:22:41 <tibbs|w> Don't think this warrants a "must", though.  Assuming that's what orionp meant by "much" in the ticket.
16:23:09 <tibbs|w> But I really don't care enough and can +1 anything at this point.
16:23:53 <orionp> Why not a "must"?  If it doesn't work without it...  I'd assume it was obvious that it should, but someone questioed it so I brought it up.
16:24:01 <mbooth> Something like "If the -static package is not useful without the -devel then the -static package must R: the -devel package"
16:24:15 <mbooth> The "If" is important and allows the "must"
16:24:28 <orionp> right
16:25:11 <tibbs|w> Anyway, counting me we're at +4, and racor seemed to be in agreement.
16:25:35 <racor> +1, sorry was slightly distracted
16:25:35 <tibbs|w> I'd hate to spend much more time on something that's this trivial.
16:25:51 <tibbs|w> Cool, this passes.  Now, how do I tell the bot that....
16:26:33 <tibbs|w> #action Should -static packages require -devel (+1: 5, 0:0, -1:0)
16:26:46 <tibbs|w> #topic #520  [Guidelines Draft] Per-Product Configuration Defaults v2
16:26:48 <tibbs|w> .fpc 520
16:26:49 <zodbot> tibbs|w: #520 ([Guidelines Draft] Per-Product Configuration Defaults v2) – fpc - https://fedorahosted.org/fpc/ticket/520
16:27:27 <tibbs|w> sgallagh: Are you around for this?  I didn't see an update to the update to the draft.
16:27:57 <tibbs|w> If not, we're kind of done unless someone found the time to play with those python macros.
16:29:02 <orionp> I made one package and it seemed to work.  Found and fixed one typo.
16:29:46 <tibbs|w> I guess we can skip 520.
16:29:51 <tibbs|w> #topic #281  New Python Macros for Easier Packaging
16:29:56 <tibbs|w> .fpc 281
16:29:57 <zodbot> tibbs|w: #281 (New Python Macros for Easier Packaging) – fpc - https://fedorahosted.org/fpc/ticket/281
16:30:25 <tibbs|w> Ah, I see your edit now.
16:30:56 <tibbs|w> I still think we shouldn't have %py_shbang_opts, because they probably won't stay the same.
16:32:01 <tibbs|w> But really I would just like to see some of the python folks chime in.  There were some CC's added, so I guess I'll just ping the ticket.
16:32:45 <tibbs|w> And just a note on this:
16:32:51 <tibbs|w> #topic #508  New GID for openstack-neutron
16:32:52 <orionp> I couldn't read the tea leaves as to a concensus on what options to use.  My python-devel thread went astray pretty quickly
16:32:53 <tibbs|w> .fpc 508
16:32:54 <zodbot> tibbs|w: #508 (New GID for openstack-neutron) – fpc - https://fedorahosted.org/fpc/ticket/508
16:33:21 <tibbs|w> orionp: Oops, sorry, I'm moving too fast.  I didn't even see that thread.  Could you post a link in the ticket?
16:33:55 <tibbs|w> About this proliferation of UIDs and GIDs, I had an idea but it's kind of a long shot.
16:34:29 <tibbs|w> Basically, everyone wants these allocations because there is no way to fix UIDs at system installation time other than hardcoding them in the setup package.
16:34:35 <orionp> I need to figure out how to link to gmane threads....
16:34:58 <tibbs|w> And we really don't want to statically allocate any more UIDs.
16:35:16 <tibbs|w> So... what if there _was_ a way to fix UIDs at kickstart time?
16:35:29 <tibbs|w> It's not possible to do it in %pre because the filesystems don't exist yet.
16:35:50 <tibbs|w> But if we had another kickstart section that happened after filesystem creation but before package install?
16:36:23 <tibbs|w> Anaconda in F22 already has one thing that it copies in at exactly that point, and in my discussions they said they'd at least look at a patch.
16:36:52 <tibbs|w> Then we could just tweak the setup package to look for some kind of configuration file on the filesystem, and add some users then.
16:37:12 <tibbs|w> It's a lot of moving parts, but in ten years I have never seen another solution.
16:37:52 <orionp> I'd like that section - I use various hacks to do that in %pre now
16:37:57 <tibbs|w> Anyway, I made about a third of the way through an implementation.
16:38:22 <tibbs|w> orionp: If you have a usecase, could you write it up?  The anaconda folks are skeptical that there's any real reason to have it.
16:38:43 <orionp> Sure, any particular location?
16:38:52 <tibbs|w> orionp: By that I just mean shoot me an email or describe it to me in IRC after the meeting or something.
16:39:09 <orionp> Okay, I'll send you an email
16:39:21 <tibbs|w> But, yeah, it would be a lot of moving parts but I don't think it's really any worse than a lot of stuff we do.
16:39:38 <tibbs|w> But I'd have to write it all and then get buy in from both the anaconda folks and the setup maintainer.
16:39:53 <tibbs|w> And in the meantime it doesn't help these openstack people who are trying to deploy things now.
16:40:17 <tibbs|w> And I don't think RHEL uses a different setup package with more fixed UIDs.
16:40:37 <tibbs|w> Which is why we're seeing this odd pressure from Red Hat customers to add things like this.
16:41:57 <tibbs|w> But if this actually gets through everything, there would only be extremely rare cases when anyone would need a static allocation.
16:42:14 <tibbs|w> Like the thing where dracut and the running system need to agree.
16:42:29 <tibbs|w> If anyone else has any input on that, I'd be happy to hear it.
16:42:50 <tibbs|w> Unfortunately my stretch of free time has about run out, so I don't know when I'll be able to get back to that.
16:42:52 * orionp needs to study the static uid issue more....
16:43:41 <tibbs|w> It's one of our longest standing annoyances, I think.
16:44:21 <tibbs|w> I guess we can move on.
16:44:28 <tibbs|w> #topic Open Floor
16:44:37 <tibbs|w> A bundling exception just came in.
16:44:42 <tibbs|w> .fpc 523
16:44:43 <zodbot> tibbs|w: #523 (Bundling exception for usbguard) – fpc - https://fedorahosted.org/fpc/ticket/523
16:44:53 <tibbs|w> Does anyone remember how we deal with header-only C++ libs?
16:45:09 <orionp> I just looked at that
16:45:11 <racor> Analogous to *-static
16:45:15 <orionp> yes
16:45:50 <tibbs|w> Which means... package separately?
16:46:30 <racor> yep, they actually are *-static and arch'ed packages
16:46:46 <orionp> arched if they have tests to run
16:46:50 <tibbs|w> I don't know how to do that, so if anyone knows of an example I'd like to take a look.
16:47:29 <orionp> eigen is one
16:47:30 <racor> IIRC, we mandated them to be arched in all cases
16:48:09 <orionp> eigen3 actually
16:48:19 <tibbs|w> I can't remember that far back.  I can grep the meetbot logs if if the discussion wasn't too long ago.
16:49:08 <tibbs|w> Heh, Dec 19, 2013.
16:49:25 <orionp> http://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Header_Only_Libraries
16:49:46 <orionp> Yup, must not be noarch
16:49:53 <tibbs|w> https://meetbot.fedoraproject.org/teams/fpc/fpc.2013-12-19-17.02.log.html
16:50:38 <tibbs|w> OK, so I guess for 523, tell them to either package them separately according to those guidelines or indicate why then can't do so?
16:51:13 <mbooth> tibbs|w: Sounds perfect -- there are already guidelines for this situation
16:51:21 <tibbs|w> Yeah, I just forgot about them.
16:51:22 * SmootherFrOgZ has to run
16:51:24 <tibbs|w> So many guidelines.
16:51:25 <sgallagh> tibbs|w: Sorry, I was at lunch. I submitted the macro for review, but no one has responded.
16:51:36 <tibbs|w> SmootherFrOgZ: Yeah, we're pretty much done.  Thanks for coming.
16:51:50 <tibbs|w> sgallagh: No problem.  We can look again next week.
16:52:08 <tibbs|w> Where did you submit it?  Not sure where we'd follow that discussion.
16:52:53 <tibbs|w> Is that in the bugzilla report?
16:53:41 <sgallagh> tibbs|w:  I submitted a patch to BZ and linked the BZ in the FPC ticket
16:53:55 <tibbs|w> If so, with redhat-rpm-config, I'd honestly just go in and make the changes if everyone else has agreed on the macro.
16:54:13 <sgallagh> Well, I'm not 100% sure if that's the right spot for it
16:54:17 <tibbs|w> I don't think the redhat-rpm-config maintainers are the gatekeepers here.
16:54:29 <tibbs|w> But if there's another package off of which you could hang that macro, all the better.
16:55:48 <tibbs|w> But that's kind of getting into semantics; if the macro is good but redhat-rpm-config isn't the right place, the macro can always be moved.  At worst the packages have to gain an additional BR.
16:57:23 <tibbs|w> Or does everyone else think I'm nuts here?
16:57:47 <tibbs|w> And I'd hate to hold all of this up because we requested one little macro to save some typing.
16:58:24 <tibbs|w> orionp: Oh, hell, that thing you just sent me is an absolutely horrible hack.  I love it.
16:58:38 <orionp> :)
16:59:15 <tibbs|w> Well, it's approaching the hour (even though I was late to the party).  Anyone have anything else?
17:00:02 <orionp> nope
17:01:26 <tibbs|w> Cool.  Hopefully James will be back next week and the pressure will be off.
17:01:35 <tibbs|w> Thanks, folks.
17:01:39 <tibbs|w> #endmeeting