16:01:51 <geppetto> #startmeeting fpc
16:01:51 <zodbot> Meeting started Thu May  7 16:01:51 2015 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:51 <geppetto> #meetingname fpc
16:01:51 <zodbot> The meeting name has been set to 'fpc'
16:01:51 <geppetto> #topic Roll Call
16:02:00 <geppetto> geppetto limburgher mbooth orionp racor Rathann SmootherFr0gZ tibbs|w tomspur: FPC ping
16:02:09 <mbooth> Hello
16:02:14 <geppetto> #chair mbooth
16:02:14 <zodbot> Current chairs: geppetto mbooth
16:02:15 <orionp> Morning
16:02:32 <geppetto> #chair orionp
16:02:32 <zodbot> Current chairs: geppetto mbooth orionp
16:02:54 <dwmw2> hello
16:03:02 <geppetto> dwmw2: hey … was just about to ping you too :)
16:05:02 <geppetto> #chair tibbs|w
16:05:02 <zodbot> Current chairs: geppetto mbooth orionp tibbs|w
16:05:06 <tibbs|w> Howdy.
16:05:11 <geppetto> hey
16:07:07 <tibbs|w> So, holding at 4?
16:07:12 <geppetto> yeh, atm :(
16:07:28 <geppetto> I assume Rathann or tomspur will turn up
16:07:56 <geppetto> They are both on IRC, just not here atm.
16:08:51 <Rathann|Mobile> hi
16:09:13 <geppetto> #chair Rathann|Mobile
16:09:13 <zodbot> Current chairs: Rathann|Mobile geppetto mbooth orionp tibbs|w
16:09:16 <geppetto> hey :)
16:09:20 <geppetto> And then there were 5 :)
16:09:31 <geppetto> #topic Schedule
16:09:36 <geppetto> https://lists.fedoraproject.org/pipermail/packaging/2015-May/010638.html
16:09:58 <geppetto> Ok, dwmw2 you want to go first?
16:10:04 <geppetto> #topic #480 	Packaging guidelines for consistent PKCS#11 usage
16:10:04 <geppetto> .fpc 480
16:10:04 <geppetto> https://fedorahosted.org/fpc/ticket/480
16:10:05 <zodbot> geppetto: #480 (Packaging guidelines for consistent PKCS#11 usage) – fpc - https://fedorahosted.org/fpc/ticket/480
16:10:05 <dwmw2> er, ok
16:10:30 <dwmw2> as noted in the ticket, I've tried to make the draft more readable and I've provided some examples
16:11:34 <geppetto> " If your application can certificate" :)
16:12:10 <dwmw2> fixed :)
16:17:04 <geppetto> ok, seems fine to me
16:17:35 <Rathann|Mobile> likewise, +1 from me
16:17:41 <tibbs|w> Yeah, +1.
16:18:17 <tibbs|w> If I were prone to bikeshedding, I'd suggest giving bug 1173546 a useful alias so people didn't have to get the number right.
16:18:19 <dwmw2> can we change the title to 'SSL Certificate' guidelines rather than 'PKCS#11' ?
16:18:31 <dwmw2> tibbs|w: good idea.
16:18:42 <tibbs|w> "SSL Certificate Handling"?
16:18:50 <geppetto> dwmw2: Maybe SSL Certificate hardware support?
16:18:52 <dwmw2> thatworks
16:18:57 <dwmw2> no, not *hardware*
16:18:58 <dwmw2> definitely not :)
16:19:14 <tibbs|w> 'SSL Certificate' sounds like it would handle generation of certificates as well.
16:19:20 <dwmw2> SSL Certificate usage?
16:19:23 <tibbs|w> Which is a separate proposal that's working its way through.  I'd hate to confuse the two.
16:19:42 <geppetto> Well I think when people see "SSL Certificate" they'll assume servers
16:19:52 <dwmw2> This is for certs with *keys*. Not just about trust.
16:20:04 <Rathann|Mobile> "Cryptographic token handling"?
16:20:07 <dwmw2> yeah, maybe it's best just left as PKCS#11.
16:20:25 <dwmw2> I was after something that people didn't glance at and ignore on the basis that "my package doesn't do that"
16:20:30 <dwmw2> when the point is that your package *should* :P)
16:20:38 <geppetto> Yeh
16:21:19 <Rathann|Mobile> or "Client SSL Certficate Handling"?
16:21:25 <dwmw2> is also for servers
16:21:32 <dwmw2> Apache should be able to do it (I haven't looked yet if it can)
16:21:35 <dwmw2> for example
16:21:42 <Rathann|Mobile> oh
16:21:44 <orionp> +1 on the draft, and I'd be fine with "SSL Certificate Handling"
16:21:44 <geppetto> ahh
16:21:47 <dwmw2> nmav just prodded me to stop talking just about 'client' :)
16:22:30 <dwmw2> https://bugzilla.redhat.com/showdependencytree.cgi?id=PKCS11
16:22:33 <dwmw2> there, an alias :)
16:22:34 <geppetto> mbooth: just you left to vote
16:22:43 <geppetto> dwmw2: nice
16:29:27 <geppetto> mbooth: ping?
16:29:27 <zodbot> geppetto: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
16:29:59 <orionp> :)
16:30:05 <dwmw2> zodbot: context is everything.
16:32:20 <Rathann|Mobile> mbooth: are you still around?
16:33:39 <mbooth> geppetto: Sorry, had a visitor
16:33:41 <tibbs|w> Have to step out for a few; sorry.
16:33:42 <mbooth> Yes
16:34:27 <mbooth> +1 for me -- it mostly makes sense to my non-cryptographer eyes
16:34:33 <geppetto> #action Packaging guidelines for consistent PKCS#11 usage (+1:5, 0:0, -1:0)
16:34:36 <geppetto> Ok, cool
16:35:20 <geppetto> dwmw2: If you still want to rename/retitle … put the name in the ticket, and tibbs will dtrt when he moves it to live.
16:35:34 <geppetto> #topic #524 	static UID for ceph
16:35:40 <geppetto> .fpc 524
16:35:40 <geppetto> https://fedorahosted.org/fpc/ticket/524
16:35:41 <zodbot> geppetto: #524 (static UID for ceph) – fpc - https://fedorahosted.org/fpc/ticket/524
16:35:42 <dwmw2> ok, thanks. I'll go for 'SSL Certificate handling', since I think that had consensus?
16:35:57 <Rathann|Mobile> I'm fine with either wording
16:36:11 <geppetto> I'm fine with most any title
16:36:53 <geppetto> So the ceph people really seem to want a static uid
16:38:57 <tibbs|w> Yeah, not sure what to do here.
16:39:15 <tibbs|w> We were kind of not super against it.
16:39:32 <tibbs|w> But I doubt we can get +5 today unless opinions have really changed.
16:40:22 <geppetto> I guess I'm a reluctant +1 … I don't think they actually need it, but they aren't arguing rationally anymore either, so meh.
16:40:25 <orionp> I'm +1 as this seems to be pretty tied to filesystems
16:41:04 <geppetto> Rathann|Mobile: mbooth: vote?
16:41:20 <mbooth> I am +1 I guess too
16:41:26 * mbooth has been fence-sitting
16:41:29 <Rathann|Mobile> +1, they did raise some valid points about chown taking long to run
16:41:55 <tibbs|w> I don't really like this, but given that they actually sort of provided info on timing, I can +1 it.
16:42:27 <geppetto> #action static UID for Ceph (+1:5, 0:0, -1:0)
16:42:30 <geppetto> ok, done
16:42:42 <geppetto> #topic #520 	[Guidelines Draft] Per-Product Configuration Defaults v2
16:42:42 <geppetto> .fpc 520
16:42:42 <geppetto> https://fedorahosted.org/fpc/ticket/520
16:42:43 <zodbot> geppetto: #520 ([Guidelines Draft] Per-Product Configuration Defaults v2) – fpc - https://fedorahosted.org/fpc/ticket/520
16:42:49 <geppetto> sgallagh: ping, fpc 520
16:42:52 <tibbs|w> Haven't had time to work on that setup thing, but everything is in place to use it.
16:43:13 <tibbs|w> (that was for 524 in case not obvious)
16:43:25 <tibbs|w> geppetto: What's left to do for 520?
16:43:36 <geppetto> oh, the variant thing
16:43:46 <geppetto> but you just did it
16:43:48 <tibbs|w> Yeah, I just went ahead and took care of it.
16:43:51 * geppetto nods
16:43:58 <tibbs|w> No point in having a guideline that doesn't match reality.
16:44:05 <geppetto> true
16:44:07 <geppetto> #topic #513 	Use python -Es in shbang
16:44:07 <geppetto> .fpc 513
16:44:07 <geppetto> https://fedorahosted.org/fpc/ticket/513
16:44:09 <zodbot> geppetto: #513 (Use python -Es in shbang) – fpc - https://fedorahosted.org/fpc/ticket/513
16:44:27 <tibbs|w> I haven't had a chance to touch this.  Not sure if anyone else has.
16:44:32 <geppetto> no
16:44:49 <geppetto> Can move on then
16:44:50 <geppetto> #topic #508 	New GID for openstack-neutron
16:44:50 <geppetto> .fpc 508
16:44:50 <geppetto> https://fedorahosted.org/fpc/ticket/508
16:44:51 <zodbot> geppetto: #508 (New GID for openstack-neutron) – fpc - https://fedorahosted.org/fpc/ticket/508
16:45:00 <tibbs|w> Is this one still churning.
16:45:02 <tibbs|w> ?
16:45:23 <tibbs|w> I mean, some of that is my setup idea, but that really isn't an FPC thing.
16:45:47 <geppetto> hey, I'm not sure what we (FPC) have/can do here
16:46:01 <tibbs|w> The last really on-topic comment from that ticket was https://fedorahosted.org/fpc/ticket/508#comment:3
16:46:37 <tibbs|w> I guess I'm thinking "give them an alternate way to do this" and then FPC doesn't have much to do.
16:47:00 <tibbs|w> But if it turns out that we can't give them an alternative, then FPC does have to at least say "nope" again.
16:47:24 <geppetto> yeh, I guess … it will be much easier to say nope if your setup thing is there :)
16:48:07 <tibbs|w> But I guess we can move on until I can get something done.
16:48:15 <tibbs|w> My current project is taking about 130% of my time.
16:48:19 * geppetto nods
16:48:49 <geppetto> I can see it from their POV … but on the other hand, it's really a local thing. Even more so than Ceph.
16:49:22 <geppetto> So it seems a lot better to allow users to configure their local uid/gids how they want than to statically allocate them at the distro level
16:49:24 <geppetto> blah
16:49:26 <geppetto> anyway …
16:49:35 <geppetto> #topic #281 	New Python Macros for Easier Packaging
16:49:35 <geppetto> .fpc 281
16:49:35 <geppetto> https://fedorahosted.org/fpc/ticket/281
16:49:36 <tibbs|w> That's my opinion as well.
16:49:37 <zodbot> geppetto: #281 (New Python Macros for Easier Packaging) – fpc - https://fedorahosted.org/fpc/ticket/281
16:49:52 <geppetto> This is the last one … and I'm not sure what we have to do here either ?:-o
16:49:53 <tibbs|w> This is really another python thing that needs more buy in from the python folks.
16:50:06 <tibbs|w> I'm all for simplifying packaging in any way possible.
16:50:41 <tibbs|w> But I don't think we can just forge ahead without some assent from the python folks, and I haven't had the time to try and stir up more discussion with them.
16:50:53 <tibbs|w> I'm also still not on the right mailing lists, I think.
16:51:10 <mbooth> A good metric would be, "by how many lines will the python guidelines shrink?"
16:51:28 <tibbs|w> If it's even a few characters, I'm for it.
16:51:51 <tibbs|w> I suspect several folks here are far more into python than I am.
16:51:57 <orionp> python guidelines are quite the mess atm
16:52:03 <tibbs|w> I agree.
16:52:12 <tibbs|w> But it's the 2/3 split that makes them really bad.
16:52:19 <tibbs|w> That and el5/6 support.
16:52:24 <orionp> Really need a standard spec template
16:53:04 <tibbs|w> Given all of the 2/3 differences and the lack of modules supporting both, I'm not sure that's feasible.
16:53:25 <tibbs|w> And honestly in the Fedora guidelines I would prefer to excise all old EL support just to keep them cleaner.
16:55:47 <geppetto> Well in a year or so we could maybe drop all py2 from the Fedora guidlines
16:55:48 <tibbs|w> I mean, I guess if I get the time I can just go over the current guideline with a chainsaw and see if I can make it less horrible.
16:56:07 <tibbs|w> BTW, do we have a mandate that things which can work with py3 be built with py3?
16:56:25 <tibbs|w> I can't recall, but I'm running into that issue with some of the stuff I'm writing.
16:56:41 <Rathann|Mobile> IIRC the guideline says if upstream supports it
16:57:41 <tibbs|w> Actually they say you can, but only if upstream supports it.
16:58:28 <tibbs|w> Which I think should really be "you must if upstream supports it" given that we actually do want to have py3 by default at some point.
16:59:27 <geppetto> isn't it default in f22?
16:59:37 <tibbs|w> Not as far as I recall.
16:59:54 <tibbs|w> https://fedoraproject.org/wiki/Changes/Python_3_as_Default
16:59:57 <tibbs|w> says F23.
17:00:01 <geppetto> I thought it was going to be, got stopped, and then went back to py3 as default
17:00:43 <tibbs|w> BTW, is there general support for "must build for py3 if supported"?  I can make a proposal later.
17:00:58 <tibbs|w> I mean, I'd +1 it as it seems kind of obvious.
17:01:09 <tibbs|w> Unless I really can't read and it's already in there.
17:01:53 <geppetto> well half my system wants to go with it if I try to remove it :)
17:03:02 <tibbs|w> There's no doubt we use it.
17:03:49 <geppetto> yeh, dnf doesn't seem to use it … which I thought it did
17:03:52 <tibbs|w> I didn't really learn python2; I just started doing "real" coding using python3.
17:04:11 <geppetto> but the desktop is def. broken if you try to remove it … so joy, worst of all possible worlds for f22
17:04:12 <tibbs|w> I think it can, but they were trying to keep only one python interpreter in the minimal install.
17:04:30 * geppetto nods
17:04:32 <tibbs|w> Well, I think the rule for desktop is "disk is cheap enough".
17:04:41 <geppetto> yeh, dnf was built for py3 at various points
17:04:47 <geppetto> lol :)
17:04:51 <tibbs|w> When minimal can go all the way over, then I think it will.  I guess check rawhide.
17:05:40 <tibbs|w> Yeah, in rawhide it wants py3.
17:05:48 <tibbs|w> itshappening.gif
17:06:42 * geppetto nods
17:07:07 <tibbs|w> So I'll keep a couple of drafts open for cleaning up/gutting/splitting the current python guidelines.
17:07:26 <geppetto> ok
17:07:33 <tibbs|w> Hmm, I am on the python-devel list.
17:07:33 <geppetto> #topic Open Floor
17:07:38 <tibbs|w> It just doesn't have any traffic.
17:07:50 <Rathann|Mobile> nothing from me and I have to drop off now
17:07:53 <geppetto> We were kind of in open floor anyway … but anything anyone wants to bring up?
17:07:58 <Rathann|Mobile> sorry and thanks
17:08:01 <geppetto> no problem
17:08:10 <geppetto> and thanks for making 5 Rathann|Mobile :)
17:08:20 <tibbs|w> We're really getting the ticket count down.
17:08:36 <sgallagh> Sorry folks, wasn't around earlier. Were there any questions for me about 520?
17:08:37 <tibbs|w> I have zero clue at all about the scintilla thing at this point.
17:08:53 <tibbs|w> sgallagh: I took care of the changes you needed.
17:09:10 <sgallagh> tibbs|w: OK, thanks
17:09:15 <tibbs|w> There was one question at the end of the ticket....
17:09:23 <tibbs|w> Not anything you have to answer now, though.
17:10:07 <sgallagh> Ah, right. I'll have to think on that.
17:10:29 <tibbs|w> But scintilla, I mean, someone's going to have to own an actual scintilla package if we want it unbundled.
17:10:34 <sgallagh> Though I'm probably okay with not worrying about it until and unless we hit it.
17:10:51 <tibbs|w> sgallagh: Someone did ask the question on one of the lists; I'm not sure if you saw it.
17:10:52 <geppetto> tibbs: yeh
17:10:57 <tibbs|w> Might be worth some discussion.
17:11:14 <tibbs|w> geppetto: The alternative is to just approve scintilla as a copylib and get on with life.
17:11:23 <sgallagh> tibbs|w: I didn't see it
17:11:33 <tibbs|w> sgallagh: I'll try to figure out where it was.
17:11:42 <sgallagh> Thanks
17:11:49 <tibbs|w> scintilla is really way too big to be a copylib, though.
17:12:10 <tibbs|w> And it almost certainly edits random things that come from the 'net.
17:13:09 <tibbs|w> And something's bundling like a ten year old version of it.
17:13:27 <geppetto> of course
17:13:45 <tibbs|w> And I'm sure if we looked harder we'd find something else that bundles it.
17:13:52 <tibbs|w> At least it's all tracked properly now.
17:14:07 <geppetto> that's what bundling is for … it's like the I installed Fedora 7 and just never turned it off method of maintenance
17:14:32 <tibbs|w> But I don't think that's sufficient to just get rid of the ticket, and I'm not the one to either package the unbundled scintilla or fix the packages to use it.
17:14:53 <tibbs|w> Might be able to twist rdieter's arm a bit.
17:15:15 <tibbs|w> Also nobody seems to want to do the work to determine how their bundled copies have been modified.
17:15:49 <tibbs|w> We don't really have any power unless we want to just decide we can force things to be pulled from the distro.
17:16:08 * geppetto gets out the cabal decider stamp
17:16:10 <tibbs|w> I mean, between us we certainly have enough access to do that.
17:16:33 <tibbs|w> But I would really hate to think we'd get to that point over some editing library that's not had a known security issue.
17:16:50 <tibbs|w> Which leaves us at, uh, pretty much where we're at.
17:17:03 <rdieter> tibbs|w I could look at it someday, been meaning to really, just lots of other higher priority stuff to do
17:17:12 <tibbs|w> rdieter: You're not the only one.
17:17:29 <tibbs|w> Do you know if qscintilla is modifying its bundled copy?
17:17:38 <rdieter> next kid-at-home-sickday, I'm all over it
17:17:39 <tibbs|w> It's almost up to date, so I'd think it's pretty close.
17:17:50 <rdieter> tibbs|w: i don't know
17:18:06 <tibbs|w> I guess that's the next step.
17:18:07 <rdieter> I would guess no, or minimally
17:18:16 <rdieter> they rebase semi-frequently
17:18:47 <tibbs|w> It's certainly not supposed to work as a shared lib.  Static would be OK with me, I guess.
17:18:58 <tibbs|w> But if it would work, that would be doubly awesome.
17:20:19 <tibbs|w> Anyway, I'm sure everyone has work to do.
17:20:32 <geppetto> yeh
17:20:48 <geppetto> See ya all next week
17:21:03 <geppetto> #endmeeting