14:00:38 <tflink> #startmeeting fedora-qadevel
14:00:38 <zodbot> Meeting started Mon Jun  1 14:00:38 2015 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:38 <tflink> #meetingname fedora-qadevel
14:00:38 <tflink> #topic Roll Call
14:00:38 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:00:50 * kparal is here
14:00:50 <tflink> #chair kparal mkrizek
14:00:50 <zodbot> Current chairs: kparal mkrizek tflink
14:00:54 * mkrizek is here
14:01:10 <tflink> hrm, no josef
14:01:13 <kparal> mkrizek: do you have any info about jskladan?
14:01:31 <mkrizek> no info
14:01:42 <kparal> :/
14:02:56 <tflink> I guess we can continue without him and figure out if this is a workable time going forward
14:03:19 <mkrizek> ok
14:04:01 <tflink> so it's the 3 of us - who wants to go first with status?
14:04:09 <mkrizek> I'll go
14:04:26 <mkrizek> #topic mkrizek status report
14:04:26 <mkrizek> #info finished remote execution for disposable clients, awaiting final review
14:04:29 <mkrizek> #link https://phab.qadevel.cloud.fedoraproject.org/D356
14:04:31 <mkrizek> #info patch for saving logs into a file prior to log init
14:04:34 <mkrizek> #link https://phab.qadevel.cloud.fedoraproject.org/D375
14:04:36 <mkrizek> #info patch for storing used config's filename
14:04:39 <mkrizek> #link https://phab.qadevel.cloud.fedoraproject.org/D374
14:04:45 <mkrizek> #info now, finally got back to work on fedmsg
14:04:56 <tflink> ah, didn't realize that D356 was complete
14:05:31 <kparal> mkrizek: I'll look at the logging changes asap
14:05:53 <kparal> which means tomorrow :)
14:06:01 <mkrizek> no worries, the logging changes aren't blocking anything
14:06:08 <kparal> good
14:06:25 <mkrizek> that's it from me
14:06:30 <mkrizek> questions?
14:06:38 * kparal is writing a reply to the fedmsg thread in qa-devel
14:06:52 <mkrizek> cool
14:06:53 <kparal> no questions here
14:06:55 <tflink> not from me, I just need to get to reviewing :)
14:07:17 <tflink> kparal: you want to go next or should I?
14:07:52 * tflink goes next
14:08:00 <kparal> I don't have any status report for the last week, I've been finalizing release tasks like common bugs and finishing some critical bugs
14:08:02 <tflink> #topic status report - tflink
14:08:02 <tflink> #info working to improve testCloud so it can be used for disposable clients
14:08:02 <tflink> #info fighting with polkit and libvirt to allow non-root users to connect to qemu:///system without a DE
14:08:02 <tflink> #info testCloud is going to need quite a bit more work at some point, trying to put some of it off for later
14:08:02 <tflink> #info rebuilt qadevel-stg as qadevel.stg.fp.o, added git hosting - needs testing
14:08:25 <tflink> kparal: ok, figured I would check anyways :)
14:08:41 <danofsatx> oh, we started?
14:08:46 <danofsatx> mornin' folks
14:08:49 <tflink> #link https://phab.qadevel.cloud.fedoraproject.org/D376
14:09:12 <tflink> out of order but that's the current work with testCloud - fighting some auth bits with polkit/libvirt
14:09:20 <kparal> I noticed the testCloud patches, roshi set me up as a project maintainer. not sure if I should review stuff, since I haven't worked with the project too much
14:09:26 <tflink> danofsatx: well, it is 14:00 UTC :)
14:09:46 <danofsatx> yeah, yeah, yeah....
14:10:03 * danofsatx is fighting with named this morning and slightly distracted
14:10:04 <tflink> kparal: feel free to join in. IIRC, roshi added you and I as maintainers to increase the bus ratio
14:10:37 <kparal> ok
14:10:40 <tflink> D356 mostly works but it's missing some setup information and requires a DE
14:10:57 <tflink> if anyone wants to poke at it, let me know and I'll add the needed docs
14:11:50 * tflink is planning to keep working on testCloud this week and hopefully get to libtaskotron integration
14:11:53 <mkrizek> ^ D376?
14:12:10 <tflink> mkrizek: whoops, yeah. D376
14:12:33 * mkrizek noteed just for the record
14:12:45 <mkrizek> *noted
14:13:04 <tflink> testCloud is gonna need quite a bit of work before it's done but for now, trying to put in the minimal amount of work needed for libtaskotron so we can figure out where the problems are
14:13:21 <tflink> any questions/comments?
14:13:44 <mkrizek> none here
14:13:48 <kparal> nope
14:13:56 <tflink> ok, moving on to ...
14:14:06 <tflink> #topic Upcoming Infrastructure Changes
14:14:21 <tflink> I've sent messages out to qadevel@ but wanted to bring it up here
14:14:39 <tflink> we currently have several services hosted in the old fedora infra cloud
14:14:47 <tflink> qadevel, testdays, taskotron-demo
14:15:02 <tflink> taskotron-demo is pretty straightforward and just needs to be migrated
14:15:20 <tflink> I'm not sure about testdays - how much is it used? are we going to continue maintaining it?
14:15:37 <tflink> IIRC, jskladan was working on updating it but I don't know any more than that
14:15:52 <tflink> qadevel is going to take the most work, I think
14:16:00 <mkrizek> I forget, what do we need taskotron-demo for?
14:16:22 <tflink> mkrizek: it was for testing execdb, probalby don't need it ATM
14:16:40 <mkrizek> ok
14:17:08 <tflink> #info new qadevel staging instance available: https://phab.qadevel.stg.fedoraproject.org/
14:17:10 <kparal> testdays are still used during the release cycle, afaik
14:17:39 <kparal> so there's some benefit in keeping it alive
14:18:35 <tflink> I'm not trying to kill it - just trying to deal with the HSTS headers issue and I want to get our stuff off the old cloud soon - preferably before we're given a deadline
14:19:04 <kparal> what is the difference between the clouds?
14:19:07 <tflink> IIRC, testdays is also an an old version of fedora
14:19:10 <kparal> something important?
14:19:28 <tflink> the new one is maintainable :)
14:19:41 <kparal> I guess it's the new one that also copr uses?
14:20:03 <tflink> yeah, I think copr was one of the first things to migrate
14:20:18 <kparal> msuchy contacted us and told us that if we wanted to use the new copr cloud for taskotron, it's much more usable and maintainable now
14:20:53 <kparal> and went into some details, but we had to cut him short, it was the release day
14:20:58 <tflink> we can look into it but I'm OK with our current route of non-cloud disposable clients
14:21:15 <kparal> yeah, just noting
14:21:45 <nirik> note for the HSTS issue, I am thinking I might rename the cloud to not use fedoraproject.org....
14:21:46 <tflink> thanks, it's worth noting
14:22:50 <kparal> nirik: that will help, as long as the person does not visit some other https site that's hosted on that cloud, right?
14:23:11 <kparal> after that, any other http-only site he/she tries to visit, will be again affected by hsts, right?
14:23:14 <tflink> kparal: as long as the HSTS headers aren't set as strictly on the cloud domain, it shouldn't be an issue
14:23:18 <nirik> kparal: well, another https site in the same domain that sets a HSTS header with subdomains set.
14:23:22 <nirik> which they should not do
14:23:42 <kparal> I see
14:23:54 <nirik> the fedoraproject.org one is set for subdomains too, because we want to try and make it all https
14:24:04 <nirik> but that doesn't work for things like this. ;)
14:24:18 <tflink> testdays has other issues, though - like running an EOL fedora and being deployed completely by hand (IIRC)  :-/
14:24:51 <kparal> but changing the cloud domain could solve at least one of the issues :)
14:24:51 <tflink> #action tflink to pester jskladan about status of testdays and any code update progress
14:25:36 <nirik> IMHO, anything you want as more than a proof of concept/test instance should just be in ansible. ;)
14:26:21 <tflink> hence the questions about how much testdays is being used and what we want to do about/with it
14:27:21 <tflink> I guess we'll follow up with this on qadevel@ or at a later meeting
14:27:24 <kparal> should I dig up some stats?
14:27:30 <tflink> sure, wouldn't hurt
14:27:56 <tflink> but the other issue is qadevel
14:28:16 <tflink> I want to move that out of the cloud and onto infra machines
14:28:52 <tflink> but the other question that comes with that is git hosting - the new setup is capable of hosting git repositories. Do we want to use that, use pagure.io or keep stuff on bitbucket?
14:29:38 <tflink> phabricator is capable of mirroring, so if we chose to put the git repos on phab, we can keep up to date mirrors on github/pagure/bitbucket
14:29:39 * kparal looking at https://pagure.io/
14:29:52 <tflink> by mirroring, I mean pushing all incoming changes to other remotes
14:29:53 <kparal> what is it?
14:30:13 <tflink> pagure is what releng has decided to use going forward instead of cgit on fedorahosted
14:30:56 <tflink> despite the domain, it's fedora infra AFAIK
14:31:45 <kparal> I don't have any strong opinions where to host stuff. I'd just want for any group member to be easily to set up a new repo, without asking admin first
14:32:01 <kparal> *able to
14:32:12 <tflink> we don't need to decide today but like I said before - I want to be done with migration before we're given a deadline to be off the old cloud
14:32:40 <tflink> kparal: why is that important? how often will we want to create repos?
14:33:02 <kparal> tflink: because if it is not possible, people will create it on github/bitbucket instead
14:33:03 <tflink> in my mind, the upcoming task repos are a different kettle of fish
14:33:17 <kparal> and then they are reluctant to move it, because it breaks links in all sort of places
14:33:25 <kparal> like with openqa stuff
14:33:56 <tflink> what are the required permissions on the new stg phab?
14:34:10 <kparal> I haven't tried it yet
14:34:21 <kparal> not sure if I can find it out easily
14:35:12 <kparal> I'm just saying I prefer having all our repos in a single place, then distributed over many hosting service, based on how mature they are
14:35:14 <tflink> kparal: you and I are admins so probably not the best people to test it :)
14:35:33 <tflink> and I'd like to do this migration once, if possible
14:35:35 <kparal> I can try to downgrade myself :)
14:35:47 <tflink> it's going to cause problems and headaches, no matter what we do
14:36:20 <kparal> let's discuss hosting once the cloud migration is done...
14:36:33 <tflink> but it looks like other fedora groups aren't interested in using phab, so I'm not to worried about the hostname changing anytime in the near future
14:37:12 <tflink> kparal: I was wondering if getting all the pain over with at the same time would work better
14:37:20 <kparal> when I see code reviews done in bugzilla (gnome devs), I'm very grateful for having Phab...
14:37:33 <tflink> ie, move phab and git hosting at the same time
14:38:11 <kparal> in that case we should decide the hosting question soon :)
14:38:12 <tflink> but we don't have to decide today - I just wanted to get more discussion and thoughts
14:38:55 <tflink> maybe have a soft deadline of migrating at least phab before the end of the month
14:39:18 <tflink> the sooner we're off that poorly set up cloud instance, the better :)
14:39:21 * mkrizek needs to leave
14:39:48 <tflink> do we need to re-evaluate the time of this meeting?
14:40:27 <kparal> I'm fine with the timing
14:40:34 <mkrizek> I am good with the current time (just today it's an exception)
14:40:46 <kparal> so, we need to ask josef
14:41:09 <tflink> mkrizek: any questions or thoughts that we haven't covered?
14:41:33 <mkrizek> nothing from me
14:41:42 <tflink> ok
14:42:00 <tflink> #action tflink to start thread on qadevel@ about git hosting
14:42:55 <tflink> I think that's about it for this topic
14:42:59 <tflink> anything else?
14:43:17 <kparal> some stats for the testday app
14:43:34 <tflink> kparal: you ok with taking the #action on that?
14:43:45 <kparal> I want to post them here :)
14:43:49 <tflink> on getting them or poking jskladan until he provides them?
14:43:59 <tflink> oh, didn't realize they were that easy to find
14:44:18 <kparal> just simple stat.s I just counted that we seem to had 7 test days during F22, and used the app in 4 of them
14:44:34 <kparal> you can see them as the first 4 items under "all events" here: http://209.132.184.193/testdays/all_events
14:44:53 <tflink> #info 7 test days during F22 cycle, 4 of which used the testdays app
14:44:56 <kparal> the number of people who used this is moderate, probably around 30 with a quick look
14:45:12 <kparal> or maybe 40
14:45:23 <tflink> we only had 7 test days for F22?
14:45:47 <kparal> it seems so. we canceled quite a few of them this cycle
14:45:48 <danofsatx> tflink: yes, it was a very slow test day release
14:46:04 <tflink> what about for F21?
14:46:04 <danofsatx> this one seemed a bit disorganized IMHO
14:46:14 <kparal> some of that was an error on our part, when roshi left for paternity leave, we forgot to take care of this tickets
14:46:23 <kparal> and then it was a bit late
14:46:34 <tflink> i was wondering if that had something to do with it
14:47:02 <kparal> I see 5 test days from F21 that used testday app
14:47:08 <roshi> probably :(
14:47:38 <roshi> when I left we had one "scheduled" for pretty much every tuesday and thursday until release
14:48:04 <kparal> and about 11 test days for F21 in total
14:48:12 <kparal> if I count correctly
14:48:59 <kparal> so about 50% of those used the testday app
14:49:08 <tflink> the eventual question is going to be whether it's worth continuing to support/maintain the testdays app
14:49:36 <kparal> let's see how much work josef already put into it
14:49:48 <tflink> agreed
14:50:15 <tflink> it's tough to have this conversation without him :)
14:50:28 <tflink> any objection to moving on?
14:50:39 * tflink has one more topic for today and the qa meeting is in 10 minutes
14:50:53 <kparal> let's move on
14:51:00 <tflink> #topic Planning
14:51:16 <tflink> I think that mkrizek and I have plenty to do for the next week or two
14:51:36 <kparal> I'd like to catch up with the reviews
14:51:38 <tflink> kparal: any guesses at how much time you'll have for devel work?
14:51:49 <kparal> I guess most of my time, now
14:52:48 <tflink> the two unassigned tasks I can think of ATM are: image downloading (default dirs, actual downloading, formula syntax) and making sure that required formula changes are in place and work well
14:53:18 <kparal> does that involve the distributed file system?
14:53:23 <tflink> it can
14:53:36 <tflink> but I'm hoping to make that pretty much invisible to libtaskotron
14:54:04 <tflink> ie - make it look as much like a regular fs as possible so it doesn't matter if there is one host or many hosts
14:54:39 <kparal> I'm not sure if I'm the best person on investigating distributed file systems
14:55:41 <kparal> I was hoping I could finally nail this depcheck bug, because I was hoping I finally know what causes it. but unless it has happened often recently, I guess it's not a big priority at the moment
14:55:58 * tflink hasn't been looking closely enough lately
14:56:11 <tflink> and since we're hiding the instances now, I don't think anyone else would notice
14:56:25 <kparal> hmm, that's true
14:57:13 <kparal> ok, so I'll check up with you on what needs to be done once I finish all the reviews
14:57:32 <tflink> ok, sounds good
14:57:42 <kparal> maybe just going with rsync for starters, that's easy :)
14:57:50 <tflink> assuming that works, yeah
14:57:56 <tflink> that works well enough, yeah
14:58:05 <tflink> but we can continue that conversation later
14:58:14 <tflink> with only 2 minutes left, we come to
14:58:18 <tflink> #topic Open Floor
14:58:34 <tflink> anything else that should be mentioned/covered?
14:59:05 <kparal> nothing here
14:59:21 <tflink> k
14:59:44 * tflink sets fuse, will send out minutes shortly
15:00:11 <tflink> boom
15:00:14 <tflink> #endmeeting