19:00:42 <kushal> #startmeeting Fedora Cloud SIG
19:00:42 <zodbot> Meeting started Wed Jun  3 19:00:42 2015 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:42 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:47 <kushal> #topic Roll Call
19:01:01 * gholms takes a seat in the bleachers
19:01:05 <dustymabe> .hellomynameis dustymabe
19:01:06 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
19:01:22 <kushal> .hellomynameis kushal
19:01:24 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:01:36 <nzwulfin> .hellomynameis mmicene
19:01:37 <zodbot> nzwulfin: mmicene 'Matt Micene' <nzwulfin@gmail.com>
19:01:42 <kushal> jsmith, scollier ^^
19:01:54 <jsmith> .hellomynameis jsmith
19:01:55 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
19:02:04 * jsmith multi-tasks like a rented mule
19:02:08 <oddshocks> .hello oddshocks
19:02:09 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
19:03:28 <kushal> #chair oddshocks jsmith nzwulfin dustymabe
19:03:28 <zodbot> Current chairs: dustymabe jsmith kushal nzwulfin oddshocks
19:03:36 <kushal> Anyone else?
19:03:56 <dustymabe> jzb ^^
19:04:40 * jbrooks here
19:05:18 <kushal> #chair jbrooks
19:05:18 <zodbot> Current chairs: dustymabe jbrooks jsmith kushal nzwulfin oddshocks
19:05:28 <kushal> Log from last meeting http://meetbot.fedoraproject.org/fedora-meeting-1/2015-05-27/fedora-meeting-1.2015-05-27-19.00.txt
19:05:37 <dustymabe> yay jbrooks
19:06:03 <kushal> #topic Action items from last week
19:06:15 <kushal> * kushal will work to get a -latest.box link up for vagrant boxes
19:06:15 <kushal> * scollier write blog for using Cockpit container on Atomic / Fedora 22
19:06:15 <kushal> * everyone start working on an agenda for Cloud WG meeting at Flock
19:06:34 <kushal> I never managed to get this done :(
19:06:41 <kushal> Will work on it this week.
19:07:03 <kushal> I am getting pulled into a lot more of fudcon meetings as I moved to Pune.
19:07:08 <kushal> No house yet.
19:07:16 * adimania is here and little late.
19:07:19 <kushal> scollier, Any update from you?
19:07:23 <dustymabe> adimania: welcome
19:07:24 <kushal> #chair adimania
19:07:24 <zodbot> Current chairs: adimania dustymabe jbrooks jsmith kushal nzwulfin oddshocks
19:08:45 <dustymabe> i think scollier isn't around today
19:08:48 <kushal> Okay
19:08:48 <dustymabe> might as well move on
19:08:53 <kushal> Moving to tickets
19:09:09 <kushal> #topic Missing Cockpit RPMs in Fedora Atomic 22 https://fedorahosted.org/cloud/ticket/105
19:09:54 <dustymabe> walters just joined so he might have some input
19:09:54 <kushal> I guess we can bring back cockpit to the updated image.
19:10:01 <kushal> walters, ^^^
19:10:06 <kushal> dustymabe, ah you are fast :)
19:11:48 <kushal> I guess he is afk.
19:12:06 <kushal> Anyone else wants to provide any thoughts?
19:12:08 <dustymabe> kushal: must be.. if mattdm was here he might have input too
19:12:14 <dustymabe> but I don't think he is in channel
19:12:14 <walters> and then aim for cockpit as a container in f23?
19:12:24 <sgallagh> I can offer an anecdote
19:12:27 <walters> i dunno...it's possible to get the contianer from the Docker hub
19:12:46 <sgallagh> I booted up the Atomic image yesterday and immediately tried to access Cockpit to examine the system.
19:13:07 <kushal> viglesias, hello there
19:13:14 <viglesias> howdy kushal
19:13:14 <kushal> sgallagh, and?
19:13:24 <sgallagh> When that didn't work, I tried to log in and start it, and discovered it wasn't there.
19:13:26 <kushal> viglesias, We are now having Fedora Cloud meeting.
19:13:34 <sgallagh> I couldn't find any documentation on how to get it
19:13:43 <viglesias> yep im planning on lurking if thats okay
19:13:49 <sgallagh> I ultimately had to ask the cockpit devs what was going on
19:14:05 <sgallagh> And was told to get it from Docker Hub.
19:14:08 <kushal> sgallagh, only thing I found was https://github.com/cockpit-project/cockpit/wiki/Atomic
19:14:22 <sgallagh> This was not a user-friendly experience
19:14:32 <kushal> sgallagh, Yup.
19:14:38 <nzwulfin> sgallagh: agreed
19:14:43 <jbrooks> This is indeed confusing -- what's the downside to putting it in the image? Size, attack surface?
19:14:45 <kushal> #link https://github.com/cockpit-project/cockpit/wiki/Atomic
19:14:52 <sgallagh> I don't care if it's a container or not, but it *should* be there and accessible by default
19:15:04 <kushal> jbrooks, I don't even know why it was removed in the first place.
19:15:12 <adimania> +1 sgallagh
19:15:16 <kushal> sgallagh, +1
19:15:25 <jbrooks> +1 to bring it back in
19:15:32 <walters> sgallagh, can you ellaborate on "there" and "accessible"?
19:15:32 <jsmith> +1
19:15:38 <adimania> yay! I so wanted this.
19:15:47 <nzwulfin> from the ticket, it was the decision of the cockpit folks ?
19:15:55 <sgallagh> walters: I should be able to browse to https://ip:9090
19:16:20 <walters> by default?
19:16:33 <sgallagh> IMHO, the ideal state would be to ship it as a container, starting by default on boot and with the option to remove that container if you don't want it
19:16:57 <jsmith> Listening only on localhost?
19:17:06 <jsmith> Or listening on a network port by default?
19:17:09 <sgallagh> jsmith: No, localhost would be pointless
19:17:35 <walters> one of the effects of Atomic is to be a "forcing function" for containerization, and there's been discussion of moving e.g. kubernetes out to a container as well
19:17:43 * jsmith has *some* reservations about network daemons enabled and listening by default
19:17:48 <jbrooks> We can just add a note to the dl page if it's important to keep this out
19:18:20 <kushal> jbrooks, we need a lot more blog posts and docs to spread the right solution.
19:18:30 <jbrooks> I was fine w/ having it in a container, but totally unclear on the canonical location of the container
19:18:49 <jbrooks> A few different ones seem legit
19:18:50 <sgallagh> jsmith: It's running that way on F21, this was (arguably) a regression to remove it
19:19:01 <jbrooks> And the cockpit project page doesn't mention it
19:19:08 <kushal> sgallagh, yup.
19:19:51 <sgallagh> jsmith: Cockpit is meant to be a remote admin interface. Having it accessible only on localhost would be useless.
19:19:58 <sgallagh> Treat it as graphical SSH, if you want :)
19:20:29 <jsmith> sgallagh: Well, that's just the thing -- I'm not sure I want a web-based graphical interface running unless I tell it I want it running
19:20:47 <dustymabe> jsmith: I agree with you on that point
19:20:47 <jsmith> sgallagh: I'm not against it per-se -- it just gives me pause
19:20:58 <dustymabe> and if you want it running then make it run using cloud-init
19:21:12 <jsmith> sgallagh: I'm much rather say "Log in via SSH, enable cockpit, then hit the web interface"
19:21:13 <sgallagh> dustymabe: And if you're using bare-metal install?
19:21:13 <nzwulfin> jsmith: +1
19:21:25 <jsmith> Have we not learned any of the lessons from webmin?
19:21:34 <jsmith> Just sayin'...
19:21:37 <dustymabe> sgallagh: can't you list the services you want to run in the kickstart
19:21:45 <jsmith> dustymabe: Indeed you can
19:21:51 <sgallagh> dustymabe: I'm not sure for Atomic
19:21:57 <sgallagh> It's not a standard service; it's a docker container.
19:22:06 <sgallagh> So I'm not sure what the procedure would be for that.
19:22:12 <kushal> jsmith, I was going to take that name ;)
19:22:17 <jbrooks> atomic run foo
19:22:24 <dustymabe> sgallagh: well I guess that is what we are talking about here.. whether it should be back as a regular service.. for now
19:22:26 <sgallagh> For a standard .service or .socket, you can play with presets
19:22:30 <dustymabe> or push forward with the container
19:22:35 <sgallagh> jbrooks: That won't work in kickstart
19:22:52 <sgallagh> (Will it?)
19:23:17 <jbrooks> I don't know
19:23:20 <dustymabe> I think there are a lot of questions that probably need to be worked out before we go with cockpit as container by default
19:23:31 <dustymabe> I would vote to restore it as normal rpm for now
19:23:34 <jbrooks> I think the previous status quo of installed but not on was fine
19:23:50 <kushal> dustymabe, +1
19:23:50 <sgallagh> I assume it's possible to make a container start with a .service or .socket file, but I don't know what it is.
19:24:13 <dustymabe> and it should be publicized during release etc..
19:24:14 <nzwulfin> sgallagh: i've done it, it's not hard
19:24:31 <jbrooks> That's how coreos does things, I believe, pull and run from systemd service files
19:24:33 <sgallagh> nzwulfin: Could you write up a blog post on that? That would be really useful information
19:25:13 <nzwulfin> sgallagh: there's an example in the getting started doc let me know if you want me to blow that out more
19:25:23 <walters> hmmm, i had forgotten that we actually had cockpit.socket enabled by default in f21
19:25:24 <sgallagh> nzwulfin: Link?
19:25:29 <kushal> nzwulfin, please do a blog post :)
19:25:29 <nzwulfin> http://www.projectatomic.io/docs/gettingstarted/
19:25:34 <walters> i had thought it required a 'systemctl enable'
19:25:43 <sgallagh> But yeah, a blog post would be awesome :)
19:25:55 * Corey84 looks in to learn more about atomic
19:26:09 <kushal> nzwulfin, feel free to add an action item in the meeting for the same :)
19:26:11 <nzwulfin> sgallagh, kushal ok .. i look at maybe combining that with the current state of getting cockpit rinning
19:26:43 <kushal> thanks :)
19:26:58 <sgallagh> Thank you
19:27:08 <dustymabe> kushal: so is this something we should take a vote on?
19:27:21 <kushal> dustymabe, On the ticket? yes we should
19:27:25 <kushal> and bring it back.
19:28:16 <kushal> dustymabe, can you please add a resolution to it so that we can vote?
19:28:31 <nzwulfin> #action nzwulfin Blog: Build systemd unit file to start containerized cockpit as service
19:28:32 <dustymabe> kushal.. a proposed resolution?
19:28:38 <walters> it's a nontrivial size increase last i looked, mainly because of PCP pulling in a world of Perl
19:29:13 <sgallagh> walters: the PCP support is optional
19:29:17 <kushal> dustymabe, I mean some text to say that we will bring it back :)
19:29:19 <sgallagh> You could just choose not to do so
19:29:28 <sgallagh> (It's a separate subpackage)
19:30:06 <walters> personally i'd say we've been sucking at updating the docs on the website
19:30:19 <dustymabe> ok. so just want to make sure that the concensus is to bring it back as an rpm for now.. you guys can vote +1 or -1
19:30:23 <kushal> walters, that is a general problem in many projects.
19:30:25 <dustymabe> walters: the atomic web site?
19:30:26 <walters> which falls a lot on me currently as I've done a lot of the commits here
19:30:28 <nzwulfin> walters: yes we have
19:30:29 <walters> dustymabe, yes.
19:30:31 <kushal> dustymabe, Yup.
19:30:53 <dustymabe> walters: yeah. I think there is quite a bit that can be done around atomic if we had more time
19:31:08 <dustymabe> there are definitly people in #atomic that we let slip through the cracks sometimes
19:31:21 <dustymabe> which means we could be losing a potential contributor
19:31:48 <nzwulfin> there's been a running email about going back over and resetting the docs, what should we have, what can we prune
19:32:23 <kushal> dustymabe, docs is a major point I want to work on during F23 release
19:32:27 <dustymabe> ok either  way for now.. for F22 we did a bad job of preparing for the change for cockpit..
19:32:38 <dustymabe> what we need to do is revert and then re-release at a future date
19:32:50 <dustymabe> with good docs, etc.. so people have the resources they need to migrate
19:33:04 <dustymabe> and with good announcements about the change
19:33:18 <kushal> dustymabe, that change was not known to us.
19:34:02 <kushal> Can we move to next ticket?
19:34:08 <dustymabe> kushal: yeah I know.. i'm not pointing fingers here though. just want to say what our state is and how we can move forward
19:34:17 <kushal> dustymabe, understood.
19:34:29 <dustymabe> ok will update the ticket.. if anyone wants to vote for or against you can do so
19:34:36 <dustymabe> now
19:34:54 <kushal> #topic Maintaining Fedora docker images for f22 https://fedorahosted.org/cloud/ticket/97
19:35:09 <walters> there's also the possibility to contribute to either the docs or the code
19:35:44 <nzwulfin> walters: +1
19:36:37 <kushal> We need to do better with docker image releases
19:37:05 <adimania> If someone would be kind enough to break the task of "docs" and create specific tasks, then I would be willing to write docs on certain topics.
19:37:06 <kushal> I will ask for the current steps required to do a release from lsm5, so that in future we can do a release when required.
19:37:16 * lsm5 here
19:37:21 <kushal> lsm5, hello
19:37:39 <lsm5> kushal: hi
19:37:42 <kushal> lsm5, can you please update us about the status of Fedora 22 docker image?
19:37:47 <walters> kushal, see https://fedorahosted.org/rel-eng/ticket/6170 for some background
19:37:58 <kushal> walters, checking
19:38:02 <lsm5> kushal: 'docker pull fedora' will fetch you the fedora 22 release version
19:38:06 <walters> it has some links to git repositories that are involved
19:38:35 <kushal> lsm5, also see if you can comment on https://fedorahosted.org/cloud/ticket/97
19:38:48 <kushal> walters, Thanks, I will go through them after meeting.
19:39:44 <lsm5> kushal: ah yup, guess there was some confusion there, I'd like to confirm: the default 'fedora' image is the f22 release version
19:40:19 <kushal> #info Default fedora image is the F22 release version
19:40:27 <kushal> lsm5, Please update the ticket too :)
19:40:34 <lsm5> kushal: sure thing, will comment there
19:41:39 <kushal> #topic Producing Updated Cloud/Atomic Images https://fedorahosted.org/cloud/ticket/94
19:42:13 <kushal> So can we fix a date when we can fix a build as the new updated release?
19:42:32 <kushal> Too many *fix* in a single sentence.
19:43:00 <sgallagh> Also, when you start releasing update images, can you create a symlink somewhere that will always point to the latest edition?
19:43:10 <sgallagh> (This will be especially useful for Vagrantfiles)
19:43:27 <kushal> sgallagh, Yes, we will have to do so. I have an action item for the same from last meeting.
19:43:30 <dustymabe> sgallagh: I think kushal does have an action item for something similar
19:43:35 <dustymabe> :)
19:43:52 <sgallagh> /me goes back to lurking
19:43:53 <dustymabe> kushal: I know you and dgilmore talked a decent amount about this one
19:44:08 <dustymabe> is all the tooling in place for this to work when we are ready?
19:44:54 <kushal> dustymabe, I think releng side is ready, now we just have to test a particular image and inform that to rel-eng
19:45:37 <dustymabe> got ya.. when you say a particular image
19:45:40 <dustymabe> what do you mean
19:45:53 <dustymabe> do they build them all the time anyway or does someone have to kick it off?
19:46:29 <kushal> dustymabe, Say first we test the nightly build from 26/June/2015 and then ask rel-eng release a new image, and do the final testing on that
19:46:42 <kushal> dustymabe, tunir will reduce testing time dramatically.
19:47:11 <dustymabe> sweet
19:47:38 <kushal> dustymabe, I will update that ticket about this.
19:47:38 <dustymabe> ok. so should we target one for late june then?
19:47:44 <kushal> dustymabe, Yup.
19:47:57 <dustymabe> if we plan to do it then maybe it will happen :)
19:48:21 <kushal> #action kushal will update https://fedorahosted.org/cloud/ticket/94 about releasing a new image in the end of june
19:48:28 <kushal> dustymabe, ^^ is that okay?
19:48:33 <dustymabe> looks great to me
19:48:39 <kushal> thanks :)
19:49:07 <kushal> Anything else on this ticket?
19:49:11 <dustymabe> we also need some messaging on the website
19:49:18 <dustymabe> I think this is the first time we have done this
19:49:23 <kushal> Yup.
19:49:31 <dustymabe> so having a separate "release day" page
19:49:37 <dustymabe> vs updated images page
19:49:39 <kushal> That means have to rope in the websites team.
19:49:39 <dustymabe> would be nice
19:49:47 <dustymabe> if you could add that to the ticket it would be nice
19:50:10 <kushal> dustymabe, I will do that :)
19:50:20 <dgilmore> kushal: dustymabe: right now we kick it off manually, I was going to look at havinga  weekly cronjob to do a build
19:50:40 <kushal> dgilmore, okay, great to know that :)
19:50:56 <kushal> 10 minutes left
19:51:05 <kushal> Moving to Open floor
19:51:15 <kushal> #topic Open Floor
19:51:33 <kushal> PRD review: Has anyone got a chance to review the PRD?
19:51:42 <oddshocks> From me: It's been sitting there a while, so I'm trying to get final opinions/votes on https://fedorahosted.org/cloud/ticket/99
19:51:48 <kushal> #link https://fedoraproject.org/wiki/Cloud/Cloud_PRD
19:51:50 <oddshocks> I'm closing the book on that this week, unless anyone has objections
19:52:00 <oddshocks> #link https://fedorahosted.org/cloud/ticket/99
19:52:39 <kushal> oddshocks, good point, may be we can just vote there.
19:53:00 * jsmith already voted there
19:53:37 <oddshocks> kushal: Agreed. I suggest we vote on the ticket. It's been brought up enough here. Just making sure folks are aware that the door is closing on that one :)
19:54:37 <kushal> oddshocks, thanks for that :)
19:56:47 <kushal> Please have a look at the PRD, we have only a few days left to update.
19:57:05 <kushal> I want to add details about containers world and vagrant specific things there.
19:57:14 <kushal> sgallagh, do you want to say anything related to this?
19:57:37 <sgallagh> The goal of the PRD is to have a strategy document that we can point to
19:57:54 <sgallagh> Specifically for the purpose of deciding whether a new idea fits the strategy or is a distraction from our goals
19:58:09 <sgallagh> So let's please try to make sure the PRD reflects our real intentions
19:59:30 <kushal> sgallagh, I will start updating it from tomorrow
19:59:38 <sgallagh> Thank you
20:00:06 <kushal> One last point, I have a draft post in magazine about tunir, please review it if you can :)
20:00:23 <kushal> After long time touched 1 hour mark properly :)
20:01:10 <kushal> Is there anything else? or else we can close the meeting.
20:01:18 <kushal> Closing in 5
20:01:20 <kushal> 4
20:01:21 <kushal> 3
20:01:26 <kushal> 2
20:01:28 <kushal> 1
20:01:32 <kushal> #endmeeting