17:02:35 <roshi> #startmeeting cloud_wg
17:02:35 <zodbot> Meeting started Wed Jun 17 17:02:35 2015 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:44 <roshi> #meetingname Cloud WG
17:02:44 <zodbot> The meeting name has been set to 'cloud_wg'
17:02:52 <roshi> #topic Roll Call
17:02:55 <dustymabe> .hellomynameis dustymabe
17:02:55 <roshi> .hello roshi
17:02:56 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
17:03:00 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:03:15 <kushal> .hellomynameis kushal
17:03:16 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
17:04:28 <roshi> anybody else?
17:04:55 <roshi> gholms jsmith jzb imcleod ^^
17:05:23 <dustymabe> number80 ^^
17:05:35 <number80> .hello hguemar
17:05:36 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:05:41 <kushal> the internet ^^^
17:05:45 <roshi> heh
17:06:45 * gholms is here
17:06:54 <roshi> sweet
17:07:04 <roshi> #topic Previous Meeting Follow-up
17:07:06 <roshi> nzwulfin Blog: Build systemd unit file to start containerized cockpit as service kushal will update https://fedorahosted.org/cloud/ticket/94 about releasing a new image in the end of june
17:07:23 <roshi> that was supposed to be two lines...
17:07:28 <roshi> nzwulfin Blog: Build systemd unit file to start containerized cockpit as service
17:07:34 <roshi> kushal will update https://fedorahosted.org/cloud/ticket/94 about releasing a new image in the end of june
17:07:46 <dustymabe> I just pinged him in #atomic
17:07:55 <roshi> I saw :)
17:08:05 <dustymabe> I think he did blog though
17:08:12 <roshi> I have it set to highlight every time someone mentions "cloud"
17:08:19 <kushal> roshi, :)
17:08:28 <dustymabe> http://www.projectatomic.io/blog/2015/06/running-cockpit-as-a-service/
17:08:31 <kushal> dgilmore, has a new tree
17:08:52 <kushal> We can ask him to create a new image if the rest is ready, then we can test it.
17:09:28 <roshi> regarding this is ticket 1444
17:09:29 <roshi> https://fedorahosted.org/fesco/ticket/1444
17:09:52 <imcleod> .hello imcleod
17:09:53 <zodbot> imcleod: imcleod 'Ian McLeod' <imcleod@redhat.com>
17:09:54 <roshi> decision is still being made regarding what all is required of an updated release media
17:09:59 <roshi> o/ imcleod
17:10:29 <imcleod> \o roshi
17:10:39 * maxamillion is here ... sorry for being late
17:10:46 <kushal> maxamillion, no problem :)
17:11:19 <roshi> no worries
17:11:30 <roshi> so, are we ready to test the images when they're ready?
17:11:41 <roshi> we're kinda blazing the trail to ensure testing gets done
17:11:43 <kushal> roshi, Yes, tunir can help in.
17:12:11 <roshi> regarding tunir, have you talked to tim to get things working with taskotron or helping with disposable clients?
17:12:18 <roshi> tim = tflink
17:12:23 <kushal> roshi, and if people have bandwidth, I can add in the docker related tests.
17:13:08 <kushal> roshi, Nope, but I am keeping my tests in such a way so that even taskotron can use them. I remember tim saying wait for the new taskotron, he wanted to design it in his way.
17:13:17 <roshi> it seems to me that tunir and taskotron should mesh well, and like there's a duplication of work happening
17:13:23 * tflink doesn't recall saying that
17:13:57 <kushal> tflink, I mean you were designing it at that time and have asked to see how that goes.
17:14:18 <kushal> My first line was not your exact words, sorry for that.
17:15:14 <roshi> I just figure since we have people working on automation, it makes sense for it to be the same automation :)
17:15:46 <kushal> roshi, Yes, that is why the actual tests are just python unittest cases, anyone or any system can use them.
17:16:01 <roshi> good to know
17:16:08 <dgilmore> kushal: I am working to enable daily trees
17:16:34 <kushal> dgilmore, Oh great news.
17:16:39 <roshi> can you sync with tim and figure out anything you could help with regarding testing within the taskotron framework?
17:16:45 <kushal> #info dgilmore is working to enable daily trees.
17:16:59 <roshi> #chair dustymabe kushal imcleod gholms
17:16:59 <zodbot> Current chairs: dustymabe gholms imcleod kushal roshi
17:17:01 <kushal> roshi, I will, but after fudcon :)
17:17:05 <roshi> ok
17:17:23 <roshi> #action kushal to sync with tflink regarding taskotron after fudcon
17:17:33 <kushal> roshi, as a separate update, I will be too busy till 29th, and may stay dead for 1-2 days that the event.
17:17:40 <tflink> it's been a while since we talked about it but cloud image testing is one of the use cases we're designing for
17:17:46 <kushal> * after that.
17:17:52 <kushal> tflink, Yes.
17:18:14 <roshi> sweet, that'll be good
17:18:18 * tflink needs to look at the test cases for tunir to see if they'd work with the design decisions we ended up making for taskotron
17:18:32 <tflink> assuming kushal isn't a zombie after fudcon, anyways
17:18:47 <tflink> :)
17:18:48 <kushal> tflink, hehe :)
17:18:53 <roshi> at this point we need to make sure any updated image gets tested, and the results documented somewhere so QA can sign off
17:19:03 <kushal> roshi, get us a wiki page.
17:19:05 <roshi> since there's no SOP for updated release media ATM
17:19:13 <roshi> for the testing?
17:19:16 <roshi> will do
17:19:32 <roshi> #action roshi to create a test matrix for testing updated images
17:19:57 <kushal> Yes
17:20:30 <roshi> onto the agenda items!
17:20:35 <roshi> of which, we have a lot
17:20:48 <gholms> Heh
17:21:06 <roshi> #topic Missing Cockpit RPMS (#105)
17:21:09 <roshi> #link https://fedorahosted.org/cloud/ticket/105
17:21:35 <dustymabe> sounds like our previous decision isn't going to be what we go with?
17:21:49 <dustymabe> we are pushing forward with the containerize it approach?
17:22:08 <dustymabe> kushal: this is the testing you were doing right ^^
17:22:16 * roshi hasn't been tracking this one
17:22:46 <kushal> dustymabe, I thought we all agreed to have it as rpms
17:23:35 <dustymabe> kushal: yeah we did.. but I don't think there is any way to enforce that
17:24:33 <dustymabe> and there is now a blog post about how to use the container
17:24:42 <dustymabe> http://www.projectatomic.io/blog/2015/06/running-cockpit-as-a-service/
17:24:48 <kushal> dustymabe, what about changing the kickstart?
17:25:24 <dustymabe> do make it be enabled by default?
17:25:26 <dustymabe> like as a service?
17:25:33 <kushal> yes
17:25:36 <maxamillion> I was under the impression that it was agreed to not to rpms ... but it's possible I'm mistaken
17:25:40 <dustymabe> yeah I don't know about that
17:26:10 <dustymabe> maxamillion: yeah we decided in last meeting to do rpms but I think others disagree
17:26:22 <dustymabe> ones that have more control over it
17:26:43 <maxamillion> dustymabe: ohhhh ok
17:27:00 <dustymabe> i'm not sold on either way really. I just want the user to have a good experience
17:27:18 <maxamillion> I think both upstream projectatomic and cockpit is recommending it be run as a container for whatever that's worth
17:27:19 <dustymabe> and since we botched to "let's move to containers" for this release we decided to just go back to the rpm approach
17:27:30 <maxamillion> let me try to find documentation on that
17:27:40 <dustymabe> maxamillion: yeah I think that is the long term
17:27:54 <dustymabe> so here's the current situation
17:27:59 <maxamillion> yeah --> http://cockpit-project.org/running.html click on "Fedora Atomic"
17:28:15 <dustymabe> we either double down and decide rpms are what we want and go try to enforce it
17:28:27 <dustymabe> or we embrace the new approach and try to make the user experience better
17:28:43 <dustymabe> kushal, roshi thoughts?
17:29:04 <kushal> dustymabe, I am in for rpms, container means more to download
17:29:08 <maxamillion> maybe related to the discussion but we're trying to come up with a testing-phase approach for https://fedoraproject.org/wiki/Changes/Layered_Docker_Image_Build_Service ... proposal should be going to the releng and/or infra lists in the near future
17:29:23 <dustymabe> obviously in comment 11 they were ignoring what I wrote in comment 7
17:29:24 <dustymabe> https://fedorahosted.org/cloud/ticket/105#comment:11
17:30:27 <roshi> honestly, I'm out of the loop enough with atomic to not trust anything I'd say regarding it
17:30:40 <dustymabe> I guess I can just comment in the ticket and try to push the discussion along
17:31:02 <roshi> speaking blindly, whatever is best for the users - but I realize that means nil because of how loosely 'user' is defined
17:31:09 <roshi> aiui, anyways
17:31:40 <dustymabe> ok. let's move on
17:31:58 <roshi> #action dustymabe to comment in ticket and keep the conversation moving
17:32:03 <roshi> that fine dustymabe ?
17:32:06 <dustymabe> sure
17:32:22 <roshi> #topic Maintaining Docker images
17:32:25 <roshi> #link https://fedorahosted.org/cloud/ticket/97
17:33:38 <roshi> do we have any hard liaison with the Base WG?
17:33:55 <roshi> I mean, docker isn't strictly cloud, I guess, but it's pretty close
17:34:05 <kushal> roshi, in my count it is cloud :)
17:34:08 <kushal> roshi, so lsm5 will update the repo with the steps on creating an official image on the github repo.
17:34:22 <kushal> too many repo in one sentence.
17:34:31 <roshi> can you update the ticket with that info?
17:34:48 * roshi realizes he doesn't even know who's all on the Base WG
17:34:56 <kushal> roshi, I will.
17:35:07 <kushal> roshi, even I don't know all the names :)
17:35:44 <roshi> #action kushal to update ticket #97 with lsm5 activities
17:36:15 <roshi> #topic Investigate systemd-networkd (#14)
17:36:18 <roshi> #link https://fedorahosted.org/cloud/ticket/14
17:36:20 <kushal> There goes my dream of staying out of action.
17:36:24 <roshi> lol
17:36:31 <roshi> comes with the territory :p
17:36:43 <kushal> roshi, So I did investigated with running instances, worked well.
17:37:02 <kushal> roshi, Now I will have to write the change proposal, and work on it through the ks file.
17:37:19 <kushal> roshi,  I will update that ticket as it goes.
17:37:28 <kushal> roshi, now add another action :p
17:37:49 <roshi> lol, will do
17:38:10 <roshi> #action kushal to write networkd change proposal and update the kickstart
17:38:34 <roshi> #topic Care and Feeding of Dockerfiles (#84)
17:38:35 <kushal> update the ticket with status updates :)
17:38:36 <roshi> #link https://fedorahosted.org/cloud/ticket/84
17:38:46 <kushal> roshi, I guess we can skip that.
17:39:15 <roshi> I don't know of any work done to split out the dockerfiles
17:39:24 <roshi> we should probably have some tests for each of them too
17:39:54 <kushal> roshi, Yes, more tests are always welcome ;)
17:40:14 <roshi> of course, you're talking to a QA guy :p
17:40:46 <roshi> kk, we'll skip it for now
17:41:05 <roshi> #topic Flyer Text (#108)
17:41:07 <roshi> #link https://fedorahosted.org/cloud/ticket/108
17:41:59 <roshi> I think a flyer could be good
17:42:52 <roshi> it might be good to get some testimonials from people who run the cloud image for their production instances
17:43:13 <kushal> Yes.
17:43:16 <dustymabe> roshi: we got some testimonials for F21 release
17:43:29 <roshi> can we use those for this?
17:43:37 <kushal> roshi, I guess os.
17:43:44 <roshi> who wants to chase those down and write up a draft?
17:43:56 * kushal volunteers dustymabe :p
17:44:00 * dustymabe ducks
17:44:08 <kushal> hah
17:44:10 <kushal> haha
17:44:20 <dustymabe> i think they are on the fedora cloud download page
17:44:23 <dustymabe> or at least they were
17:44:27 <dustymabe> let me see if I can find
17:44:56 <dustymabe> roshi: yeah here is the one we got from Major
17:44:57 <roshi> looks like there needs to be about 6 paragraphs and links to our docs/etc
17:44:58 <dustymabe> V
17:44:59 <dustymabe> https://getfedora.org/en/cloud/
17:45:07 <dustymabe> that was short though
17:45:25 <roshi> judging fromthe server flyer
17:46:32 <dustymabe> roshi: yeah I don't want to sign up for anything extra right now
17:46:41 <dustymabe> summit next week is going to consume life for a while
17:47:07 <roshi> I'm pretty swamped as is, so if it falls to me it's going to take a while
17:47:15 <roshi> makes sense dustymabe
17:47:27 <kushal> dustymabe, yes yes, that was not that serious :)
17:48:16 <dustymabe> open floor?
17:48:37 <roshi> we've got 3 more items
17:48:42 <dustymabe> oh ok
17:48:47 <roshi> we'll punt on this and move on I guess
17:48:50 * dustymabe has to leave on the hour
17:49:12 <roshi> #topic Updated images (#94)
17:49:14 <roshi> #link https://fedorahosted.org/cloud/ticket/94
17:49:28 <roshi> this is all still in the discussion phase at a higher level
17:49:34 <roshi> as we talked about a bit earlier
17:49:50 <roshi> the best we can do, I think is get a RC ready, run the tests and submit to QA
17:49:57 <dustymabe> roshi: ok
17:50:03 <roshi> once that happens we can take it to whoever and then see if it's good enough
17:50:09 <roshi> then the process can evolve from there
17:50:12 <dustymabe> how are we on the issue that I listed
17:50:16 <dustymabe> issues
17:50:31 <roshi> can't say off the top of my head
17:50:44 <roshi> v2 qcows is a non-trivial fix, aiui
17:50:59 <kushal> Yes
17:51:00 <roshi> didn't nfs-utils go stable a while back?
17:51:01 <dustymabe> roshi: really?
17:51:08 <dustymabe> roshi: yes nfs did
17:51:12 <roshi> yeah, it's something deep in koji
17:51:14 <roshi> aiui
17:51:33 <dustymabe> I really wish we could just run the qemu-img command and be done with it
17:51:50 <roshi> honestly, it might be faster to write a patch for openstack to do the conversion if it needs it
17:51:59 <roshi> ie, has an older version of libvirt installed
17:52:11 <roshi> that's me just guessing though
17:52:21 <dustymabe> roshi: can the *old* openstack do the conversion
17:52:31 <roshi> dustymabe: want to jump to open floor before you leave?
17:52:34 <roshi> that, I don't know
17:52:45 <dustymabe> roshi: no that's fine
17:52:54 <dustymabe> Id like to talk a bit more about these issues
17:52:55 <kushal> dustymabe, I think nope.
17:52:56 <roshi> ok, just checking
17:53:13 <dustymabe> so fix selinux policy
17:53:15 <roshi> I don't know if there is an easy fix, aside from people converting it themselves
17:53:17 <dustymabe> BZ#1227484
17:53:27 <roshi> .bug 1227484
17:53:31 <zodbot> roshi: Bug 1227484 install of packages during cloud-init boot fails with dnf selinux avc denials - https://bugzilla.redhat.com/1227484
17:53:40 <dustymabe> supposedly fix is out but I don't see any builds of the rpm
17:53:48 <dustymabe> I asked in the bug but no response
17:53:54 <roshi> I haven't either (but I haven't looked)
17:53:59 <dustymabe> does anyone know how we can get a copy and test it
17:54:21 <roshi> have to check if there's a koji build of it, then spin up a customized image to test
17:54:30 <roshi> and I haven't been able to get local builds to work for me
17:54:33 <roshi> always fails out
17:55:07 <dustymabe> https://admin.fedoraproject.org/updates/selinux-policy doesn't list the new rpm
17:55:21 <dustymabe> i guess I'll keep asking
17:55:24 <dustymabe> ok
17:55:24 <kushal> dustymabe, ouch.
17:55:46 <roshi> not much we can do if we're not a maintainer for the package, I don't think
17:55:59 <roshi> download the source, do a custom copr build and test with that?
17:56:01 <roshi> I dunno
17:56:35 <dustymabe> it's fine.. I just want to get this in before we release new images
17:56:41 <roshi> yeah, for sure
17:56:49 <roshi> the silver lining is that other tools work
17:57:04 <roshi> so at least you're not totally blocked by it
17:57:10 <dustymabe> yeah
17:57:13 <roshi> still needs fixed and is annoying
17:57:15 <dustymabe> ok that's it for me
17:57:20 <roshi> kk
17:57:23 <roshi> gl hf!
17:57:26 <roshi> thanks dustymabe
17:57:31 <dustymabe> ok going to run now
17:57:37 <dustymabe> here is one thing before I leave
17:57:39 <dustymabe> http://www.fpaste.org/233213/43456328/
17:57:55 <dustymabe> I gain some space back if I just from fstrim on rootfs of our image
17:58:01 <dustymabe> might be worth looking at
17:58:05 <kushal> dustymabe, Okay
17:58:22 <kushal> We need to update the PRD.
17:58:23 <roshi> good to know
17:58:42 <roshi> #topic 32 bit image (#106)
17:58:44 <roshi> #link https://fedorahosted.org/cloud/ticket/106
17:59:05 <roshi> I think that sans stats on users/downloads, the only way we can know if it's being used
17:59:12 <roshi> is if we pull it and people scream
17:59:27 <roshi> so, I'm +1 that we remove it, provided we can bring it back if we need to
18:00:10 <roshi> thoughts?
18:00:26 <roshi> (we can continue discussion in #fedora-cloud regarding the PRD)
18:00:54 <kushal> roshi, I did a +1
18:01:15 <roshi> I'll vote in the ticket
18:01:24 <roshi> #topic Open Floor
18:02:14 * gholms notes that EC2 introduced a new 32-bit instance type today
18:02:26 <gholms> (Not that that necessarily means anyone cares)
18:02:58 <roshi> interesting
18:03:08 <roshi> I didn't figure there'd be anything new for 32 bit
18:03:14 * roshi sets the fuse
18:03:15 <roshi> 3...
18:03:23 <kushal> We have to update the PRD
18:03:27 <gholms> Every instance type with 4G of memory or less supports it.
18:03:32 * gholms shrugs
18:03:39 <roshi> 2...
18:03:44 <kushal> gholms, Yes.
18:03:52 <roshi> #info PRD discussion to continue in #fedora-cloud
18:03:56 <roshi> 1...
18:04:02 <roshi> thanks for coming folks!
18:04:10 <roshi> #endmeeting