#fedora-meeting-1: fpc

Meeting started by geppetto at 16:01:51 UTC (full logs).

Meeting summary

  1. Roll Call (geppetto, 16:01:52)
  2. Schedule (geppetto, 16:06:04)
    1. https://lists.fedoraproject.org/pipermail/packaging/2015-June/010749.html (geppetto, 16:06:08)

  3. #281 New Python Macros for Easier Packaging (geppetto, 16:06:59)
    1. https://fedorahosted.org/fpc/ticket/281 (geppetto, 16:07:00)
    2. https://fedoraproject.org/w/index.php?title=User%3ATomspur%2FPackaging%3APython&diff=cur&oldid=414855 (geppetto, 16:07:55)
    3. ACTION: New Python Macros for Easier Packaging, py2_build/py2_install/etc. (+1:6, 0:1, -1:0) (geppetto, 16:19:03)

  4. #541 Package Naming Guidelines - Clarification Required (geppetto, 16:19:22)
    1. ACTION: Package Naming Guidelines - Clarification. Lowercase better than mixedcase package names. (+1:6, 0:0, -1:2) (geppetto, 16:31:39)

  5. #281 New Python Macros for Easier Packaging (geppetto, 16:32:10)
    1. https://fedorahosted.org/fpc/ticket/281 (geppetto, 16:32:10)
    2. ACTION: New Python Macros for Easier Packaging, py2_build/py2_install/etc. (+1:7, 0:1, -1:0) (geppetto, 16:32:21)

  6. #542 Forbid "python -OO" for Python < 3.5 (geppetto, 16:32:28)
    1. https://fedorahosted.org/fpc/ticket/542 (geppetto, 16:32:28)
    2. ACTION: Forbid "python -OO" for all versions of Python, no need for rationale in policy (+1:7, 0:1, -1:0) (geppetto, 16:37:24)

  7. #543 secure config and log permissions (geppetto, 16:37:49)
    1. https://fedorahosted.org/fpc/ticket/543 (geppetto, 16:37:49)
    2. ACTION: Seems like too big a change for FPC to just accept it, needs systemwide change and FESCO sign off. (geppetto, 16:46:55)

  8. #544 Case of package names (geppetto, 16:47:10)
    1. https://fedorahosted.org/fpc/ticket/544 (geppetto, 16:47:11)
    2. ACTION: DUP of 541 (geppetto, 16:48:24)

  9. #545 Python guidelines cleanup (geppetto, 16:48:33)
    1. https://fedorahosted.org/fpc/ticket/545 (geppetto, 16:48:34)
    2. This isn't a real ticket. (geppetto, 16:49:33)

  10. #546 Review/clarity on minor fork of nghttp2; b64.c (geppetto, 16:49:45)
    1. https://fedorahosted.org/fpc/ticket/546 (geppetto, 16:49:45)
    2. http://git.libwebsockets.org/cgi-bin/cgit/libwebsockets/tree/lib/ssl-http2.c#n111 (geppetto, 16:58:04)
    3. ACTION: Bundling of base64/random SSL setup bits. (+1:5, 0:1, -1:0) (geppetto, 17:19:48)
    4. ACTION: Bundling of "custom" sha1 implementation. (+1:3, 0:1, -1:2) … just link to the openssl functions, as you have build options for it. (geppetto, 17:20:04)

  11. #538 Bundling exception for htmlunit-core-js (geppetto, 17:21:11)
    1. https://fedorahosted.org/fpc/ticket/538 (geppetto, 17:21:12)
    2. ACTION: Bundling exception for htmlunit-core-js (+1:0, 0:0, -1:4) (geppetto, 17:34:41)
    3. ACTION: Work with the rhino package in Fedora to get it updated. (geppetto, 17:34:51)
    4. ACTION: Answer the questions in the bundling exception process about why you can't merge the diffs. into upstream rhino. (geppetto, 17:35:15)
    5. rhino is really big, actively maintained and security sensitive. At best you'll get permission to ship a forked copy. (geppetto, 17:37:06)

  12. Open Floor (geppetto, 17:37:22)


Meeting ended at 17:55:24 UTC (full logs).

Action items

  1. New Python Macros for Easier Packaging, py2_build/py2_install/etc. (+1:6, 0:1, -1:0)
  2. Package Naming Guidelines - Clarification. Lowercase better than mixedcase package names. (+1:6, 0:0, -1:2)
  3. New Python Macros for Easier Packaging, py2_build/py2_install/etc. (+1:7, 0:1, -1:0)
  4. Forbid "python -OO" for all versions of Python, no need for rationale in policy (+1:7, 0:1, -1:0)
  5. Seems like too big a change for FPC to just accept it, needs systemwide change and FESCO sign off.
  6. DUP of 541
  7. Bundling of base64/random SSL setup bits. (+1:5, 0:1, -1:0)
  8. Bundling of "custom" sha1 implementation. (+1:3, 0:1, -1:2) … just link to the openssl functions, as you have build options for it.
  9. Bundling exception for htmlunit-core-js (+1:0, 0:0, -1:4)
  10. Work with the rhino package in Fedora to get it updated.
  11. Answer the questions in the bundling exception process about why you can't merge the diffs. into upstream rhino.


People present (lines said)

  1. geppetto (203)
  2. tibbs|w (104)
  3. Rathann (55)
  4. orionp (22)
  5. zodbot (20)
  6. tomspur (18)
  7. SmootherFrOgZ (12)
  8. gbcox (10)
  9. gholms (2)
  10. Corey84 (1)
  11. RemiFedora (1)
  12. tibbs (0)


Generated by MeetBot 0.1.4.