17:00:25 <kushal> #startmeeting Fedora Cloud SIG
17:00:25 <zodbot> Meeting started Wed Jul  1 17:00:25 2015 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:36 <kushal> #topic Roll Call
17:00:37 <dustymabe> .hellomynameis dustymabe
17:00:38 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
17:00:44 <kushal> .hellomynameis kushal
17:00:45 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
17:00:48 <kushal> #chair dustymabe
17:00:48 <zodbot> Current chairs: dustymabe kushal
17:01:08 <kushal> #chair  agrimm dustymabe imcleod jsmith jzb number80 oddshocks roshi scollier
17:01:08 <zodbot> Current chairs: agrimm dustymabe imcleod jsmith jzb kushal number80 oddshocks roshi scollier
17:01:22 <kushal> Anyone else for the meeting?
17:01:29 <number80> o/
17:02:30 <kushal> Oops
17:02:34 <kushal> that is less
17:03:08 <kushal> Anyone else?
17:03:28 <number80> ?
17:03:32 <dustymabe> I know jzb asked me earlier this week about the meeting.. which makes me think he was intending to com e
17:03:41 * kushal is wondering if we should continue or not.
17:04:05 <number80> I suspect that we could close it in a few minutes
17:04:26 <number80> the hot weather has killed everyone's motivation :)
17:04:33 <kushal> :)
17:04:48 <kushal> The bright red point is the kernel is missing from installs
17:04:51 <dustymabe> kushal: how many meeting items do we have?
17:05:06 <kushal> We will add the kernel package manually and then test it
17:05:19 <dustymabe> kushal: action item on that?
17:05:38 <kushal> https://fedorahosted.org/cloud/report/9
17:05:52 <kushal> dustymabe, nope, I will add one, and mark your bug
17:05:59 <dustymabe> kushal: thanks!
17:06:16 <kushal> dustymabe, just that fudcon took away too much energy from life.
17:06:25 <dustymabe> gholms: welcome
17:06:29 <gholms> o/
17:06:51 <kushal> dustymabe, I am thinking to close the meeting for today.
17:06:57 <dustymabe> kushal: yeah summit took a good portion of time
17:07:03 <kushal> dustymabe, and continue the discussion over email
17:07:05 <dustymabe> kushal: lets discuss a few items and then we can close
17:07:17 <dustymabe> https://fedorahosted.org/cloud/ticket/14
17:07:19 <kushal> dustymabe, Okay, feel free to take the lead :)
17:07:24 <dustymabe> systemd/networkd
17:07:38 <dustymabe> can you add your discussion with gholms to the ticket
17:07:43 <dustymabe> so we can better make a decision
17:07:58 <kushal> So, one of the point about having separate products, is that they can choose a different path.
17:08:17 <kushal> ^^^ this point was mentioned by dgilmore in face to face meeting.
17:08:36 <dustymabe> define "separate products"
17:08:45 <kushal> dustymabe, workstation and cloud
17:09:08 <dustymabe> ok.. is that related to systemd-networkd vs networkmanager?
17:09:13 <kushal> yes.
17:09:15 <gholms> It hasn't been a discussion so much as people missing the point.  :(
17:09:16 <kushal> dustymabe, :)
17:09:37 <kushal> gholms, True, we only discussed it over here.
17:09:53 <kushal> dustymabe, gholms do you suggest that I should drop a mail to the list?
17:10:04 <gholms> So, one of the things the cloud PRD talks about is preventing differences in the environment.
17:10:05 <dustymabe> kushal: I suggest we add as much as possible to the ticket
17:10:23 <kushal> dustymabe, Okay.
17:10:24 <dustymabe> and then also send an email to the list and encourage important discussion points to make it back into the ticket
17:10:30 <kushal> dustymabe, Okay.
17:10:44 <gholms> Yeah, I think the discussion should go somewhere.  The ticket's fine.  I just keep forgetting about it.
17:10:49 <kushal> gholms, Okay, I guess we should update the PRD too :)
17:10:52 * roshi comes in late
17:11:03 <dustymabe> roshi: right when they are talking about PRD
17:11:04 <roshi> notifications seem to be broken in my cinnamon
17:11:05 <dustymabe> :)
17:11:22 <roshi> topic is still roll call, so thought I made it in time :)
17:11:30 <gholms> Heh
17:12:01 * dustymabe is meeting noob
17:12:13 <dustymabe> #topic https://fedorahosted.org/cloud/ticket/14
17:12:27 <dustymabe> crap.. how do we get it to do the name and everything
17:12:46 <gholms> Eh?
17:12:49 <roshi> it's all done by hand :p
17:12:57 <dustymabe> ahh ok.
17:13:00 <dustymabe> #undo
17:13:00 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x37816650>
17:13:04 <kushal> #topic Investigate systemd-networkd https://fedorahosted.org/cloud/ticket/14
17:13:07 <gholms> Oh.  You have to punch in fhe topic yourself.
17:13:09 <roshi> $topic Name of thing here (#foo) - then a link
17:13:16 <kushal> dustymabe, :)
17:13:24 <dustymabe> :)
17:13:28 <dustymabe> ok yeah.. that is the topic
17:13:48 <dustymabe> kushal and gholms are going to add their discussion to the ticket and kushal is going to send email to the list
17:13:55 <dustymabe> to provoke further discussion
17:14:01 <dustymabe> roshi you can weigh in with QA perspective
17:14:26 <roshi> for sure
17:14:30 <gholms> I'm not *against* networkd so much as I want the feature to address the costs, is all.
17:14:58 <roshi> the main thing, is it just adds another tree of possible errors and breakage
17:15:26 <roshi> I'm not familiar with it, so it'd take me time to get spun up on it to do any debugging if it were needed
17:15:38 <roshi> most I could do is say "Yo, it's broke. I think."
17:15:40 <dustymabe> ok. yep. we've all talked about this before amongst each other
17:15:48 <roshi> yeah
17:15:53 <dustymabe> we'll take it to the ticket and to the list
17:15:54 <kushal> roshi, it is a new feature, so yes :)
17:15:54 <roshi> I can add that to the ticket as well
17:16:21 <roshi> eh, I think it's less of a new feature and more of a new method
17:16:33 <dustymabe> #action gholms kushal roshi to update networkd/NM ticket with discussion
17:16:36 <roshi> at least, that's how I look at it
17:16:46 <dustymabe> sigh
17:17:07 <roshi> ?
17:17:11 <gholms> Thanks, everyone
17:17:14 <dustymabe> how do you assign action item?
17:17:25 <roshi> #action
17:17:27 <dustymabe> I thought it was just #action
17:17:39 <dustymabe> yeah I did that.. didn't work
17:17:39 <roshi> you did it right, nothing shows up on stdout though when you do it
17:17:45 <dustymabe> oh ok :)
17:17:45 <roshi> it'll be in the meeting minutes at the end
17:17:53 <roshi> :)
17:18:03 <dustymabe> # action kushal to send email to list to invite others to comment
17:18:08 <dustymabe> #action kushal to send email to list to invite others to comment
17:18:08 <roshi> meeting wrangling is fun, no? :p
17:18:15 <gholms> Heh
17:18:15 <kushal> roshi, haha
17:18:19 <dustymabe> roshi: :) - will be much more familiar soon
17:18:29 <dustymabe> ok moving on
17:18:30 <scollier> heya
17:18:32 <roshi> yup
17:18:45 <dustymabe> #topic "Producing Updated Cloud/Atomic Images https://fedorahosted.org/cloud/ticket/94"
17:19:01 <dustymabe> scollier: hey hey
17:19:22 <kushal> dgilmore, has the part of the scripts ready for the same, he will make it nightly too
17:19:32 <kushal> but for now kernel is missing from the installations.
17:19:36 <dustymabe> ok for this one there is a bug for cloud images not including kernel-core rpm
17:19:37 <kushal> So, they will not boot
17:19:51 <dustymabe> https://bugzilla.redhat.com/show_bug.cgi?id=1234504
17:20:02 * lalatenduM is late to meeting (this timing of meeting suits him better)
17:20:11 <dustymabe> kushal: is going to work on it (perhaps with dgilmore) and get it sorted out
17:20:14 <kushal> lalatenduM, welcome :)
17:20:22 <lalatenduM> :)
17:20:24 <kushal> dustymabe, I will do a local build tomorrow
17:20:48 <dustymabe> #action kushal to sort out missing kernel rpms BZ1234504
17:20:58 <dustymabe> kushal: thanks for that
17:21:08 <kushal> dustymabe, you are welcome :)
17:21:14 <dustymabe> I think most of the other stuff in this ticket is working itself out
17:21:26 <dustymabe> several fixes have been submitted and are in stable now
17:21:44 <dustymabe> one thing that hasn't is the qcow2 vs qcow3
17:21:46 <dustymabe> https://bugzilla.redhat.com/show_bug.cgi?id=1234504
17:21:52 <dustymabe> .bug 1234504
17:21:56 <zodbot> dustymabe: Bug 1234504 No kernel rpms in latest cloud base images - https://bugzilla.redhat.com/1234504
17:22:02 <dustymabe> oops
17:22:02 <kushal> dustymabe, so I talked with dgilmore on the same.
17:22:17 <dustymabe> .bug 1230914
17:22:19 <zodbot> dustymabe: Bug 1230914 Fedora-Cloud-Base-22-20150521.x86_64.qcow2 image is NOT qcow2, can't be launched by libvirt - https://bugzilla.redhat.com/1230914
17:22:22 <kushal> dustymabe, We will have to submit a patch upstream and then rebuild the fedora package for the same.
17:22:25 <kushal> and then deploy them
17:22:38 <dustymabe> kushal: ok.. so there is not an upstream patch already?
17:22:44 <dustymabe> I thought there was for some reason
17:22:50 <kushal> The biggest problem I see is about "How to test?"
17:22:57 <kushal> dustymabe, upstream in koji
17:23:44 <dustymabe> kushal: ahh got ya
17:23:58 <dustymabe> kushal: are there koji developers we can work with on that?
17:24:05 <dustymabe> won't they know how to test best?
17:25:11 <kushal> dustymabe, we can, but if I write a patch, I would love to test that before submitting :)
17:25:49 <dustymabe> kushal: got ya. if you were the one to do it maybe you could even ask them the best way to test in a separate env
17:26:08 <kushal> Okay
17:26:38 <dustymabe> ok. so those two items are really the only two that I see that block us getting some builds to test and put out
17:26:58 <dustymabe> I guess the qcow2 thing isn't a necessity.. maybe we target that for the "next" released image
17:28:28 <dustymabe> ok moving on to next topic?
17:28:39 <dustymabe> actually just next topic for this ticket:
17:28:52 <dustymabe> and also next topic
17:29:03 <dustymabe> #topic Missing Cockpit RPMs in Fedora Atomic 22 https://fedorahosted.org/cloud/ticket/105
17:29:27 <dustymabe> check out my last comment
17:30:54 <dustymabe> did we lose everyone?
17:31:09 <gholms> Heh
17:31:30 <roshi> I was reading the networkd ticket
17:31:35 <roshi> still here though
17:31:52 <lalatenduM> thats a lot of comments in that ticket
17:32:03 <dustymabe> lalatenduM: which ticket?
17:32:20 <lalatenduM> dustymabe: https://fedorahosted.org/cloud/ticket/105
17:32:58 <dustymabe> lalatenduM: yeah. I guess there was some back and forth. I tried to summarize in my last comment
17:33:25 <roshi> tldr: don't include cockpit at all provided we have docs on how to get it working?
17:33:35 <dustymabe> roshi: more or less
17:33:53 <dustymabe> in an automated fashion
17:33:55 <roshi> I'm +1 to that. Makes sense
17:34:21 <dustymabe> ok anyone who has any comments, +1 or otherwise, add to ticket
17:34:46 <roshi> kk
17:34:48 <dustymabe> any volunteers to write up some posts about how to do it would be greatly appreciated as well
17:35:38 <dustymabe> #topic Open Floor
17:35:58 <dustymabe> Anyone with anything for this?
17:36:28 <roshi> I have nothing atm
17:36:32 <lalatenduM> just wanted to know that who is responsible for fedora vagrant images
17:36:48 <roshi> I'm looking at some internal cloud stuff to see if we can leverage it here
17:36:57 <roshi> and trying to get testcloud packaged
17:37:05 <dustymabe> lalatenduM: I really don't know the answer to that question
17:37:06 <lalatenduM> imcleod: is it you?
17:37:18 <dustymabe> kushal: may know but I think we lost him
17:37:31 <lalatenduM> dustymabe: no prob
17:37:49 <kushal> lalatenduM, I guess sgallagh
17:37:57 <kushal> and we as a group too
17:38:08 <dustymabe> Josef Stribny wrote this post
17:38:11 <dustymabe> http://fedoramagazine.org/running-vagrant-fedora-22/
17:38:18 <kushal> dustymabe, I was actually here, can not sleep as the nose is blocked
17:38:21 <sgallagh> uh, what did I just get volunteered for?
17:38:23 <lalatenduM> yeah I have read that post
17:38:27 <kushal> sgallagh, hehe :)
17:38:34 <lalatenduM> sgallagh: lol :)
17:39:10 <sgallagh> I'd like to state for the record that the vagrant images are very clearly the responsibility of this SIG. I'm not sure why my name came up...
17:39:37 <dustymabe> sgallagh: welcome we were just trying to understand who did the initial work
17:39:42 <sgallagh> (I only really discovered Vagrant after that Magazine article, honestly. Though now I am smitten)
17:39:56 <dustymabe> sgallagh: :)
17:40:04 <lalatenduM> may be I look for the build job in koji
17:40:30 <dustymabe> lalatenduM: ok. let us know what you come up with. we need more expertise within the core sig
17:40:39 <dustymabe> if we are going to be responsible for it
17:40:48 <dustymabe> sgallagh: thanks for chiming in
17:41:01 <roshi> I'm only barely poked vagrant
17:41:19 <roshi> but willing to learn as I find spare cycles (the few that there are)
17:41:20 <lalatenduM> I am doing some vagrant images for centos, so I was thinking I might be able to help
17:41:22 <dustymabe> roshi: I used it recently but it was with the rhel7 box and not the fedora one
17:41:49 <dustymabe> lalatenduM: awesome.. you should be a fedora cloud WG member :)
17:42:48 <dustymabe> ok if no one has anything else I'll close it.
17:43:12 <lalatenduM> dustymabe: lets see what I can do
17:43:48 <dustymabe> lalatenduM: thanks!
17:43:55 <dustymabe> ok all see you later!
17:43:59 <dustymabe> #endmeeting