15:00:55 <sgallagh> #startmeeting Server SIG Weekly Meeting (2015-08-04)
15:00:55 <zodbot> Meeting started Tue Aug  4 15:00:55 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:56 <sgallagh> #meetingname ServerSIG
15:00:56 <zodbot> The meeting name has been set to 'serversig'
15:00:56 <sgallagh> #chair sgallagh mizmo nirik stefw adamw simo tuanta mitr danofsatx
15:00:56 <sgallagh> #topic roll call
15:00:56 <zodbot> Current chairs: adamw danofsatx mitr mizmo nirik sgallagh simo stefw tuanta
15:01:02 <nirik> morning
15:01:06 <mizmo> hi
15:01:06 <stefw> .hello stefw
15:01:08 <zodbot> stefw: stefw 'Stef Walter' <stefw@redhat.com>
15:01:22 <sgallagh> .hello sgallagh
15:01:23 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:01:55 <tuanta> .hello tuanta
15:01:56 <zodbot> tuanta: tuanta 'Truong Anh Tuan' <tuanta@iwayvietnam.com>
15:02:37 <tuanta> hi everyone
15:03:17 <mitr> Hello
15:04:01 <simo> .hello simo
15:04:01 <zodbot> simo: simo 'Simo Sorce' <ssorce@redhat.com>
15:04:21 <sgallagh> OK, let's get started, then.
15:04:25 <sgallagh> #topic Agenda
15:04:40 <sgallagh> I suppose we should discuss the talking points today
15:04:53 <sgallagh> #topic Agenda Item: F23 Talking Points
15:05:09 <sgallagh> #undo
15:05:09 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x4b14050>
15:05:13 <sgallagh> #info Agenda Item: F23 Talking Points
15:05:20 <sgallagh> Other items for this week?
15:05:42 <nirik> any server related stuff at flock we should discuss?
15:05:47 <stefw> What about the /etc/issue work?
15:05:56 <sgallagh> BTW, I have a hard stop at 45 minutes, so if we go longer, can someone take over?
15:06:11 <sgallagh> nirik: Good question
15:06:35 <sgallagh> #info Agenda Item: Server SIG at Flock in Rochester, New York
15:06:51 <sgallagh> #topic Agenda Item: /etc/issue work
15:06:55 <sgallagh> dammit
15:06:56 <sgallagh> #undo
15:06:56 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f54e5a93110>
15:06:59 <sgallagh> #info Agenda Item: /etc/issue work
15:07:31 <sgallagh> OK, let's actually do those in reverse order, since I think the latter two we can cover quickly.
15:07:55 <sgallagh> #topic /etc/issue work
15:08:16 <stefw> We have most of the pieces in place to show an IP address or Cockpit URL in the VT before login
15:08:30 <stefw> useful for Fedora Server in VMs and so on
15:08:43 <stefw> sgallagh, i believe we even have a freeze exception for this?
15:09:05 <stefw> but the util-linux maintainer doesn't want to rush a release
15:09:13 <stefw> of the agetty code that would allow this
15:09:20 <sgallagh> stefw: That's the sum of it, yes
15:09:24 <stefw> is it okay to wait for beta to include this?
15:09:28 <stefw> iow, there's no rush right?
15:09:45 <nirik> well, after alpha, yeah...
15:09:46 <sgallagh> It's nice to have, but I don't think it's super-critical at Alpha
15:10:17 <sgallagh> Also, Alpha RC1 is expected to drop today and I believe all the known blockers are expected to be fixed.
15:10:34 <sgallagh> So the chances of landing it at this point are pretty low, unfortunately.
15:10:38 <nirik> right.
15:10:51 <sgallagh> As soon as the getty patch is built, I'll make the necessary fedora-release-server changes.
15:11:16 <stefw> the patch is in upstream git, and needs a release there
15:11:41 <sgallagh> stefw: The maintainer isn't willing to pull the patch downstream?
15:11:54 <stefw> i think he wanted to wait and do a proper release
15:11:56 <sgallagh> ok
15:12:06 <stefw> if it doesn't happen then i'll poke further
15:12:10 <sgallagh> Thanks
15:12:23 <sgallagh> #action sgallagh to build fedora-release-server changes as soon as getty patches land
15:12:40 <sgallagh> #action stefw to follow up with getty maintainer as needed
15:13:04 <sgallagh> #info This is unlikely to land in Alpha, but we will try to get it in as soon after Alpha Freeze lifts as possible
15:13:20 <sgallagh> Anything else on this?
15:13:37 <stefw> nope that's it
15:13:40 <sgallagh> #topic Server SIG at Flock in Rochester, New York
15:14:26 * nirik will be there, not giving any particularly server talks, but happy to meet up with server working group folks.
15:14:27 <sgallagh> OK, so Fedora Server has two directly-relevant sessions at Flock
15:15:06 <tuanta> I will not attend :(
15:15:07 <sgallagh> I'm running "Fedora Server: Past, Present and Future" on Wednesday and a rolekit hackfest on Friday.
15:15:27 <nirik> sorry you will not make it tuanta. ;(
15:15:34 <sgallagh> #info "Fedora Server: Past, Present and Future" session on Wednesday
15:15:45 <tuanta> any video conferencing?
15:15:45 <sgallagh> #info rolekit hackfest on Friday
15:16:03 <sgallagh> tuanta: Some (all?) sessions will be recorded and live broadcast.
15:16:17 <tuanta> cool. thanks sgallagh
15:16:21 * nirik nods, yeah, should be.
15:16:30 <sgallagh> (The rolekit hackfest was originally going to be "Build your first server role", but we're retooling the interfaces and it wasn't ready in time)
15:16:38 <tuanta> I will join with all of you :)
15:17:03 <tuanta> nice topic, sgallagh
15:17:06 <sgallagh> Surprisingly, nothing from Cockpit on the schedule
15:17:20 <tuanta> then all details should be updated to wiki
15:17:38 <sgallagh> tuanta: Which details?
15:17:57 <tuanta> sgallagh, the hackfest details: "Build your first server role"
15:19:00 <sgallagh> tuanta: The schedule page has an update
15:19:22 <tuanta> #link https://flock2015.sched.org/event/5e0b4b224a61632e5be1a556db6c6949#.VcDX1ZNOC1E
15:19:23 <sgallagh> Anything else going on at Flock that's relevant to this group?
15:20:19 <sgallagh> #topic Fedora 23 Talking Points
15:20:22 <sgallagh> #link https://fedoraproject.org/wiki/Fedora_23_talking_points
15:20:47 <sgallagh> We'll need to strike the Cockpit GUI for Domain Controller from the list, unfortunately.
15:21:15 <sgallagh> We'll want to add the /etc/issue on there as well, though it won't be ready for Alpha.
15:21:36 <sgallagh> I don't think these really go to the public; they're used to base the other public sites' informatino on
15:21:36 <tuanta> I will take care of aggregating all points to the wiki as usual
15:21:41 <sgallagh> tuanta: Thank you
15:22:12 <sgallagh> Another thing that we have coming for Beta: role deployment in Anaconda kickstart.
15:22:51 <sgallagh> #info Remove Cockpit GUI for Domain Controller from the list
15:23:17 <tuanta> #action tuanta to remove Cockpit GUI for Domain Controller from the list
15:23:18 <sgallagh> #info Add notes about console login prompt displaying IP Address of the machine
15:23:37 <sgallagh> #info Add notes about rolekit deployments in kickstart files
15:24:19 <sgallagh> stefw: Any particular enhancements to Cockpit we would want to talk about?
15:24:27 <sgallagh> You're the most visible project
15:24:33 <tuanta> who can write those contents? or where can I find them?
15:24:46 * stefw takes a look
15:24:56 <sgallagh> tuanta: Which?
15:25:11 <tuanta> I meant: two last #info points
15:25:21 <sgallagh> stefw: (Differences from F22 launch; it's okay that F22 updates has many of them)
15:25:53 <sgallagh> tuanta: Stick placeholders there for now. I'll write up a blog post for both of them, once they're ready.
15:26:02 <sgallagh> I'll make sure you see them
15:26:04 <tuanta> sgallagh, thanks
15:26:23 <sgallagh> Actually, I'll probably submit them for the Fedora Magazine
15:26:28 <stefw> I would highlight the kubernetes UI, SSH key management (that's landing now), as well as the new journal and logging work
15:27:12 <sgallagh> #info Cockpit enhancements in F23 include a UI for managing a kubernetes cluster, SSH key management and new logging functionality based on the journal.
15:27:41 <sgallagh> tuanta: Please ask for details in #cockpit if you need them
15:27:51 <tuanta> thanks, sgallagh. I will
15:29:06 * adamw shows up late
15:29:16 <sgallagh> danofsatx: You were talking about working on some SCAP stuff; is that likely to be in F23 Beta?
15:29:22 <sgallagh> If so, we should add that to the list as well.
15:30:08 <sgallagh> I don't think he's around.
15:30:24 <sgallagh> tuanta: Could you try to catch him and ask him about that?
15:30:39 <sgallagh> (I'll try to remember next time I talk to him as well)
15:30:44 <tuanta> sgallagh, ok, I will
15:30:51 <sgallagh> Thank you
15:31:23 <sgallagh> Anything else on this topic?
15:31:33 <tuanta> #action tuanta to catch danofsatx about "some SCAP stuff" which he is working on
15:32:24 <sgallagh> #topic Open Floor
15:32:39 <nirik> are we meeting next week? lots of folks might be traveling to flock...
15:32:43 <sgallagh> adamw: Now that you're here, I've been meaning to ask you a question.
15:32:51 <sgallagh> nirik: I will be in-transit during the meeting itme
15:32:57 <adamw> sgallagh: fire away
15:33:12 * nirik will be hopefully watching f23alpha release day.
15:33:45 <sgallagh> adamw: Any chance you can attend my rolekit hackfest on Flock Friday and help brainstorm https://github.com/libre-server/rolekit/issues/12
15:33:48 * adamw will hopefully be drunk
15:34:03 <adamw> will there be beer? if so, then sure!
15:34:05 <tuanta> +1 adamw :)
15:34:18 <sgallagh> adamw: I cannot promise beer, as I do not know the venue policies.
15:34:35 <adamw> sok, i'll bring it internally.
15:34:49 <sgallagh> If beer is not permitted, I will do my best to provide flasks, which are easier to smuggle.
15:35:02 <tuanta> I can buy some beer here and join with you remotely via video conferencing :)
15:35:25 <adamw> sgallagh: you know I have these, right? https://www.happyassassin.net/ks/oc/
15:35:28 <adamw> should make it easier.
15:35:40 <sgallagh> adamw: I did not, and yes it probably will.
15:35:58 <sgallagh> There's more to it than that, but I'll save it for the hackgest.
15:36:05 <sgallagh> (Particularly since I need to go soon)
15:36:51 <adamw> sure
15:36:54 <sgallagh> OK, anything else for open floor?
15:37:40 <sgallagh> /me lights the fuse
15:37:45 <sgallagh> 3...
15:39:08 <sgallagh> 2..
15:39:25 <sgallagh> 1.
15:39:30 <sgallagh> #endmeeting