17:00:47 <kushal> #startmeeting Cloud Working Group
17:00:48 <zodbot> Meeting started Wed Sep  2 17:00:47 2015 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:52 <rtnpro> .fas rtnpro
17:00:52 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:00:55 <kushal> #topic Roll Call
17:01:03 <kushal> .hellomynameis kushal
17:01:04 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
17:01:08 <rtnpro> .fas rtnpro
17:01:08 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:01:18 <number80> .hello hguemar
17:01:20 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:01:25 <adimania> .hello adimania
17:01:26 <zodbot> adimania: adimania 'Aditya Patawari' <adimania@gmail.com>
17:01:27 <roshi> .hello roshi
17:01:29 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:02:00 <dustymabe> .hellomynameis dustymabe
17:02:02 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
17:02:41 <kushal> #chair rtnpro number80 adimania dustymabe
17:02:41 <zodbot> Current chairs: adimania dustymabe kushal number80 rtnpro
17:02:56 <jbrooks> .hello jasonbrooks
17:02:57 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:03:42 <kushal> #chair jbrooks
17:03:42 <zodbot> Current chairs: adimania dustymabe jbrooks kushal number80 rtnpro
17:03:57 <maxamillion> .hello maxamillion
17:03:58 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:04:10 <kushal> Now can anyone pass the meeting log from last meeting? https://meetbot-raw.fedoraproject.org/teams/fedora-meeting-1/fedora-meeting-1.2015-08-26-17.00.log.txt is not helping
17:04:15 <kushal> #chair maxamillion
17:04:15 <zodbot> Current chairs: adimania dustymabe jbrooks kushal maxamillion number80 rtnpro
17:04:35 <maxamillion> oh man, we're all in trouble if I'm chairing meetings now :P
17:04:36 <kushal> Or at least  find the action items :)
17:04:44 <kushal> maxamillion, hehe, you are welcome :)
17:04:52 <maxamillion> kushal: thanks :)
17:04:53 * danofsatx grabs some popcorn to watch
17:05:36 <striker> https://meetbot.fedoraproject.org/fedora-meeting-1/2015-08-26/cloud_wg.2015-08-26-17.00.log.html/ ?
17:06:06 <adimania> https://meetbot.fedoraproject.org/meetbot/fedora-meeting-1/2015-08-26/cloud_wg.2015-08-26-17.00.html
17:06:21 <roshi> yeah, that's it
17:06:31 <adimania> here is the full log: https://meetbot.fedoraproject.org/meetbot/fedora-meeting-1/2015-08-26/cloud_wg.2015-08-26-17.00.log.txt
17:06:32 <kushal> #chair roshi
17:06:32 <zodbot> Current chairs: adimania dustymabe jbrooks kushal maxamillion number80 roshi rtnpro
17:07:01 <kushal> #topic Action items from last meeting
17:07:11 <kushal> * roshi to create wiki pages with new groups and link to the governance page
17:07:11 <kushal> * number80 to organize vote on Cloud WG membership renewal
17:07:18 * roshi did that
17:08:02 * number80 is doing it now
17:08:06 <kushal> number80, :)
17:08:17 <number80> or it will never happen thanks to my packed schedule
17:08:30 <dustymabe> jzb: did create the ticket to vote on atomic
17:08:30 <kushal> I need some update on the docs group, did we select the place to write the docs?
17:08:44 <number80> jzb++
17:08:44 <zodbot> number80: Karma for jzb changed to 4 (for the f22 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:08:54 <kushal> dustymabe, oh, that is missing from action item, I guess it was from flock :)
17:08:59 * kushal still has to vote
17:09:46 <kushal> I guess we can discuss more on the open floor.
17:10:20 <scollier> heya.
17:10:35 <sayan> .hello sayanchowdhury
17:10:36 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:10:52 <kushal> scollier, Hello
17:10:58 <kushal> #chair scollier sayan
17:10:58 <zodbot> Current chairs: adimania dustymabe jbrooks kushal maxamillion number80 roshi rtnpro sayan scollier
17:11:17 <kushal> Moving to tickets
17:11:35 <roshi> kushal: we should do deliverables firstish
17:11:37 <kushal> #topic Missing Cockpit RPMs in Fedora Atomic 22 https://fedorahosted.org/cloud/ticket/105
17:11:41 <roshi> so we don't miss it
17:12:12 <kushal> roshi, ah
17:12:15 <kushal> oops
17:12:18 <jbrooks> kushal, I wrote a post, updated that ticket, need to put it in the wiki somewhere
17:12:25 <kushal> roshi, can you go ahead after this ticket?
17:12:35 <kushal> jbrooks, Yup, thanks for your update.
17:12:42 <kushal> I have some update from the docs side.
17:13:43 <kushal> roshi, please go ahead on the deliverable discussion, I can not find the details from the log right now.
17:14:28 <roshi> #topic Deliverables
17:14:31 <roshi> #link https://fedorahosted.org/cloud/ticket/118
17:15:00 <roshi> this was started a while back, but fesco needs a list of release deliverables that each WG wants to produce for a release
17:15:12 <dustymabe> do we have a starting list?
17:15:36 <kushal> dustymabe, the changes for cloud, let me find the list
17:15:49 <roshi> for F23 I think we have: Base (Blocking), Vagrant (Non), Docker (Non) (and atomic is a spin now, so I don't think we worry about it for F23)
17:16:22 <kushal> roshi, sounds good.
17:16:47 <kushal> I have to find out how much details they want it to be.
17:17:00 <roshi> for F24, we should probably come up with our list during the lull between F23 and F24 this winter
17:17:04 <roshi> just as a thought
17:17:47 * roshi updated that ticket with the list I just said
17:18:23 <kushal> roshi, thanks.
17:18:51 <number80> roshi, kushal we need to make it clear that i686 is not anymore a blocking target
17:19:12 <kushal> number80, I thought that was a general nonblocker for every product.
17:19:14 <number80> fesco already agreed but it's not reflected in our document
17:19:21 <roshi> yep
17:19:43 <number80> kushal: for F24, it will be
17:20:12 <kushal> number80, Okay.
17:20:44 <kushal> I guess we can go ahead now if nothing else to discuss here.
17:20:51 <number80> *nods*
17:21:08 <kushal> number80, roshi who will update the wiki page?
17:21:16 <kushal> https://fedoraproject.org/wiki/Fedora_Program_Management/ReleaseBlocking/Fedora23
17:21:19 <kushal> Jan?
17:21:28 <number80> jan for this page
17:21:38 <roshi> Jan is running the process, afaik
17:21:39 <number80> we need to update PRD and the ticket
17:21:47 <kushal> number80, Yup.
17:22:02 <kushal> number80, can I action you on that? or may be roshi :)
17:22:46 <number80> #action number80 update PRD about i686
17:22:52 <kushal> :)
17:22:55 <kushal> number80, Thank you.
17:23:26 <kushal> #topic Investigate systemd-networkd https://fedorahosted.org/cloud/ticket/14
17:24:02 <kushal> mhayden did few more blog posts about his use cases of networkd
17:24:27 <kushal> We are surely pushing this for F24, but we should be ready with usecases.
17:25:05 <roshi> when did we decide we're "surely pushing this?"
17:25:23 <roshi> we still need to flesh out the comparison docs and actually do the comparison
17:25:25 <kushal> roshi, I mean surely pushing it to F24 for discussion.
17:25:31 <roshi> ah
17:25:33 <roshi> gotcha :)
17:25:40 * roshi thought he missed a bunch of stuff
17:26:01 <maxamillion> +1
17:26:07 <kushal> I need some volunteer to try out NM for the same :)
17:26:21 <kushal> sayan,  ^^^
17:26:46 <kushal> anyone else?
17:27:03 <sayan> kushal, yes, i can help out with that
17:27:04 <roshi> for the comparison?
17:27:45 <roshi> https://fedoraproject.org/wiki/Cloud/Network-Requirements
17:28:04 <roshi> should beef that up, polish it and then look to start creating testcases for the comparison
17:28:42 <number80> yes, especially as the other WG are pushing NM, needs specific doc
17:28:57 <rtnpro> kushal, I will also be able to help out
17:29:11 <kushal> number80, one of the idea about WG is that we should be able to choose what fits us better :)
17:29:15 <roshi> awesome - thanks rtnpro and sayan
17:29:36 <number80> kushal: yeah, we just need to weight pros and cons
17:29:51 <kushal> number80, Yes.
17:29:59 <number80> personally, I'm in favor for the switch
17:30:26 <kushal> #action rtnpro sayan kushal will work to create testcases and try out NM and networkd, docs on https://fedoraproject.org/wiki/Cloud/Network-Requirements
17:31:02 <kushal> I guess we can move to next ticket.
17:31:40 <roshi> looks like it
17:31:43 <kushal> #topic Care and Feeding, Fedora Dockerfiles https://fedorahosted.org/cloud/ticket/84
17:32:04 <kushal> scollier, adimania, do you want to say anything on this?
17:32:21 <scollier> kushal, looking
17:32:35 <adimania> I have to replace yum with dnf for f22 branch and run my testing script again.
17:32:52 <adimania> I will do that over the weekend and report back.
17:33:07 <adimania> scollier, anything else we want here?
17:33:23 <scollier> adimania, thanks.  that is a great start.
17:33:28 <kushal> #action adimania will replace yum with dnf for f22 branch, and report back (for Fedora dockerfiles)
17:33:37 <kushal> scollier, adimania ^^ I guess this is okay.
17:33:38 <scollier> adimania, looking forward to results of that next week.
17:33:50 <adimania> kushal, yes.
17:34:03 <dustymabe> adimania++
17:34:15 <kushal> #topic [VOTE] Make Atomic the primary focus of the Cloud Working Group https://fedorahosted.org/cloud/ticket/117
17:34:20 * kushal just now voted :)
17:34:32 <scollier> kushal, adimania, i would still like us to advance some of these services. into nulecule apps, etc...
17:34:33 <kushal> Anyone wants to say anything?
17:34:34 <roshi> looked like we had votes in ticket at least
17:34:38 * dustymabe has his "voted" sticker
17:34:47 * scollier will go vote now.
17:34:55 <adimania> scollier, depending on the results, we will either fix it or drop it. no point of having bad dockerfiles.
17:34:59 <kushal> scollier, rtnpro will surely help us in that :)
17:35:23 <scollier> kushal, ok.  perhaps we should break that ticket up into separate tickets.
17:35:33 <scollier> so people can focus on specific items.
17:35:34 <rtnpro> :)
17:35:47 <kushal> scollier, feel free to add action items :)
17:35:57 <roshi> that'd be a good idea - breaking up the ticket
17:36:14 <kushal> After that we should discuss the atomic discussion :)
17:36:16 <scollier> #action scollier will break up https://fedorahosted.org/cloud/ticket/84 into consumable tickets.
17:36:21 <scollier> kushal, done.  thanks.
17:37:51 * adimania is looking for the cookies which dustymabe just sent. :P
17:37:55 <kushal> scollier, Thanks :)
17:39:17 <kushal> Remaining voters please vote on #117 :)
17:39:39 <kushal> Moving to next ticket
17:39:40 <dustymabe> adimania: yeah where are the cookies?
17:39:46 <dustymabe> let me try in #fedora-cloud
17:39:55 <kushal> #topic Producing Updated Cloud/Atomic Images https://fedorahosted.org/cloud/ticket/94
17:40:34 <dustymabe> kushal: at this point is it moot since F23 is around the corner?
17:40:56 <kushal> I got update from rel-eng today that they never got time to work on the ticket I filed, I think we can test the latest trees from them, and update the rel-eng ticket.
17:41:02 <roshi> pretty much for F22, but we'll still want to be able to do this for later releases
17:41:08 <kushal> dustymabe, We should release once in this month :)
17:41:34 <kushal> dustymabe, roshi there are many updates in between, and F23 still a bit far away (for users at least).
17:41:51 <kushal> I can add an action item on myself for this.
17:42:58 <kushal> any notes on this ?
17:43:48 <dustymabe> notes on what?
17:43:54 <dustymabe> updated images?
17:44:21 <kushal> I mean if anyone wants to say anything :)
17:44:30 <dustymabe> nah
17:44:43 <kushal> #action kushal will test and update the rel-eng ticket with the latest tree
17:45:10 <kushal> #topic No longer provide 32 bit image https://fedorahosted.org/cloud/ticket/106
17:45:51 <kushal> As number80 mentioned before, we will have to make sure that docs reflect this.
17:46:41 <kushal> Any comments from anyone?
17:47:03 <dustymabe> kushal: I don't think so
17:47:16 <dustymabe> the ticket had something in it about messaging though
17:47:17 * roshi doesn't have anything
17:47:18 <dustymabe> right?
17:47:18 <kushal> Moving next
17:47:39 <dustymabe> from mattdm
17:47:56 <dustymabe> "get a comms plan going to sunset the image in the F24 timeframe"
17:48:03 <dustymabe> what is a comms plan?
17:48:11 <roshi> marketing/communication
17:48:19 <dustymabe> can we action anybody on that?
17:48:24 <roshi> so, still produce it for 23 I guess
17:48:27 <dustymabe> I think oddshocks was heading things up before he left
17:48:33 <roshi> and market that it won't be there for F24
17:48:36 <roshi> ?
17:48:40 <kushal> dustymabe, for 23 it will be there.
17:48:43 <dustymabe> roshi: sounds good to me
17:48:46 <kushal> roshi, yes.
17:49:02 <dustymabe> but can we action anybody on the communication part of it?
17:49:06 <dustymabe> and what does that involve?
17:49:09 <dustymabe> fedmag post?
17:49:12 <dustymabe> mailing list post?
17:49:14 <dustymabe> etc..
17:49:28 <kushal> dustymabe, I think we should coordinate with the marketing team on this.
17:49:43 <dustymabe> in that case jzb would be good :)
17:50:00 <kushal> yes, as he is not here, let us add more action items on him :)
17:50:01 <dustymabe> I'll update the ticket to ask him if he would help here
17:50:09 <kushal> dustymabe, :)
17:50:12 <roshi> probably PRD or a F24 Change
17:50:22 <roshi> that'd be about it, I think
17:50:50 <kushal> #topic PRD Discussion https://fedorahosted.org/cloud/ticket/107
17:51:00 <kushal> roshi, I guess we can close this ticket for now?
17:51:01 <roshi> this is kinda moot for F23
17:51:08 <roshi> but we should work on it for F24
17:51:18 <roshi> something for the FAD?
17:51:35 <kushal> roshi, May be.
17:51:36 <dustymabe> yeah
17:53:03 <kushal> Moving on
17:53:26 <kushal> #topic Text for cloud product on getfedora.org and marketing in general https://fedorahosted.org/cloud/ticket/108
17:54:22 <dustymabe> number80: was assigned to this
17:55:04 <number80> dustymabe: yeah, and completely overwhelmed with work, if someone has more time than me, I can relinquish the ticket
17:55:27 <kushal> dustymabe, we all can now look at getfedora.org and think if we want something more
17:55:45 <kushal> otherwise marketing would go ahead with the current texts.
17:55:52 <kushal> As it is now for general usecase.
17:56:12 <dustymabe> ok.
17:56:13 <jzb> did I miss all the things?
17:56:19 <kushal> I am good with that text.
17:56:32 <kushal> jzb, not at all, we kept the action items for you :)
17:56:33 <jzb> sorry, new person starting this week, and am having in-person meetings
17:56:39 <kushal> jzb, welcome btw :)
17:56:46 <dustymabe> "in-person" what is that :)
17:56:56 <jzb> dustymabe: IKR?
17:57:11 <dustymabe> jzb: I may have asked you a question in https://fedorahosted.org/cloud/ticket/106#comment:16
17:57:18 <dustymabe> you can respond there
17:57:34 <kushal> There are still tickets left, and we have 3 minutes.
17:57:44 <kushal> Should we move to Open floor, if any update from anyone?
17:57:52 <roshi> I don't have anything
17:58:01 <kushal> #topic Open Floor
17:58:03 <roshi> just wanted to make sure we hit the deliverables one for fesco
17:58:09 <dustymabe> are the remaining tickets important?
17:58:09 <roshi> which we did
17:58:14 <jzb> has everyone voted on the cloud/atomic issue?
17:58:22 <kushal> dustymabe, we need a FAD :)
17:58:32 <kushal> jzb, not everyone :)
17:59:16 <dustymabe> one item for open floor: http://fedoramagazine.org/f23-cloud-base-test-day-september-8th/
17:59:22 <kushal> dustymabe++
17:59:22 <zodbot> kushal: Karma for dustymabe changed to 8 (for the f22 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:00:29 <kushal> Btw, as I said during flock, I have started a git repo for fedora cloud docs focusing for users, one single place, everyone can update (over git), later docs team can publish the way they want from the new tooling they are working on.
18:00:44 <kushal> I will send out a mail to the list after putting in some content it.
18:01:00 <dustymabe> kushal: thanks
18:01:09 <number80> +1
18:01:12 <kushal> I was interested in it seeing the usefulness of my worknotes.
18:01:20 * number80 will be attending fesco meeting
18:01:25 <kushal> We can close the meeting now.
18:01:34 <kushal> Thank you everyone for coming down.
18:01:37 <kushal> #endmeeting