15:00:26 <sgallagh> #startmeeting Server SIG Weekly Meeting (2015-09-15)
15:00:26 <zodbot> Meeting started Tue Sep 15 15:00:26 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:27 <sgallagh> #meetingname ServerSIG
15:00:27 <sgallagh> #chair sgallagh mizmo nirik stefw adamw simo tuanta mitr danofsatx
15:00:27 <sgallagh> #topic roll call
15:00:27 <zodbot> The meeting name has been set to 'serversig'
15:00:27 <zodbot> Current chairs: adamw danofsatx mitr mizmo nirik sgallagh simo stefw tuanta
15:00:31 <sgallagh> .hello sgallagh
15:00:32 <nirik> morning
15:00:32 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:00:32 <stefw> .hello stefw
15:00:35 <zodbot> stefw: stefw 'Stef Walter' <stefw@redhat.com>
15:00:53 <tuanta> .hello tuanta
15:00:53 <zodbot> tuanta: tuanta 'Truong Anh Tuan' <tuanta@iwayvietnam.com>
15:01:14 <mizmo> .hello duffy
15:01:15 <zodbot> mizmo: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
15:02:36 <adamw> .hello adamwill
15:02:37 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
15:04:04 <sgallagh> OK, we have quorum at least.
15:04:08 <sgallagh> Let's get started.
15:04:13 <sgallagh> #topic Agenda
15:04:24 <sgallagh> #info Agenda Item: Reducing the F24 package set
15:04:28 <sgallagh> Any other items on the agenda?
15:05:08 * nirik nothing off hand
15:06:02 <sgallagh> OK, if something comes up, we have Open Floor
15:06:12 <sgallagh> #topic Reducing the F24 package set
15:06:28 <sgallagh> #link https://lists.fedoraproject.org/pipermail/server/2015-September/002035.html
15:06:57 <sgallagh> I sent out some thoughts following up on an earlier thread.
15:07:37 <sgallagh> My reasoning is that I think we really want to be positioning Fedora Server as more of an OS than a distribution. To that end, I think our media should describe only that which we consider part of the OS.
15:07:54 * nirik is ok with that
15:08:51 <nirik> one thing somewhat related: I've seen a number of users use the server dvd or netinstall on devices with wireless network... it works on install, but we don't include the 'hardware support' group so there isn't wireless firmware after the install. ;(
15:09:20 <sgallagh> nirik: We don't include it by default, but it's on the disk as an optional checkbox.
15:09:28 <nirik> right, but they don't know to check it
15:09:29 <sgallagh> (As of shortly after Alpha, anyway)
15:09:39 <nirik> their net is working, they assume it will after install too.
15:10:16 <sgallagh> nirik: I'm open to including a subset from the @hardware-support group in the @server-hardware-support if people feel it makes sense.
15:10:29 <sgallagh> But I really don't love carrying all the support cruft in standard installs.
15:10:43 <sgallagh> I mean, wireless on a server *is* kind of an edge-case.
15:10:52 <nirik> well, all the default packages in the hardware support group are firmware for wireless devices.
15:11:51 <nirik> I'm not sure what size it adds, but I would think we could just add hardware-support...
15:12:13 <sgallagh> Ah, I think some of that changed around.
15:12:17 <nirik> could be.
15:12:28 <sgallagh> It used to have a few more things in "default" that we didn't want, I think
15:12:35 <nirik> yeah, likely so.
15:12:44 <nirik> but in f24 at least iit seems not too bad
15:13:49 <sgallagh> OK, I'm amenable to adding the firmware back in. (Also to F23 Final, if people think that's ok)
15:14:09 <sgallagh> Let's table the rest of that discussion for another #topic, though
15:14:36 * adamw is OK with this at least as a short-term test
15:15:02 <nirik> cool.
15:15:05 <sgallagh> So, on this topic. The primary counter-argument is for people who want to do offline installations. They immediately came out of the woodwork to complain about not including their favorite package.
15:15:26 <sgallagh> Of course, they also all noted that the existing DVD is missing something they want, so that (to me) negated their argument somewhat.
15:16:22 <nirik> there's no way we can include anything anyone might want.
15:16:34 * nirik wonders what size blueray media is these days. ;)
15:16:43 <sgallagh> nirik: Sure there is, we just have to clone the Everything repo :-)
15:17:00 <nirik> right, but fiting on what thing? I guess external drive?
15:17:17 <sgallagh> nirik: SDHC is quite large these days :)
15:17:21 <sgallagh> OK, I digress
15:17:24 <adamw> elephant man's thumb drive?
15:17:56 <sgallagh> The reason for my two specific proposals are basically so that they are non-judgemental about what we remove.
15:18:15 <sgallagh> If we get into picking and choosing from the list, it's going to be a quagmire.
15:18:38 <sgallagh> I think it would be better to drop to the bare minimum and then slowly re-add things if and when it makes sense to do so.
15:18:50 <sgallagh> But I'm open to differing opinions here.
15:19:12 <nirik> I think thats a good approach
15:19:21 <mizmo> i think where we will get pushback is from ppl who are using the server media to install non server things
15:19:42 <mizmo> but there isnt anything we can do about that; its not really our problem
15:19:43 <sgallagh> mizmo: They can still do that with netinstall
15:19:57 <mizmo> yeh thats true, and that honestly should be a reasonable answer
15:19:58 <sgallagh> Or by taking the DVD install and adding one or more local network repos
15:20:34 <nirik> or by making their own dvd with sever + their stuff
15:20:44 <sgallagh> Sure, the tools exist to do that.
15:21:45 <sgallagh> OK, I'm seeing basically a lazy consensus here. (No one appears to be arguing against this at least)
15:22:08 <sgallagh> So let's define bare minimum: is it Server Default Install or Server Default Install plus role support packages?
15:22:32 <mizmo> what happens if we dont include role support pkgs
15:23:26 <sgallagh> If they have internet access, nothing changes :)
15:23:43 <sgallagh> (Rolekit always tries to grab the latest version of the role from the network if the network is available0
15:24:21 <adamw> mizmo: the server DVD doesn't make a great tool for deploying non-server stuff, I don't think. that case wouldn't worry me.
15:24:22 <sgallagh> Otherwise, they have to manually select the role packages in Anaconda and they'll be able to use rolekit to deploy them without network access after first boot.
15:24:44 * adamw likes option 1 on the selfish basis that it makes blocker bugs less likely ;)
15:24:44 <sgallagh> adamw: Sorry, can you rephrase that? I'm not sure what you were getting at.
15:24:54 <sgallagh> adamw: That... may have crossed my mind as well
15:24:58 <adamw> sgallagh: i was replying to mizmo's concern about the DVD being used to deploy non-DVD stuff.
15:24:58 <mizmo> hm
15:25:04 <adamw> er, non-Server stuff.
15:25:24 <mizmo> do we have a lot of non network server users?
15:25:26 <sgallagh> Ah ok. I thought it was related to the Role stuff and didn't quite follow.
15:25:43 <sgallagh> mizmo: To me, "non-network server" is oxymoronic.
15:26:03 <sgallagh> But there are some who have access restricted to a LAN.
15:26:03 <mizmo> sgallagh, its definitely an actual thing, but i dont think it intersects at all with *fedora* usage
15:26:11 <nirik> There may be some people who install on an isolated network, but they would likely have a local mirror I would think
15:26:17 <mizmo> oh by non network i mean non public internet
15:26:18 <sgallagh> But that's the same set of people who are probably curating their own local mirror already
15:26:31 <sgallagh> nirik: jinx ;-)
15:26:36 <mizmo> yep
15:26:56 <mizmo> well i vote keep it simple then, no role support pkgs
15:27:30 <nirik> sure, lets go that way and if there's an outcry we can revisit. ;)
15:27:35 <sgallagh> True enough.
15:27:56 <sgallagh> stefw, tuanta: Any thoughts?
15:28:04 <sgallagh> (BTW, has anyone heard from mitr in the last month?)
15:30:02 * mizmo has not
15:30:23 * nirik hasn't really either, although I think he's posted to devel list
15:30:35 <sgallagh> Yeah, I've seen the occasional email, but he seems to have dropped off IRC
15:30:52 <stefw> if i had to choose between the two options it would be Option B
15:31:19 <sgallagh> stefw: Reasoning?
15:32:02 <sgallagh> The primary advantages to A) are reduced download size and reduced risk of blocking releases. That has to be weighed against convenience of having the packages at hand.
15:32:05 <stefw> I think that shipping a "DVD" means shipping our product
15:32:13 <stefw> the roles are definitely part of the Fedora Server product
15:32:29 <sgallagh> That's a fair point
15:32:49 <stefw> if we were shipping a "getting started" usb image or something targetted that way, then sure, i can see it being just the bare minimum and download everything else.
15:32:51 <sgallagh> Though the end-user experience shouldn't be much different.
15:32:56 <stefw> indeed
15:33:03 <stefw> fedora is completely out of date the day after its released
15:33:12 <stefw> and needs hundreds of megabytes of updates, even if you install nothing
15:33:21 <sgallagh> stefw: Actually, usually the same day because of the zero-day updates push
15:33:22 <stefw> so i guess this is nitpicking ...
15:33:29 <stefw> but perhaps if we do Option A
15:33:33 <simo> .hello simo
15:33:34 <zodbot> simo: simo 'Simo Sorce' <ssorce@redhat.com>
15:33:35 <stefw> we should reword the download text
15:33:58 <stefw> to reflect the fact that one is downloading the bootstrap for Fedora Server, rather than downloading the product
15:34:23 <sgallagh> Well, that's not strictly true
15:34:34 <sgallagh> Fedora Server's default installation is still quite useful
15:34:45 <sgallagh> It's a platform upon which we added several useful features.
15:34:53 <sgallagh> Fedora Server > minimal install
15:35:22 <mizmo> my thought was i dont think youd practically ever install every role available (right?), so im thinking of them more as a layer on top of the base server platform
15:35:24 <tuanta> once people get the DVD at the event, they do hope that they receive a complete product (Fedora Server product, in this case)
15:35:35 <mizmo> kind of how rhn has the base channel + the layered channels on top
15:35:37 <mizmo> well, did
15:35:54 <sgallagh> tuanta: Right, but that DVD isn't going to be useful without network updates in any case.
15:35:55 <mizmo> eg
15:36:12 <sgallagh> Which results in a user experience that is not (obviously) hampered by the lack of content on the disk.
15:36:17 <mizmo> when you buy an ipod, you dont receive every music album possible in the itunes store, i think they ship blank, but you can't do much with an ipod without music
15:36:18 <tuanta> so I think all "Server" packages should be included in the DVD
15:36:32 <simo> sgallagh: why not useful w/o network ?
15:36:40 <stefw> simo, the fact that the packages are mostly out of date
15:36:51 <stefw> even if you download on release day
15:37:01 <simo> stefw: if I just want to test something it should work though
15:37:12 <stefw> yes, true
15:37:17 <tuanta> +1 simo. people want to test the product
15:37:33 <tuanta> once we five a DVD to them
15:37:34 <sgallagh> simo: How often would you test something without network access?
15:37:37 <tuanta> s/give
15:37:42 <simo> sgallagh: classrooms
15:37:49 <sgallagh> hmm
15:37:56 <simo> pleaces where you simply have no bandwidth
15:38:05 <simo> (train ride)
15:38:14 <simo> I often build VMs out of DVDs
15:38:20 <sgallagh> If you're installing server software on a train, you deserve what you get ;-)
15:38:22 <simo> it may not be interesting to update them immediately
15:38:29 <sgallagh> But you make a compelling argument.
15:38:29 <tuanta> sgallagh, it is more often at the beginning when they don't know much about our product
15:38:45 <mizmo> here's a question
15:38:52 <mizmo> are they actually going to be using DVDs?
15:38:56 <mizmo> like, optical media, DVDs?
15:38:58 <mizmo> likely not, right?
15:39:01 <sgallagh> tuanta: Right, but the question is more about whether it matters *how* they get the add-on content as much as whether it's available.
15:39:03 <simo> mizmo: no .iso usually
15:39:07 <sgallagh> simo: makes a decent point here.
15:39:17 <mizmo> why not ship the roles as a separate iso
15:39:17 <sgallagh> mizmo: Why is that relevant?
15:39:24 <mizmo> sgallagh, see ^^
15:39:40 <sgallagh> mizmo: That's actually quite a lot harder to accomplish
15:39:47 <mizmo> but does it make more sense to do?
15:40:09 <sgallagh> mizmo: IMHO it doesn't cross the cost/benefit threshold.
15:40:27 <sgallagh> If we really want media available with the roles on them, it's more beneficial to just ship it on the main disc
15:41:05 <nirik> if folks think the GA roles are usefull for offline use, we could ship them on the dvd. I doubt we are talking much space.
15:42:40 <sgallagh> nirik: The FreeIPA dependency chain is actually fairly sizeable
15:42:55 <sgallagh> I think it's north of 200MB
15:43:16 <nirik> ok, still kinda small in the grand scheme of things tho
15:43:29 <sgallagh> Well, that's 10% of the current disk :)
15:43:53 <stefw> sgallagh, what does the rolekit ui look like for installing from DVD?
15:43:54 <adamw> i'm kinda sold on tuanta's case for the server roles, i guess
15:44:03 <stefw> sgallagh, and by UI, i'm not talking GUI
15:44:07 <sgallagh> stefw: No GUI at present. Kickstart only.
15:44:14 <stefw> what about from command line?
15:44:19 <sgallagh> `rolectl deploy domaincontroller --name example.com --deferred`
15:44:29 <stefw> and that'll get from the DVD
15:44:32 <stefw> if the files were on the DVD?
15:44:40 <sgallagh> Not exactly
15:44:47 <stefw> so ... all this is very academic
15:44:58 <stefw> all this discussion, that is
15:45:00 <sgallagh> If you selected the right packages in the %install section and were disconnected from the network, then it would use the ones already on the system
15:45:10 <stefw> because people won't realistically use the roles from DVD anyway
15:45:12 <sgallagh> But it will always *try* to update before deploying
15:45:30 <sgallagh> stefw: It can be done, but it's not the default behavior is my point
15:46:16 <sgallagh> The --deferred argument is telling rolectl to set it up so that systemd will kick off a deployment on the next system boot.
15:46:55 <sgallagh> If during that boot, the network is unavailable, rolekit will proceed if all the packages are already present. (If they were manually selected for installation during anaconda)
15:47:12 <sgallagh> At least, it should. I really need to test that, actually.
15:49:55 <adamw> long ,long ago, we had code to use the DVD as a package repo.
15:50:57 <sgallagh> adamw: I think it's still possible, but not discoverable by humans
15:51:10 <sgallagh> Anyway, this *is* getting a bit academic.
15:51:15 <adamw> yeah, i meant it was actually used by default
15:51:34 <sgallagh> Right, I remember that causing me headaches back around FC6 :)
15:52:23 <sgallagh> I'll propose A) and we'll see if it passes. If not, I'll propose B).
15:53:00 <sgallagh> Proposal: Remove everything from the DVD that isn't part of the default installation
15:53:05 <nirik> +1
15:53:36 <stefw> I'm in favor of this until the situation changes
15:53:37 <stefw> +1
15:54:17 <sgallagh> (Actually, slight addendum; remove everything but the default installation and any optional hardware enablement)
15:54:33 <tuanta> +1
15:55:46 <sgallagh> mizmo, simo, adamw?
15:55:57 <adamw> sorry ,multitasking
15:56:07 <adamw> i can be +1
15:56:22 <adamw> but i can see the value in a better setup for using roles from the DVD
15:56:48 <sgallagh> adamw: Yeah, it's worth considering for the future.
15:57:02 <sgallagh> The problem is that role setup generally needs to actually happen on the installed system for a variety of reasons.
15:57:11 <sgallagh> (Which is why the kickstart behavior works the way it does)
15:57:59 <sgallagh> I'm going to cast a +1 vote here and bring us to a majority.
15:58:11 <sgallagh> We'll see how much of a storm that brings.
15:58:31 <sgallagh> #agreed Remove everything from the DVD that isn't part of the default installation or optional hardware enablement (+5, 0, -0)
15:58:35 <sgallagh> #topic Open Floor
15:58:42 <adamw> sgallagh: hence the 'use the DVD as a repo' thing :)
15:59:13 <sgallagh> I have a hard stop to get to a meatspace meeting (meating?) in two minutes, so if there's more to discuss, would someone else mind taking over?
15:59:32 <simo> -1
16:00:00 <simo> sorry came late, but I have a -1 for the previous vote
16:00:25 <sgallagh> Noted
16:00:47 <sgallagh> OK, with nothing else on the agenda, thanks for coming folks.
16:00:50 <sgallagh> #endmeeting