15:36:01 <dgilmore> #startmeeting RELENG (2015-09-21)
15:36:01 <zodbot> Meeting started Mon Sep 21 15:36:01 2015 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:36:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:36:10 <dgilmore> #meetingname releng
15:36:10 <zodbot> The meeting name has been set to 'releng'
15:36:10 <dgilmore> #chair dgilmore nirik tyll sharkcz bochecha masta pbrobinson pingou maxamillion
15:36:10 <zodbot> Current chairs: bochecha dgilmore masta maxamillion nirik pbrobinson pingou sharkcz tyll
15:36:13 <dgilmore> #topic init process
15:36:21 <dgilmore> who is here?
15:36:24 <nirik> .hello kevin
15:36:25 <maxamillion> #init maxamillion
15:36:25 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
15:36:27 * pbrobinson is mostly
15:36:29 <maxamillion> errr
15:36:31 * sharkcz is here
15:36:33 <maxamillion> .hello maxamillion
15:36:34 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:36:40 * maxamillion can't remember things
15:36:42 * pbrobinson goes and gets another drink
15:36:56 <pbrobinson> maxamillion: are you drunk already?
15:37:00 <maxamillion> pbrobinson: I wish
15:37:15 * danofsatx is watching from the sidelines
15:38:49 <dgilmore> #topic #6244 package blocking not working in koji for EPEL
15:38:59 <dgilmore> https://fedorahosted.org/rel-eng/ticket/6244
15:39:10 <dgilmore> not sure this really needs to be discussed at the meeting
15:39:18 <nirik> we really need to get a koji update out...
15:39:19 <dgilmore> but it has the keyword so lets discuss
15:39:21 * masta is here
15:39:22 <nirik> that has the ssl junk fixed.
15:39:25 <dgilmore> nirik: indeed
15:39:32 <dgilmore> I need to do that
15:39:41 <dgilmore> I need to see about a propper fix for koji
15:39:53 <pbrobinson> something to push out updates as soon as the freeze lifts?
15:39:53 <nirik> I think part of it was merged upstream
15:39:57 <nirik> but not sure it's all of it.
15:40:06 <dgilmore> because so far all the patches really bandaid the issue that the ssl auth code needs to be thrown out
15:40:19 <dgilmore> nirik: yeah its only part of it
15:40:29 <maxamillion> nirik: did it ever get merged? I saw the patch proposed on the mailing list but didn't see it get merged
15:40:37 <pbrobinson> well we need to get a bigger/better bandaid quickly while awaiting a proper fix?
15:41:00 <dgilmore> maxamillion: did what ever get merged?
15:41:24 <maxamillion> dgilmore: the ssl fix, I thought bcochecha sent one in
15:41:26 <dgilmore> maxamillion: there are quite a few different patches, so I have no idea what one you are talking about
15:41:36 <nirik> https://git.fedorahosted.org/cgit/koji/commit/?id=ab0b2e465d0f8ad930f28eb3a49850afb57250c2
15:41:37 <dgilmore> maxamillion: its partially fixed
15:41:51 <maxamillion> nirik: ah, +1
15:41:59 <maxamillion> yeah, nirik linked the one I was talking about
15:42:00 <nirik> yeah, there's some other patch at least
15:42:12 <nirik> anyhow... just needs doing. ;)
15:42:13 <maxamillion> alright, that part I missed ... sorry for the line noise
15:42:15 <nirik> happy to help test.
15:44:07 <dgilmore> #action dgilmore to get a koji update out
15:44:29 <dgilmore> #topic Secondary Architectures updates
15:44:29 <dgilmore> #topic Secondary Architectures update - ppc
15:44:44 <dgilmore> pbrobinson: hows the world acording to ppc?
15:45:00 <pbrobinson> we're looking good
15:45:20 <pbrobinson> unless something terrible is discovered we'll be going out for beta tomorrow
15:45:44 <dgilmore> awesome
15:45:54 <pbrobinson> the core RC1 was done last week, I had to dig and find a regression in cloud image creation but I fixed that now too and they're looking OK in testing
15:46:07 <dgilmore> great
15:46:22 <dgilmore> any new deliverables for f23?
15:46:23 <pbrobinson> I'm now looking at docker images, but we won't block Beta on that
15:46:51 <pbrobinson> there needs to be at least patches to oz/imagefactory which I'm playing with now
15:46:52 <dgilmore> cool
15:47:02 <pbrobinson> and I'm getting my head around exactly how they're created
15:47:20 <dgilmore> okay
15:47:25 <dgilmore> its a two step process
15:47:35 <dgilmore> you make the image using imagefactory
15:47:50 <dgilmore> then you run a second step and convert that image to docker format
15:47:54 <pbrobinson> yea, I believe it's you make the base cloud image and then convert it to a docker image
15:48:15 <dgilmore> we use a docker kickstart, it is more minimal than the cloud base image
15:48:33 <pbrobinson> yea, I'm working on that now
15:48:59 <dgilmore> but similar process
15:49:12 <dgilmore> anything else we should cover for ppc?
15:49:19 <pbrobinson> nope
15:49:20 <dgilmore> #topic Secondary Architectures update - s390
15:49:29 <dgilmore> sharkcz: how is s390 looking?
15:50:12 <dgilmore> guess he is not here
15:50:19 <sharkcz> build-wise we are up-to-date with primary, now catching after a week of PTO and will do a test Beta compose, but the needed fixes in anaconda&co are already in, so should be fine
15:50:36 <dgilmore> okay
15:50:46 <dgilmore> so you will ship Beta in a week or two?
15:51:00 <sharkcz> next week should be doable
15:51:11 <dgilmore> okay
15:51:37 <dgilmore> anything else we should cover for s390?
15:51:56 <sharkcz> will ask you and nirik about some setting on the hub
15:52:01 <dgilmore> are we getting anywhere in discussions to drop 31 bit?
15:52:07 <dgilmore> okay
15:52:14 <dgilmore> which setting?
15:52:28 <nirik> I know there's a bunch of stuff pending we want to tweak on that ticket. Just haven't gotten to it...
15:52:47 <sharkcz> like hardlinking in the daily mashes don't work (and eat diskspace), setting kojira
15:52:49 <nirik> and also, if we are going to merge all arches to one koji, not sure how much work it's worth doing.
15:53:09 <dgilmore> sharkcz: hardlinking not working is know
15:53:13 <dgilmore> known
15:53:16 <sharkcz> ah
15:53:20 <pbrobinson> nirik: that I suspect will be a f25 task so likely worth while to some degree
15:53:25 <dgilmore> it will be fixed when we move to a newer process
15:53:36 <nirik> alright.
15:53:43 <sharkcz> and no new info about 31-bit
15:53:59 <dgilmore> sharkcz: whats the issue with kojira?
15:54:13 <sharkcz> I think new cert is needed
15:54:25 <dgilmore> should not be needed
15:54:36 <dgilmore> it should use the same kojira cert as primary
15:54:54 <sharkcz> ah, that should work
15:55:22 <sharkcz> so it's more about checking if it is set properly on the hub
15:56:33 <dgilmore> yeah
15:57:47 <dgilmore> #info need to make sure that the right kojira cert is in place
15:57:53 <dgilmore> anything else?
15:57:57 <sharkcz> nope
15:58:10 <dgilmore> #topic Secondary Architectures update - arm
15:58:19 <dgilmore> pbrobinson: you're up again
15:58:24 <pbrobinson> we're looking good here
15:58:35 <pbrobinson> we signed off on Beta last week
15:58:42 <pbrobinson> so we're good to go for tomorrow
15:59:04 <pbrobinson> builds wise we're pretty much up to date, a few stranglers
15:59:21 <dgilmore> excellent
15:59:33 <pbrobinson> I'm slowly looking through all the go packaging for secondary arches in general
16:00:23 <pbrobinson> looking at docker for it as well but there's also ongoing issues with virt in general with firmwares etc so it's lower down my overall priority list
16:00:30 <dgilmore> sounds like awesome fun
16:00:42 <dgilmore> go that is
16:00:52 <pbrobinson> no, it's not ;-)
16:01:11 <dgilmore> we still can not ship firmware in Fedora right?
16:01:20 <pbrobinson> correct
16:01:29 <dgilmore> the joys
16:01:39 <pbrobinson> we obviously don't need that for docker, but do for the image creation
16:01:48 <dgilmore> right
16:02:12 <dgilmore> I sometimes wonder what it would take to make docker images without the need for virt
16:02:30 <pbrobinson> possibly
16:02:36 <dgilmore> at the least you can use yum/dnf to make a tree you can import
16:02:47 <dgilmore> its more about the glue outside of making the tree
16:03:08 <pbrobinson> anyway, I'm looking at oz/imagefactory anyway so it's all in a similar pile to PPC
16:03:19 <dgilmore> cool
16:03:24 <dgilmore> anything else?
16:04:40 <pbrobinson> not from me
16:04:50 <dgilmore> #topic Open Floor
16:05:30 <dgilmore> I had something but its gone from my mind now
16:05:49 * nirik too
16:06:50 <nirik> Oh, I posted about bodhi2 update push stuff...
16:07:14 <nirik> short summary: bodhi1 was taking about 12-18 hours to push everything, bodhi2 takes 6 or so...
16:07:22 <pbrobinson> nirik: read it while pushing today, made good sense and a good overview
16:07:29 <dgilmore> nice
16:07:34 <maxamillion> tangentially related to the Two Week Atomic stuff, adamw got openQA tests going for the Atomic ISO installer https://openqa.happyassassin.net/tests/5248 (this isn't it's final resting place but I thought I'd mention it)
16:07:39 <nirik> pbrobinson: oh and btw, some of your stuff failed a bit ago. ;)
16:08:11 <adamw> maxamillion: note i've turned off the nightly run for now to save my bandwidth
16:08:23 <dgilmore> we really need to redesign the compose processes so that we do everything in one location and it is all public
16:08:32 <pbrobinson> nirik: where are the logs that I watch that?
16:08:35 <adamw> maxamillion: one of the patches needed to get it in the official openQA has been reviewed and accepted, the other is waiting on a needle that might need a small change
16:08:41 <tyll> btw. I do not yet have access to the F24 key, therefore there is no automatic signing running from me currently - should this be changed?
16:08:47 <maxamillion> adamw: totally fair, just having the one to show that it works is plenty for now
16:08:51 <maxamillion> adamw: awesome, thanks :)
16:09:12 <nirik> pbrobinson: systemd journal... 'sudo journalctl -u fedmsg-hub'
16:09:38 <nirik> tyll: I've been doing manual runs... so it should be somewhat up to date. I'd be ok with re-enabling autosign tho. ;)
16:11:21 <tyll> nirik: hehe, I read about it in your blog, therefore I wanted to ask :-)
16:11:46 <nirik> dgilmore: ok with granting f24 key access to tyll ?
16:11:54 <tyll> and is it useful to sign secondary rawhide as well or is there probably nobody checking signatures?
16:12:30 <nirik> well, can we keep up with primary even?
16:12:30 <dgilmore> nirik: he should already have it
16:12:39 <dgilmore> and just need to change his password
16:12:50 <tyll> nirik: are you signing secondary rawhide as well?
16:13:09 <nirik> tyll: I have not been... so likely they are way way behind
16:13:27 <tyll> nirik: iirc it worked more or less when it ran the last time - the simple one that just signs everything that is unsigned
16:13:34 <tyll> dgilmore: uh, ok, I will take a look
16:14:13 <dgilmore> the machine that I have setup for secondary arch sigul is currently powered off
16:15:12 <dgilmore> does anyone have anything else for open floor?
16:16:51 <dgilmore> ill take that as a no
16:16:57 <dgilmore> #endmeeting