15:00:12 <sgallagh> #startmeeting Server SIG Weekly Meeting (2015-10-27)
15:00:12 <zodbot> Meeting started Tue Oct 27 15:00:12 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:12 <sgallagh> #meetingname ServerSIG
15:00:12 <sgallagh> #chair sgallagh mizmo nirik stefw adamw simo danofsatx
15:00:12 <sgallagh> #topic roll call
15:00:12 <zodbot> The meeting name has been set to 'serversig'
15:00:12 <zodbot> Current chairs: adamw danofsatx mizmo nirik sgallagh simo stefw
15:00:19 <simo> .hello simo
15:00:21 <zodbot> simo: simo 'Simo Sorce' <ssorce@redhat.com>
15:00:29 <sgallagh> It's that time of the week, folks. Who's here?
15:00:32 <sgallagh> .hello sgallagh
15:00:33 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:00:38 <nirik> .hello kevin
15:00:39 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
15:01:00 * jds2001 is about
15:01:17 <danofsatx> .hello dmossor
15:01:18 <zodbot> danofsatx: dmossor 'Dan Mossor' <danofsatx@gmail.com>
15:02:07 <mizmo> .hello duffy
15:02:09 <zodbot> mizmo: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
15:02:18 <mhayden> .hello mhayden
15:02:18 <zodbot> mhayden: mhayden 'Major Hayden' <major@mhtx.net>
15:03:26 <danofsatx> oh, hay mhayden! We were just discussing you at UIW yesterday ;)
15:03:35 <stefw> .hello stefw
15:03:36 <zodbot> stefw: stefw 'Stef Walter' <stefw@redhat.com>
15:03:40 <mhayden> uh-oh, that can't be good
15:03:47 <danofsatx> ;)
15:04:26 <sgallagh> OK, let's get started.
15:04:33 <sgallagh> #topic Agenda
15:04:33 <sgallagh> #info Agenda Item: Empty WG Seats
15:04:33 <sgallagh> #info Agenda Item: Server/Cloud Interaction
15:05:22 <sgallagh> Any other items for the agenda today?
15:06:25 <sgallagh> OK, then.
15:06:29 <sgallagh> #topic Empty WG Seats
15:06:44 <sgallagh> As I assume everyone is aware by now, we have two open seats on the Server Working Group
15:06:54 <sgallagh> #info There are two open seats on the Server Working Group
15:07:10 <sgallagh> We have currently two candidates to fill them.
15:07:34 <sgallagh> #info Candidate: Major Hayden
15:07:34 <sgallagh> #info Candidate: Jon Stanley
15:07:46 * jds2001 waves
15:08:00 * nirik nods. :)
15:08:40 <sgallagh> Our governance charter requires that a majority of the remaining members must vote in the affirmative to grant them a seat.
15:09:00 <sgallagh> http://fedoraproject.org/wiki/Server/Governance_Charter
15:09:22 * nirik is +1 for both. Would be great to have them aboard.
15:09:38 * danofsatx longs for the days of hazing...
15:09:38 <sgallagh> I'll open the floor to interrogating the candidates if anyone wants to do so.
15:09:56 * mhayden wonders when the interrogation light comes on ;)
15:10:06 <simo> bzzzzoot
15:10:15 <jds2001> is there waterboarding involved? :D
15:10:16 <sgallagh> simo: Oops, that was the death-ray.
15:10:16 <dustymabe> mhayden: I would worry more about when the light goes off
15:10:32 <simo> sgallagh: hey they are all just the same led color on my uberpanel :)
15:10:34 <mhayden> dustymabe: mabe so, mabe not
15:10:39 <dustymabe> :)
15:10:46 <simo> anyway
15:11:09 <simo> q.1) Do you think you'll have enough time to dedicate to the SIG?
15:11:14 * danofsatx digs up the letters from the ml
15:11:37 <simo> q.2) Why do you think you'd be a good candidate ?
15:11:43 <simo> those are my q.s
15:12:08 <sgallagh> simo: I *think* 2) was covered by the introductory emails they sent to server@lists.fp.o, do you disagree?
15:12:09 <simo> mhayden: jds2001: feel free to respond with short answers
15:12:16 <jds2001> simo: my involvement is specifically approved by $DAYJOB, and it's precisely because of $DAYJOB that I'm an excellent candidate :)
15:12:25 <simo> sgallagh: just want to have a record here
15:12:28 <sgallagh> Sure
15:12:48 <mhayden> Q1) although i don't know the specific time commitments necessary for the role, some of these items are congruent with my $dayjob
15:13:04 <mhayden> and i seem to keep running more an more fedora servers/vm's at home :P
15:13:26 <jds2001> simo: being out in the trenches, architecting server solutions. I tend to be aware of what works and doesn't in the enterprise :D
15:13:44 <sgallagh> So, the time-commitment we hope for is this meeting plus at least a couple hours a week working towards our stated goals for the release.
15:14:09 <mhayden> Q2) although i run a fedora laptop, the majority of my fedora interactions are with servers, and i've build some products at work using fedora
15:14:29 <mhayden> and i enjoy working with other folks to make the community/products better
15:14:46 <mhayden> i'm told that i know how to ensure pain really well, too, since i'm on the security team :P
15:14:50 <sgallagh> Also, just to be clear: neither candidate's $DAYJOB resolves to "Red Hat".
15:15:05 <mhayden> yeah, full transparency, i work on OpenStack at Rackspace
15:15:09 <sgallagh> mhayden: "ensure" or "endure"? Both fits.
15:15:19 <mhayden> sgallagh: oops, s/ensure/endure/
15:15:38 * jds2001 works on cloud hosting architecture at Bank of America (mostly internal for now, based on openstack and propietary products)
15:15:55 * dustymabe waves a jds2001
15:16:01 <dustymabe> s/a/at
15:16:24 * jds2001 waves at dustymabe
15:16:41 <mhayden> dustymabe: put jds2001 down and stop waving him in the air :P
15:17:33 <sgallagh> Any other questions for our candidates? I think they're fairly well-known 'round these here parts
15:18:01 <simo> sgallagh: I do not have any other question
15:18:41 <sgallagh> OK, let's open the formal voting.
15:19:41 <simo> sgallagh: one candidate at a time or both at the same time ?
15:20:11 <sgallagh> Proposal: Major Hayden and Jon Stanley should be seated in the Server Working Group.
15:20:19 <sgallagh> +1 (Major) / +1 (Jon)
15:20:21 <danofsatx> seconded
15:20:32 <danofsatx> erm, +1 to both, even
15:20:48 <stefw> +1 and +1
15:21:00 <simo> +2
15:21:00 * danofsatx got mixed up with parlimentary proceedings
15:21:03 <mizmo> +1/+1
15:21:29 <nirik> +1/+1
15:22:43 <sgallagh> #agreed Major Hayden and Jon Stanley are seated in the Server Working Group (+6, 0, -0)
15:22:49 <sgallagh> Welcome aboard!
15:22:54 <sgallagh> #chair mhayden jds2001
15:22:55 <zodbot> Current chairs: adamw danofsatx jds2001 mhayden mizmo nirik sgallagh simo stefw
15:22:55 <mizmo> \o/
15:23:09 <nirik> welcome to the fun. ;)
15:23:12 <stefw> nice how that works
15:23:29 <mhayden> woo! :)
15:23:29 <sgallagh> Who wants to take care of the Wiki updates?
15:23:33 * mhayden high fives jds2001
15:23:34 <jds2001> where's the party? :D
15:23:41 * jds2001 high fives mhayden
15:23:50 <mhayden> okay so jds2001 and i talked and we feel like systemd is a bad idea, let's go back to upstart
15:23:53 * mhayden ducks
15:23:55 <mhayden> :P
15:24:02 * simo kicks mhayden
15:24:02 * jds2001 hides
15:24:16 <mhayden> how did i guess that simo would be first on that one :)
15:24:18 <sgallagh> #unchair mhayden
15:24:18 <zodbot> Current chairs: adamw danofsatx jds2001 mizmo nirik sgallagh simo stefw
15:24:21 <sgallagh> ;-)
15:24:24 <mhayden> oh burn
15:24:32 <sgallagh> #chair mhayden
15:24:32 <zodbot> Current chairs: adamw danofsatx jds2001 mhayden mizmo nirik sgallagh simo stefw
15:24:34 <simo> ouch
15:24:52 * simo disables SELinux on mhayden's computers
15:24:56 <mhayden> no!
15:25:11 <simo> I knew this would hurt more
15:25:18 <sgallagh> ok, so with that out of the way, let's move on.
15:25:21 <sgallagh> #info Agenda Item: Server/Cloud Interaction
15:25:22 <simo> ack
15:25:26 * jds2001 steals all of mhayden's 'setenforce 1' t-shirts :D
15:25:28 <sgallagh> #undo
15:25:28 <zodbot> Removing item from minutes: INFO by sgallagh at 15:25:21 : Agenda Item: Server/Cloud Interaction
15:25:31 <sgallagh> #topic Server/Cloud Interaction
15:25:49 <sgallagh> I asked dustymabe to join us today to represent the Cloud SIG
15:25:57 <simo> sgallagh: is this about using the server install for cloud images ?
15:25:59 <sgallagh> I understand he's splitting his attention, so we'll be kind.
15:26:03 <dustymabe> sgallagh: for the record mhayden is also "around" the cloud space quite a bit
15:26:18 <dustymabe> so having him in server will help interactions with cloud WG
15:26:24 <simo> ok guys who is *not* around the clud space ?
15:26:30 <sgallagh> I expect that to be true of both our new members
15:26:32 <mhayden> simo: the answer is cloudy
15:26:38 <simo> we have a winner
15:26:39 <sgallagh> mhayden: "nebulous"
15:26:56 <simo> but more seriopusly
15:27:00 <simo> err seriously
15:27:09 <danofsatx> I'm not...at least not yet.
15:27:13 <sgallagh> dustymabe, mhayden: Can either of you comment on the rumor that the traditional cloud image is going away?
15:27:22 <sgallagh> Because that's pretty central to this discussion
15:27:29 <simo> does this proposal mean we need to deliver the server product as a docker/rocket/whatever image as one of the deliverables ?
15:27:42 <mhayden> i don't think i've been privy to that whole discussion
15:27:43 <sgallagh> simo: There's no proposal at all yet.
15:28:06 <mizmo> i dont think the cloud image is going away
15:28:06 <dustymabe> sgallagh: the traditional cloud image is here to stay
15:28:10 <jds2001> simo: that would seem...odd...to me
15:28:18 <mizmo> but it's not going to be fedora cloud as an elevated edition of the 3 we have
15:28:19 <sgallagh> There has been some suggestion that we might supplant the traditional cloud image as our AMI/etc. offering
15:28:23 <mizmo> rather it'll be an alternative download
15:28:26 <mizmo> on alt.fpo
15:28:26 <dustymabe> the idea is that the focus of the WG will be more on Atomic Host
15:28:40 <mizmo> kind of like the minimal image
15:28:41 <dustymabe> and our promotions will be more around that
15:28:51 <mizmo> where the minimal image exists, but it's not featured
15:29:05 <dustymabe> but the traditional cloud image is still there and will be there to stay if I have anything to do with it
15:29:10 <jds2001> mizmo: do we still upload AMI's of it?
15:29:16 <mizmo> jds2001, i think so
15:29:18 <dustymabe> jds2001: yes
15:29:20 <jds2001> or what is the "official" AMI that's featured?
15:29:29 <sgallagh> I was asked a while back by mattdm whether it would make sense for Server to provide a more mainstream choice for people looking through Amazon images.
15:29:57 <simo> well I thought fedora server could become the "base image"
15:30:00 <sgallagh> So someone looking for "Fedora-but-not-Atomic" would still have a target.
15:30:11 <jds2001> sgallagh: i thought that the server product was more for pets than catlle
15:30:17 <simo> but I guess I misunderstood what it means for cloud to concentrate on atomic
15:30:17 <sgallagh> simo: Well, Server might be heavyweight for that use-case.
15:30:30 <simo> sgallagh: minimal install server of course
15:30:33 <sgallagh> jds2001: It is; but that doesn't mean there are no pets in the public cloud
15:30:40 <sgallagh> man, way too many negatives in that sentence
15:30:45 * mattdm parachutes in
15:30:51 <sgallagh> simo: minimal-install isn't *really* Server.
15:30:55 <simo> ok
15:30:59 <mattdm> Yeah — story would be cattle? atomic! pets? server!
15:31:42 <dustymabe> mattdm: what about cattle that aren't containerized?
15:31:59 <sgallagh> dustymabe: They're roaming and you need to get the dogs out looking for them
15:32:04 <sgallagh> *rimshot*
15:32:06 * nirik has not too many complaints with the current cloud image. Not sure what would be changed
15:32:07 <mattdm> sgallagh++
15:32:08 <zodbot> mattdm: Karma for sgallagh changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:32:26 <mattdm> dustymabe: you could really still do them on top of the server image
15:32:32 <mattdm> #link https://fedorahosted.org/cloud/ticket/127
15:32:39 <dustymabe> nirik: you should stop by our meeting on wednesdays, I'd like to hear them
15:32:48 <mattdm> maybe pets v cattle isn't the best way to make the distinction, really
15:32:51 <jds2001> mattdm: server is a bit heavy, no?
15:32:59 <nirik> mostly things that have already sailed I fear... like disable root, etc.
15:33:13 <nirik> server is going to be a lot larger than cloud
15:33:32 <dustymabe> nirik: you can't log in as root on a cloud image unless you tell cloud-init you want to
15:33:47 <nirik> I well know it. ;)
15:33:47 <mattdm> jds2001: maybe. keeping the cloud base minimal is a continual fight, and one not really well resourced
15:34:07 <stefw> given the above points, i worry that we'll end up having to carry two versions of server ... instead of cloud carrying two versions
15:34:12 <dustymabe> mattdm: I won't argue with you that the cloud group could use more resources
15:34:42 <dustymabe> my $job isn't even to work on cloud
15:34:50 <sgallagh> If we opt to build Server AMIs, I'd want them to be identical to Server on bare-metal except possibly for kernel drivers and cloud-init
15:34:54 <mattdm> How big is the server mimimal?
15:35:01 <mattdm> sgallagh +1
15:35:13 <sgallagh> mattdm: Do you mean "server default"?
15:35:22 <mattdm> sgallagh: sure :)
15:35:24 <sgallagh> Because we have a "minimal install" option, but it's not branded Server
15:35:41 <mizmo> we have a minimal image, a cloud image, a server image
15:35:42 <nirik> it sounds like really people want to merge server and cloud and form a new 'atomic/container/new tech' working group?
15:36:07 <simo> sgallagh: so the AIM is just to provide a normal server image that can be easily installed on existing public/private infrastructures ?
15:36:09 <sgallagh> nirik: It does sound rather like that to me as well
15:36:11 <mattdm> nirik: hmmmm.
15:36:24 <dustymabe> sgallagh: nirik
15:36:25 <mattdm> I think that's a good idea only if server goes all-in on atomic.
15:36:25 <sgallagh> simo: That's what *I'm* thinking. I don't know if it agrees with everyone else :)
15:36:31 <dustymabe> I don't know about that
15:36:39 <simo> well that's why I am asking
15:36:59 <simo> so back a second, who came up with the original cloudy idea ?
15:37:12 <mattdm> simo which one when?
15:37:17 <nirik> well, it would be odd to me to have a "cloud working group" and the cloud images are all done by the "server working group"... but perhaps thats just me
15:37:18 <mattdm> how far are we backing? :)
15:37:24 <simo> to ask server to do something with cloud images
15:38:10 <jds2001> mattdm: i dont think what nirik meant was to change anything but names of the two wg's
15:38:11 <mattdm> nirik -- In _my_ picture, Cloud SIG would still exist and help with cloud guest images of all sorts
15:38:12 <adamw> morning
15:38:21 * roshi shows up
15:38:21 <mattdm> but Cloud WG would become Atomic WG
15:38:36 <jds2001> i.e. not actually merge server and cloud, but have server concentrate on both, and the existing cloud wg focus on atomic/containers/etc
15:38:40 * roshi reads backscroll
15:38:47 <nirik> right.
15:38:47 <dustymabe> hmmm
15:39:02 <mattdm> possibly with a new mailing list to avoid confusion
15:39:12 * mattdm regrets keeping Workstation on desktop mailing list
15:39:18 <sgallagh> So essentially drop the "Cloud" name entirely and focus on solutions based on use-case rather than environmnet
15:39:23 <mattdm> sgallagh++
15:39:25 <mattdm> sgallagh++
15:39:27 <mattdm> sgallagh++
15:39:29 <mattdm> sgallagh++
15:39:31 <mattdm> sgallagh++
15:39:33 <mattdm> sgallagh++
15:39:36 <sgallagh> mattdm: Uh... thanks?
15:40:27 <mattdm> (I'm in favor.)
15:40:27 <jds2001> but does the amount of our deliverables increase? I'm thinking it has to....
15:40:32 <dustymabe> sure.. but I think there should still be a cloud wg that is at least partly focused on the minimal cloud image like it is delivered today
15:40:59 <sgallagh> dustymabe: Well, we don't need a WG for anything that we aren't considering a top-level deliverable of the Fedora Project.
15:41:01 <dustymabe> I don't think merging server with cloud makes sense.. I think we care about different things
15:41:07 <sgallagh> We have spin SIGs for that.
15:41:19 <sgallagh> Which is (I think) what the minimal cloud image would become, essentially
15:41:38 <dustymabe> why?
15:41:41 <roshi> that's a lot to read
15:42:04 <dustymabe> so what you are saying is that the server delivered cloud image is now more important than the minimal cloud image we have been delivering?
15:42:26 <mattdm> dustymabe: I would suggest that yes, we should promote it that way
15:42:40 <mattdm> Because we don't have a great marketing story for the minimal cloud image
15:43:08 <dustymabe> I don't disagree that we don't have a good marketing story
15:43:25 <dustymabe> but that doesn't make it the right thing to do
15:43:34 <dustymabe> I guess I need to think about this more
15:43:41 <mattdm> dustymabe: thinking is fair :)
15:43:45 <dustymabe> it's just odd to me
15:43:53 <sgallagh> dustymabe: Yeah, no one is prepared to make a binding decision today, I don't think
15:44:11 <mattdm> dustymabe: minimal cloud image would become something more like KDE
15:44:13 <dustymabe> i've been at companies that use cloud images a lot and the minimal image is what they used to "build" off of
15:44:32 <mattdm> yeah, we do want to have it available and discoverable for people who know they want that
15:44:32 <dustymabe> to build their cattle
15:44:47 <roshi> to me too, this isn't in the ball park of what I had in mind - so I need to think about it as well
15:44:50 * nirik uses the cloud images all the time.
15:44:55 <dustymabe> but I thought promoting "pets" in pub cloud was a bad thing though
15:44:57 <sgallagh> But are they using Fedora for that or are they using CentOS/Ubuntu/whatever>
15:45:08 <dustymabe> and you are saying that is what we should do
15:45:25 <mattdm> (other than nirik)
15:45:43 <nirik> we are definitely using the fedora cloud images in our openstack. ;)
15:45:51 <mattdm> well, server isn't -necessarily- pets, _really_
15:45:59 <sgallagh> mattdm: I feel like this might be a candidate for a Council slot where we gather representatives from the Cloud and Server SIGs to discuss this in a high-bandwidth mode.
15:46:04 <dustymabe> nirik: and ould you prefer to use a "server" cloud image?
15:46:10 <mattdm> sgallagh yes good idea
15:46:39 <mattdm> nirik, dustymabe What if there were Server roles for 90% of what you wanted to do?
15:46:43 <simo> dustymabe: I do not think the name really is important
15:46:50 * jds2001 thinks that the option of that is valuable
15:46:59 <simo> I think what matters is: how different is this image from the default server install ?
15:47:04 <nirik> dustymabe: not really.
15:47:10 <simo> and is this soemthing the server WG can take on reasonably well
15:47:10 <nirik> mattdm: I would be pretty amazed. ;)
15:47:15 <sgallagh> simo: Well, that and "is it worth expending the effort to produce it"?
15:47:25 <simo> what are the resources we have to handle it ? (whatever thet "it" turns out to be
15:47:39 <simo> sgallagh: it seem there are quite a few users
15:47:55 <simo> so I gather it would be worth (let's assume it is for the sake of conversation)
15:48:35 <nirik> testing, making sure it stays small and pruning deps, etc
15:48:40 <mattdm> nirik: We should amaze people :)
15:48:43 <dustymabe> it's just going to be hard to convince someone that server is better for them when they already know what they want to do and how to do it
15:48:55 <sgallagh> nirik: In general, we should be pruning deps in Server as well, wherever possible.
15:48:56 <dustymabe> and they just want a minimal image..
15:49:07 <nirik> mattdm: often our cloud instances are dev for some new thing someone is working on, so it would be unlikely there would be a role for a thing that doesn't yet exist
15:49:12 <dustymabe> which I would argue people that do cloud right already know
15:49:14 <sgallagh> If we're building a cloud image, it just becomes more obvious
15:49:49 <mattdm> dustymabe: my argument is that those people will be able to find it. They don't need to be told any more than that it exists and where to get it
15:49:49 <roshi> dustymabe: right
15:49:53 <dustymabe> I don't mind the server group building a cloud image.. that is fine.. but I don't like the traditional cloud image getting minimized as a result
15:49:56 <nirik> if I wanted to deploy something that we have a role for then yeah, the server image and rokekit might be a good fit... but you can always install that on top.
15:49:59 <mattdm> it is akin to https://arm.fedoraproject.org/
15:50:15 <dustymabe> nirik++
15:50:15 <zodbot> dustymabe: Karma for kevin changed to 4 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:50:38 <dustymabe> which means that a good path from cloud minimal to server might be a good idea?
15:50:46 <mattdm> nirik: I'd like to see it get to the point where roles cover enough that people look there first, and then second, consider contributing a role if one is missing
15:50:51 <dustymabe> that could happen on instance instantiation
15:50:58 <sgallagh> dustymabe: Well, here's the other part. When one installs Server, they're not just getting an OS. We're working to assure that they're getting a known platform.
15:51:13 <mattdm> dustymabe: note that we do have https://fedoraproject.org/wiki/Changes/Convert_Fedora_Cloud_Image_to_Fedora_Server
15:51:20 <sgallagh> Sure, they can mix and match whatever packages they want, but the aim is for the default Server install to be a known quantity.
15:51:38 <dustymabe> sgallagh: so make a cloud image
15:51:48 <mattdm> dustymabe: I think you've convinced me that we shouldn't _drop_ Cloud Base in favor of the Server image
15:52:05 <dustymabe> sorry guys. I don't mean to be difficult
15:52:06 <roshi> we've got at least two scripts for converting cloud to server, one bash and one python
15:52:17 <adamw> choice!
15:52:29 <mattdm> dustymabe: no no. difficult is good
15:52:29 <simo> I am still confused about what are the goals and deliverables
15:52:31 <simo> call me thick
15:52:38 <sgallagh> simo: You're thick :-P
15:52:41 <mattdm> thick is less good :) :) :)
15:52:48 <mattdm> .fire adamw
15:52:48 <zodbot> adamw fires adamw
15:52:52 <danofsatx> cloud-to-server is the python one, innit?
15:53:06 <simo> what's the use case of cloud-to-server ?
15:53:19 <jds2001> .fire adamw for showing up late
15:53:19 <zodbot> adamw fires adamw for showing up late
15:53:23 <sgallagh> simo: Promote the cloud base image to something that provides the Server platform
15:53:28 <adamw> does that mean I can go home now?
15:53:30 <mattdm> simo: current easy way to get Server in EC2.
15:53:31 <nirik> simo: you want to deploy something that has a role ?
15:53:34 <roshi> yeah, and I rewrote it in bash since there was talk of removing python from the cloud base image
15:53:40 * roshi should probably test it
15:53:40 <sgallagh> So I suppose we could take that over.
15:53:42 <simo> sgallagh: that's what it does not what is the use case :)
15:53:47 <danofsatx> my use case was: deploy VMs using cloud image because it was faster, convert to server for more traditional management
15:54:11 <roshi> yeah, that ^^
15:54:17 <simo> nirik: why wouldn't I just install an image built by a server install ?
15:54:30 <mattdm> danofsatx: is that actually _net_ faster?
15:54:36 <mattdm> simo: because we don't have one? :)
15:54:43 <nirik> simo: is there one that has cloud-init and partitioning, etc?
15:54:44 <simo> meh
15:54:49 <sgallagh> simo: Sorry, can you clarify what you mean by "an image built by a server install"?
15:54:59 * mattdm runs off to get a flu shot
15:55:08 <nirik> sure you could make your own, but thats like work...
15:55:10 <roshi> another usecase: I spin up a droplet on Digital Ocean (which is a cloud base image), and turn that into a server since it's more of a pet for me than cattle
15:55:14 <danofsatx> mattdm: yes, in my particular corner case, spinning up cloud image and running cloud-to-server was faster than installing via Server DVD.
15:55:32 <adamw> danofsatx: why not just use virt-install or something?
15:55:38 <mattdm> danofsatx: *nod*, but if there was a server image to start with, that've been faster total
15:55:39 <dustymabe> yeah. so there would be value in having a server cloud image in some cases
15:55:40 <dustymabe> I agree
15:55:42 * mattdm really runs off
15:55:50 <danofsatx> adamw: 'cuz I was a noob
15:55:56 <nirik> perhaps we should see what all the differences really are?
15:56:01 <dustymabe> but I don't think it would be better than the cloud minimal image
15:56:01 <danofsatx> mattdm: (now that you're gone) yes, probably
15:56:05 <dustymabe> for most use cases
15:56:07 <nirik> perhaps we could conditionalize them so it would work either way?
15:56:12 <sgallagh> Ironically-enough, I'm starting to reduce my sense that this is valuable (vs. enhancing the promotion script)
15:56:20 <simo> ok
15:56:21 <nirik> (ie, run cloud-init only if it's a cloud, etc)
15:56:32 <simo> seem we are still all thinking about this
15:56:40 <simo> and we are not going to take a decision in the next 5 minutes
15:56:44 <sgallagh> Right, there's definitely no decision to be made today.
15:56:47 * nirik nods.
15:56:50 <nirik> lots to mull over
15:56:51 <dustymabe> sgallagh: enhancing the script that does the conversion?
15:56:55 <simo> so what about someone with an interest puts down a proposal ?
15:57:04 <sgallagh> dustymabe: Perhaps s/enhancing/maintaining better/
15:57:09 <simo> I would like to have at least 2 proposal from 2 people that have different ideas
15:57:11 <dustymabe> sgallagh++
15:57:11 <zodbot> dustymabe: Karma for sgallagh changed to 2 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:57:12 <sgallagh> But yes, that's what I meant
15:57:33 <simo> the proposal would explain what are the deliverables with enough detail to understand what we are talking about
15:57:35 <dustymabe> that would be my vote.. and making it really easy for someone to start a cloud minimal image and end up with "server" and apply a role
15:57:45 <dustymabe> boom*
15:57:53 <dustymabe> that's what the minimal image is all about
15:57:59 <dustymabe> being able to be molded into other things
15:58:07 <dustymabe> but nothing that you don't want
15:58:12 <sgallagh> dustymabe: Hey, thanks. You just kicked me into position 4 on the badges leaderboard :-D
15:58:21 <simo> sounds like a minimal install in form of an image that can be easily started on a cloud infrastructure
15:58:24 <dustymabe> :)
15:58:30 <simo> ie minimal-install + cloud-init
15:58:41 <simo> is there anything more than that to this base image ?
15:58:50 * jds2001 will make a detailed proposal later, but I think that a server based image makes sense
15:59:15 <jds2001> perhaps as something discoverable, but not promoted as our primary cloud image (that would be the existing miniaml image)
15:59:15 <simo> ok
15:59:23 <dustymabe> jds2001: that would be fine too!
15:59:29 <sgallagh> simo: I think that's what we were discussing: does it make sense to just help the base image convert to Server post-install?
15:59:33 <dustymabe> we could even promote it as an option if we wanted..
15:59:49 <dustymabe> I just don't think it makes sense to have it be "The" cloud thing we offer
16:00:07 <sgallagh> dustymabe: Well, it made more sense when I was hearing that the base image was being abandoned :)
16:00:10 <dustymabe> as traditionally cloud images have been minimal and that would be unexpected
16:00:14 <roshi> so, what's the timeline here? We've got a release to get out the door
16:00:15 <jds2001> dustymabe: who is going to maintain that existing image?
16:00:25 <sgallagh> roshi: All of this is F24 discussion
16:00:27 <dustymabe> jds2001: the cloud working group
16:00:40 <dustymabe> it's not our focus but it is still ours
16:00:42 <roshi> sgallagh: I mean for the proposals?
16:00:49 <jds2001> dustymabe: that works. so long as it's not abandonware
16:01:01 <dustymabe> jds2001: nope.. and we'd love to have more people in the CLOUD WG
16:01:05 <sgallagh> roshi: I'd say at least 3 weeks before Alpha Freeze, personally
16:01:12 <roshi> dustymabe and I can sync up and then take it to the cloud WG
16:01:56 <dustymabe> roshi: thanks
16:02:07 <dustymabe> sgallagh: feel free to hit me up anytime you want to chat about this
16:02:12 <roshi> np - does that sound like a good plan?
16:02:23 <sgallagh> /me nods
16:02:39 <roshi> once we have something (we'll come up with one of the proposals simo wants) we'll ping you guys and have a joint meeting
16:02:40 <sgallagh> Shall we continue this discussion on the server@ list, the cloud@ list or other?
16:02:45 <roshi> or go to the council or whatever
16:02:59 * dustymabe might have to go to council for the first time
16:03:01 * roshi probably needs to subscribe to the server list
16:03:13 <dustymabe> like a pilgrimage
16:04:00 <sgallagh> heh
16:04:00 <roshi> lol
16:04:10 <sgallagh> OK, I'm going to close out the meeting unless there's anything urgent.
16:04:52 <dustymabe> sounds good
16:05:08 * roshi doesn't have anything
16:05:08 * nirik nods.
16:05:31 * simo waves
16:05:37 * jds2001 waves
16:05:55 <sgallagh> #action roshi and dustymabe will discuss the Cloud/Server images and come back with a proposal.
16:05:58 * danofsatx wanders back to the cover letter
16:06:00 <sgallagh> #endmeeting