16:00:22 <sgallagh> #startmeeting Server SIG Weekly Meeting (2015-11-17)
16:00:22 <zodbot> Meeting started Tue Nov 17 16:00:22 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:22 <sgallagh> #meetingname ServerSIG
16:00:22 <zodbot> The meeting name has been set to 'serversig'
16:00:22 <sgallagh> #chair sgallagh mizmo nirik stefw adamw simo danofsatx mhayden jds2001
16:00:22 <sgallagh> #topic roll call
16:00:22 <zodbot> Current chairs: adamw danofsatx jds2001 mhayden mizmo nirik sgallagh simo stefw
16:00:25 <sgallagh> .hello sgallagh
16:00:26 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:00:36 <jds2001> .hello jstanley
16:00:36 <adamw> morning
16:00:36 <zodbot> jds2001: jstanley 'Jon Stanley' <jonstanley@gmail.com>
16:00:38 <adamw> .hello adamwill
16:00:40 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
16:00:52 <nirik> .hello kevin
16:00:53 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
16:02:03 <stefw> .hello stefw
16:02:04 <zodbot> stefw: stefw 'Stef Walter' <stefw@redhat.com>
16:02:10 <mizmo-wfh> .hello duffy
16:02:11 <zodbot> mizmo-wfh: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
16:02:51 <sgallagh> #topic Agenda
16:03:07 <sgallagh> Sorry for not sending out the agenda before the meeting.
16:03:14 <sgallagh> The only topic I have is:
16:03:30 <sgallagh> #info Agenda Item: Reducing the size of the default install
16:03:49 <sgallagh> (See the thread I started on devel@ for an overview)
16:04:26 <sgallagh> Anyone else have topics they would like to see discussed today?
16:04:27 <simo> .hello simo
16:04:28 <zodbot> simo: simo 'Simo Sorce' <ssorce@redhat.com>
16:05:48 <sgallagh> OK, then let's get started.
16:05:57 <sgallagh> #topic Reducing the size of the default install
16:06:27 <sgallagh> #info "Size" is defined both as disk space and software attack surface
16:06:46 <nirik> I think this is a good idea, but will just take work... not sure how much/what else we can do here.
16:07:04 <sgallagh> I spent most of yesterday digging into what were some of the trouble spots
16:07:39 <sgallagh> Initially, I wanted to see what the diff between minimal and Server was, to see if we can largely eliminate the need for them to be separate concepts
16:07:42 <jds2001> sgallagh: saw your mail. the glibc locale archive has always stuck out like a sore thumb
16:08:01 <simo> why is the locale archive so huge ?
16:08:03 <sgallagh> While doing so, it also became apparent that the minimal install is also overlarge
16:08:29 <jds2001> sgallagh: compared to what?
16:08:57 <sgallagh> I'd hazard a guess it has something to do with unicode, but I'm basing that on the fact that libicu is another extremely large package
16:09:42 <sgallagh> jds2001: Good question. I don't have a good reference point, but "almost 800MB" doesn't say "minimal" to me.
16:09:56 <stefw> yup
16:10:10 <simo> sgallagh: what would be "minimal" ?
16:10:27 <simo> 400M? 80M? .. ?
16:10:34 <sgallagh> simo: In my ideal world, it would be little more than the early boot process plus init
16:10:41 <stefw> sgallagh, do you have any data on which package "groups" are leaves, and have dependencies on unique things nothing else depends on?
16:10:48 <adamw> sgallagh: why, when you were young, a whole operating system could fit onto a floppy disk! and also, there were floppy disks. and all this was fields.
16:10:49 <sgallagh> With Server becoming then the minimal useful set
16:11:16 <sgallagh> stefw: Not yet; I'm trying to figure out how to actually get that data
16:11:24 <sgallagh> Working with the RPM database is... non-trivial
16:11:55 <sgallagh> adamw: When I was young, several operating systems would fit on a single floppy disk
16:11:56 <mizmo-wfh> sgallagh, i dont know that minimal and server could be the same, i do think theres different use cases there
16:12:12 <sgallagh> mizmo-wfh: Perhaps I misspoke
16:12:19 <simo> sgallagh: what do you expect to be able to do with a minimal install ?
16:12:39 <sgallagh> I meant that "minimal" should really just be "Base WG output" and the core building block for Editions and Spins and not expected to be useful on its own
16:12:50 <sgallagh> And Server should be the minimal *useful* ste.
16:12:53 <sgallagh> *set
16:12:59 <mizmo-wfh> ah okay
16:13:00 <sgallagh> simo: Build a spin.
16:13:04 <mizmo-wfh> two different types of minimal :)
16:13:05 <jds2001> what counts as useful?
16:13:39 <adamw> that still doesn't work for me
16:13:52 <sgallagh> Yeah, words are hard
16:13:54 <adamw> same problem as last week: we want Cockpit in Server, right? but that doesn't mean it's part of the 'minimal useful set'
16:13:56 <simo> sgallagh: so minimal would be unusable ?
16:13:58 <adamw> i think it's not just words
16:13:59 <jds2001> what is useful to me is different that what's useful to you :)
16:14:10 <simo> if you install it you get soemthing broken ?
16:14:11 <sgallagh> jds2001: Sure.
16:14:13 <stefw> minimal should boot and be able to log in
16:14:15 <stefw> that's it
16:14:19 <stefw> anything else is installed on top of it
16:14:23 <adamw> i think that while the concept behind the current 'minimal' install is very vague and hard to nail down, it's actually something people want
16:14:26 <sgallagh> Let's start with a reminder of the Server Edition goal:
16:14:31 <simo> stefw: so let me try to be more proactive rather than inquisitive
16:14:46 <sgallagh> It should provide a defined platform that is useful to the Personas we defined during the PRD process
16:14:52 <simo> should it be: kernel, boot, init, shell, rpm, dnf, and basic editor ?
16:14:59 <simo> should it have networking support ?
16:15:02 <sgallagh> It is not expected to be the pre-Fedora.next build-your-own-OS
16:15:08 <adamw> we have this very fuzzed shared concept of 'all the bits that people kinda expect to be there' and that's what minimal is
16:15:15 <stefw> simo, minimal should be accessible over the network, yes
16:15:32 <simo> so add in there network stack
16:15:38 <sgallagh> adamw: That's kind of why I want us to consider dropping the "minimal" environment group entirely
16:15:58 <simo> should it have things like cron, ssh, name-your-own ?
16:15:59 <sgallagh> stefw: Actually, I disagree :)
16:16:07 <adamw> sgallagh: wait, which bit is the reason?
16:16:17 <jds2001> sgallagh: there are folks out there that could care less about cockpit, realmd, rolekit, ...
16:16:27 <sgallagh> adamw: Nearly all of this conversation, but I was replying to your last statement before that
16:16:40 <jds2001> but in my mind, those things are minimally useful to what we've defined the server product to be.
16:16:43 <mizmo-wfh> jds2001, wouldn't they go with a minimal version instead of server tho?
16:16:46 <simo> jds2001: I do not think cockpit, realmd, rolekit belonmd in minimal
16:16:51 <simo> but they belong to server
16:16:54 <stefw> exactly
16:17:15 <sgallagh> jds2001: So, the thing we have to get away with  (in my mind) is the idea that it is our responsibility to continue to solve every situation that Fedora used to solve.
16:17:28 <simo> sgallagh: it seem to me minimal should be functional enough that you can install other stuff
16:17:33 <sgallagh> We still have kickstart installs and spins for people who want to just roll entirely their own set of packages.
16:17:40 <simo> so I would say ssh, editor and network stack are needed
16:18:01 <simo> bu not other daemon, not even cron (although that is being swallowed by the ever powerful systemd anyway
16:18:23 <sgallagh> Let's take a step back; we pretty much decided last week that the "minimal install" group is not something we feel the Server WG should decide upon, right?
16:18:35 <simo> sgallagh: yes and no
16:18:48 <simo> IIRC Base WG didn't want to do minimal
16:19:01 <simo> and we need to define what minimal is if we want to build Server on top of it
16:19:05 <simo> at least to some degree
16:19:22 <sgallagh> simo: If Base WG isn't doing their job, then we have to work around them.
16:19:48 <sgallagh> For now, I'm comfortable with us just deciding what makes sense for Server and then retrofitting if Base ever provides something useful
16:19:57 <jds2001> what does the Base WG *do*, if not define the base?
16:20:03 <jds2001> ^^ serious question
16:20:20 <sgallagh> jds2001: That *is* their charter. Their follow-through has been lacking.
16:20:33 <sgallagh> I think it's mostly due to their getting caught up in this same circular argument.
16:20:38 <sgallagh> (That we were just having)
16:20:44 <adamw> is the problem you want to solve here in fact more '@fedora-server has to be built on @base' than 'we need to fix the 'minimal' install'?
16:21:11 <sgallagh> Mostly because no one can agree on whether Base is 1) installable or just a set of requirements and 2) self-hosted
16:21:48 <sgallagh> adamw: The problem I want to solve here is really only the contents of the Server default install
16:22:17 <sgallagh> Unfortunately, I phrased that in terms of my comparisons with the "minimal" install, which I'm increasingly seeing as a distraction.,
16:23:13 <sgallagh> Since the minimal install really isn't what anyone would call minimal and isn't really directly relevant to us anyway.
16:23:23 <jds2001> sgallagh: sort of. We have to solve @base bloat, and as a follow-on, @fedora-server bloat.
16:23:35 <sgallagh> (Except to decide whether to drop the minimal env group so it doesn't show up in anaconda as an installable option)
16:24:18 <sgallagh> jds2001: I was actually looking at it in reverse, initially
16:24:31 <sgallagh> Reduce the delta from "minimal" to Server first, then move down the stack
16:24:42 <sgallagh> Because right now, it's a perception problem
16:24:55 <mizmo-wfh> server gets the brunt of the perception prob
16:25:01 <sgallagh> People don't choose Server because the delta from "minimal" (even if that really isn't minimal) is large
16:25:53 <jds2001> sgallagh: that makes sense too
16:25:54 <sgallagh> If we start from the base definition, we probably won't impact the *diff* between them significantly and the perception problem will remain
16:26:55 <sgallagh> I have two points that I think we can address on that front, one I want to direct at simo and the other at stefw
16:27:06 <adamw> right, i think the smart thing to do is work on the low-hanging fruit first: stuff that can be done without controversy
16:27:22 <adamw> stuff in Server itself, and then stuff that's pure 'bloat' - unnecessary dependencies and maybe really old crap
16:27:37 <sgallagh> adamw++
16:27:37 <zodbot> sgallagh: Karma for adamwill changed to 5 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:28:00 <adamw> once that's trimmed down, *then* you can get into the more awkward stuff which involves the questions of the multiple personalities of @core
16:28:02 <adamw> er, @base .
16:28:05 <adamw> er, whichever it's called.
16:28:07 <sgallagh> The first and most obvious question I have is for simo: What is the status of Python 3 support in Samba and FreeIPA?
16:28:32 <sgallagh> Because freeipa-client and samba-common-tools are currently the only packages we explicitly require in the default install that pulls in the Python 2 stack
16:28:45 <sgallagh> Killing off the whole py2 stack would be a big win
16:28:55 <adamw> sgallagh: well, except you still need it for ansible :/
16:29:04 <adamw> but for non-ansible folks it's good.
16:29:07 <sgallagh> ...
16:29:49 <sgallagh> adamw: I could see a *strong* argument for making that an Optional component (included on the DVD, but not installed by default) and creating an @ansible-agents group
16:30:04 <adamw> that's probably useful throughout the distro, yeah
16:30:17 <nirik> that might be handy... well, agents doesn't sound right... but sure.
16:30:56 <adamw> hell, we could knock that out in like 15 minutes.
16:31:01 <nirik> "legacy python2 support" or something.
16:31:02 <sgallagh> nirik: Well, I was trying to cover the case where we also might include ansible modules in that group
16:31:23 <sgallagh> nirik: No, I was thinking *specifically* about a group for ansible use-cases.
16:31:38 <sgallagh> "Legacy python 2" is more complicated (IMHO)
16:31:54 <nirik> well, really you just want python2 and python-dnf
16:32:10 <sgallagh> nirik: Today, sure.
16:32:11 <jds2001> sgallagh: are you interpreting legacy python2 to be all modules or something?
16:32:18 <nirik> then people can install whatever they like.
16:32:22 * jds2001 just sees it as core python2 runtime
16:32:24 <sgallagh> jds2001: I'm explicitly trying *not* to interpret it
16:32:52 <sgallagh> nirik: I'd rather have something in Anaconda that can read "Support for managing the system via ansible"
16:32:53 <adamw> yeah, i like the idea of a purpose-based group better.
16:33:08 <sgallagh> If under the hood, that's just python-dnf, that's irrelevant to the user
16:34:03 * nirik doesn't much care what it's called.
16:34:38 <simo> sgallagh: python 3 support is moving, but it is a hard road
16:34:42 <sgallagh> I prefer the purpose-based groups because it will also leave us an easier path to changing out the pieces if that becomes necessary
16:34:50 <simo> sgallagh: as you have seen the dependencies are quite a lot
16:34:55 <sgallagh> simo: Yeah, it's enormous.
16:35:08 <stefw> doesn't rolekit install the packages you need?
16:35:13 <sgallagh> So that leads me to the other option for getting rid of Python 2
16:35:13 <mizmo-wfh> purpose-based groups++ (fwiw :) )
16:35:16 <stefw> why would freeipa be in the default install?
16:35:23 <sgallagh> stefw: We ship with the freeipa-client installed by default
16:35:26 <jds2001> stefw: so you can join a domain
16:35:30 <sgallagh> As well as samba tools
16:35:35 <stefw> realmd (like rolekit) installs the packages you need
16:35:44 <stefw> including freeipa-client
16:35:45 <sgallagh> jds2001, stefw: That's actually where I was going
16:36:16 <jds2001> sgallagh: with easier roles, we dont really need a ton of stuff installed by default
16:36:33 <sgallagh> We originally decided that it was best to include the domain-client components in the default install to address cases where someone might want to join a domain during install/first-boot without having external network access
16:36:35 <jds2001> sgallagh: what's the status of mere mortals like me being able to make roles?
16:36:49 <sgallagh> jds2001: ETA 2 months
16:37:14 <simo> sgallagh: they can be on the DVD but not installed by default
16:37:21 <simo> they would still be accessible w/o network
16:37:23 <sgallagh> Right, that was the suggestion I was just about to make
16:37:32 <simo> but this is a installed vs DVD thing
16:37:32 <sgallagh> However, we still have samba to contend with
16:37:40 <simo> doesn;t really do anything to reduce the DVD image size
16:37:47 <simo> but it may change the installed size
16:37:49 <sgallagh> simo: I don't care much about the DVD size
16:37:59 <simo> sgallagh: why do you need samba by default ?
16:38:00 <sgallagh> (Provided it remains under 4GB, of course)
16:38:07 <sgallagh> simo: That was my next question :)
16:38:23 <simo> probably a dependency coming from sssd ?
16:38:44 <sgallagh> simo: Well, some of the libs are, but we can avoid that by having sssd installed by realmd
16:38:49 <sgallagh> Rather than by default.
16:39:08 <sgallagh> But I *think* we opted to have the samba client installed by default for convenience.
16:39:18 <sgallagh> I no longer remember the justification, however
16:39:29 <simo> sgallagh: we are going toward a sssd managing local accounts eventually
16:39:30 <simo> so default
16:39:48 <simo> but we can split packaging so that "network" modules can be installed on demand I guess
16:40:05 <sgallagh> simo: I'm aware, but as that day is not yet here and is unlikely to beat Python 3 support in, I'm disregarding it for the purposes of this discussion
16:40:39 <simo> anyway we can simply change packaging to not drag in samba if it is a big problem
16:40:40 <sgallagh> simo: And I doubt we can actually split packaging like that anyway.
16:40:53 <simo> (or to drag in a much smaller package with just libs or something
16:40:55 <adamw> http://paste.fedoraproject.org/291483/78446144 , anyone?
16:41:29 <simo> sgallagh: our stuff is (was ?) mostly DSOs, I built it explicitly with the idea we can split it into packages (among other reasons)
16:41:34 <sgallagh> adamw: Ack from me.
16:42:00 <jds2001> adamw++
16:42:02 <zodbot> jds2001: Karma for adamwill changed to 6 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:42:05 <simo> sorry to ask, but whay does ansible need python2 ?
16:42:19 <stefw> it's not yet ported to python3
16:42:20 <sgallagh> simo: Right, I mostly meant that the SSSD core uses a bunch of samba-derived libraries. But we can probably make sure the default install ignores the Python stuff
16:42:22 <nirik> adamw: sure.
16:42:27 <stefw> simo, and it expects python on the target host
16:42:58 <sgallagh> adamw: Do you have commit privs on comps? (I would expect so, but if not I'll commit it)
16:42:59 <simo> sgallagh: tdb, ldb, talloc, tevent are separate libs, they do not come out of the samba package since long time
16:43:29 <sgallagh> simo: I suppose the stuff that's risky would be the stuff from the sssd-ad and sssd-ipa subpackages.
16:43:39 <adamw> well, it's not just that it's 'not ported yet', it's that ansible is kinda inherently forced to be conservative - as long as it's reasonably commonly being used to manage py2-only nodes, it needs to be py2
16:43:42 <adamw> sgallagh: yes.
16:43:48 <simo> stefw: so maybe we can expresse our need to get them to support python3 so we can support ansible by default ?
16:44:00 <sgallagh> stefw: Can realmd properly determine the domain type before the samba packages are present?
16:44:05 <stefw> yup
16:44:07 <sgallagh> ok
16:44:19 <sgallagh> simo: This is a long-running topic.
16:44:27 <nirik> ansible folks are working on their 2.0 release, after that they will look at python3 plans... I'm sure it will happen, just not overnight.
16:44:32 <sgallagh> They don't want to bother as long as their primary customer base is on RHEL 6 and 7
16:44:38 <simo> adamw: dunno about ansible but I have a lot of python code that works on 2 and 3 at the same time
16:44:40 <sgallagh> So... probably years yet
16:45:01 <adamw> simo: just read the thread 'ansible in Fedora 23+' on devel@
16:45:04 <adamw> covers most of it
16:45:08 <jds2001> sgallagh: you can get a supported py3 stack for both of those os's :)
16:45:10 <simo> I trust your tl;dr :)
16:45:28 <sgallagh> jds2001: But not out of the gate, which is problematic if you want to use ansible to install software :)
16:45:43 * nirik thinks it may be less than years, but estimating things is always difficult.
16:46:07 <simo> ansible could run dnf install python-dnf itself
16:46:17 <simo> but not my place to solve their problem
16:46:25 <nirik> it can sure.
16:46:31 * danofsatx is here, late
16:46:31 <nirik> with it's raw mode.
16:47:01 <simo> then problem solved and we need no 'legacy' group
16:47:04 <simo> let's move on :)
16:47:08 <stefw> yes lets
16:47:12 <simo> sgallagh: it is still not clear to me what you want to attack
16:47:14 <sgallagh> OK, so right now I've seen two proposals, so let's tally those?
16:47:29 <simo> sgallagh: cl;early you need to make the hard job of looking at packages and propose something to drop
16:47:34 <sgallagh> Proposal 1) Create an ansible-support group
16:47:41 <simo> and then be screamed at when you remove the editor of choice of someone
16:47:50 <simo> (and if you remove vim I will unfriend you <g>)
16:47:57 <sgallagh> simo: I'm used to getting yelled at
16:48:26 <simo> tbh given ansible can install the packages it needs I am not sure we really need a group for ansible
16:48:28 <nirik> well, the group is handy on server so you could add it to your kickstart or select it on install...
16:48:42 <simo> nirik: ok
16:48:43 <sgallagh> Proposal 2) Remove samba and domain-client from the default install, leave it as optional on the DVD
16:48:59 <sgallagh> Goal of both being to eliminate Python 2 from the default set
16:49:18 <mizmo-wfh> potentially dumb question, are these proposals mutually exclusive?
16:49:26 <simo> sgallagh: are those the only 2 packages requiring python2 a t this point ?
16:49:47 <danofsatx> what is there besides vim (1.0M) and emacs (3.0M)?
16:50:02 <sgallagh> simo: Yes. We converted everything else fromthe default install
16:50:05 <simo> nano, pico, ed, etc...
16:50:06 <danofsatx> nevermind, I think I'm lost
16:50:10 <sgallagh> danofsatx: We are *not* having the editor discussion
16:50:24 <danofsatx> I see that now. please disregard.
16:50:37 <sgallagh> mizmo-wfh: Sorry, Proposal 1 should note that it is optional, not installed by default
16:50:40 <simo> sgallagh: ok then +-0 to 1) and +1 to 2)
16:51:09 <jds2001> +1 to both, as a practical matter
16:51:34 * nirik reads 'ansible support group' and thinks 'hi, it's been 15minutes since I last used ansible'
16:51:41 <nirik> anyhow, +1 to both here.
16:51:44 <sgallagh> /me cracks up
16:51:55 <mizmo-wfh> 12 steps for ansible users
16:52:26 <nirik> step one: admit you have a python2.
16:52:41 * adamw just pushed the comps commit for 1), so i guess that counts as a +1? :)
16:52:57 <mizmo-wfh> i kind of think proposal 1 breaks one of the most compelling features of ansible unless i misunderstand?
16:53:10 <mizmo-wfh> (where the compelling feature is it just works on any client?)
16:53:42 <sgallagh> mizmo-wfh: That was never actually true
16:53:45 <simo> naughty nirik ...
16:53:46 <adamw> mizmo: you're kinda misunderstanding. it works on any client where sufficient bits of python2 are present
16:53:48 <sgallagh> It was marketing fluff
16:54:01 <mizmo-wfh> adamw, yeh but thats the thing so the sufficient bits of python 2 aren't going to be present now
16:54:06 <sgallagh> And actually, it *still* works in raw mode without python 2
16:54:07 <mizmo-wfh> right?
16:54:10 <adamw> mizmo: this has usually been a safe assumption, but now fedora is actually getting to the point where various commonly-used package subsets are python3 only, it's no longer a reasonable assumption for fedora
16:54:11 <sgallagh> It's just not tremendously useful
16:54:21 <adamw> mizmo: that was already happening
16:54:30 <mizmo-wfh> sgallagh, and raw mode can be used to install this optional support group?
16:54:33 <nirik> has happened on f23 cloud
16:54:35 <sgallagh> mizmo: It's already the case for Fedora Cloud
16:54:36 <misc> mizmo-wfh: yes
16:54:42 <sgallagh> mizmo-wfh: Yes
16:54:42 <mizmo-wfh> oh okay, +1 to proposal 1 from me then
16:54:43 <adamw> also core and workstation i think?
16:54:51 <mizmo-wfh> thanks for the explanation (im not super familiar with ansible)
16:54:56 <sgallagh> adamw: Unclear about workstation and core isn't a thing :)
16:54:59 <adamw> mizmo: the 1) change is literally just adding the group to comps, it's not taking python2 out of anywhere it hasn't already been taken out of
16:55:21 <jds2001> sgallagh: i havent went thourgh the entire dep chain yet
16:55:25 <mizmo-wfh> removing samba and domain-client means out of the box you can't join samba groups?
16:55:28 <mizmo-wfh> er domains
16:55:29 <nirik> well, we were going to also add that to the dvd as a optional/not checked?
16:55:32 <sgallagh> mizmo-wfh: It's something RHT is going to have to figure out for RHEL 8 as well, since it seems likely that they won't want to ship both stacks there if they can help it
16:55:37 <stefw> mizmo-wfh, yes you still can, via realmd
16:55:42 <jds2001> sgallagh: but dnf remove python on rawhide is.....interesting.
16:55:57 <sgallagh> mizmo-wfh: We're leaving in realmd, which can auto-install the necessary software
16:55:59 <mizmo-wfh> stefw, whats the downside of removing samba and domain-client
16:56:07 <adamw> nirik: oh yeah, i'll add that to spin-kickstarts.
16:56:08 <sgallagh> (Provided it has access to a mirror)
16:56:26 <sgallagh> adamw: Thanks
16:56:29 <stefw> mizmo-wfh, the downside is that you have to use something (like realmd) to install them
16:56:38 <stefw> realmd makes that really easy (detecting which software is necessary for a given domain)
16:56:39 * danofsatx wonders if those could be set up as roles for rolekit
16:56:50 <sgallagh> danofsatx: If what could?
16:57:02 <danofsatx> samba, domain-client
16:57:09 * stefw will turn into a pumpkin in 3 minutes
16:57:10 <danofsatx> or would rolekit be overkill
16:57:37 <sgallagh> mizmo-wfh: The primary downside is that if you don't have external network access, then you would need to make sure to explicitly add the "domain client" packages during install (either via kickstart or anaconda)
16:57:49 <sgallagh> We're keeping them on the DVD for this purpose.
16:58:05 <mizmo-wfh> sgallagh, seems reasonable to me then, +1 to proposal 2 as well :) thanks for the explanations
16:58:08 <sgallagh> So it won't save us space on the disk, but plenty of space in the default install
16:58:30 <danofsatx> now that I think I have the idea of what we're talking about, I'm +1 to both proposals
16:58:39 <sgallagh> danofsatx: That would be overkill considering we already have exactly that capability in realmd
16:58:48 <sgallagh> Which is staying in the default install
16:59:27 <sgallagh> /me tries to add up the counts
17:00:49 <sgallagh> I'm +1 to both, for the record.
17:01:00 <sgallagh> Someone else want to chime in? I've got +4 on both proposals
17:01:02 <sgallagh> Unless I miscounted
17:01:10 <mizmo-wfh> simo did 0 on 1 and +1 on 2
17:01:11 <stefw> +1 from me on both proposals
17:01:16 <mizmo-wfh> so you shouldn't have the same number for both
17:01:43 <sgallagh> mizmo-wfh: adamw didn't vote on 2
17:01:57 <adamw> oh sorry
17:01:58 * adamw reads
17:02:10 <mizmo-wfh> simo - / 1; jds2001 1 / 1; nirik 1 / 1; adamw 1 / ?; mizmo 1/1; sgallagh 1/1; stefw 1/1; danofsatx 1/1
17:02:19 <mizmo-wfh> thats what i see in scrollback?
17:02:27 <sgallagh> OK, I must have missed some
17:02:28 <acarter> fyi - for folks looking for Fedora Release we're in #fedora-meeting
17:02:30 <adamw> i guess +1 to 2), sure
17:02:38 <sgallagh> acarter: We're closing out in 30s or so
17:02:43 <sgallagh> If you need this channel
17:02:52 <mizmo-wfh> +7 for proposal 1
17:03:01 <mizmo-wfh> +8 for proposal 2
17:03:07 <mizmo-wfh> one 0 for proposal 1
17:03:54 <simo> passed
17:03:56 <simo> both
17:03:57 <sgallagh> #agreed Create an optional ansible-support comps group (+7, 1, -0)
17:03:57 <sgallagh> #agreed Remove samba and domain-client from the default install, leave it as optional on the DVD (+8, 0, -0)
17:04:06 <sgallagh> #topic Open Floor
17:04:14 <sgallagh> If there's nothing for Open Floor, I'll close the meeting in 30s
17:04:19 <simo> sgallagh: are we going to create a working group like for rolekit to work on this slimming work ?
17:05:05 <sgallagh> simo: There are folks working on this already, not all in Server WG
17:05:24 <sgallagh> danofsatx and I are from the Server side, pbrobinson was looking into dep reduction from the rel-eng side.
17:05:25 <simo> ok
17:05:33 <sgallagh> Any and all help is welcome and encouraged, of course
17:05:38 <simo> that's enough for me
17:05:52 <mizmo-wfh> fedora weight watchers
17:05:57 <mizmo-wfh> counting up those points / packages
17:05:57 <simo> lol
17:05:59 <sgallagh> mizmo++
17:06:08 <mizmo-wfh> choosing lower calorie alternatives
17:06:09 <mizmo-wfh> hehe
17:06:14 <pbrobinson> sgallagh: not from rel-eng side, from own interest side
17:06:30 <sgallagh> pbrobinson: Either way, immensely appreciated
17:07:05 <sgallagh> OK, anything else?
17:07:12 <pbrobinson> sgallagh: biggest reduction IMO would be removal of non core bits like perl from freeipa, I've filed bugs to split things out but that team just constantly ignores even with tested patches
17:07:49 <danofsatx> I just wanted to note that my presence has been scarce lately.
17:07:51 <sgallagh> simo: Could you check on that? You're most closely involved with that team.
17:08:10 <danofsatx> I recently became unemployed, so my schedule is all out of whack while I search for a new job.
17:08:55 <sgallagh> danofsatx: What I'm hearing is that you have plenty of time to work on Fedora, now ;-)
17:09:52 <sgallagh> OK, on that note, I'm going to close out the meeting this week.
17:10:01 <sgallagh> Thanks everyone for participating in the discussion
17:11:08 <sgallagh> #endmeeting