16:40:05 <dgilmore> #startmeeting RELENG (2015-12-07)
16:40:05 <zodbot> Meeting started Mon Dec  7 16:40:05 2015 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:40:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:40:05 <zodbot> The meeting name has been set to 'releng_(2015-12-07)'
16:40:12 <dgilmore> #meetingname releng
16:40:12 <zodbot> The meeting name has been set to 'releng'
16:40:12 <dgilmore> #chair dgilmore nirik tyll sharkcz bochecha masta pbrobinson pingou maxamillion
16:40:12 <zodbot> Current chairs: bochecha dgilmore masta maxamillion nirik pbrobinson pingou sharkcz tyll
16:40:15 <dgilmore> #topic init process
16:40:25 <maxamillion> .hello maxamillion
16:40:26 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:40:31 * sharkcz is here
16:41:33 * nirik is sort of here, sorta of catching up with emails
16:41:35 <dgilmore> i suspect that pbrobinson is not here, it is 12:40am where he is
16:41:52 <dgilmore> #topic tickets
16:42:06 <dgilmore> no tickets have the meeting keyword
16:42:13 <dgilmore> https://fedorahosted.org/rel-eng/report/1 is the list of tickets
16:42:41 <dgilmore> I think we need to go through the tickets, find ones that should be tracked in taiga or elsewhere and close them
16:42:57 <dgilmore> do the things that need doing
16:43:09 <dgilmore> close ones that we are juts not going to do, etc
16:43:32 <maxamillion> +1
16:44:39 * nirik nods
16:44:56 <dgilmore> not sure the best way to do that
16:45:05 <dgilmore> if we all should commit to looking and doing some
16:45:12 <dgilmore> or one person should just do it
16:46:28 <nirik> perhaps we could just do 5 a week or something in meeting?
16:47:18 <dgilmore> sure
16:47:34 * masta is here now
16:48:01 <dgilmore> I think I will go through them. pick some to be covered and see whats needed
16:49:30 <masta> wow, bunch of tickets
16:49:34 <dgilmore> #topic Secondary Architectures updates
16:49:47 <dgilmore> nirik: how goes the migration to ansibilised hosts
16:49:48 <dgilmore> ?
16:50:12 <nirik> new arm hub/db is close to ready
16:50:25 <nirik> I dump/restored the db over on it and got all the playbooks finished running
16:50:34 <nirik> I think it needs a new cert for it's local kojid
16:50:49 <nirik> and then if you all are ok with it, we should schedule a migration time/date
16:51:41 <dgilmore> nirik: cool. probably shuold talk with pbrobinson, but I think one day this week would be good
16:52:00 <nirik> works for me. Just let me know and I can be around to help out.
16:52:01 <dgilmore> nirik: we would then just need to do ppc?
16:52:06 <nirik> yepp
16:55:04 <dgilmore> cool
16:55:13 <dgilmore> #topic Secondary Architectures update - ppc
16:55:20 <dgilmore> sharkcz: do you know where ppc is?
16:56:05 <sharkcz> Fedora goes well AFAIK, main focus these days is EPEL, solving the issues pbrobinson found right now, so he can move forward
16:56:30 <sharkcz> 1800 out of 2100 archful builds should be done
16:57:16 <dgilmore> nice
16:57:26 <sharkcz> issues like util-linux is missing from the minimal (or usual) buildroot after updating to 7.2
16:57:35 <sharkcz> but getting there
16:58:10 <dgilmore> okay
16:58:20 <dgilmore> #topic Secondary Architectures update - s390
16:58:28 <dgilmore> sharkcz: and how is s390?
16:58:39 <dgilmore> have we managed to secure a plan to drop 31 bit yet?
16:58:59 <sharkcz> got the update for mariadb, build is in progress, shadow should restart then
16:59:20 <sharkcz> no plan for 31-bit removal yet, will ping the internal people again
17:00:34 <dgilmore> sharkcz: okay, I really really think we need to remove it sooner rather than later
17:02:28 <dgilmore> #topic Secondary Architectures update - arm
17:02:31 * sharkcz agrees, but consider the current costs lower than having to add 31-bits back for the next rhel i fdropped now
17:03:04 <dgilmore> pbrobinson had told me during last week that aarch64 is pretty much fully current
17:03:38 <dgilmore> #topic Open Floor
17:03:48 <dgilmore> does anyone have anything to bring up
17:03:52 <nirik> I have a few FYI's...
17:04:00 <dgilmore> nirik: go for it
17:04:13 <nirik> 1. looks like we will be getting in some more ssd's for arm socs... can replace the ones with bad disks and have more ssd ones.
17:04:40 <dgilmore> :) nice
17:04:44 <nirik> 2. smooge and I will be in phx2 in january (11-15th)
17:04:50 <dgilmore> okay
17:05:01 <nirik> hopefully there will be installing the aarch64 hardware...
17:05:11 <nirik> and doing a bunch of rewiring, etc.
17:05:16 <nirik> so there may be outages that week
17:05:44 <nirik> I think thats it
17:06:03 <dgilmore> cool cheers
17:06:17 <dgilmore> reminds me
17:06:38 <dgilmore> we need to be pretty agressive with getting f24 deliverables done
17:06:57 <dgilmore> https://fedoraproject.org/wiki/Releases/24/Schedule
17:07:17 <dgilmore> branching is feb 2
17:07:30 <dgilmore> and change freeze feb 16
17:07:43 <dgilmore> devconf is in the middle of those two events
17:07:59 <dgilmore> we need to be really sure of our stuff way in advance
17:08:40 <dgilmore> there is also a bump of gcc to 5.3.1 going on right now
17:09:18 <maxamillion> dgilmore: bump of gcc means mass rebuild, yes?
17:09:23 <dgilmore> maxamillion: no
17:09:31 <maxamillion> only glibc?
17:09:41 <dgilmore> but it does mean that there could be unexpected failures
17:09:49 <maxamillion> rgr
17:09:55 <dgilmore> maxamillion: depends on what type of gcc bump
17:10:19 <dgilmore> this I am assuming has no ABI changes since it is being pushed to f22 and f23
17:10:39 <nirik> I thought there was some reason for mass rebuild...
17:10:43 <nirik> but I can't recall what it was now
17:11:02 <dgilmore> nirik: not sure
17:11:15 <dgilmore> there is very little time in the schedule for a mass rebuild
17:11:36 <nirik> yep. I don't see anything off hand that needs it so far.
17:12:27 <nirik> oh, perhaps the systemd triggers one
17:13:09 <dgilmore> okay
17:13:20 <dgilmore> we should put out feelers for it
17:13:37 <dgilmore> #action dgilmore to see if we will need a mass rebuild for f24
17:14:52 <dgilmore> anything else we need to cover?
17:15:46 <maxamillion> not that I can think of
17:15:55 <dgilmore> okay cheers
17:15:59 <dgilmore> #endmeeting