17:00:44 <geppetto> #startmeeting fpc
17:00:44 <zodbot> Meeting started Thu Dec 10 17:00:44 2015 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:44 <zodbot> The meeting name has been set to 'fpc'
17:00:44 <geppetto> #meetingname fpc
17:00:44 <zodbot> The meeting name has been set to 'fpc'
17:00:44 <geppetto> #topic Roll Call
17:02:04 <geppetto> geppetto limburgher mbooth orionp racor Rathann SmootherFr0gZ tibbs|w: FPC ping
17:02:10 <orionp> hello
17:02:12 <mbooth> Hi
17:02:14 <geppetto> #chair orionp
17:02:14 <zodbot> Current chairs: geppetto orionp
17:02:16 <geppetto> #chair mbooth
17:02:16 <zodbot> Current chairs: geppetto mbooth orionp
17:03:31 <geppetto> tibbs: You around?
17:04:14 <geppetto> Ok, might be a short meeting this week
17:04:43 <geppetto> #chair racor
17:04:43 <zodbot> Current chairs: geppetto mbooth orionp racor
17:04:52 <geppetto> Hey racor
17:05:24 <racor> hi
17:06:36 <geppetto> I'm going to give it another few minutes and then skip this week.
17:06:56 <geppetto> AFAIK nothing important is on the agenda
17:07:08 <geppetto> Anyone else have anything we really need to talk about?
17:07:33 <orionp> not from me
17:07:42 <Rathann> hi
17:07:43 <Rathann> sorry
17:07:51 <geppetto> And then there were 5 :)
17:07:54 <geppetto> #chair Rathann
17:07:54 <zodbot> Current chairs: Rathann geppetto mbooth orionp racor
17:08:02 <geppetto> #topic Schedule
17:08:07 <geppetto> https://lists.fedoraproject.org/archives/list/packaging%40lists.fedoraproject.org/message/YFHSMMFJCA7TP6JDTXJF4T3U3CDSYGZH/
17:09:10 <geppetto> #topic #582 Delegate legibility vs cross-distro maintainability trade-off to package maintainers
17:09:15 <geppetto> .fpc 582
17:09:17 <zodbot> geppetto: #582 (Delegate legibility vs cross-distro maintainability trade-off to package maintainers) – fpc - https://fedorahosted.org/fpc/ticket/582
17:09:19 <geppetto> https://fedorahosted.org/fpc/ticket/582
17:09:56 <geppetto> Ok, this is kind of long … so you can read it all … or skip to the indented section of comment 6
17:10:29 <geppetto> Which appears to be what people want us to vote on now
17:12:11 <geppetto> I would change "are not permitted in the main Fedora repositories" with "are not permitted for use in specfiles in the main Fedora repositories"
17:12:47 <geppetto> Which clarifies that you can do something like scl-utils, which installs macros for use … but you just can't use them in official pkgdb packages
17:12:58 <geppetto> So +1 with that change, from me
17:17:20 <orionp> I'm +1 too.  The () seems redundant though
17:18:43 <geppetto> yeh, it's common sense … but maybe nick assume it's not common ;)
17:19:50 <geppetto> #chair tibbs
17:19:50 <zodbot> Current chairs: Rathann geppetto mbooth orionp racor tibbs
17:19:54 <geppetto> Hey
17:20:19 <tibbs|w> Sorry, not a good morning.
17:20:38 <racor> I am ambivalent. Not being a native English speaker, geppetto's wording to me doesn't change anything. Also, as long as COPRs don't have an formal role in Fedora, I don't see much reason to mention them.
17:22:05 <geppetto> racor: They are a way to easily make packages available to Fedora users
17:22:30 <mbooth> I think it's fair to mention COPRs -- It avoids us being questioned about what to do when a packager wants to do something non-standard and also
17:22:36 <geppetto> I think the idea was more to say "No, but you can do this which is more suited to what you want" Rahter than just "No"
17:22:48 <mbooth> makes COPR more discoverable
17:23:21 <mbooth> I'm +1 on the change, I think
17:23:28 <racor> geppetto: to me, they are private sandbox for inoffical uses. Not of any importance to us  at all.
17:24:32 <geppetto> Ok, we're at +4 now … vote racor, Rathann ?
17:24:46 <racor> 0
17:24:54 <Rathann> racor: they make it easier to maintain private repos, for example for packages pending review
17:25:51 <racor> Rathann: May-be, I don't know. I've never used them nor do I see a pressing need to use them.
17:26:59 <orionp> I find them extremely useful
17:27:18 <Rathann> so this is about comment 6, is it?
17:27:37 <racor> Rathann: About the indented section of comment 6
17:28:19 <mbooth> I even use COPR to build SCLs :-o
17:28:28 <geppetto> mbooth: :)
17:28:29 <Rathann> bleh, SCLs
17:29:03 <Rathann> I'm 0 on this
17:30:15 <tibbs|w> Well, crap, I've been dumb and typing in the query geppetto used to send me the backlog instead of typing in this channel.
17:30:23 <tibbs|w> I'l; +1 this.
17:30:43 <geppetto> Ok, so that's +1:4, 0:2
17:31:07 <Rathann> weren't we at +4 just a few minutes ago?
17:31:19 <Rathann> [18:24:32] <geppetto> Ok, we're at +4 now … vote racor, Rathann ?
17:31:23 <geppetto> Rathann: I was already counting tibbs
17:31:36 <Rathann> ah
17:31:42 <tibbs|w> Yeah, sorry, I just didn't look at the channel tab.  Wondered why only geppetto and I were talking.
17:31:51 <racor> geppetto: I already voted 0.
17:31:55 <orionp> So, can we get to 5 if we drop mentioning COPR?
17:32:09 <racor> orionp: yes
17:32:11 <geppetto> Or any other wording change you'd like Rathann or racor ?
17:32:23 <geppetto> Ok, I'm still +1 without the COPR reference.
17:32:32 <tibbs|w> +1 if we drop COPR.
17:32:37 <Rathann> COPR reference doesn't matter for me
17:32:43 <racor> geppetto: I'd vote +1 with COPR dropped
17:32:49 * geppetto nods
17:33:19 <geppetto> mbooth: I assume you are still +1 without the COPR reference?
17:33:35 <orionp> I'm +1 too
17:33:56 <mbooth> geppetto: Sure still +1, but it's disappointing we can't point users to where they need to go :-(
17:34:26 <tibbs|w> I am not entirely sure we need to do that.
17:34:36 <geppetto> #info Dropping COPR reference, add some text to make it obvious you can still install macros just not use them from specfiles.
17:34:37 <tibbs|w> They could go to obs, for example, if they wanted.
17:35:09 <geppetto> #action paragraph be added to the spec legibility section of the guidelines (+1:5, 0:1, -1:0)
17:35:33 <geppetto> #topic #580 [Clarification] Policy on auto-generated code
17:35:37 <geppetto> .fpc 580
17:35:38 <zodbot> geppetto: #580 ([Clarification] Policy on auto-generated code) – fpc - https://fedorahosted.org/fpc/ticket/580
17:35:41 <geppetto> https://fedorahosted.org/fpc/ticket/580
17:35:52 <geppetto> tibbs: You got a new draft?
17:36:13 <tibbs|w> No, I'm behind.  Sorry.
17:36:17 <geppetto> No problem
17:36:29 <geppetto> #topic #567 Packaging Python 3 applications and modules for EPEL 7+
17:36:31 <tibbs|w> Did chat with fesco about the issue, though.  Going to be a fun one for them to slog through.
17:36:33 <geppetto> .fpc 567
17:36:35 <zodbot> geppetto: #567 (Packaging Python 3 applications and modules for EPEL 7+) – fpc - https://fedorahosted.org/fpc/ticket/567
17:36:38 <geppetto> https://fedorahosted.org/fpc/ticket/567
17:36:42 <tibbs|w> Pretty much the same thing here.
17:36:49 <geppetto> Ok, I'd seen some updates
17:36:58 <geppetto> wasn't sure if we had anything to talk about
17:37:02 <tibbs|w> As far as I know, the ifdef-spaghetti method works.
17:37:13 * geppetto nods
17:37:20 <tibbs|w> There was a mention of an extra macro containing the python major version or something.
17:37:27 <tibbs|w> I don't know if that went in or not.
17:37:48 <orionp> I think %python3_pkgversion may be missing from fedora - not sure why at this point
17:38:18 <orionp> It seems the python maintainers have dropped out of this....
17:38:35 <tibbs|w> Yes, that was the macro.
17:38:55 <tibbs|w> I thought you were going to just add it to redhat-rpm-config.
17:39:09 <tibbs|w> Really, pushing it through python isn't the best way.
17:39:31 <tibbs|w> I also recall that we were going to get a package added to the buildroot; do you remember what that package was?
17:39:38 <orionp> well, it's tied to the version of python3, so it seems to belong to that...
17:39:52 <geppetto> tibbs: I thought that was some extra macro package
17:40:15 <tibbs|w> The problem with the macros being in the python package is that we have to rev the python package to change the macros.
17:40:46 <tibbs|w> And that's often more difficult than anyone really wants it to be.  At one point things were held up becaue the python package didn't even build.
17:40:53 <orionp> Well, for that particular macro, that when you'd need to change it, but yeah, then you have a mess of them
17:41:51 <tibbs|w> And, yeah, this would add some kind of procedural dependency, but python doesn't really get upgraded all that often.  I think it could be handled.  Maybe even with a direct version dependency somewhere so we know that things have to be bumped.
17:42:03 <tibbs|w> But maybe after this stuff is stable it could move into the main python package.
17:42:35 <tibbs|w> Anyway, that has been swapped out of my brain for long enough that I've forgotten the details.  I wish I had more time.
17:45:58 * geppetto nods … I think that's universal :(
17:46:08 <geppetto> #topic Open Floor
17:46:21 <geppetto> Ok, anything else anybody wants to talk about?
17:46:30 <tibbs|w> Nothing from me.  I think I have enough going on.
17:47:22 <mbooth> Nope, I need to go anyway
17:48:04 <geppetto> #endmeeting