17:01:19 <kushal> #startmeeting Fedora Cloud WG
17:01:20 <zodbot> Meeting started Wed Jan 20 17:01:19 2016 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:20 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
17:01:25 <kushal> #topic Roll Call
17:01:28 <sayan> .fas sayanchowdhury
17:01:28 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:01:32 <kushal> .hellomynameis kushal
17:01:33 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:01:48 <fhackdroid> .hellomynameis farhaan
17:01:49 <zodbot> fhackdroid: farhaan 'Farhaan Bukhsh' <farhaan.bukhsh@gmail.com>
17:02:17 <adimania> .fas adimania
17:02:17 <zodbot> adimania: adimania 'Aditya Patawari' <adimania@gmail.com>
17:02:24 * praveenkumar is busy with release so not able to make it today.
17:02:28 <rtnpro> .fas rtnpro
17:02:28 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:02:52 <dustymabe> .hellomynameis dustymabe
17:02:52 <jbrooks> .fas jasonbrooks
17:02:54 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:02:57 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:03:04 <jzb> .hellomynameis jzb
17:03:05 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:03:09 <kushal> #chair scollier sayan fhackdroid adamw rtnpro dustymabe jbrooks jzb
17:03:09 <zodbot> Current chairs: adamw dustymabe fhackdroid jbrooks jzb kushal rtnpro sayan scollier
17:03:19 <kushal> Did I miss anyone?
17:03:28 <adimania> !
17:03:48 * adamw kinda around
17:03:57 <kushal> #chair adamw
17:03:57 <zodbot> Current chairs: adamw dustymabe fhackdroid jbrooks jzb kushal rtnpro sayan scollier
17:03:58 <dustymabe> adamw: welcome
17:04:00 <kushal> adimania, ask :)
17:04:06 <adamw> you included me already, was just saying hi :)
17:04:20 <adimania> you missed me! that why raising the hand :D
17:04:52 <kushal> #chair adimania
17:04:52 <zodbot> Current chairs: adamw adimania dustymabe fhackdroid jbrooks jzb kushal rtnpro sayan scollier
17:04:56 <kushal> adimania, sorry :)
17:05:15 <adimania> no problem. :)
17:05:44 <kushal> Give me 1 minute
17:06:19 <kushal> #topic Action items from last meeting
17:06:21 <kushal> * dustymabe to update #115 after talking to mhayden
17:06:21 <kushal> * kushal to work on https://fedorahosted.org/cloud/ticket/136
17:06:21 <kushal> * kushal will build an unofficial image with all lang packs for #146
17:06:58 <dustymabe> kushal: unfortunately mhayden didn't bring it up at the server wg meeting
17:07:10 <dustymabe> I may sit in on the meeting and bring it up
17:07:14 <kushal> dustymabe, no problem, I think we should go ahead and submit our proposal
17:07:40 <kushal> dustymabe, otherwise it may become late, and other FAD(s) may get the money in the first come first serve basis
17:07:54 <dustymabe> kushal: true
17:08:09 <kushal> jzb, dustymabe so we need to get a proposal ready :)
17:08:45 <dustymabe> kushal: right
17:09:00 <dustymabe> worst case scenario lets sit down at fosdem and hammer one out
17:09:06 <dustymabe> next weekend
17:09:17 <kushal> jzb, any comments?
17:09:27 <jzb> just a sec
17:09:46 <jzb> dustymabe: +1 to hammer @ FOSDEM
17:09:50 <jzb> but let's get it in soon
17:10:25 <kushal> jzb +1 to that.
17:10:54 <mzee1000> hey guys
17:11:03 <dustymabe> mzee1000: welcome
17:11:12 <kushal> For ticket 136, I found that having a CD ROM device depends on the Vm definition, which has nothing to do with the way we build the vagrant image.
17:11:18 <kushal> mzee1000, hello there
17:11:46 <kushal> On a virtualbox system, the user can easily stop the vm, and add the device manually, or define it in the vagrantfile
17:12:56 <dustymabe> kushal: ok. you added that to the ticket already I believe
17:13:10 <kushal> dustymabe, yes, just wanted to share it here
17:13:24 <dustymabe> kushal: ok
17:14:11 <kushal> For ticket 146 I made an image, striker do you want to say anything there?
17:14:58 <dustymabe> I started to work with striker on seeing if we could achieve the desired effect using just cloud-init.. but I think we both got too busy later in the week to complete that
17:14:58 <striker> just to say thanks :)
17:15:26 <kushal> striker, If it worked, can you please say that in the ticket, and close it?
17:15:34 <striker> I am working on getting our Openstack instance to accept it, but will let you know when I do
17:15:36 <striker> yep
17:15:53 <kushal> striker, and in future also feel free to create a new ticket for any updated image
17:16:43 <kushal> Moving to tickets then
17:17:04 <kushal> #topic AMI lifetimes (Cloud WG members vote needed) https://fedorahosted.org/cloud/ticket/99
17:17:19 <kushal> sayan, will give more input to this
17:17:55 <sayan> I have compiled a list of the AMI ids by scraping through the git-log of the websites repo and the wiki
17:18:22 <kushal> sayan, can you please update the wiki with that list of AMI(s) ?
17:18:33 <kushal> s/wiki/trac
17:18:40 <sayan> kushal, sure
17:18:43 <adimania> aren't these AMIs associated with our account?
17:19:14 <adimania> I thought that is why we have getting bills.
17:19:21 <kushal> adimania, our == ?
17:19:55 <adimania> fedora cloud or whatever account we are publishing these with,
17:20:00 <mhayden> dustymabe: i did bring up the Server/Cloud FAD but i think it got looked over -- will ask again next week
17:20:16 <adimania> quoting from ticket "our official and community cloud accounts"
17:20:17 <dustymabe> mhayden: cool. I might sit in on the server wg meeting next week
17:20:18 <kushal> adimania, that is our official AWS account, and it is costing a lot of money every month.
17:20:23 <kushal> mhayden, thanks :)
17:20:41 <sayan> adimania, so these AMIs which I have scraped are safe to keep
17:20:54 <sayan> and all the others would be removed
17:21:11 <kushal> We also agreed to delete any nightly after 5 days
17:21:18 <dustymabe> sayan: let's take an intermediate step
17:21:39 <adimania> Ah! so if you get an ami by scraping, even if old, you'd keep it?
17:21:48 <jzb> do we need to do a post about the change in keeping AMIs?
17:21:51 <dustymabe> for all of the AMIs we plan to delete let's remove lauch permissions for 2 or 3 weeks
17:22:02 <adimania> otherwise, we can get a list of AMIs using AWS api.
17:22:17 <dustymabe> if no one complains, then remove
17:22:29 <kushal> jzb, only the final released ones are being kept
17:22:31 <dustymabe> if someone does complain then we either made a mistake, or they are using an image they shouldn't be
17:23:03 <kushal> dustymabe, it is a huge list, and most of them are nightlies
17:23:07 <jzb> kushal: sorry, no I meant do we need to notify people we plan to stop retaining AMIs indefinitely?
17:23:22 <kushal> jzb, we are retaining the released ones
17:23:40 <jzb> kushal: yes, but that's different than what we're doing right now, right?
17:23:43 <dustymabe> kushal: right.. but scripting it shouldn't be hard to do
17:24:06 <dustymabe> kushal: I'm not saying we announce it, just saying to "remove access" then delete
17:24:10 <kushal> dustymabe, also that 2-3 weeks will cost us another $3k+
17:24:21 <kushal> jzb, a post about it should be okay
17:24:30 <dustymabe> ok. just don't want to make a mistake and accidentally delete the wrong images
17:25:04 <kushal> :)
17:25:16 <kushal> So moving to next ticket?
17:25:44 <kushal> #topic Fedora Cloud FAD (late 2015/early 2016) https://fedorahosted.org/cloud/ticket/115
17:25:54 <kushal> dustymabe, just now updated us about it
17:26:02 <kushal> I guess we can safely move to next one
17:26:10 <dustymabe> kushal: yep
17:26:21 <kushal> #topic Fedora 23 Retrospective https://fedorahosted.org/cloud/ticket/135
17:26:33 <kushal> jzb, you were supposed to update it, and then close it :)
17:27:04 <jzb> kushal: argh
17:27:15 <kushal> jzb, sorry for disturbing :)
17:27:26 <jzb> kushal: Will set myself to owner so I make sure to do that.
17:27:33 <kushal> Thanks :)
17:27:35 <jzb> #action jzb actually update ticket 135
17:27:41 <kushal> #action jzb will update and close 135
17:28:08 <kushal> Skipping 136 as we discussed it few minutes ago
17:28:17 <kushal> #topic Produce updated cloud base images monthly https://fedorahosted.org/cloud/ticket/138
17:29:13 <kushal> we have to find the last build of F23 images from https://dl.fedoraproject.org/pub/alt/atomic/testing/
17:29:30 <kushal> and then make sure that it passed all tests, and then we can ask rel-eng to release it
17:29:36 <dustymabe> should we not just coincide with a 2 week atomic release
17:29:38 <adamw> kush:http://ur1.ca/oflo1
17:30:35 <adamw> i can already find all the images for each night's compose, and tell you if any are missing, and tell you if the openQA test(s) passed. give me an API for autocloud and I can tell you about those tests too. :P
17:30:50 <kushal> adamw, yes, we will give you that
17:31:03 <kushal> adamw, sadly the cloud base images are missing
17:31:08 <adamw> yep.
17:31:26 <kushal> https://dl.fedoraproject.org/pub/alt/atomic/testing/23-20160116/Cloud-Images/
17:31:35 <adamw> yes, that's the last time they showed up.
17:31:35 <kushal> ^^ I can see these as the latest builds
17:32:17 <kushal> So, I will confirm that they passed the autocloud tests, and adamw can confirm if the openQA tests passed or not :)
17:32:28 <kushal> and then open a ticket in rel-eng, and then update our ticket :)
17:32:36 <kushal> Anything I am missing?
17:34:06 <kushal> #action kushal to find test results and then create the ticket to release https://dl.fedoraproject.org/pub/alt/atomic/testing/23-20160116/Cloud-Images/
17:34:59 <kushal> #topic Producing 2 week atomic images https://fedorahosted.org/cloud/ticket/139
17:35:16 <kushal> As discussed before, after next 2 week release, we will close this ticket.
17:35:27 <kushal> #topic Proposals for F24 features https://fedorahosted.org/cloud/ticket/143
17:35:35 <kushal> jzb, anything you want input?
17:35:44 <kushal> rtnpro, you have a feature
17:35:51 <kushal> do you want to talk about it here?
17:36:04 <rtnpro> kushal, yes
17:36:37 <jzb> kushal: quick question
17:36:43 <rtnpro> so, I have now a working POC for cloud-motd at github.com/rtnpro/fedora-motd
17:37:13 <kushal> jzb, go ahead
17:37:25 <jzb> kushal: the write-up from nzwulflin seems OK, but it hasn't been accepted or given a tracker
17:37:26 <rtnpro> so, we are showing utime, updateinfo in motd, currently
17:37:46 <kushal> jzb, can you please point me to the change wiki page?
17:37:55 <rtnpro> suggestions for other motd plugins are welcome
17:38:04 <jzb> https://fedoraproject.org/wiki/Changes/AtomicStorageClients
17:38:07 <jzb> kushal: ^^
17:38:20 <kushal> checking
17:38:41 * rtnpro waits...
17:39:04 <kushal> jzb, it says Category:ChangePageIncomplete, that has to be changed to Category:ChangeReadyForWrangler
17:39:12 <kushal> jzb, go to edit, and at the end of the page
17:39:24 <jzb> ahhh
17:39:36 <jzb> I figured there was a bit that needed to be toggled somewhere
17:39:39 <jzb> kushal: thanks
17:39:44 <kushal> jzb, you are welcome :)
17:40:00 <kushal> So, anyone wants to tell something to rtnpro ?
17:40:37 <kushal> Nothing?
17:40:47 <kushal> rtnpro, better you drop a mail to the list
17:40:52 <rtnpro> kushal, I will
17:41:08 <kushal> rtnpro, also keep an eye for the announcement to the devel list, if anyone asked any question on that
17:41:09 <jzb> isn't updateinfo sufficient?
17:41:20 <jzb> (and date)
17:41:21 <jzb> or ...?
17:41:45 <rtnpro> jzb, yes, for now, and we can easily extend it
17:41:50 <dustymabe> maybe load information for the machine
17:41:58 <dustymabe> free mem/disk etc..
17:42:05 <dustymabe> but thats not required, just a suggestion
17:42:09 <rtnpro> dustymabe, that's taken care in the uptime plugin
17:42:23 <dustymabe> rtnpro: cool then
17:42:25 <rtnpro> jzb, and also, we made it very easy to write plugins
17:42:38 <rtnpro> so, adding new plugins won't be difficult
17:42:44 <dustymabe> rtnpro: is it easy to install them?
17:42:52 <dustymabe> so could someone write a plugin rpm?
17:43:01 <dustymabe> and have the file get dropped in and used?
17:43:30 <rtnpro> dustymabe, not yet, I will prepare a setup script and then drop a mail to the list, so that people can easily try it out
17:43:44 <rtnpro> dustymabe, that's the long term plan
17:44:02 <rtnpro> dustymabe, it'd be possible now as well
17:44:17 <rtnpro> but, now I am focusing on releasing the first cut
17:44:40 <dustymabe> cool
17:45:23 <kushal> Moving next
17:45:24 <kushal> #topic Don't overwrite download location for 2 week atomic images https://fedorahosted.org/cloud/ticket/147
17:45:30 <kushal> I guess no update here.
17:45:34 <kushal> dustymabe, ?
17:45:48 <dustymabe> we agreed to change it but it has not been changed yet
17:45:52 <dustymabe> it is pending
17:45:57 <dustymabe> EOF
17:46:40 <kushal> Okay
17:47:03 <kushal> #topic 	Container "Packager" Guildelines and Naming Conventions https://fedorahosted.org/cloud/ticket/148
17:47:12 * kushal never got time to look at it.
17:47:15 <kushal> Anyone else?
17:47:38 <jzb> kushal: I haven't but
17:47:50 <jzb> I know that other RHT groups/folks are looking at package guidelines
17:47:52 <jzb> for containers
17:47:55 <jzb> or best practices
17:48:20 <jzb> https://github.com/projectatomic/container-best-practices
17:48:39 <jzb> might be good to sync efforts
17:49:36 <kushal> jzb, thanks for the link.
17:49:39 <kushal> I will have a read
17:50:07 <kushal> I guess we can now move to open floor
17:50:11 <kushal> #topic Open Floor
17:50:18 <kushal> After a long time :)
17:50:23 <kushal> Anyone else ?
17:50:32 <jzb> one thing
17:50:35 <dustymabe> I have something
17:50:43 <jzb> I suspect several of us will be in transit to FOSDEM next week
17:50:44 <adimania> !
17:50:54 <jzb> and RHT meetings the week after
17:50:59 <jzb> so that may impact the next two meetings
17:51:02 <jzb> EOF
17:51:16 <dustymabe> I can make the one next week
17:51:20 <dustymabe> but not following week
17:51:28 <dustymabe> my item: https://lists.fedoraproject.org/archives/list/cloud%40lists.fedoraproject.org/thread/NXSCO5HG5N6RXEUX7SNQ5C5RMGBHFMMC/
17:51:32 <dustymabe> jzb: ^^
17:51:44 <dustymabe> the AMIs on the web page for atomic are the ones from F23 release
17:51:50 <dustymabe> not 2 week atomic images
17:52:26 <dustymabe> (which also means they would have probably been deleted by sayan :))
17:52:51 <jzb> hmm
17:52:59 <jzb> dustymabe: do you know if we're producing the AMIs?
17:53:07 <dustymabe> can we link in with some websites people and figure out why this is?
17:53:09 <jzb> is it just the site that's not being updated?
17:53:12 <dustymabe> jzb: I only assume so
17:53:18 <dustymabe> kushal: ^^
17:54:30 <kushal> we are producing AMI(s)
17:54:51 <kushal> dustymabe, Adam can tell more about the 2 week release
17:54:59 <kushal> dustymabe, we will not delete any two week release
17:55:08 <jzb> OK
17:55:12 <jzb> I'll check on the site thing
17:55:22 <dustymabe> kushal: ok. but what I was saying is that since the AMI hasn't been listed on the web page then maybe it would have been deleted
17:55:24 <dustymabe> by accident
17:55:34 <jzb> #action jzb open ticket with Websites about listing current AMIs
17:55:49 <dustymabe> can someone else confirm that it is broken and I'm not just crazy
17:55:54 <dustymabe> thanks jzb
17:56:17 <jzb> dustymabe: that's not mutually exclusive ;-)
17:56:21 <kushal> dustymabe, It will not be, as sayan compiled the list for 5-6 different sources
17:56:26 <sayan> so two-week atomic AMIs are also on the list
17:56:42 <dustymabe> ok
17:56:47 <dustymabe> jzb: :)
17:57:18 <sayan> Ralph helped compiling the 2-week atomic list from datagrepper
17:58:17 <kushal> 2 minutes more
17:58:40 <adimania> many of us would be at FOSDEM. any plans for informal meeting?
17:58:55 <dustymabe> i'm +1
17:58:56 <jzb> I'll be in the virt devroom much of the weekend
17:59:04 <jzb> but +1 Friday or Saturday night perhaps
17:59:20 <jzb> also, anybody at FOSDEM is welcome to help out in the IaaS/Virt devroom :-)
17:59:48 <adimania> I have a talk in container devroom.
18:00:09 <adimania> if that does not clash with Virt devroom then I'd be happy to help
18:00:58 <kushal> Closing the meeting then.
18:01:04 <kushal> #endmeeting