15:33:48 <dgilmore> #startmeeting RELENG (2016-03-21)
15:33:48 <zodbot> Meeting started Mon Mar 21 15:33:48 2016 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:33:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:33:48 <zodbot> The meeting name has been set to 'releng_(2016-03-21)'
15:33:48 <dgilmore> #meetingname releng
15:33:48 <dgilmore> #chair dgilmore nirik tyll sharkcz bochecha masta pbrobinson pingou maxamillion
15:33:48 <zodbot> The meeting name has been set to 'releng'
15:33:48 <zodbot> Current chairs: bochecha dgilmore masta maxamillion nirik pbrobinson pingou sharkcz tyll
15:33:51 <dgilmore> #topic init process
15:33:56 <dgilmore> who is her
15:33:58 <dgilmore> here
15:34:01 <nirik> morning
15:34:04 * sharkcz is here
15:34:06 <maxamillion> .hello maxamillion
15:34:07 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:34:08 * nirik runs to get a cup of coffee
15:36:17 * pbrobinson is sort of here
15:38:24 <dgilmore> lets get started
15:38:37 <dgilmore> there is no tickets with meeting keyword
15:38:48 <dgilmore> we really need to go through the open tickets soon
15:38:59 <dgilmore> #topic Secondary Architectures updates
15:38:59 <dgilmore> #topic Secondary Architectures update - ppc
15:39:05 <dgilmore> pbrobinson: how is ppc?
15:39:16 <pbrobinson> fine
15:39:23 <pbrobinson> rebuild is done
15:39:29 <pbrobinson> pungi4 is running nightly OK
15:39:37 <pbrobinson> got a few fixes to do this week
15:39:44 * masta is here
15:39:46 <pbrobinson> and to add some other bits
15:39:57 <pbrobinson> other than that it's looking reasonably good
15:41:09 <dgilmore> cool
15:41:26 <dgilmore> and other than the hub infra is all done?
15:41:32 <pbrobinson> yep
15:41:47 <pbrobinson> so hub will be rebuilt post alpha
15:41:51 <dgilmore> awesome
15:41:59 <pbrobinson> and I'll be reinstalling all the power8 boxes too
15:42:11 <dgilmore> have we started to look at teh shared koji-shadow box yet?
15:42:15 <pbrobinson> but that's all just ansible so that's just standand and no outage
15:42:40 <pbrobinson> I have a sort of shared shadow box running but not in Fedora infra yet. sort of a prototype
15:42:53 <pbrobinson> post alpha I'll be dealing with that properly as well
15:43:14 <dgilmore> awesome
15:43:25 <dgilmore> #info ppc is moving along well
15:43:49 <dgilmore> #info ppc infra is all in ansible except for the hub (It will be done post alpha)
15:44:04 <dgilmore> #topic Secondary Architectures update - s390
15:44:10 <dgilmore> sharkcz: how is s390?
15:44:42 <pbrobinson> so it's OK
15:44:44 <sharkcz> except pungi4 we are looking good, largely up-to-date with f24/f24-updates-testing, f25 builds have also started
15:45:03 <pbrobinson> I want to move over to a pungi4 Everything only compose soon
15:45:18 <pbrobinson> but I'll work with sharkcz to deal with that soon
15:45:29 <sharkcz> ok, to have the repos soon
15:45:37 <pbrobinson> yep
15:46:11 <dgilmore> as a short term thing we should be able to turn off building installable media
15:46:21 <dgilmore> but we will need to find an answer for that
15:46:42 <pbrobinson> yes, going to work with sharkcz post alpha
15:46:48 <sharkcz> ack
15:47:35 <pbrobinson> so pungi4 for s390 will be a two phase approach with 1 RSN and 2 a little later
15:48:15 <sharkcz> right, for beta we want to have it somehow solved
15:48:26 <pbrobinson> yep
15:48:47 <dgilmore> #info s390 builds going well
15:48:55 <pbrobinson> I have some ideas on that, post alpha I'll have some breathing room to test my theoryies
15:49:01 <dgilmore> #info we need to find an answer for building install media
15:49:42 <dgilmore> sharkcz: do we have qemu or hercules docs somewhere?
15:49:57 <dgilmore> and does one of them work better than another?
15:50:10 <dgilmore> if I wanted to setup something in my test environment at home?
15:50:20 <sharkcz> dgilmore: dunno how well can qemu do s390 umaltion, but for hercules we have something on my blog
15:50:41 <sharkcz> s390 emulation
15:51:29 <sharkcz> http://sharkcz.livejournal.com/12268.html
15:52:20 <dgilmore> sharkcz: okay, I thought I read somewhere that qemu-system-s390x was a better way to go
15:52:53 <dgilmore> anyway we can take this out of the meeting
15:53:10 <pbrobinson> dgilmore: yep
15:53:15 <sharkcz> dgilmore: I know qemu does the job well for kvm, but no idea how it does full system emulation
15:53:30 <sharkcz> yep, just ping me if you have questions
15:53:36 <dgilmore> sharkcz: will do
15:53:38 <dgilmore> #topic Secondary Architectures update - arm
15:53:43 <dgilmore> pbrobinson: how is aarch64?
15:53:50 <pbrobinson> good
15:53:56 <pbrobinson> similar status to ppc
15:54:06 <pbrobinson> we have pungi 4 nightly composes
15:54:11 <dgilmore> #info aarch64 is similiar to ppc
15:54:17 <dgilmore> #info pungi4 composes
15:54:32 <dgilmore> pbrobinson: have we tried to do an alpha compose for either?
15:54:33 <pbrobinson> looking to hack in a lmc add a nightly minimal image for it this week
15:54:44 <pbrobinson> dgilmore: tomorrow likely
15:54:51 <dgilmore> cool
15:54:56 <pbrobinson> I was waiting to see what the state of 1.6
15:55:02 <dgilmore> its not good
15:55:15 <pbrobinson> I figured
15:55:30 <dgilmore> was going to do alpha status next
15:55:41 <pbrobinson> I took a few days off pungi4 once I got the nightlies working
15:56:08 <pbrobinson> this week is back to it to clean up a bunch of things on nightlies and look at adding things like qemu/docker/images etc
15:56:15 <pbrobinson> across both ppc/arm
15:56:25 <pbrobinson> and get alpha releases in order
15:56:25 <dgilmore> should not be hard
15:56:36 <pbrobinson> no, it's not, it just needs testing and time
15:56:49 * nirik notes the ppc/arm pungi4 crons are going to root@ still. ;)
15:57:34 <pbrobinson> nirik: yes, I know, it's on my list for this week
15:57:48 <nirik> no worries.
15:57:56 <pbrobinson> nirik: it's erroring out on line 25 for some reason, that line is nothing
15:58:01 <pbrobinson> I've got a few bugs to work out
15:58:16 <nirik> let me know if I can assist any
15:58:23 <pbrobinson> I needed some time out from it all, it was sending me a little more mad that usual last week ;-)
16:01:32 <dgilmore> anything else on arm?
16:02:02 <pbrobinson> nope
16:02:12 <dgilmore> #topic Alpha Status
16:02:28 <dgilmore> so right now we are expecting another compose request
16:02:44 <dgilmore> the background bug was not fixed 100%
16:03:00 <maxamillion> dgilmore: background bug?
16:03:05 <dgilmore> a couple of places needed updating to pull in the new backgrounds
16:03:48 <dgilmore> https://bugzilla.redhat.com/show_bug.cgi?id=1319043
16:04:22 <maxamillion> dgilmore: +1 thanks
16:04:36 <dgilmore> there is a few proposed blockers also
16:04:44 <dgilmore> https://qa.fedoraproject.org/blockerbugs/milestone/24/alpha/buglist
16:04:59 <sgallagh> Blocker bug meeting going on right now in #fedora-blocker-review
16:05:13 <dgilmore> sharkcz: we know
16:05:17 <dgilmore> sgallagh: we know
16:05:20 <dgilmore> shorry sharkcz
16:06:03 <dgilmore> One thing I really do not like about the new compose process
16:06:17 <dgilmore> I have to edit the config every time we do a compose
16:06:29 <maxamillion> dgilmore: really?
16:06:31 <maxamillion> dgilmore: why so?
16:06:33 <dgilmore> I will have to file some RFE's so we can not do that
16:06:41 <maxamillion> +1
16:06:45 <maxamillion> that does not sound ideal
16:07:14 <dgilmore> maxamillion: see https://pagure.io/pungi-fedora/7e9270e19193d6980b6f8c9968b1c29e51378062 as an example
16:07:28 <maxamillion> dgilmore: ah ... ouch
16:08:06 <maxamillion> dgilmore: I mean ... it kind of makes sense, similar to how packagers have to bump the Release ... but :/
16:08:12 <dgilmore> other than some weird issues with koji tasks though it has been pretty smooth
16:08:39 <maxamillion> that's good
16:08:40 <dgilmore> maxamillion: yeah I think a CLI flag to set it would be better
16:09:05 <maxamillion> +1
16:09:27 <dgilmore> potentially we would also want to set the git hash for spin-kickstarts
16:09:41 <maxamillion> +1
16:09:50 <maxamillion> yeah, I could see that being useful
16:10:41 <dgilmore> still not had much feedback
16:10:53 <dgilmore> oh one other thing
16:11:10 <dgilmore> due to kernel bugs on i386 all 32 bit x86 images are turned off
16:11:33 <dgilmore> we are not making lives or cloud images
16:11:56 <dgilmore> I am going to work this week on some openQA integration
16:12:18 <dgilmore> so we only push composes live after they have passed some amount of automated install testing
16:12:36 <dgilmore> that will include rawhide and possibly branched
16:13:46 <dgilmore> #info no 32 bit x86 images
16:13:59 <dgilmore> #info alpha is going reasonably well
16:14:16 <maxamillion> dgilmore: the openqa integration would be great
16:14:21 <dgilmore> #info looking at gating composes based on openQA results
16:14:25 <nirik> rawhide? that would be adding gating to rawhide composes?
16:14:35 <dgilmore> nirik: yeah
16:14:51 <nirik> cool. I'm on board with that. We could also make sure everything is signed.
16:15:01 <nirik> (well, after we have a f25 key and sign everything)
16:15:01 <dgilmore> right now if rawhide is not installable it fails the compose
16:15:14 <dgilmore> nirik: yeah I need to do that today
16:15:44 <dgilmore> #action dgilmore to make f25 keys
16:16:04 <nirik> dgilmore: we have a hardware box for autosign02... I've done nothign at all with it yet.
16:16:09 <dgilmore> nirik: so I figure if the compose has to be installable, lets make sure it works
16:16:29 <dgilmore> nirik: yeah we should sit down and figure the pieces out for that
16:16:41 <nirik> yep. so much to do, so little time.
16:16:47 <dgilmore> since we will need some dev work to enable signing requests
16:17:08 <dgilmore> so we can sign repo metadata etc
16:17:31 * nirik nods.
16:17:32 <dgilmore> anyway that is it from me for alpha
16:18:07 <dgilmore> #topic open floor
16:18:15 * sharkcz has 3 items
16:18:16 <dgilmore> does anyone want to bring something up?
16:18:22 <dgilmore> sharkcz: the floor is yours
16:18:22 <nirik> lmacken: you make any progress with faster composes for bodhi?
16:19:25 <sharkcz> 1st - the empty buildroot info - I was updating s390 builders, saw the same issue, but at the end it seems that a missing restart o fkojid was the culprit, now the builders work fine with latest f23 rpm and koji from the infra repo
16:19:44 <nirik> huh. weird.
16:19:44 <sharkcz> would be great if someone could confirm that on the staging koji
16:20:05 <dgilmore> sharkcz: weird
16:20:10 <sharkcz> I agree
16:20:47 <dgilmore> sharkcz:  I need to do some work on stg koji today
16:20:52 <dgilmore> I will do some testing
16:21:38 <sharkcz> dgilmore: thx, I havent' checked the koji spec, but if I did explicit "systemdctl restart kojid", it started to work correctly
16:22:26 <sharkcz> 2nd - for the weak deps - I'm working with the dnf guy, so hopefully it will start moving ahead too (bug 1300669)
16:22:46 <dgilmore> sharkcz: koji used to restart on upgrade, but that stoped happening with teh move to systemd
16:23:08 <dgilmore> sharkcz: I need to follow up with tibbs|w about what the policy should be
16:23:38 <dgilmore> #action dgilmore follow up with tibbs on the fpc ticket for how weak deps should be handled in the buildroot
16:23:39 <sharkcz> dgilmore: ok, and what exceptions are allowed
16:23:42 <tibbs|w> dgilmore: I think everything FPC had to add was in that ticket.
16:23:51 <sharkcz> ah, it was for weak deps
16:24:19 <dgilmore> tibbs|w: which ticket?
16:24:27 <dgilmore> I went looking last week and couold not find it
16:24:49 <tibbs|w> Didn't you file one for the FPC?  I went on vacation and now I can't remember the state of things.
16:25:00 <sharkcz> dgilmore: my goal is to confirm with the dnf guys that all arches behave correctly and the same
16:25:03 <dgilmore> tibbs|w: I do not know
16:25:13 <tibbs|w> OK, I'll try to swap all of that back in.
16:25:51 <sharkcz> their functional testing was limited to x86
16:25:53 <tibbs|w> I do remember we talked about it and basically the thing is that if you really need something in order to build, you had damn well not depend on anything following weak deps.
16:26:07 <dgilmore> tibbs|w: maybe I forgot to file a ticket
16:26:09 <tibbs|w> That's really the only thing that makes sense.
16:26:25 <dgilmore> tibbs|w: that is fine.
16:26:28 <tibbs|w> I know there was some FPC discussion at least.  I will try to dig it up.
16:26:37 <dgilmore> thanks
16:26:55 <dgilmore> sharkcz: :(
16:27:05 <dgilmore> sharkcz: we will figure out what we should be doing
16:27:20 <dgilmore> but I suspect that it will be making sure weakdeps is turned off
16:27:47 <dgilmore> sharkcz: what was the third thing?
16:28:29 <sharkcz> last is integrating srpm-excluded-arch.py back to the compose/mash process so we have up-to-date list for koji-shadow
16:28:42 <dgilmore> sharkcz: it is, its just not quite right
16:28:47 <dgilmore> it is producing empty files
16:28:54 <sharkcz> ah
16:29:32 <dgilmore> https://kojipkgs.fedoraproject.org/compose/branched/Fedora-24-20160321.n.0/logs/
16:29:43 <dgilmore> the excludearch files there
16:30:00 <dgilmore> critpath needs fixing also
16:30:03 <sharkcz> I see
16:30:32 * linux-modder super  late sorry
16:31:01 <dgilmore> #info there is some fixes that need to be made in compose scripts, patches welcome
16:31:07 <dgilmore> linuxmodder: almost done :)
16:31:12 <dgilmore> but welcome
16:32:10 <dgilmore> does anyone have anything else for open floor?
16:33:16 <dgilmore> okay lets wrap up
16:33:20 <dgilmore> #endmeeting