17:01:24 <jzb> #startmeeting Fedora Cloud Working Group
17:01:24 <zodbot> Meeting started Wed Mar 23 17:01:24 2016 UTC.  The chair is jzb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:24 <zodbot> The meeting name has been set to 'fedora_cloud_working_group'
17:01:30 <dustymabe> .hellomynameis dustymabe
17:01:31 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:01:32 <jzb> oh
17:01:34 <jzb> er, OK
17:01:41 <jzb> .hellomynameis jzb
17:01:42 <rtnpro> .fas rtnpro
17:01:42 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:01:45 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:01:46 <trishnag> .hello trishnag
17:01:47 <scollier> .hello scollier
17:01:47 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:01:50 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
17:02:13 <maxamillion> .hello maxamillion
17:02:14 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:02:28 <tflink> .hello tflink
17:02:29 <bexelbie> .hello bex
17:02:29 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
17:02:32 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
17:03:22 <jzb> it will take me a minute to get organized,
17:03:37 <jzb> wasn't planning on running the meeting today, but came back from lunch to pleas :-)
17:03:37 <jberkus> back, sorry
17:03:47 <jberkus> cat knocked over a whole carafe of iced coffee
17:03:54 <jberkus> .hello jberkus
17:03:55 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:03:56 <jzb> #chair jberkus bexelbie tflink scollier trishnag kushal dustymabe
17:03:56 <zodbot> Current chairs: bexelbie dustymabe jberkus jzb kushal scollier tflink trishnag
17:04:04 <dustymabe> jzb: :)
17:04:14 <imcleod> .hello imcleod
17:04:15 <zodbot> imcleod: imcleod 'Ian McLeod' <imcleod@redhat.com>
17:04:19 <jbrooks> .hello jasonbrooks
17:04:20 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:04:21 <dustymabe> that reminds me that I haven't had lunch :)
17:04:34 <jzb> #chair imcleod jbrooks
17:04:35 <zodbot> Current chairs: bexelbie dustymabe imcleod jberkus jbrooks jzb kushal scollier tflink trishnag
17:04:46 <gholms> Aaand now I'm hungry, too.  :/
17:05:16 <jzb> let's start with the most urgent ticket (AFAIK)
17:05:24 <jzb> #topic Fedora Cloud FAD
17:05:32 <jzb> this is ticket 115
17:05:42 <jzb> #info https://fedorahosted.org/cloud/ticket/115
17:06:03 <jzb> dustymabe: any updates?
17:06:31 <dustymabe> jzb: none from me. I believe kushal was working on updating the proposal
17:06:47 <dustymabe> kushal: are you back yet?
17:07:00 <dustymabe> we may come back to this at the end when kushal is back
17:07:22 <jzb> k
17:07:25 <jzb> moving on
17:08:00 <jzb> #topic Document process for using Fedora-Dockerfile branches
17:08:07 <jzb> #info https://fedorahosted.org/cloud/ticket/123
17:08:14 * scollier looks
17:08:15 <jzb> scollier: I don't see an owner for this
17:08:24 <jberkus> FAD looks fairly together, do we need anything else on it?
17:08:26 <jzb> scollier: but I'm going by the "you touched it last" theory and asking if you have an update :-)
17:08:42 <scollier> jzb, i just need to delete the branches.  will do before this meeting is over and update ticket.
17:09:19 <jzb> scollier: and the instructions are found in the CONTRIBUTING file now?
17:09:54 <scollier> jzb, i will have to look, but if there are, they need to be removed, as we aren't using f2x branches anymore.
17:10:12 <scollier> jzb, only master, now that f21 is deprecated.
17:10:46 <jzb> scollier: ah. Where does one find the "how I contribute" instructions now?
17:10:54 <jzb> apologies if I missed in the ticket, just skimming.
17:11:50 <scollier> jzb, i need to write those up. we don't have a contributing.md yet.
17:11:53 <scollier> jzb, i will do.
17:12:43 <jzb> scollier: ack. Thanks!
17:12:59 <jzb> #action scollier to write up a CONTRIBUTING.md doc for contributing to the Fedora Dockerfiles
17:13:17 <jzb> scollier: thanks!
17:13:33 <jzb> going to switch gears slightly and look at action items from last meeting.
17:13:42 <jzb> #topic action items from 9 March 2016 Meeting
17:14:03 <jzb> maxamillion: I have an action for you to write an SOP for the two-week Atomic release.
17:14:28 <jzb> maxamillion: is that done, in progress, or to be started?
17:14:42 <maxamillion> jzb: done https://docs.pagure.org/releng/sop_two_week_atomic.html
17:15:33 <jzb> maxamillion: excellent!
17:16:01 <jzb> #info 2WA SOP written by maxamillion here: https://docs.pagure.org/releng/sop_two_week_atomic.html
17:16:12 <jzb> that's awesome, thanks much
17:16:15 <jzb> maxamillion++
17:16:15 <zodbot> jzb: Karma for maxamillion changed to 14 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:16:20 <maxamillion> :)
17:16:20 <dustymabe> maxamillion++
17:16:21 <scollier> there should be a badge for doing something ontime.
17:16:35 <jzb> scollier: agreed
17:16:36 <scollier> i'd never get one, but there should be one.
17:16:47 <jzb> scollier: we could admire it from afar.
17:17:13 <jzb> kushal: if you've returned, we also have an action from 9 March
17:17:28 <jzb> release an updated Cloud image based on 2016-03-09 F23 compose
17:17:34 <jzb> anybody know if this has been completed?
17:17:39 * jzb should know this...
17:18:48 <dustymabe> jzb: not that I know of
17:18:55 <bexelbie> jzb, not done per getfedora.org
17:19:09 <dustymabe> kushal seemed optimistic about it
17:19:19 <dustymabe> but I haven't seen anything
17:19:38 <jzb> #action kushal Report on progress about F23 Cloud Image update from 2016-03-09 compose (or later)
17:19:42 <jzb> moving on
17:19:56 <jzb> back to tickets
17:20:05 <jzb> #topic Fedora-Dockerfiles examples for kubernetes
17:20:23 <jberkus> is there a ticket for that?
17:20:27 <jzb> looks like this was updated last by dustymabe a few weeks ago
17:20:35 <jzb> #info https://fedorahosted.org/cloud/ticket/125
17:20:43 <jzb> jberkus: ^^ yes
17:21:11 <jberkus> I'll take that one.  Where can I get my hands on an FAH with Kubernetes 1.2?
17:21:54 <jzb> jberkus: feel free to grab the ticket
17:22:04 <jberkus> I was just at the Docker Birthday last night and was thinking we should re-do the Docker Tutorial as Kube
17:22:16 <jzb> #action jberkus Fedora-Dockerfiles examples for Kubernetes (ticket #125)
17:22:37 <jzb> jberkus: is k8s 1.2 packaged for Fedora + in stable?
17:22:51 <jberkus> probably not
17:23:10 <jberkus> but it's frankly a gating factor on doing any useful demo apps
17:23:39 <jzb> jberkus: is 1.2 actually released ?
17:23:47 <jberkus> yes, as of March 17
17:24:09 <misc> mhh even in f2', that's still a snapshot
17:24:12 <misc> 24
17:24:53 <jzb> yeah, that's a bit newish to have made it into stable
17:24:55 <jberkus> anyway, let's have that discussion after the meeting
17:25:09 <jzb> jberkus: I'm going to bet that if I look 1.2 may be packaged and patiently awaiting karma
17:25:55 <jzb> ok
17:26:25 <jzb> #topic make docker archived image get imported with lowercase tag
17:26:33 <jzb> #info https://fedorahosted.org/cloud/ticket/131
17:26:38 <jzb> imcleod: this has yer name on it.
17:27:10 <imcleod> jzb: New imagefactory and imagefactory-plugin builds that address this are in updates-testing for f23, f24, epel6 and epel7
17:27:39 <dustymabe> hey guys.. sorry I am having connection issues
17:28:32 <jzb> imcleod: updated the ticket
17:28:41 <imcleod> jzb: Thanks.  Apologies, should have done that myself.
17:28:51 <jzb> imcleod: should we consider this solved or is there more to do to complete the mission?
17:29:06 <dustymabe> jberkus: jzb: we have been testing alpha releases of 1.2 as we go- I don't know if 1.2 final is packages up yet or not
17:29:17 <imcleod> jzb: Well... it will need to be karmaed and promoted, and then installed on the builders, so there's more to do.
17:29:42 <misc> dustymabe: there is no build in bodhi as of 5 minutes ago
17:29:44 <imcleod> jzb: These updates also have some changes that rel-eng need for other things, mainly secondary and non-x86 arch support for image building, including docker base images.
17:29:54 <jzb> imcleod: so this will happen naturally?
17:30:00 <imcleod> jzb: Heh.
17:30:09 <imcleod> jzb: Organically?
17:30:28 <imcleod> jzb: I'll try to facilitate some testing and the rel-eng roll out.  maxamillion, can you help as well?
17:30:39 <jberkus> dustymabe: well, this is another reason for an FAH CI build, no?
17:30:46 <dustymabe> misc: https://bodhi.fedoraproject.org/updates/?packages=kubernetes
17:31:05 <misc> dustymabe: of 1.2 stable ?
17:31:09 <maxamillion> imcleod: what?
17:31:15 <dustymabe> misc: no
17:31:24 <misc> dustymabe: so yeah, we agree, i was just not precise :)
17:31:24 <dustymabe> we have to talk to jchaloup about that
17:31:30 <maxamillion> imcleod: oh, uhmmm ... yeah, I'll see what I can do
17:32:09 <imcleod> maxamillion: Cheers. :-) - I've already given dgilmore and pbrobinson a heads up on this as well.
17:32:52 <jberkus> feh, Adam just let us know that the 2-week release is delayed by a releng breakdown
17:33:04 <jzb> jberkus: IIRC we do have an updates-testing FAH build
17:33:06 <maxamillion> indeed I did
17:33:20 <maxamillion> http://maxamillion.sh/ThisIsFine.jpg
17:33:24 <dustymabe> jzb: we have the updates-testing tree
17:33:26 <jzb> you can rebase on that, I know that walters has sent info on that to cloud@
17:33:31 <dustymabe> which you can easily rebase to
17:33:46 <jzb> dustymabe: "easily" == it's actually documented on a page somewhere mortals can find?
17:33:49 <dustymabe> http://dustymabe.com/2015/06/23/fedora-22-updates-testing-atomic-tree/
17:33:49 <jzb> :-)
17:33:50 <jberkus> jzb: WFM, that's just what those kinds of builds are for
17:34:03 <dustymabe> just replace F22 with F23
17:34:13 <dustymabe> jzb: it's on some other page as well (a fedora wiki)
17:34:18 <jzb> dustymabe: could we put that documentation somewhere "official"?
17:34:19 <jzb> ok
17:34:20 <dustymabe> I just know that page better?
17:34:30 <dustymabe> s/?/./
17:34:41 <jzb> #action jzb put updates-testing info somewhere more prominent.
17:35:03 <jzb> imcleod: any actions we need to assign to you?
17:35:11 <dustymabe> jzb: https://fedoraproject.org/wiki/QA:Updates_Testing
17:35:20 <imcleod> jzb: Wrangle karma for Factory updates?
17:35:22 <dustymabe> its on that page ^^ needs updating though
17:35:40 <jzb> dustymabe: thanks
17:36:01 <jzb> #action imcleod wrangle karma for Factory updates (Ticket 131)
17:36:45 <jzb> #topic Vagrant Boxes Fixups
17:36:49 <jzb> #info http://maxamillion.sh/ThisIsFine.jpg
17:36:53 <jzb> d'oh
17:36:56 <jzb> #undo
17:36:56 <zodbot> Removing item from minutes: INFO by jzb at 17:36:49 : http://maxamillion.sh/ThisIsFine.jpg
17:37:06 <jzb> #info https://fedorahosted.org/cloud/ticket/136
17:37:08 <jzb> ok
17:37:24 <jzb> dustymabe: this is still tagged with "meeting" - should it be?
17:37:34 <jzb> it's neither owned nor do I think it's really urgent anymore.
17:37:38 <jzb> or a going concern.
17:37:43 <maxamillion> jzb: :)
17:37:56 <dustymabe> jzb: well it would have been nice to get some of those suggestions in for F24
17:38:18 <dustymabe> I'm of the belief that if it doesn't have the meeting tag then it will never get looked at again
17:38:30 <dustymabe> I don't think there is anybody going through old tickets
17:38:47 <jzb> dustymabe: but if it has the meeting tag, it just gets brought up, we all say "totally should look at that someday" and ...yeah :-)
17:38:54 <imcleod> jzb, dustymabe: Actually, I can add something to that.  We had someone suggest configuring the boxes with very large virtual disks and then modifying the kickstarts to initially set up only the existing 40 GB of filesystems.
17:38:55 <jzb> dustymabe: we can assign it to someone or action it
17:39:33 <imcleod> Because the underlying disks are all COW-type formats, this has no actual space penalty but allows power users to expand the filesystems at runtime if they wish.
17:39:59 <imcleod> jzb: You can assign it to me.  I'm in that code at the moment anyway and have been meaning to experiment with this.
17:40:08 <dustymabe> imcleod++
17:40:08 <zodbot> dustymabe: Karma for imcleod changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:41:19 <jzb> imcleod: OK
17:41:36 <jzb> #action imcleod take ticket 136 on vagrant file fixups
17:42:31 <jzb> #topic Produce updated cloud base images monthly
17:42:38 <jzb> #info https://fedorahosted.org/cloud/ticket/138
17:42:45 <jzb> also unassigned
17:42:48 <kushal> back
17:42:50 <jzb> last updated by dustymabe
17:42:54 <jzb> dustymabe: do we need this one still?
17:42:54 <kushal> That should be assigned to me
17:43:11 <kushal> I could not find out all the steps required to get an updated release out :(
17:43:23 <dustymabe> kushal: what did you find out?
17:43:34 <jzb> #info assigned ticket 138 (produce updated cloud base images monthly) to kushal
17:44:24 <kushal> dustymabe, we will have to file a ticket to rel-eng so that they can sign the checksums, and put the images to a proper place. But I still have to find out how to get the websites updated, and how to find the corresponding AMI details which also need update
17:46:17 <jzb> kushal: for website talk to Amanda Carter
17:46:32 <jzb> she sort of led the charge there, and I think she can point us/you in the right direction.
17:46:33 <kushal> jzb, even for cloud base image?
17:46:37 <kushal> Okay
17:47:38 <jzb> kushal: might be threebean
17:47:40 <dustymabe> kushal: did we file the tickets with releng?
17:49:05 <kushal> dustymabe, nope, first I had to find out what all needs to be done
17:50:37 <dustymabe> ok so just circling back.. we think we have some of the steps figured out to do this
17:50:43 <dustymabe> but we haven't quite got it done yet
17:50:48 <jzb> ok
17:50:51 <dustymabe> when is the schedule for F24?
17:51:04 <dustymabe> is it too late now to even try to do the updated release of F23?
17:51:06 <jzb> dustymabe: I think they're doing go/no-go today
17:51:15 <dustymabe> jzb: for alpha?
17:51:19 <dustymabe> not for Final
17:51:27 <kushal> dustymabe, Nope, as we have to release for the CVEs
17:51:49 <dustymabe> kushal: well we don't have too. we'd like to
17:52:05 <dustymabe> its not like they are respinning fedora ISO media or anything for the CVEs
17:52:24 <jzb> dustymabe: right
17:52:35 <dustymabe> I think we should put a time limit on this
17:52:53 <dustymabe> if we can't get it out sooner than later then there is really no point in working on it
17:53:19 <jzb> dustymabe: well, we need to figure out steps and get this to a routine right?
17:53:27 <jzb> so it may be worth doing regardless, but yes sooner is better.
17:53:45 <dustymabe> jzb: assuming we are going to release cloud images monthly then yes
17:53:55 <dustymabe> but I think it should really follow the 2 week atomic process
17:54:00 <jzb> dustymabe: +1
17:54:00 <dustymabe> except on a 4 week cadence
17:54:44 <dustymabe> so we "should" be already figuring out a process for releasing updated images in a streamlined fashion
17:54:51 <dustymabe> I believe
17:55:30 <jzb> yes
17:55:31 <dustymabe> ok, maybe we should move on
17:55:41 <jzb> any actions left here?
17:56:08 <jzb> #topic Proposals for F24 features
17:56:16 <jzb> #info https://fedorahosted.org/cloud/ticket/143
17:56:32 <jzb> This one's mine. Still on it - still finishing up talking points.
17:56:37 <jzb> nothing further to report, really.
17:57:05 <jzb> #topic Don't overwrite download location for 2 week atomic images
17:57:21 <jzb> #info https://fedorahosted.org/cloud/ticket/147
17:57:28 <dustymabe> maxamillion: ^^
17:57:35 <jzb> according to the last update I think this is pretty much ready to cycle out
17:57:41 <jzb> maxamillion: do we need to keep meeting tagged for this?
17:58:05 <maxamillion> sorry, I'm also on a call
17:58:17 <maxamillion> yeah, that's still on the roadmap ... just don't have time
17:58:34 <maxamillion> we need to fix some things first, which I thought would be done by now but they aren't
17:58:41 <jzb> maxamillion: OK
17:58:55 <jzb> #action maxamillion continue on ticket 147
17:59:08 <jzb> ok
17:59:15 <jzb> we're 1 minute away from end of meeting
17:59:20 <jzb> I don't think any of the other tickets are huge
17:59:23 <jzb> #open floor
17:59:26 <jzb> d'oh
17:59:30 <jzb> #topic Open Floor
17:59:39 <jzb> any open floor issues we can't go a week without discussing?
17:59:43 <dustymabe> fedora-motd
17:59:51 <dustymabe> we need to get that in for F24
17:59:51 <jzb> kushal: we still had an open Q about FAD, too
17:59:58 <jzb> dustymabe: I thought it was?
18:00:09 <dustymabe> well the package is created and all
18:00:17 <dustymabe> but we need to get it in to the kickstarts
18:00:24 <dustymabe> so that it is included in the images
18:00:37 <dustymabe> I tested it myself for rtnpro
18:00:55 <dustymabe> but I don't have the bandwidth to push the patches to the kickstarts and make sure the builds come out right
18:01:03 <rtnpro> dustymabe++
18:01:06 <dustymabe> so having someone help with that would be nice
18:01:53 <rtnpro> dustymabe, I will ping kushal to help us with this
18:02:03 <jzb> I was going to say, sounds like kushal
18:02:30 * rtnpro wonders why the spin-kickstarts repo is not on pagure
18:02:53 <jzb> any other topics this week?
18:02:55 <jzb> going once...
18:02:56 <rtnpro> pushing the patch would have been as easy as sending a PR and someone accepting it
18:03:02 <dustymabe> kushal: do you think you can help with that?
18:03:37 <kushal> dustymabe, I can, but right now busy with many firefighting
18:04:18 <dustymabe> kushal: thanks!
18:04:37 <bexelbie> kushal, I remain interested in helping if it is useful
18:04:43 * bexelbie was on the phone :(
18:04:46 <dustymabe> bexelbie++
18:04:46 <zodbot> dustymabe: Karma for bex changed to 3 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:04:55 <jzb> ok
18:05:03 <jzb> going to close it out, discussion can continue
18:05:17 <jzb> #endmeeting