17:01:17 <kushal> #startmeeting Cloud WG
17:01:17 <zodbot> Meeting started Wed Mar 30 17:01:17 2016 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:17 <zodbot> The meeting name has been set to 'cloud_wg'
17:01:24 <kushal> #topic Roll Call
17:01:28 <jberkus> .hello jberkus
17:01:29 <dustymabe> .hellomynameis dustymabe
17:01:29 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:01:32 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:01:33 <kushal> .hellomynameis kushal
17:01:35 <roshi> .hello roshi
17:01:35 <rtnpro> .fas rtnpro
17:01:38 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:01:41 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:01:43 <dustymabe> roshi!!!!!!!!!!!!!!!!!!!!
17:01:44 <chandankumar> .hello chandankumar
17:01:44 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:01:47 <zodbot> chandankumar: chandankumar 'Chandan Kumar' <chkumar246@gmail.com>
17:01:51 <dustymabe> roshi++
17:01:51 <zodbot> dustymabe: Karma for roshi changed to 5 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:01:57 <roshi> :D how's it going?
17:02:04 <dustymabe> glad to see you
17:02:06 * roshi thought he'd drop back in for a bit :)
17:02:13 <bexelbie> .hello bex
17:02:14 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
17:02:17 <roshi> see how things are going
17:02:24 <kushal> roshi, Hi there :)
17:02:25 <roshi> glad to be seen :)
17:02:34 <kushal> roshi, welcome back :)
17:02:38 <roshi> (and have confirmation that I'd be remembered :p)
17:02:40 <roshi> thanks
17:02:58 <kushal> #chair jberkus dustymabe rtnpro roshi chandankumar bexelbie
17:02:58 <zodbot> Current chairs: bexelbie chandankumar dustymabe jberkus kushal roshi rtnpro
17:03:07 <kushal> Anyone else?
17:03:11 <tflink> .hello tflink
17:03:12 <dustymabe> roshi: you have been sorely missed
17:03:13 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
17:03:18 <kushal> #chair tflink
17:03:18 <zodbot> Current chairs: bexelbie chandankumar dustymabe jberkus kushal roshi rtnpro tflink
17:03:59 <kushal> I guess we can start
17:04:04 <roshi> glad to hear it :)
17:04:09 <kushal> #topic Action items from last meeting
17:04:24 <kushal> * scollier to write up a CONTRIBUTING.md doc for contributing to the
17:04:24 <kushal> Fedora Dockerfiles
17:04:24 <kushal> * kushal Report on progress about F23 Cloud Image update from 2016-03-09
17:04:24 <kushal> compose (or later)
17:04:24 <kushal> * jberkus Fedora-Dockerfiles examples for Kubernetes (ticket #125)
17:04:25 <kushal> * jzb put updates-testing info somewhere more prominent.
17:04:26 <maxamillion> .hello maxam
17:04:27 <kushal> * imcleod wrangle karma for Factory updates (Ticket 131)
17:04:27 <zodbot> maxamillion: maxam 'None' <maxamaxim@me.com>
17:04:27 <maxamillion> .hello maxamillion
17:04:29 <kushal> * imcleod take ticket 136 on vagrant file fixups
17:04:30 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:04:31 <kushal> * maxamillion continue on ticket 147
17:04:33 <kushal> #chair maxamillion
17:04:33 <zodbot> Current chairs: bexelbie chandankumar dustymabe jberkus kushal maxamillion roshi rtnpro tflink
17:05:03 <jberkus> nothing new on #125 yet
17:05:10 <kushal> Rest of last week (after meeting), and Monday I was on leave
17:05:37 <kushal> so no could not work on updated image.
17:05:46 <dustymabe> jzb: here today?
17:05:50 <kushal> But I have updated the wiki page for FAD, we need the budget details.
17:06:24 <jzb> dustymabe: I are
17:06:28 <jzb> sorry
17:06:29 <kushal> jzb, Hello :)
17:06:37 <jzb> .hellomynameis jzb
17:06:37 <kushal> dustymabe, you have magic in your pings :)
17:06:37 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:06:40 <kushal> #chair jzb
17:06:40 <zodbot> Current chairs: bexelbie chandankumar dustymabe jberkus jzb kushal maxamillion roshi rtnpro tflink
17:06:47 <kushal> #chair imcleod
17:06:47 <zodbot> Current chairs: bexelbie chandankumar dustymabe imcleod jberkus jzb kushal maxamillion roshi rtnpro tflink
17:07:02 <jberkus> kushal: what will it take to get the budget details?
17:07:32 <kushal> jberkus, who ever will require to fly in and need budget for the same, have to fill that up in the wiki
17:07:34 <kushal> including me
17:07:37 <kushal> * imcleod wrangle karma for Factory updates (Ticket 131)
17:07:37 <kushal> * imcleod take ticket 136 on vagrant file fixups
17:07:47 <kushal> imcleod, ^^ we are discussing action items from the last meeting
17:07:51 <jberkus> kushal: consider yourself harassed for cost figures
17:07:55 <jberkus> kushal: am I ordering food?
17:08:07 <imcleod> kushal: Apologies - will have to lurke at the moment - am on a phone meeting - can you come back to me?
17:08:15 <kushal> imcleod, Yes, no problem.
17:08:26 <kushal> jberkus, who ever can pay :)
17:08:30 <kushal> I can not :)
17:08:47 <kushal> jberkus, I hope you have an official credit card
17:08:55 <kushal> jberkus, or we have to ping jzb :)
17:09:00 <jberkus> well, there's paying, and there's arranging
17:09:06 <jberkus> whcih are two separate tasks
17:09:19 <kushal> jberkus, Yes
17:09:31 <dustymabe> and you should only say you
17:09:49 <dustymabe> "need travel funding" if the money needs to come from the fedora budget right
17:09:54 <kushal> jberkus, if you can do the both, that will be awesome
17:10:01 <jzb> how many people are we looking at currently?
17:10:01 <dustymabe> if you can get someone else to pay for it then you should answer "no" to that question?
17:10:12 <jzb> are we even looking at more than $500 at this point for catering/food?
17:10:14 <kushal> dustymabe +1 to that
17:10:37 <kushal> jzb, I just filled in from a previous FAD in the same place
17:10:41 <kushal> food total that is
17:10:47 <jberkus> jzb: 8 to 12
17:11:07 <jberkus> jzb: probably not
17:11:08 <fhackdroid> .hellomynameis farhaan
17:11:10 <zodbot> fhackdroid: farhaan 'Farhaan Bukhsh' <farhaan.bukhsh@gmail.com>
17:11:19 <jberkus> I think only lunch/coffee is covered in the FAD budget
17:11:19 <jzb> jberkus: is it two or three days?
17:11:22 <jberkus> jzb: 2
17:11:35 <kushal> We still have 9 names in the list
17:11:43 <kushal> #chair fhackdroid
17:11:43 <zodbot> Current chairs: bexelbie chandankumar dustymabe fhackdroid imcleod jberkus jzb kushal maxamillion roshi rtnpro tflink
17:11:46 <jberkus> kushal: I'll need to harass people about food preferences too ...
17:12:00 <jzb> Let's say 12 people, two meals per day, two days, that's 48 meals
17:12:08 <jzb> guessing $15 per person per meal
17:12:12 <kushal> jzb, Yes
17:12:24 <kushal> 720
17:12:44 <jzb> so there's our food budget, round up to $750
17:12:57 <kushal> jzb, I have 850 there already I guess
17:12:58 <kushal> :)
17:13:03 <jzb> OK
17:13:38 <kushal> We will have to find details for hotel + travel
17:14:13 <jberkus> seems good.  Jzb, I'll need advice on catering vendors for Raleigh
17:14:26 <jberkus> assumign we want food in, instead of just breaking for the cafeteria
17:14:37 <kushal> I think I will mark the topic as the first ticket
17:14:56 <kushal> #topic Fedora Cloud FAD  https://fedorahosted.org/cloud/ticket/115
17:15:06 <kushal> Because this what we are discussing anyway :)
17:16:06 <kushal> tflink, said most probably he will be able to come down.
17:16:22 <tflink> budget will be the issue for me
17:16:32 <kushal> tflink, we should be able to help you with that part.
17:16:33 <tflink> I doubt that I'll have travel budget from my team for it
17:16:57 <jzb> tflink: where are you located?
17:19:29 <tflink> jzb: CO, usa
17:20:05 <jzb> jberkus: there's a page on Mojo about ordering catering
17:20:24 <jzb> tflink: ok, so it's not like international travel.
17:20:40 <tflink> nope
17:21:06 <jberkus> jzb: have a link?
17:21:38 <jzb> jberkus: not off hand. Mojo has search :-)
17:21:49 <jberkus> ok
17:21:51 <kushal> Can we move to next ticket?
17:23:35 <kushal> #topic Fedora-Dockerfiles examples for Kubernetes https://fedorahosted.org/cloud/ticket/125
17:23:47 <kushal> jberkus, can we continue the action item from last meeting/
17:23:49 <kushal> ?
17:24:43 <jberkus> kushal: I have nothing to report on that; I haven't had a chance to put together examples since last meeting, which is when I took the ticket
17:24:54 <kushal> so adding the action item
17:24:59 <jberkus> yah
17:25:11 <kushal> #action jberkus to update Fedora-Dockerfiles examples for Kubernetes (ticket #125)
17:25:17 <kushal> next ticket
17:25:49 <kushal> #topic make docker archived image get imported with lowercase tag https://fedorahosted.org/cloud/ticket/131
17:26:04 <kushal> #action imcleod wrangle karma for Factory updates (Ticket 131)
17:26:12 <kushal> As he is busy right now.
17:26:13 <kushal> Moving
17:26:37 <kushal> #topic vagrant boxes fixups https://fedorahosted.org/cloud/ticket/136
17:26:49 <kushal> #action  imcleod take ticket 136 on vagrant file fixups
17:27:07 <kushal> #topic Produce updated cloud base images monthly https://fedorahosted.org/cloud/ticket/138
17:27:25 <kushal> #action kushal will work on #138 for updated cloud image.
17:27:37 <kushal> Hoping to get it done this time.
17:28:01 <kushal> #topic Proposals for F24 features https://fedorahosted.org/cloud/ticket/143
17:28:12 <kushal> Any feature owner wants to say something?
17:28:39 <dustymabe> kushal: other than rtnpro fedora cloud motd
17:28:45 <dustymabe> there was openshift origin as well
17:28:47 <dustymabe> maxamillion: ^^
17:28:56 <kushal> dustymabe, openshift was packaged properly iirc
17:29:00 <maxamillion> dustymabe: ?
17:29:12 <dustymabe> kushal: ok then, thats done?
17:29:19 <maxamillion> openshift has been in for a while now ... since December
17:29:41 <kushal> dustymabe, yes :)
17:29:49 <jzb> maxamillion: do we have a use guide for that?
17:30:09 <jzb> maxamillion: I put Origin in the alpha notes, but a "here's how to do it" would not be remiss
17:30:16 <maxamillion> jzb: not other than upstream docs, I added support in the upstream ansible deployment stuff with fedora notes
17:30:30 <jzb> maxamillion: OK, we definitely need that.
17:30:34 <kushal> This can be a good story
17:30:35 <jzb> anybody interested in taking that?
17:30:38 <maxamillion> jzb: https://github.com/openshift/openshift-ansible/blob/master/README_origin.md
17:30:55 <jzb> maxamillion: also, this is RPM - have I asked about doing it as a container?
17:31:31 <maxamillion> jzb: you have not, and I don't plan to work on that until after I get the layered image build service done (which is still the bane of my existance)
17:31:52 <jzb> maxamillion: any idea how long until you're ... unbaned? :-)
17:32:05 <jzb> baneless?
17:32:09 <jzb> bane free?
17:32:25 <kushal> That will take time I think :)
17:32:29 <maxamillion> jzb: no, I thought I was done last November but then docker 1.10 happened and the whole backend system had to be rewritten because universal truths about docker were no longer true
17:32:50 <jzb> ugh
17:32:51 <jberkus> maxamillion: just wait for 1.11
17:32:53 <jzb> OK
17:32:55 <roshi> who needs universal truths :p
17:33:09 <jberkus> maxamillion: API consistency is for sissies
17:33:18 <maxamillion> jzb: there's been a *lot* of code changes to osbs-client, atomic-reactor, and koji-containerbuild to cater to all of this, as well as pulp and friends
17:33:30 <maxamillion> jzb: there's multiple teams working on this, I'm just the Fedora person working on it
17:33:51 <jberkus> maxamillion: should we consider using Google's thing for building containers instead?
17:33:53 <kushal> maxamillion is taking all the heat by himself, and saving us.
17:34:02 <kushal> jberkus, what is that?
17:34:05 <maxamillion> anyhoo ... I won't drivel on about it, tl;dr - no I don't have a good estimate right now, I *hope* by the end of the week I'll have something working but I don't want to claim that and be wrong
17:34:32 <jzb> maxamillion: Yeah, not trying to imply you're not doing all you can or anything, mainly wondering if we can containerize this for F24
17:34:34 <maxamillion> jberkus: no because we can't tie that into koji, the composes, FAS, etc
17:34:44 <maxamillion> jberkus: fedmsg, taskotron, etc etc
17:34:49 <jberkus> ok
17:34:52 <jzb> otherwise we don't have an atomic story, unless we're including the RPMs in host.
17:35:03 <maxamillion> jzb: no, it will not happen for f24 ... the only container we are shipping in f24 will be cockpit
17:35:33 <maxamillion> jzb: this work was scoped and agreed on out months ago
17:35:51 <jberkus> oh, the Google Container Builder is only a cloud service.  I was hoping there was some OSS there
17:35:53 <maxamillion> scoped out and agreed upon*
17:36:06 <maxamillion> jberkus: correct
17:36:19 <maxamillion> jberkus: unfortunate, but correct
17:36:34 <kushal> Moving to next ticket then.
17:36:49 <jzb> maxamillion: doesn't prevent anybody else from trying to make Dockerfiles and whatnot though, yeah?
17:37:06 <kushal> jzb, people can build locally.
17:37:22 <maxamillion> jzb: it doesn't, but we will not ship or host them as an official Fedora deliverable for F24 from a Rel-Eng standpoint
17:38:27 <maxamillion> jzb: they can be on the docker hub though as something from the Fedora Cloud SIG ... there's all sorts of stuff up there as it is
17:38:44 <maxamillion> jzb: I don't see why we can't throw openshift there as well
17:39:02 <jzb> groovy
17:39:15 <maxamillion> jzb: note the package set is titled origin and not openshift because that's the upstream project name
17:39:30 <dustymabe> maxamillion++
17:39:46 * dustymabe is going to write a bot to ++ maxamillion constantly
17:39:50 <jzb> K
17:39:50 <maxamillion> lol
17:39:52 <kushal> hehe
17:39:56 <kushal> maxamillion++
17:39:59 <jzb> dustymabe: I think only one ++ counts
17:40:04 <jzb> maxamillion++
17:40:10 <kushal> jzb, at least people will read
17:40:13 <jzb> yeah, I've already ++'ed him.
17:40:20 <maxamillion> you're all too kind, I feel like I'm just failing constantly and trying to scramble
17:40:55 <jzb> maxamillion: I don't think anyone's ever accused me of being kind.
17:41:00 <dustymabe> maxamillion: i'm faling constantly too
17:41:01 <jzb> but anyway :-)
17:41:05 <dustymabe> failing
17:41:06 <jberkus> maxamillion++
17:41:06 <zodbot> jberkus: Karma for maxamillion changed to 15 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:41:07 <maxamillion> dustymabe: go team!
17:41:08 <jzb> dustymabe: Heh
17:41:09 <kushal> Who does not?
17:41:27 <jzb> shall we put the meeting back on the rails?
17:41:28 <jzb> :_)
17:41:35 <kushal> dustymabe, failing is better than falling
17:41:36 <kushal> #topic Don't overwrite download location for 2 week atomic images https://fedorahosted.org/cloud/ticket/147
17:41:57 <dustymabe> skip. this is on adam's radar
17:42:13 <kushal> So we started looking into the changes required for the autocloud side change, it will take between 6-8 weeks to go on production for compose based test runs.
17:42:43 <kushal> Any questions?
17:42:50 <maxamillion> yeah, I know about it ... we need to get changes done, just have to find the time
17:43:14 <kushal> maxamillion++ to that too :)
17:43:30 <maxamillion> well, don't get all excited until I actually get some work done on it ;)
17:43:44 <kushal> #topic Container "Packager" Guildelines and Naming Conventions https://fedorahosted.org/cloud/ticket/148
17:43:49 <kushal> maxamillion, again you  :)
17:44:18 <roshi> so my question is, did maxamillion know he had ALL THE TICKETS!?
17:44:28 <maxamillion> roshi: I did ... indeed I did
17:44:33 <roshi> or did he just miss a meeting and get voluntold :p
17:44:38 <roshi> ah, lol
17:44:41 <jberkus> kushal: there's docs up here, but they're not linked from anywhere: http://docs.projectatomic.io/container-best-practices/
17:44:50 <maxamillion> I had some people on the line to help with those but they kind of fizzled out, so I'll get to the guidelines asap
17:44:58 <kushal> jberkus, yes, I read that from atomic list
17:45:55 <kushal> maxamillion, want to add yourself into an action item?
17:46:52 <maxamillion> kushal: I can, but I don't know that it'll get done before next time we meet
17:47:03 <kushal> maxamillion, skip it then :)
17:47:06 <maxamillion> +1
17:47:08 <kushal> we will anyway discuss the ticket
17:47:11 <kushal> #topic Docker container refresh cadence https://fedorahosted.org/cloud/ticket/150
17:47:31 <kushal> Should we close it?
17:49:08 <kushal> No one
17:49:14 <kushal> Moving then
17:49:19 <kushal> #topic Open Floor
17:49:26 <kushal> We have 11 minutes :)
17:50:00 <kushal> Anyone anything for Open Floor?
17:50:17 * roshi has nothing
17:50:33 <kushal> roshi, you came back for the meeting, that is a lot to start with :)
17:50:52 <kushal> roshi, we miss you.
17:50:56 <roshi> lol, IRC meetings are easy :)
17:51:01 <jberkus> mattdm, is there anything we need to talk about in terms of nightlies?
17:51:10 <roshi> thanks, I miss being more available :)
17:51:55 <kushal> I have released a new version of Tunir today, lots of refactored codebase, and new features. Will do a blog post tonight.
17:52:34 <roshi> have you finally moved to using an updated testcloud lib?
17:52:38 <dustymabe> any update on atomic in F24?
17:52:52 <roshi> last time I checked, it was a direct copy of some really old, janky testcloud code in there :p
17:53:32 <kushal> roshi, nope, keeping the old idea, but in a cleaner way from the old hacks :)
17:53:56 <jberkus> note added to 2-week cadence; I don't agree that we shouldn't make an extra release for high-risk security fixes
17:53:57 <kushal> roshi, it really started on top of testcloud codebase :)
17:53:59 <dustymabe> also any update on releasing f23 updated image? did I miss that somewhere?
17:54:09 <kushal> dustymabe, I will be working on it this week.
17:54:19 <kushal> dustymabe, last week was mostly leaves etc
17:54:21 * roshi will be happy when our testing is all moved to taskotron and in that one place - less code bases to think about
17:54:41 <kushal> roshi, yes, I am in talk with tflink for the same.
17:54:56 <kushal> Anything else?
17:55:04 <kushal> or can we end the meeting before time?
17:55:04 <roshi> glad to hear it :) it'll be good to get everything migrated
17:55:08 <tflink> i think the current plan is for tunir to work with libtaskotron with no redesign on our part. I'm not crazy about the plan but I have few objections
17:55:16 <tflink> s/our/taskotron's/
17:55:36 <tflink> but i could easily be wrong, some of the discussion has ended up a bit open ended
17:55:49 <kushal> tflink, yes, we will close them with time :)
17:56:23 <tflink> kushal: when we have features due for F25, "closing them with time" isn't of a whole lot of comfort
17:57:07 <kushal> tflink, understood, we can discuss this after meeting.
17:57:14 <tflink> sure
17:57:16 <kushal> Can I just close the meeting?
17:57:21 <kushal> 5
17:57:23 <kushal> 4
17:57:25 <kushal> 3
17:57:28 <kushal> 2
17:57:30 <kushal> 1
17:57:36 <kushal> #endmeeting