17:00:28 <kushal> #startmeeting Cloud WG
17:00:28 <zodbot> Meeting started Wed Apr  6 17:00:28 2016 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:28 <zodbot> The meeting name has been set to 'cloud_wg'
17:00:34 <kushal> #topic Roll Call
17:00:37 <maxamillion> .hello maxamillion
17:00:38 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:00:42 <kushal> .hellomynameis kushal
17:00:44 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:00:45 <number80> .hello hguemar
17:00:48 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:01:03 <jbrooks> .hello jasonbrooks
17:01:04 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:01:11 <kushal> #chair jbrooks number80 maxamillion
17:01:11 <zodbot> Current chairs: jbrooks kushal maxamillion number80
17:01:18 <nzwulfin> .hello mmicene
17:01:19 <zodbot> nzwulfin: mmicene 'Matt Micene' <nzwulfin@gmail.com>
17:01:34 <kushal> #chair nzwulfin
17:01:34 <zodbot> Current chairs: jbrooks kushal maxamillion number80 nzwulfin
17:01:39 <kushal> Anyone else?
17:02:01 <rtnpro> .fas rtnpro
17:02:02 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:02:10 <kushal> #chair rtnpro
17:02:11 <zodbot> Current chairs: jbrooks kushal maxamillion number80 nzwulfin rtnpro
17:02:18 <kushal> #chair dustymabe
17:02:18 <zodbot> Current chairs: dustymabe jbrooks kushal maxamillion number80 nzwulfin rtnpro
17:02:24 <dustymabe> .hellomynameis dustymabe
17:02:25 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:02:57 <kushal> Okay, we can move to items from last meeting
17:02:58 <jzb> .hellomynameis jzb
17:02:59 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:03:04 <jberkus> .hello jberkus
17:03:05 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:03:13 <kushal> * jberkus to update Fedora-Dockerfiles examples for Kubernetes (ticket
17:03:13 <kushal> #125)
17:03:13 <kushal> * imcleod wrangle karma for Factory updates (Ticket 131)
17:03:13 <kushal> * imcleod take ticket 136 on vagrant file fixups
17:03:14 <kushal> * kushal will work on #138 for updated cloud image.
17:03:16 <kushal> oops
17:03:22 <kushal> #chair jzb jberkus
17:03:22 <zodbot> Current chairs: dustymabe jberkus jbrooks jzb kushal maxamillion number80 nzwulfin rtnpro
17:03:28 <kushal> #topic Action items from last meeting
17:03:28 <kushal> * jberkus to update Fedora-Dockerfiles examples for Kubernetes (ticket
17:03:28 <kushal> #125)
17:03:30 <kushal> * imcleod wrangle karma for Factory updates (Ticket 131)
17:03:32 <kushal> * imcleod take ticket 136 on vagrant file fixups
17:03:35 <jberkus> kushal: got nothing on 125, curently out sice
17:03:35 <kushal> * kushal will work on #138 for updated cloud image.
17:03:37 <jberkus> sick
17:03:39 <chandankumar> .hello chandankumar
17:03:40 <zodbot> chandankumar: chandankumar 'Chandan Kumar' <chkumar246@gmail.com>
17:03:41 <jberkus> push to next meeting
17:04:04 <kushal> jberkus, I am also down (whole family this side) with viral fevers :(
17:04:17 <kushal> #action  jberkus to update Fedora-Dockerfiles examples for Kubernetes (ticket #125)
17:04:32 <jberkus> kushal: do we have existing examples?
17:05:08 <kushal> jberkus, Nope
17:05:15 <kushal> jberkus, Not that I know about
17:05:27 <scollier> .hello scollier
17:05:28 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
17:05:29 <kushal> I tested rtnpro;'s patches for motd, gave him some feedback
17:05:33 <kushal> #chari scollier
17:05:39 <kushal> #chair scollier
17:05:39 <zodbot> Current chairs: dustymabe jberkus jbrooks jzb kushal maxamillion number80 nzwulfin rtnpro scollier
17:05:56 <sayan> .hello sayanchowdhury
17:05:58 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:07:34 <kushal> #chair sayan
17:07:34 <zodbot> Current chairs: dustymabe jberkus jbrooks jzb kushal maxamillion number80 nzwulfin rtnpro sayan scollier
17:07:49 <jzb> Note we just got an interesting PR to th Dockerfiles repo
17:07:53 <jzb> I'd love to see Mattermost
17:08:09 <jberkus> yeah, saw thjat
17:08:23 <jberkus> jzb: seems bloggable, actually
17:08:29 <scollier> jzb, small nits, then will merge.
17:08:42 <jzb> scollier: woot!
17:08:49 <jzb> scollier: also, personally, I would like to use it :-)
17:08:56 <jzb> so that was awesome to see coming in
17:09:10 <jzb> I def owe Goern a beer on that one.
17:09:15 <jzb> jberkus: totally
17:09:37 <kushal> :)
17:09:57 <kushal> so can we move to tickets?
17:10:43 <jzb> kushal: no
17:10:47 <jzb> I mean, yes
17:10:56 <kushal> no means yes :)
17:11:05 <kushal> nope, bad idea/ slogan
17:11:18 <kushal> Just moving to tickets.
17:11:23 <kushal> https://fedorahosted.org/cloud/report/9
17:11:37 <kushal> #chair Fedora Cloud FAD (late 2015/early 2016) https://fedorahosted.org/cloud/ticket/115
17:11:37 <zodbot> Current chairs: (late 2015/early 2016) Cloud FAD Fedora dustymabe https://fedorahosted.org/cloud/ticket/115 jberkus jbrooks jzb kushal maxamillion number80 nzwulfin rtnpro sayan scollier
17:11:46 <kushal> Okay I am sick :(
17:11:53 <kushal> #topic Fedora Cloud FAD (late 2015/early 2016) https://fedorahosted.org/cloud/ticket/115
17:12:02 <kushal> We need flight/travel cost details
17:12:06 <jberkus> yeah
17:12:13 <dustymabe> kushal: I updated my information
17:12:17 <kushal> including me, jbrooks and tflink I guess
17:12:25 * tflink puts it on his todo list for today
17:12:36 <kushal> dustymabe, tflink Thanks
17:12:54 <nzwulfin> i'm officially not making the FAD
17:13:00 <kushal> nzwulfin, oh :(
17:13:00 <dustymabe> nzwulfin: :(
17:13:09 <nzwulfin> :(
17:14:04 <kushal> Moving on then.
17:14:34 <kushal> skipping 131, and 136 for ian
17:15:15 <kushal> #action  imcleod wrangle karma for Factory updates (Ticket 131)
17:15:23 <kushal> #action  imcleod take ticket 136 on vagrant file fixups
17:15:39 <kushal> Next
17:15:48 <kushal> #topic Produce updated cloud base images monthly https://fedorahosted.org/cloud/ticket/138
17:16:31 <kushal> I am still stuck on this, 2016-04-05 is the latest all good candidate, I am again asking rel-eng to find out what to do next to get the updated image out.
17:16:37 <kushal> I need help here.
17:16:42 <kushal> Any volunteers ?
17:16:49 <jzb> kushal: what kind of help?
17:17:01 <kushal> jzb, to get it  moving in the rel-eng side
17:17:39 <kushal> jzb, I will open up a ticket, then it will be nice to have more people commenting on that ticket :)
17:18:11 <jzb> kushal: I was wondering whether it's like "I need someone to code dis" or "I need someone to herd cats" or whatnot
17:18:26 <kushal> jzb, second one :)
17:18:39 <maxamillion> kushal: what's the scope here? does this need website changes or is it just "push the image to fedimg"?
17:18:51 <kushal> maxamillion, website changes too
17:19:47 <kushal> maxamillion, the image is already supposed to be on fedimg, just have to mark it as an updated release from rel-eng side, and then update the websites
17:20:36 <maxamillion> kushal: ok, so someone needs to submit a patch to the websites or find someone ont he website team willing to do that work and then find out what is needed to mark it in fedimg, yes?
17:21:13 <kushal> maxamillion, Yes (actually I am getting to know the steps for the first time, which is good) :)
17:21:32 <maxamillion> kushal: "the steps" ?
17:21:39 <jzb> if we're talking a text change
17:21:42 <kushal> maxamillion, things you mentioned right now
17:21:44 <jzb> I can send a patch to the Web team
17:21:48 <jzb> I have done it before.
17:21:51 <maxamillion> jzb: no, it's a giant pile of JS
17:22:09 <jzb> ah
17:22:11 <jzb> :-/
17:22:12 <maxamillion> jzb: if we want it to be similar to the Atomic site's auto-updating info when a release happens
17:22:39 <jzb> ack
17:22:43 <kushal> maxamillion, we have the plan to auto-release once in a month
17:22:51 <maxamillion> jzb: however, I imagine the change to the Atomic site would be a guide for how to add it to the Cloud page since they are similar ... but I've not looked at the code
17:22:54 <maxamillion> kushal: yes, I know
17:23:01 <maxamillion> oh ok, so basically this hasn't yet been scoped?
17:23:09 <jberkus> maxamillion: the main atomic site is a manual push
17:23:30 <maxamillion> jberkus: https://getfedora.org/en/cloud/download/atomic.html
17:23:43 <maxamillion> jberkus: that site is auto updated based on fedmsgs and some javascript magic
17:23:57 <jberkus> sounds good
17:24:12 <jberkus> maxamillion: btw, I could really use a "current" link for the latest FAH
17:24:34 <jberkus> It's annoying to have to keep updating links in atomic-site manually
17:24:56 <kushal> maxamillion, nope, it will be first time.
17:25:47 <maxamillion> jberkus: yup, there's a ticket for it, it's on the TODO list but the docker layered image build system has been consuming all of my time ... I'd be happy to review a patch if someone wanted to do it though
17:25:58 <maxamillion> kushal: alright
17:26:09 <jberkus> probably i should just link to that page ...
17:27:26 <jberkus> maxamillion: you mean layered images wasnt just a weekend projrct?
17:27:39 <jberkus> ;-)
17:28:01 <kushal> jberkus, I almost got a heart attack!
17:28:10 <maxamillion> jberkus: :)
17:28:14 <kushal> jberkus, :)
17:28:20 <kushal> #action kushal to drop a mail to the list after creating a ticket for new base image release for f23
17:28:30 <kushal> Moving
17:29:13 <kushal> #topic Proposals for F24 features https://fedorahosted.org/cloud/ticket/143
17:29:27 <jzb> no updates on ticket from me this week
17:29:34 <kushal> I have sent a mail to the atomic-devel list about enabling it for our atomic hosts
17:29:42 <kushal> I need help to push it there.
17:29:59 <kushal> I don't have commit access to fedora-atomic repo, maxamillion do you have it?
17:30:16 <kushal> dustymabe, tested the atomic side on his build iirc
17:30:38 <jberkus> enable what?
17:30:55 <kushal> jberkus, motd updates, http://fedoraproject.org/wiki/Changes/Cloud_MOTD
17:30:56 <dustymabe> kushal: have you submitted it as a patch?
17:31:08 <maxamillion> kushal: what repo?
17:31:09 <dustymabe> send it as a patch to the mail list
17:31:14 <kushal> dustymabe, I have sent the links to two patches required
17:31:24 <kushal> maxamillion, fedora-atomic
17:31:27 <kushal> rtnpro, ^^^^
17:31:56 * rtnpro scrolls up
17:31:58 <jzb> kushal: walters would def have it
17:32:13 <kushal> jzb, Yes he has for sure :)
17:32:22 <maxamillion> kushal: can you link me to the exact URL? I have 3 things in my local ~/src/ dir that could be what you're talking about
17:32:41 <kushal> maxamillion, https://rtnpro.fedorapeople.org/fedora_motd/0001-Added-fedora-motd-package.patch
17:33:03 <kushal> then for our spin-kickstarts repo https://rtnpro.fedorapeople.org/fedora_motd/0002-Include-motdgen-in-etc-pam.d-sshd-on-fedora-cloud-at.patch
17:33:06 <rtnpro> kushal, jberkus, I will update the docs at http://fedoraproject.org/wiki/Changes/Cloud_MOTD, currently the docs are available upstream at https://github.com/rtnpro/fedora-motd
17:33:13 <maxamillion> kushal: I'm pretty sure that's the spins-kickstart repo
17:33:40 <kushal> rtnpro, ^^^
17:33:51 <rtnpro> yes
17:34:18 <kushal> maxamillion, The json file is not at  spins-kickstart
17:34:32 <rtnpro> kushal, maxamillion, https://rtnpro.fedorapeople.org/fedora_motd/0001-Added-fedora-motd-package.patch is for fedora-atomic repo
17:34:38 <maxamillion> holy shit
17:34:45 <maxamillion> can someone just link the repo please?
17:34:54 <maxamillion> I have no idea what you're talking about "fedora-atomic" is not enough context
17:35:07 <rtnpro> maxamillion, give me a moment
17:35:22 <kushal> Okay, the repo has moved
17:35:28 <kushal> maxamillion, https://pagure.io/fedora-atomic.git
17:35:28 <jbrooks> https://git.fedorahosted.org/cgit/fedora-atomic.git
17:35:31 <jbrooks> oh
17:35:39 <kushal> https://pagure.io/fedora-atomic
17:35:40 <rtnpro> maxamillion, https://git.fedorahosted.org/git/fedora-atomic.git,
17:35:44 <maxamillion> *sigh*
17:36:01 <kushal> jberkus, rtnpro It has moved to https://pagure.io/fedora-atomic
17:36:19 <rtnpro> nice :)
17:36:20 <kushal> rtnpro, you will have to submit a PR there
17:36:20 <dustymabe> kushal: in that case then why can't you submit a pull request?
17:36:29 <maxamillion> dustymabe: +1
17:36:36 <rtnpro> kushal, that's much easier, I will do it
17:36:52 <maxamillion> also, pagure shows who has commit access right there on the project landing page
17:36:54 <kushal> dustymabe, I also missed the moving part, last time I checked it was under fedorahosted
17:37:13 <kushal> dustymabe, mostly because I was directly typing the whole path on the URL
17:37:48 <dustymabe> kushal: yeah I didn't know it moved either
17:38:06 <dustymabe> so that covers one part of it.. spin kickstarts also need to be updated right?
17:38:27 <kushal> dustymabe, Yes, that we can commit
17:38:35 <kushal> dustymabe after the package gets in
17:39:39 <dustymabe> kushal: and we would need to make that change on the f24 branch of that fedora-atomic repo
17:40:04 <kushal> dustymabe, rawhide and F24
17:41:32 <kushal> #action rtnpro will submit a PR to fedora-atomic repo
17:41:50 <kushal> #topic Container "Packager" Guildelines and Naming Conventions https://fedorahosted.org/cloud/ticket/148
17:41:57 <kushal> maxamillion, anything on this?
17:42:46 <maxamillion> kushal: no, it's been backburnered because I was working on the Content Generator import patches to make the system actually function ... now it does, I'm trying to get it deployed to stage, then I'll get to that
17:43:08 <kushal> maxamillion, thanks for the update
17:43:14 <kushal> We have similar discussion on https://fedorahosted.org/cloud/ticket/150
17:44:14 <kushal> We can actually move into Open Flor
17:44:17 <kushal> * floor
17:44:23 <kushal> #topic Open Floor
17:44:30 <kushal> Anything anyone?
17:44:44 <dustymabe> kushal: I have something
17:44:53 <kushal> dustymabe, Go ahead, stage is yours.
17:44:59 <dustymabe> https://fedoramagazine.org/vagrant-sharing-folders-vagrant-sshfs/
17:45:08 <jberkus> yay
17:45:11 <kushal> dustymabe++ for that :)
17:45:15 <dustymabe> just wondering if we should consider adding fuse-sshfs to our vagrant boxes we produce
17:45:17 <jberkus> dustymabe: I'll echo that in the atomic blog
17:45:26 <dustymabe> jberkus: well
17:45:35 <dustymabe> there is one thing interesting about this and atomic Host
17:46:03 <dustymabe> It won't work with atomic host because fuse-sshfs rpm isn't in atomic host
17:46:24 <dustymabe> I don't know if it makes sense to add it
17:46:32 <dustymabe> the answer is probably no
17:46:44 <dustymabe> I have played around with running sshfs from inside a container
17:46:44 <nzwulfin> dustymabe: wihtout a bigger usecase than vagrant, i'd say no
17:46:51 <maxamillion> dustymabe: could you somehow do it with a super priv container?
17:46:58 <dustymabe> maxamillion: yeah
17:47:03 <jberkus> dustymabe: you know, we have an increasing # of things we want for atomic host dev mode
17:47:04 <dustymabe> I've done it
17:47:11 <maxamillion> might not be the prettiest solution, but it's something
17:47:18 <dustymabe> maxamillion: right
17:47:39 <dustymabe> basically in order to do it right I think we'd need to build containers that have sshfs in them
17:47:45 <dustymabe> which is ok.. but that has to be maintained
17:47:52 <kushal> Yes, layered images :)
17:47:55 <dustymabe> i just want to think about it first before we open that can :)
17:48:06 <dustymabe> and also I want this to work for CoreOS too
17:48:16 <maxamillion> dustymabe: interesting
17:48:17 <dustymabe> so we'd have to figure out a strategy there as well
17:48:20 <maxamillion> kushal: yeah ...
17:48:32 <dustymabe> https://github.com/dustymabe/vagrant-sshfs/issues/8
17:48:37 <dustymabe> there is an issue I opened
17:48:38 <jberkus> dustymabe: why not just make it work for AH and then let the CoreOS folks figure it out?
17:48:47 <maxamillion> I've honestly still not really done anything with CoreOS
17:48:53 <maxamillion> I probably should
17:49:02 <dustymabe> maxamillion: I need to do more
17:49:41 <dustymabe> I'd like to be able to answer questions about CoreOS vs Atomic Host - and have the answers be ones that I've learned through experience
17:49:41 <jberkus> aside from comparatives, why>
17:49:50 <jberkus> ah, ok
17:50:13 <dustymabe> unfortunately #aintnobodygottimefothat
17:50:45 <jberkus> yah
17:52:15 <dustymabe> so maybe we can at least get sshfs added to the cloud vagrant box
17:52:20 <dustymabe> I'll submit up a patch for that
17:53:22 <kushal> Is anyone among ourselves using containers in production?
17:53:49 <jberkus> kushal: at RH, or otherwise?
17:54:20 <maxamillion> kushal: I did on my previous team when I was on the OpenShift Online team ... why so?
17:54:41 <kushal> jberkus, RH, personally anything.
17:55:05 <kushal> maxamillion, just trying to understand how are we doing in dogfooding :)
17:55:15 <jberkus> well, I am
17:55:24 <jberkus> for non-RH projects
17:55:38 <kushal> jberkus, nice, I will ping you after this meeting then :)
17:55:45 <kushal> Anything else for open floor?
17:56:00 <jberkus> note that I'm not using the Atomic stuff though
17:56:12 <jberkus> just Docker, Compose, Kubernetes
17:56:16 <maxamillion> kushal: the OpenShift team uses containers all over the place in production if you're interested in anything specific, you should talk with them
17:56:41 <kushal> maxamillion, Yes, they are the only ones iirc :)
17:57:11 <kushal> I mean I do not know anyone else.
17:57:11 <maxamillion> maybe? I'm honestly not sure
17:57:23 <kushal> Yes, same here.
17:57:28 <kushal> Anyway, closing the meeting for now.
17:57:29 <kushal> 5
17:57:31 <kushal> 4
17:57:33 <kushal> 3
17:57:34 <kushal> 2
17:57:35 <kushal> 1.5
17:57:36 <kushal> 1
17:57:38 <kushal> 0.5
17:57:46 <kushal> #endmeeting