16:00:12 <geppetto> #startmeeting fpc
16:00:12 <zodbot> Meeting started Thu May  5 16:00:12 2016 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:12 <zodbot> The meeting name has been set to 'fpc'
16:00:13 <geppetto> #meetingname fpc
16:00:13 <zodbot> The meeting name has been set to 'fpc'
16:00:13 <geppetto> #topic Roll Call
16:00:17 <geppetto> #chair tibbs
16:00:17 <zodbot> Current chairs: geppetto tibbs
16:00:18 <geppetto> #chair mbooth
16:00:18 <zodbot> Current chairs: geppetto mbooth tibbs
16:00:20 <orionp> hello
16:00:22 <geppetto> hey
16:00:24 <geppetto> #chair orionp
16:00:24 <zodbot> Current chairs: geppetto mbooth orionp tibbs
16:00:27 <contyk> hi
16:00:31 * contyk is lurking
16:00:35 <tomspur> Hi
16:00:45 <geppetto> #chair tomspur
16:00:45 <zodbot> Current chairs: geppetto mbooth orionp tibbs tomspur
16:00:51 <geppetto> contyk: that's ok :)
16:00:52 <mbooth> Quickest Quorum eva
16:00:58 <geppetto> probably :)
16:01:21 <geppetto> for some reason I thought a few people said they couldn't make it this week
16:01:22 * ppisar ready for Perl
16:01:47 <tomspur> There is a holiday in Germany
16:01:51 <geppetto> Ahh
16:02:00 <geppetto> so no racor rathan then, I guess?
16:02:00 * tomspur found the time anyway ;)
16:02:24 <geppetto> Cool :)
16:02:33 <geppetto> Well, might as well start then
16:02:52 <geppetto> #topic Schedule
16:03:04 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/AL2GD7TG6WS7N77KADOYIS2LYHRDCP3W/
16:03:18 <geppetto> #chair Rathann
16:03:18 <zodbot> Current chairs: Rathann geppetto mbooth orionp tibbs tomspur
16:03:30 <geppetto> #topic #622 improve description of /run
16:03:34 <geppetto> .fpc 622
16:03:36 <zodbot> geppetto: #622 (improve description of /run) – fpc - https://fedorahosted.org/fpc/ticket/622
16:04:06 <tibbs|w> I think we have sufficient votes, given the two +1s in the ticket.
16:04:13 <geppetto> So with the votes in the ticket I think we are at +6 now … any objects or anything?
16:05:09 <orionp> I'm fine with it
16:05:19 <Rathann> yup
16:05:25 <geppetto> #action improve description of /run (+1:6, 0:0, -1:0)
16:05:33 <geppetto> #topic #620 Perl Build-Requires Packaging guidelines update
16:05:39 <geppetto> .fpc 620
16:05:40 <zodbot> geppetto: #620 (Perl Build-Requires Packaging guidelines update) – fpc - https://fedorahosted.org/fpc/ticket/620
16:06:01 <Rathann> I have to leave early today, probably in about 30 minutes
16:06:08 <geppetto> Rathann: ok
16:06:15 <geppetto> ppisar: You are up :)
16:06:24 <orionp> ppisar: Thanks for having a plan to monitor changes
16:06:46 <Rathann> I'm satisfied with the explanations and proposed (build)dependency requirements
16:06:59 <Rathann> so +1 from me
16:07:24 <Rathann> though I thought perl-devel required perl anyway
16:07:30 <ppisar> So do you want perl-generators or perl-build package?
16:07:52 <tibbs|w> perl-build does make a lot more sense as a name.  To me at least.
16:07:56 <ppisar> Rathann: Yes. It's so. Internal details because of some scripts.
16:08:31 <Rathann> so it's enough to BR: perl-devel perl-generators in case 3, right?
16:08:36 <tibbs|w> I'm happy with this either way.
16:09:23 <orionp> There is no consistent naming for these packages at the moment, so I'm okay with it remaining inconsistent for now
16:09:32 <orionp> Though it would be nice to have a scheme
16:09:36 <tibbs|w> I don't seem the harm in being explicit with the build deps, but if it works without having to list perl explicitly then someone will eventually try to do it.
16:09:48 <Rathann> well, I'm not entirely happy with the name, but I don't think it's worth the effort to rename at this point
16:09:49 <ppisar> Rathann: If guidlines will define it, then perl-devel will guarnatee dependency on perl.
16:10:13 <tibbs|w> Is there any reason at all that perl-devel wouldn't want to require perl in the future?
16:10:20 <geppetto> Yeh, I think that's pretty normal/reasonable
16:10:26 <contyk> requiring perl-devel doesn't necessarily bring the perl interpreter to the buildroot
16:10:30 <contyk> unless you define it that way, yeah
16:10:37 <Rathann> ppisar: I don't want to introduce artificial dependencies - if something in perl-devel requires perl, then it should be so
16:10:56 <Rathann> otherwise it should be BR'd explicitly if necessary
16:11:11 <tibbs|w> I'm happy to just make it explicit in the guidelines.  If packagers do something different and it breaks later, then... they'll have to deal.
16:11:38 <Rathann> though the majority of other -devel packages do require their base package
16:12:21 <contyk> that's probably because most of the are libraries
16:12:23 <ppisar> perl-devel delivers /usr/bin/h2xs and /usr/bin/perlivp scripts. These have #!/usr/bin/perl, so it pulls perl. But that does not have to be true forever.
16:12:35 <Rathann> ppisar: understood
16:12:37 <mbooth> I would assume that perl-devel pulls in perl-libs
16:12:41 * mbooth shrugs
16:12:49 <Rathann> mbooth: oh, right
16:12:51 <mbooth> But I don't think it matters much
16:12:54 <Rathann> I forgot about perl-libs
16:13:13 <tibbs|w> https://fedoraproject.org/wiki/Packaging:Guidelines#Devel_Packages doesn't specify any kind of dependency from *-devel to the base package.
16:13:47 <geppetto> fair enough
16:13:48 <tibbs|w> I think we should just let the perl folks decide which dependencies they want to guarantee, and let the guidelines specify build deps accordingly.
16:14:00 <Rathann> tibbs|w: +1
16:14:00 <geppetto> +1 then
16:14:02 <ppisar> mbooth: perl-devel requires "/usr/bin/perl" found by shell bang scanner.
16:14:23 <mbooth> Yeah, I really don't have objections to this as currently drafted
16:14:35 <Rathann> well, the guidelines say you don't have to BR: anything that's pulled in by something else you BR:
16:14:38 <orionp> I'm +1
16:14:47 <mbooth> I'm +1 too
16:14:49 <ppisar> I'm rather for explicit dependency on perl, especially if the spec files execute perl explicitely.
16:14:54 <geppetto> Ok, +4 now
16:14:57 <tibbs|w> +1 to the current draft.
16:15:36 <geppetto> And done … tomspur want to vote for the record?
16:16:06 <tomspur> +1 for letting the perl folks decide about the dependencies too :)
16:16:13 <geppetto> #action Perl Build-Requires Packaging guidelines update (+1:6, 0:0, -1:0)
16:16:18 <geppetto> Ok, cool.
16:16:22 <orionp> ppisar: Happy sed'ing
16:16:24 <ppisar> Great.
16:16:29 <geppetto> #topic #619 Need a statically reserved uid and gid for heketi
16:16:33 <geppetto> .fpc 619
16:16:34 <zodbot> geppetto: #619 (Need a statically reserved uid and gid for heketi) – fpc - https://fedorahosted.org/fpc/ticket/619
16:16:50 <tibbs|w> Guess I'll go and fix up my perl packages.
16:17:03 <geppetto> Nothing seems to have happened here
16:17:24 <mbooth> Nothing changed, looks like
16:18:07 <tomspur> Which bz 13069154 is mentioned there?
16:18:09 <tibbs|w> I think we should just stick it in needinfo and pretend it doesn't exist until it's ping time.
16:18:20 * geppetto nods
16:18:26 <geppetto> 612 also doesn't seem to have changed
16:18:26 <tomspur> Doesn't seem to be the normal bz.
16:18:29 <geppetto> so …
16:18:33 <geppetto> #topic #610 Packaging guidelines: Check upstream tarball signatures
16:18:38 <geppetto> .fpc 610
16:18:40 <zodbot> geppetto: #610 (Packaging guidelines: Check upstream tarball signatures) – fpc - https://fedorahosted.org/fpc/ticket/610
16:18:52 <tibbs|w> Lots of discussion on this, but I don't think anything is ready for a vote.
16:19:11 <geppetto> tibbs: ok, wasn't sure if you had anything … as it seemed like you were pretty close to something
16:19:15 <tibbs|w> Feel free to try https://pagure.io/gpg-macros
16:19:40 <tibbs|w> I mean, it's there and there's documentation in the actual macro file.  I'll stick that on the main pagure page so you don't have to dig.
16:19:40 <geppetto> #info Please try the signature checking macros: https://pagure.io/gpg-macros
16:19:57 <tibbs|w> If you check out that repo, you can fedpkg prep or fedpkg mockbuild directly in there.
16:20:45 <tibbs|w> Feel free to look at https://pagure.io/misc-rpm-macros as well, which formalizes the lua stuff I've been working on.
16:21:05 <geppetto> ok, cool
16:21:15 <mbooth> Cool, I will try the gpg one later
16:21:36 <tibbs|w> I still have one big feature to implement.
16:21:43 <tibbs|w> But two things concern me:
16:21:57 <tomspur> Nice, it seems you like working with lua these days :)
16:21:58 <tibbs|w> If you think the arguments are terrible, please let me know.
16:22:26 <tibbs|w> And if anyone thinks that actually making a macro for this is a bad idea, please do say so before I spend much more time on it.
16:22:37 <tibbs|w> (where "this" is the gpg thing).
16:22:48 <tibbs|w> tomspur: "like" is rather a strong word.
16:23:14 <tibbs|w> Programming in Lua feels like working on a Commodore 64.  There's a language there, but...
16:23:31 <geppetto> Basic ftw ?;)
16:24:23 <tibbs|w> Really it's just verbose, which makes it looks like I've written some horribly bloated thing when it doesn't do all that much.
16:24:31 <geppetto> tibbs: So what where the two things that concerned you?
16:24:43 <tibbs|w> As above.
16:24:49 <tibbs|w> If you think the arguments are terrible, please let me know.
16:24:54 <tibbs|w> And if anyone thinks that actually making a macro for this is a bad idea, please do say so before I spend much more time on it.
16:24:58 <geppetto> Oh, the arguments and using a macro?
16:25:06 <tibbs|w> I'm just not sold on how the args work.
16:25:08 <geppetto> Both of those seem fine to me
16:25:26 <tibbs|w> I mean, doing things by number means that if you renumber your sources, you have to change the macro.
16:26:03 <tibbs|w> But doing it by filename (which I can actually do) means that if you rename your sources, you have to adjust the macro call, too.
16:26:17 <Rathann> yeah, that's not very convenient
16:26:48 <tibbs|w> Even if you did it manually, you'd have to include a filename in %prep somewhere, so I don't think it's much worse.
16:27:07 <mbooth> I wonder if you can enumerate the sources to find the one that has .asc or .gpg extensions and use them by default
16:27:09 <geppetto> I would be happy with using a fixed name for the keyring, and using <source>.asc for the signature … which leaves only a single arg.
16:27:09 <tibbs|w> I think the majority of the setups will just work with no arguments at all, or maybe just -k.
16:27:15 <tibbs|w> mbooth: I do.
16:27:19 <geppetto> But you way will probably make people happier
16:27:44 <geppetto> Cool
16:27:47 <tibbs|w> I will probably just do both, because fun, and if someone says that's too much then I can scale it back.
16:28:20 <geppetto> :)
16:28:22 <tibbs|w> Anyway, will hopefully be done with that today, and can try and mock up a page for the guidelines.
16:28:51 <mbooth> Next step: Get upstreams to sign their sources :-p
16:28:55 <tibbs|w> But again, I am not really familiar with gpg (still) so someone may need to write or rewrite it.
16:29:00 <tibbs|w> Oh, and one other thing.
16:29:02 <tibbs|w> %autosetup.
16:29:16 <geppetto> yeh?
16:29:22 <tibbs|w> I would like autosetup to accept -G or something, which will call %gpg_verify.
16:29:34 <tibbs|w> But %autosetup is defined in rpm itself, not redhat-rpm-config.
16:29:56 <geppetto> Can you just do an %autosetup_g ?
16:30:08 <tibbs|w> I'd prefer not, honestly, but I can.
16:30:19 <tibbs|w> Now, I can override the definition of %autosetup.  Easily.
16:30:29 <geppetto> ha
16:30:31 <tibbs|w> But I have no idea if that would cause "problems".
16:30:39 <geppetto> yeh, I've no idea
16:30:43 <tibbs|w> As in, pissing off the rpm people.
16:30:50 <Rathann> ask Panu/Florian? ;)
16:30:56 <geppetto> yeh, email florian, I guess
16:31:00 <mbooth> I wouldn't be too concerned about that to be honest -- it's only trivial jump from writing "-G" to "gpg_verify"
16:31:05 <tibbs|w> Or having people complain that Fedora RPM is deviating from real RPM.
16:31:24 <tibbs|w> You're right, of course, but... maybe eventually... just do it without anyone doing anything.
16:31:27 <orionp> seems worthwhile to get it into rpm upstream
16:31:30 <tibbs|w> I.e call it unconditionally.
16:31:51 <mbooth> Long term plan? Sure
16:32:02 <mbooth> But if what you have works right now...
16:32:04 <tibbs|w> And, yes, all of this may be nice to just include upstream, but I really don't want to wait for that to happen.
16:32:29 <tibbs|w> Anyway, yes, I'll mock up what having it done in %autosetup would look like just for lulz.
16:33:38 <tibbs|w> I'm done, but if anyone has suggestions...
16:34:03 <geppetto> No, that seems cool
16:34:30 <tibbs|w> And feel free to file issues in pagure.
16:35:04 <Rathann> it's good enough as it is - automatically detecting the signature for a given source would be nice to have, but it's fine without that, too
16:35:32 <tibbs|w> It does automatically detect them.  It just doesn't actually do anything with them yet.
16:35:42 <Rathann> oh ok
16:35:54 <tibbs|w> Hopefully later today.
16:36:24 <geppetto> Awesome
16:36:30 <geppetto> #topic Open floor
16:36:42 <tibbs|w> Fortunately my schedule today appears to be clear.
16:36:46 <geppetto> ok, that's pretty much it … anyone else have anything they'd like to bring up?
16:36:54 <Rathann> nothing from me, thanks
16:37:02 <Rathann> and I have to go anyway
16:37:08 * geppetto nods
16:37:15 <Rathann> thanks for the meeting and take care
16:37:21 <tibbs|w> Wow, we're really done?
16:37:23 <tomspur> Bye Rathann
16:37:46 <tibbs|w> 20 open tickets.
16:38:15 <tibbs|w> I never heard back from the pascal guy; I think that his macro package is in F23 now so I should make the update there.
16:38:39 <tibbs|w> Can we just close 612?
16:38:52 <geppetto> I'm not sure
16:38:58 <geppetto> I think so though
16:39:18 <tibbs|w> It sort of went off into something else.  It's obvious that sphinx has the problem here.
16:39:32 <tibbs|w> I'd say close it and if someone gets pissed they can just reopen it.
16:39:39 * geppetto nods
16:40:10 <geppetto> #action geppetto Close 612, if anything else is wanted/needed then just reopen and ask.
16:41:03 <tibbs|w> I should ping the needinfos.
16:41:18 <tibbs|w> And I need to re-establish context on a couple of my tickets.
16:41:33 <tibbs|w> And I think I have, now, three writeups to do.
16:42:17 <tibbs|w> I also need to get back to that removal of useless %defattr thing.
16:42:26 <tibbs|w> Was supposed to do that after branching, and then I forgot.
16:42:56 <tibbs|w> So I guess I have plenty to do today.
16:43:32 <tibbs|w> I wish we could get 591 done, though.
16:44:33 <geppetto> .fpc 591
16:44:34 <zodbot> geppetto: #591 (Description of filtering macros in Packaging:AutoProvidesAndRequiresFiltering#Perl is outdated) – fpc - https://fedorahosted.org/fpc/ticket/591
16:45:47 <tibbs|w> It turned into sort of a mess, and I'm not even clear on whether the current guidelines are OK or not.
16:45:52 <geppetto> who needs to be pinged here? zbyszek?
16:46:02 <tibbs|w> Or ppisar.
16:46:06 <tibbs|w> And we had him around today.
16:46:14 * geppetto nods
16:47:09 <ppisar> I wrote my opinion in comment #6.
16:47:29 <tibbs|w> Right, but I just don't know where we go from here.
16:48:17 <tibbs|w> I can try to bang out a draft based on that comment and then ping in the ticket.
16:49:12 <tibbs|w> I just wasn't really sure on how much the draft in comment 5 differs from what ppisar suggest in comment 6. I guess I'l try to dig into it.
16:50:03 <ppisar> The issue was with redefining the filters.
16:50:13 <tibbs|w> Right, you need to preserve the old value.
16:50:49 <tibbs|w> Is the current %perl_default_filter macro working properly?
16:51:33 <tibbs|w> I just want to make sure that if we change the guidelines, we're not out of step with reality.
16:52:01 <ppisar> Current perl_default_filter appends.
16:52:06 <tibbs|w> OK, cool.
16:52:41 <tibbs|w> I'm all out.
16:52:50 <geppetto> Ok, I'll close in a minute then
16:53:06 <geppetto> Enjoy lunch … and a "free" afternoon playing with lua some more
16:53:10 <geppetto> ;)
16:53:12 <tomspur> :D
16:53:34 <tomspur> See you next week then
16:53:41 * geppetto nods
16:53:48 <ppisar> Bye.
16:54:19 <geppetto> #endmeeting