14:00:26 <tflink> #startmeeting fedora-qadevel
14:00:26 <zodbot> Meeting started Mon May  9 14:00:26 2016 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:26 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:00:26 <tflink> #meetingname fedora-qadevel
14:00:26 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:00:26 <tflink> #topic Roll Call
14:00:40 <tflink> who all's here for the always exciting qadevel meeting?
14:00:59 * kparal is here
14:01:46 * mkrizek here
14:01:57 * lbrabec is here
14:02:54 <tflink> ok, let's get started
14:03:07 <tflink> I suspect that this may end up being a short meeting
14:03:17 <tflink> #topic Announcements and Information
14:03:27 <tflink> #info F23-25 base images for disposable minions are building on dev - jskladan
14:03:27 <tflink> #info deployed task-libabigail in dev - mkrizek
14:03:27 <tflink> #info deployed distgit style tasks support in dev - mkrizek
14:04:01 <tflink> any additions/comments/questions?
14:04:57 * kparal has none
14:05:25 <mkrizek> nope
14:05:33 <lbrabec> nope
14:06:15 <tflink> ok, moving on
14:06:17 <tflink> #topic Docker Testing
14:06:28 <tflink> just wanted to quickly touch base on this
14:06:48 <tflink> we're mostly waiting for D842 and some examples ATM, right?
14:07:14 <tflink> we'll need to figure out how to download layered images but I'm not sure that can be done quite yet since the build process isn't finalized
14:07:48 <lbrabec> xunitparser package is on review, i hope it will be ok
14:08:26 <tflink> that's waiting on another package, no?
14:08:44 <tflink> I'd rather not push that change until python-xunit is packaged, at least in COPR
14:08:54 <tflink> and added to our list of "stuff to package for fedora"
14:09:06 * tflink is OK with that diff otherwise
14:09:39 <lbrabec> well already packaged the xunitparser, I'm waiting for sponsor
14:10:02 <tflink> oh, didn't know that
14:10:17 <tflink> can you post the bz# for the review?
14:10:32 * tflink will poke some sponsors, didn't realize that's what we were waiting on
14:10:51 <tflink> sponsor or reviewer?
14:10:59 <lbrabec> #link https://bugzilla.redhat.com/show_bug.cgi?id=1332999
14:11:13 <lbrabec> sponsor, it is my first package
14:11:51 <mkrizek> https://bugzilla.redhat.com/show_bug.cgi?id=1333525 - someone also had the same idea apparently
14:12:28 <tflink> within a day of eachother, too
14:13:15 <tflink> anything else on this?
14:13:20 <mkrizek> not here
14:13:41 <tflink> ok, moving on
14:13:46 <tflink> #topic ABI Checking
14:13:55 <tflink> Another topic that I just wanted to touch base on
14:14:12 <tflink> #info ABI Checking has been deployed to dev, appears to be working so far
14:14:20 * tflink cheers
14:14:41 <tflink> is there anything else that we know of which needs to be done on this?
14:15:08 <mkrizek> https://github.com/sinnykumari/task-libabigail/issues/1
14:15:08 * kparal just requested the task to use /var/tmp instead of /tmp for extracting rpms
14:15:12 <kparal> ^^
14:15:31 <tflink> yeah, extracting to /tmp seems like a bad idea
14:15:45 <kparal> so we might see a larger number of OOM-killed runs in the meantime
14:15:46 <tflink> especially since we're not sure if 6GB is gonna be enough RAM to start with
14:16:14 <mkrizek> other thing would be to figure out what builds we want to exclude from critpath
14:16:40 <mkrizek> and of course let the task run for a day or two to see if there are any other explosions :)
14:16:58 <kparal> what are we currently running on, all packages?
14:17:02 <kparal> all critpath?
14:17:04 <mkrizek> critpath
14:17:08 <kparal> ok
14:17:31 <tflink> did sinny or dodji (hoping i spelled their names right) have any more input on what to run, or what not to run
14:17:47 <tflink> IIRC, anything webkit or llvm should be avoided for now
14:18:28 <tflink> but I also think that was an incomplete list
14:18:51 <kparal> <ksinny> mkrizek: I will look into list of packages available in critpath and will try to figure out which all packages may take more than 10GB of RAM while running libabigail task
14:18:51 <kparal> <ksinny> it's a big list, so a bit time consumig work
14:19:07 <kparal> later we clarified we only have 6 GB RAM
14:19:19 <kparal> I hope, if I'm reading scrollback correctly
14:19:20 <tflink> if we need to reconfigure some stuff, that's an option
14:19:44 <tflink> alternatively, we can try to flag the ones which die from OOM (after the /tmp thing is fixed)
14:20:00 * tflink wonders if it would be wise for us to disable tmpfs on the taskotron images
14:20:29 <kparal> not sure
14:20:41 <tflink> let's see how things go
14:20:49 <tflink> I'd rather not spend time on that if we don't have to right now
14:21:04 <mkrizek> +1
14:21:32 <tflink> anything else on this? it sounds like things are progressing well
14:22:49 * tflink takes silence as a "no"
14:22:58 <tflink> #topic Packaging
14:23:05 <tflink> Another topic which should be quick
14:23:30 * kparal wonders why he initially read "#topic Panicking" :-)
14:23:47 <tflink> There was a thread on qa-devel@ but as a quick summary: we've been asked to package all the libtaskotron bits in Fedora instead of building things outside koji
14:23:53 <tflink> kparal: bad experiences packaging?
14:24:28 <kparal> has to be my subconsciousness
14:24:58 <tflink> I've committed to getting everything packaged in Fedora by F25, so it's not a "NOW! NOW! PANIK!!11!!" kind of thing but I'd like to get started sooner than later
14:25:12 <tflink> i've/we've ... yay, English pronouns!
14:25:38 <mkrizek> speaking of packaging, libtaskotron build finally got a builder in copr after 3 hours of waiting in a queue \o/
14:25:43 <tflink> :)
14:26:18 <mkrizek> by F25 you mean by branch?
14:26:19 <tflink> in the long run, we need to get libtaskotron into the Fedora repos and I think doing builds there will be better for us in the long run, anyways
14:26:56 <tflink> mkrizek: it wasn't very specific, I'd like to shoot for that, though in case we hit problems
14:27:36 <tflink> the biggest thing from infra was more that we have plans to do it
14:28:27 <tflink> there was a miscommunication where they heard "yeah, we might get around to scheduling that task in the next month and might finish it in the next year" and that led to the "no more non-koji builds in the infra repo"
14:28:42 <tflink> miscommunication/misunderstanding/whatever
14:29:43 <tflink> it's been sorted out now, AFAIK
14:30:11 <tflink> if something like this comes up again in the future, please let the team know
14:30:57 * tflink doesn't recall hearing anything more than "we won't be able to push builds into infra repo" but it's very possible that he just forgot :(
14:31:26 <tflink> not blaming, don't care otherwise now that it's been figured out, just bringing up the "please tell folks" bit :)
14:31:49 <tflink> moving on
14:31:58 <tflink> if there's nothing else on this topic?
14:32:23 <kparal> nothing here
14:32:30 <tflink> #topic Tasking
14:32:44 <tflink> Other than jskladan, is anyone else in need of tasks right now?
14:33:25 * kparal is not
14:33:35 <mkrizek> other than potential update of stg/prod, I don't have tasks now
14:34:43 <tflink> mkrizek: can you start taking a few of the packaging tasks, then?
14:35:13 <tflink> unless there are remaining dist-git tasks that I'm forgetting
14:35:45 <mkrizek> I don't think there are
14:35:47 <mkrizek> ok, will do
14:36:12 <mkrizek> we still need guinea pigs for the distgit :)
14:36:13 <tflink> it'd be nice to have more of the dist-git stuff documented, though
14:36:17 <tflink> i have a few in mind
14:36:28 <tflink> #action tflink to find guinea pigs for distgit style tasks
14:37:13 <mkrizek> thanks
14:37:43 <tflink> anyone else in need of tasks?
14:39:44 * tflink assumes not
14:39:49 <tflink> if you do, let me know :)
14:39:55 <tflink> #topic Open Floor
14:40:01 <tflink> Anything else that folks wanted to bring up?
14:40:51 <kparal> nothing here
14:41:02 <mkrizek> nothing here
14:41:15 <lbrabec> nothing here
14:41:31 * tflink lights the magical patent-pending non-deterministic fuse
14:43:04 <tflink> thanks for coming, everyone!
14:43:08 * tflink will send out minutes shortly
14:43:11 <tflink> #endmeeting