16:00:04 <geppetto> #startmeeting fpc
16:00:04 <zodbot> Meeting started Thu May 19 16:00:04 2016 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:04 <zodbot> The meeting name has been set to 'fpc'
16:00:04 <geppetto> #meetingname fpc
16:00:04 <zodbot> The meeting name has been set to 'fpc'
16:00:04 <geppetto> #topic Roll Call
16:00:55 <mbooth> Hi
16:00:59 <geppetto> #chair mbooth
16:00:59 <zodbot> Current chairs: geppetto mbooth
16:01:02 <geppetto> Hey
16:01:07 * racor is here
16:01:28 <geppetto> #chair racor
16:01:28 <zodbot> Current chairs: geppetto mbooth racor
16:02:14 <geppetto> #chair tomspur
16:02:14 <zodbot> Current chairs: geppetto mbooth racor tomspur
16:02:25 <tomspur> Hi
16:02:31 <geppetto> Hey
16:03:04 <Rathann> hi
16:03:11 <geppetto> #chair Rathann
16:03:11 <zodbot> Current chairs: Rathann geppetto mbooth racor tomspur
16:03:39 <geppetto> wait a few more minutes to see if orion or tibbs can make it
16:03:49 <orionp> hello
16:04:13 <geppetto> #chair orionp
16:04:13 <zodbot> Current chairs: Rathann geppetto mbooth orionp racor tomspur
16:05:12 <geppetto> #topic Schedule
16:05:15 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/I2J2MQ4NK2RXFHDEMYHJOOCOWLRELZFJ/
16:05:23 <geppetto> Ok
16:05:30 <geppetto> #topic #625  GAP Packaging Guidelines Draft
16:05:33 <geppetto> .fpc 625
16:05:35 <zodbot> geppetto: #625 (GAP Packaging Guidelines Draft) – fpc - https://fedorahosted.org/fpc/ticket/625
16:07:22 <geppetto> It could do with an example
16:08:23 <tibbs|w> Hey, folks.  Sorry about that.
16:08:32 <geppetto> #chair tibbs
16:08:32 <zodbot> Current chairs: Rathann geppetto mbooth orionp racor tibbs tomspur
16:08:35 <geppetto> No problem
16:08:47 <tibbs|w> Wow, seven.  Not bad.
16:08:50 <orionp> yeah, sample spec would be good
16:08:56 <tomspur> TTH could be explained brieflx in the text. But maybe that's obvious if you know GAP packages
16:09:31 <Rathann> it'd be nice to actually map the 2-level GAP dep system to RPMs hard/soft/weak deps instead of leaving it to the discretion of the packager
16:09:42 <Rathann> that's what guidelines are for, after all
16:09:49 <orionp> otherwise, nice work
16:09:55 <Rathann> maybe "should" instead of "must" but still
16:10:11 <geppetto> yeh
16:10:32 <Rathann> also, a dep generator that would parse this PackageInfo.g and spit them out automatically would be extra nice
16:10:39 <geppetto> tomspur: Yeh, I think that bit mostly says "if you need tth to build, add tth as a buildrequires" ... but maybe it's saying something else too
16:10:58 <geppetto> Rathann: What colour would you like your pony ;)
16:11:08 <Rathann> pink and blue
16:11:36 <geppetto> :)
16:11:45 <mbooth> Rathann: Purple. Got it.
16:11:54 <Rathann> well, anyway, the draft looks sane enough for +1
16:12:10 <Rathann> it's quite good for the first draft
16:12:17 <tibbs|w> I agree, it's relatively sane for a first go at it.
16:12:35 <Rathann> oh, just one thing
16:12:50 <Rathann> I don't think it's correct to exclude license files from the package
16:12:55 <tibbs|w> Sadly, someone didn't read the guidelines about naming things in lower case with they packaged GAPDoc.
16:13:01 <Rathann> they should go into %license line
16:13:23 <geppetto> Rathann: If you have the same license as something you depend on ... I think it's fine.
16:13:27 <tibbs|w> Rathann: I think the intent of that was that they wouldn't be installed down in the gap_dir/pkg directory.
16:13:32 <geppetto> Rathann: If you are an addon/plugin/etc.
16:13:44 <tibbs|w> But the wording suggests otherwise.
16:13:47 <Rathann> indeed
16:14:04 <Rathann> ah well
16:14:09 <tibbs|w> Honestly, a sample spec would kind of be nice.  If for no reason other than letting me look at it.
16:14:21 * geppetto nods
16:14:30 <Rathann> two sentences earlier it says it's talking about files going into %{_gap_dir}/pkg
16:14:38 <Rathann> so maybe I'm exaggerating
16:15:18 <tibbs|w> Right, it's just confusing.
16:15:27 <tibbs|w> Let me make an edit.
16:16:44 <tibbs|w> https://fedoraproject.org/w/index.php?title=User%3AJjames%2FGAP_packaging_guidelines&diff=447141&oldid=446656
16:17:02 <Rathann> +1
16:18:17 <geppetto> +1
16:18:56 <geppetto> do we want to approve it as is though, or ask for the examples and cleanup the tth bit and the weak deps?
16:19:07 <tomspur> #1
16:19:22 <tomspur> +1
16:19:22 <geppetto> I don't think I mind +1'ing as is, and asking for improvements :)
16:20:10 <orionp> yeah, tibbs change is better, but I still want the other changes
16:20:20 <tibbs|w> I'm happy to +1 now and work out kinks as we find them.
16:20:34 <tibbs|w> But I don't think it hurts to ask for a sample.
16:21:13 <tibbs|w> Also, maybe a macro to clean up some cruft from the installed package directory so people aren't all making up their own long find commands.
16:22:46 <racor> I wonder if the %docdir stuff actually is a packaging/configuration bug in some gap-package somewhere.
16:25:23 <tibbs|w> Down at the bottom?  I don't think so.
16:26:16 <tibbs|w> This kind of thing isn't really uncommon with software suites which have their own documentation system.
16:26:31 <racor> tibbs|w: yes, the "documentation" section
16:26:50 <tibbs|w> Though maybe it would be possible to just make that internal documentation system look in the same place as we normally keep documentation.
16:27:23 <racor> tibbs|w: I wonder, what prevents them from using /usr/share/doc/gap or similar
16:27:41 <tibbs|w> Probably nothing besides the will to avoid figuring out how to make that work and patching it in.
16:28:43 <racor> tibbs|w: Possible, I don't know ;)
16:31:20 <geppetto> Ok, so if we want to vote now and ask for a few kinks to be fixed later ... who is +1 for that?
16:31:25 <geppetto> +1
16:31:39 <geppetto> (after tibbs fix, of course)
16:31:40 <mbooth> +1
16:31:45 <Rathann> +1
16:32:00 <tibbs|w> Sorry, a line of people appeared at the door.
16:32:06 <tibbs|w> I'm still +1.
16:32:29 <tomspur> +1
16:32:52 <racor> +1 (just to give people something to play with)
16:33:39 <geppetto> orionp: want to vote?
16:33:59 <orionp> Sure +1
16:34:06 <geppetto> #action GAP Packaging Guidelines (+1:7, 0:0, -1:0)
16:35:27 <geppetto> #info While approved a couple of things: 1) An example or two would be nice. 2) Might be nice to make a choice on the week deps. mapping, even if it's SHOULD and not MUST.
16:35:39 <geppetto> Anything else we want to ask?
16:36:21 <Rathann> yes, suggest writing an auto dependency generator
16:36:24 <racor> How about multilibs in gap-packages?
16:36:28 <Rathann> s/week/weak/
16:36:34 <geppetto> #info 3) A macro to clean up the cruft from installed package so all packagers don't do it 666 different ways.
16:36:42 <Rathann> that too
16:37:00 <geppetto> #info 4) An auto dep. generator would be cool :).
16:37:08 <geppetto> racor: What about multilibs?
16:38:04 <racor> geppetto: I suspect gab i386/x86_64 packages to conflict
16:38:12 <racor> s/gab/gap/
16:38:34 <geppetto> maybe ... could use requires _isa?
16:39:45 <racor> geppetto: I don't know ... To be investigated, IMHO.
16:40:08 <tibbs|w> I don't think they have any intention of making this multilib.
16:40:26 <geppetto> .me nods
16:40:33 <geppetto> ok ...
16:40:35 <geppetto> #topic #610  Packaging guidelines: Check upstream tarball signatures
16:40:40 <geppetto> .fpc 610
16:40:44 <zodbot> geppetto: #610 (Packaging guidelines: Check upstream tarball signatures) – fpc - https://fedorahosted.org/fpc/ticket/610
16:40:45 <tibbs|w> gap-devel is the only thing that's currently multilib-ed.
16:40:47 <geppetto> tibbs: Anything new for this week?
16:41:03 <racor> tibbs|w: Quite likely, but this often applies to upstreams.
16:41:18 <tibbs|w> geppetto: Not really.  Some people have decided they don't like the way something works.
16:41:36 <tibbs|w> And some bugs were found, which isn't surprising. I'm dealing with those in the pagure repo.
16:41:51 <tibbs|w> I blew pretty much the whole week working on quick-fedora-mirror instead.
16:43:15 <geppetto> ok, no problem ... what is quick fedora mirror though, that sounds cool :)
16:43:30 <tibbs|w> https://pagure.io/quick-fedora-mirror
16:44:10 <geppetto> Ahh, cool. Di dyou look at how debian do this?
16:44:28 <geppetto> Bah, this is probably off topic anyway. But cool.
16:44:41 <geppetto> #topic Open Floor
16:44:44 <geppetto> So anything else?
16:45:01 <tibbs|w> There was the naming guidelines thing.
16:45:33 <tibbs|w> I started making those trivial changes and found out that the python section of that document was terrible and rather wrong.
16:46:03 <tibbs|w> So I did some cleanup.  The result is at https://fedoraproject.org/wiki/Packaging:NamingGuidelines#Addon_Packages_.28Python_modules.29
16:46:44 <geppetto> Missing the %
16:47:01 <tibbs|w> Sorry, what's missing the %?
16:47:37 <geppetto> Weird, the link didn't take me to the right section
16:47:40 <Rathann> looks good, tibbs|w
16:47:50 <geppetto> I assumed it was missing %'s, but it's not it ... just buggy firefox I think
16:48:00 <Rathann> geppetto: worksforme ;)
16:48:23 <geppetto> Anyway, looks good
16:48:49 <tibbs|w> Anyway, that's already in there but I did  it pretty late last night after losing my edits several times (thanks, wiki) so if you see anything stupid please let me know.
16:49:39 * orionp is fixing some typos/grammar
16:50:21 <tibbs|w> To be fair I haven't even re-read it after sleeping.
16:50:31 <tibbs|w> But feel free to fix away.
16:51:13 <orionp> I don't quite follow the: Python2 module packages were named using a python- prefix.
16:51:24 <orionp> as being previous convention
16:51:33 <orionp> Isn't that the current convention?
16:52:34 <orionp> or is that referring to the binary rpm?
16:53:04 <tibbs|w> Yes, that should be talking about the binary package.
16:54:06 <tibbs|w> Anyway, orionp and I can probably hash this out if we want to finish off the meeting.
16:57:03 <orionp> thanks for working on on that
16:57:12 <geppetto> Sure
16:57:24 <Rathann> well, I have one bit of news to share: my unbundling workshop was accepted for Flock
16:57:28 <geppetto> I'll close at 1 unless someone else wants to talk about something
16:57:34 <geppetto> Rathann: cool
16:57:39 <Rathann> examples to tackle are welcome ;)
16:58:13 <mbooth> I have to duck out
16:58:26 <mbooth> And will not be present at next meeting (vacation, yay)
16:58:41 <Rathann> good for you, get some rest!
16:58:46 <mbooth> Enjoy the rest of your days :-)
17:01:34 <geppetto> #endmeeting