14:35:50 <dgilmore> #startmeeting RELENG (2016-08-08)
14:35:50 <zodbot> Meeting started Mon Aug  8 14:35:50 2016 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:35:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:35:50 <zodbot> The meeting name has been set to 'releng_(2016-08-08)'
14:35:50 <dgilmore> #meetingname releng
14:35:50 <dgilmore> #chair dgilmore nirik tyll sharkcz bochecha masta pbrobinson pingou maxamillion mboddu
14:35:50 <zodbot> The meeting name has been set to 'releng'
14:35:50 <zodbot> Current chairs: bochecha dgilmore masta maxamillion mboddu nirik pbrobinson pingou sharkcz tyll
14:35:54 <dgilmore> #topic init process
14:36:28 <nirik> morning
14:36:30 * sharkcz is here
14:37:30 * coremodule is here
14:37:47 <dgilmore> afternoon all
14:38:01 <mboddu> morning everyone
14:38:52 <coremodule> Hello@
14:38:53 <coremodule> !
14:38:55 * pbrobinson o/
14:40:23 <dgilmore> welcome coremodule
14:40:37 * dgilmore wanted to start witha  new topic
14:40:41 <coremodule> Thanks, glad to be here!
14:40:46 <dgilmore> #topic close trac
14:41:14 <dgilmore> I was thinking over the weekend about closing the releng trac entirely
14:41:26 <dgilmore> and doing ticket tracking in bugzilla or pagure
14:41:51 <dgilmore> I think that pagure would be nicer
14:41:53 <pbrobinson> useful to get rid of one of them, they're all terrible for most of our usecase though sadly
14:42:02 <dgilmore> indeed
14:42:27 <nirik> we should see if the trac converter is all ready...
14:42:33 <nirik> trac->pargure that is
14:42:43 <dgilmore> mboddu: has been working on a tool to automate unblocking of packages when they get approved in pkgdb,  which covers a number of tickets we get
14:42:51 <nirik> They were working on the attachment suppport, once thats done it should all be ready to go
14:43:01 <dgilmore> okay
14:43:13 <dgilmore> not sure we have any tickets with attachements
14:43:29 <dgilmore> Figured I would bring it up and get peoples thoughts
14:43:32 <nirik> yeah, probibly not many.
14:43:43 * nirik is +1 to the idea. One less tracker is good.
14:44:16 <dgilmore> #info seems to be a good idea to move off of trac entirely
14:45:39 <dgilmore> #info likely pagure is best, need to evaluate
14:45:51 <dgilmore> #topic #6420 Hypothetical maximum speed mirroring
14:46:00 <dgilmore> https://fedorahosted.org/rel-eng/ticket/6420
14:46:11 <dgilmore> pbrobinson: did you get a chance to talk to tibbs?
14:46:19 <pbrobinson> about?
14:46:31 <dgilmore> or was it just nirik that you needed to get with
14:46:31 <tibbs> I don't believe so.
14:46:41 <tibbs> Unless my memory is really, really terrible.
14:46:48 <pbrobinson> I sat down with nirik about the file list thing, got that sorted
14:46:49 <nirik> pbrobinson: the secondary updating the fullfiletimelist... yes we did
14:46:52 <dgilmore> updating the filelist files for secondary to make the mirroring tool tibbs wrote work better
14:47:02 <pbrobinson> yep, nirik and I did that
14:47:06 <dgilmore> cool
14:47:08 <tibbs> Cool.
14:47:17 <dgilmore> I was not 100% sure if it was tibbs or nirik
14:47:35 <dgilmore> not sure we need to keep this ticket open
14:47:44 <dgilmore> tibbs: do you consider our side done?
14:47:59 <tibbs> I don't know what was done here, actually.
14:48:03 <pbrobinson> I have a few minor bits to clean up today or tomorrow but basically all done
14:48:23 <tibbs> But if the file list generation is all done, then I think everything's OK.
14:48:28 <nirik> we need a fedmsg still...
14:48:38 <tibbs> I'm supposed to get with smooge to watch the move to archive.
14:48:40 <nirik> but that can be a infra ticket or local task for me
14:48:48 <dgilmore> tibbs: just updating processes to update the filelist files
14:50:21 <dgilmore> lets remove the meeting keyword
14:50:33 <dgilmore> and I guess we should update the ticket from the releng side
14:54:13 <dgilmore> #topic Alpha preperation
14:54:27 <dgilmore> so we have bodhi enablement tomorrow
14:54:37 <dgilmore> well this evening
14:54:44 <dgilmore> after UTC 00:00
14:55:08 <dgilmore> #info Alpha freeze starts at 00:00UTC
14:55:09 <nirik> https://fedorahosted.org/rel-eng/ticket/6456 needs sorting... and I worry it's going to cause some problems. ;(
14:55:49 <dgilmore> fedorahosted is not reachable from here
14:55:55 <nirik> I just fixed it
14:56:02 <nirik> had to restart httpd
14:56:42 <dgilmore> nirik: so if he did fedpkg retire they are blocked
14:56:45 <dgilmore> or should be
14:56:50 <dgilmore> and he said that is what he did
14:57:29 <nirik> I think it has something to do with him not having commit on the package?
14:57:38 <dgilmore> hrrm
14:57:53 <nirik> I don't see any of them blocked
14:58:25 <dgilmore> joy
14:58:42 <dgilmore> I guess we need to file bugs in pkgdb then
14:58:56 <dgilmore> they will have to all be retired correctly
14:59:32 <paragan> I think pingou told me if I was SCM admin then everything would have worked fine.
14:59:55 <pbrobinson> looking through that list I suspect the CERN people are going to be pissed
15:00:13 <nirik> we can unretire things that peopel actually fix. ;)
15:00:27 <dgilmore> paragan: right, it needs to be done by some one with appropriate permissions, no offense but you really should not have tried to do it
15:00:42 <paragan> I am sorry I was not knowing that
15:00:45 <dgilmore> there should have been a ticket filed so we can handle it
15:00:46 <nirik> well, it's unclear if provenpackager should be able to
15:01:02 <nirik> so we should make that clear and/or allow provenpackager to retire
15:01:03 <dgilmore> nirik: we can ask FESCo to clear that up
15:01:07 <paragan> I too thought being provenpackager it can be possible
15:01:19 <nirik> dgilmore: sure.
15:01:21 <dgilmore> #info ask FESCo to clear up if provenpackager can retire any package
15:01:29 * nirik is fine with provenpackager being able to.
15:01:41 * dgilmore has no strong prefernece
15:01:54 <pbrobinson> I'm sure I've retired with proven packager (pre rel-eng) but that might be arch maintainer that gave me that in the past
15:02:18 <dgilmore> #info all the packages in ticket 6456 need to be cleaned up fully
15:03:09 <dgilmore> #action file ticket for pkgdb to ensure that people without permission to retire a package have everything rejected
15:03:56 <dgilmore> #action file ticket with fedpkg to check if retiring person has permission to retire package
15:05:26 <dgilmore> anything else that anyone is aware of that we need to get done today?
15:06:39 <coremodule> Would someone be willing to walk me through the process of pushing an updated comp.xml file? I have an update for Fedora Electronic Lab that needs to get pushed, but I am unsure of how to do it...
15:06:51 <pbrobinson> dgilmore: have you done permissions on the new f26 keys or just created them atm
15:07:12 <pbrobinson> coremodule: pull request against the pagure repo
15:07:33 <pbrobinson> coremodule: the rest of the details are in the fedora wiki
15:08:36 <dgilmore> pbrobinson: right now I have given you and nirik access, I need to  add everyone else. just been in meetings all afternoon
15:09:12 <pbrobinson> dgilmore: more just wondering if it's time to change the passwords, or if I should wait a bit
15:09:20 <dgilmore> coremodule: fork https://pagure.io/fedora-comps make your changes and follow up as pbrobinson said
15:09:47 <nirik> coremodule: happy to help assist further in #fedora-devel or #fedora-releng after the meeting.
15:09:49 <dgilmore> pbrobinson: you can do it now. I just need to give more people access to the keys
15:10:07 <coremodule> pbrobinson, dgilmore, Thanks, I'll check it out.
15:10:14 <dgilmore> and get everyone to change their passwords
15:10:24 <coremodule> nirik, Thanks, I'll ping you after the meeting, I have a question about permissions regarding that.
15:10:37 <nirik> cool
15:10:45 <dgilmore> I am not 100% sure that the docs for adding a release to bodhi have been updated
15:10:53 <dgilmore> hopefully they have
15:11:02 <dgilmore> otherwise we may be in for fun
15:11:18 <dgilmore> since lmacken is on PTO
15:12:14 <nirik> I think we should be ok... but we will see.
15:13:50 <dgilmore> #info thanks to pbrobinson and mboddu for handling branching and setting up branched compose while I was on PTO
15:14:11 <dgilmore> I think thats all I have for alpha
15:14:27 <pbrobinson> no problems, I think mboddu and I mostly muddled our way through it to success
15:14:49 <dgilmore> #topic Secondary Architectures updates
15:14:50 <dgilmore> #topic Secondary Architectures update - ppc
15:14:58 <dgilmore> pbrobinson: how is ppc looking?
15:14:59 <pbrobinson> we're mostly looking good here
15:15:10 <pbrobinson> I think I might have fixed nightly composes for tomorrow
15:15:20 <pbrobinson> there's a couple of packages blocking builds though
15:15:33 <pbrobinson> so we're trying to get those debugged ATM
15:15:51 <dgilmore> okay
15:16:03 <dgilmore> #info composes sorted out
15:16:13 * nirik notes we should add to branching docs: create updates/updates-testing repos (empty)
15:16:29 <dgilmore> #info a couple of blockers being looked at and worked on
15:16:58 <dgilmore> nirik: yeah. hopefully mboddu has that in the Pull request I am hoping he will do shortly
15:17:12 <pbrobinson> nirik: yes! I knew about that but wasn't sure on primary if that was something bodhi added or if we create a first pass for mirroring manually until bodhi overwrites them
15:17:35 <nirik> yeah, it's manual. bodhi doesn't do em...
15:17:40 <pbrobinson> OK
15:18:06 <dgilmore> #topic Secondary Architectures update - s390
15:18:13 <dgilmore> sharkcz: how is s390?
15:18:42 <sharkcz> it looks good, still only hours behind primary build-wise, no blockers
15:19:29 <sharkcz> for composes & co we will work with pbrobinson after ppc is sorted out
15:19:35 <dgilmore> #info no blockers, builds in good shape
15:19:39 <dgilmore> okay
15:19:49 <dgilmore> #info composes still being sorted
15:19:50 <pbrobinson> yep, s390 compose is on my list for this week too
15:20:08 <pbrobinson> it's getting the repos done, just not a full server compose
15:20:25 <pbrobinson> we have Docker on the list for s390 for this cycle too but it might be one that lands for beta
15:20:42 <dgilmore> I think that is okay
15:20:49 <sharkcz> yep
15:21:54 <dgilmore> #topic Secondary Architectures update - arm
15:22:00 <dgilmore> pbrobinson: how is aarch64?
15:22:39 <pbrobinson> builds are pretty much up to date. Compose is running fine, but I need to fix the cloudy bits (imagefactory is broken again basically)
15:23:41 <dgilmore> okay
15:23:57 <dgilmore> #info builds okay, composes running, imagefactory being naughty
15:24:01 <nirik> pbrobinson: there was a primary imagefactory fix... might be related?
15:24:28 <nirik> http://koji.fedoraproject.org/koji/buildinfo?buildID=786264
15:24:37 <nirik> (do not fail if vsphere fails to import)
15:24:58 <pbrobinson> nirik: from memory the f23 build we used was a copr build and we just need to get the patch upstream (which is apparently in the latest release due in fedora soon)
15:25:09 <nirik> ok cool.
15:25:39 <pbrobinson> I spoke with Ian about it, just not had time to follow up basically :)
15:25:43 <dgilmore> cool
15:25:49 <dgilmore> anything else to add?
15:25:57 <pbrobinson> nope
15:26:00 <dgilmore> #topic Open Floor
15:26:10 <dgilmore> does anyone have anything else to bring up?
15:27:01 <dgilmore> I will give ita  minute and close up otherwise
15:27:03 <nirik> can we drop i686 images ?
15:27:13 <nirik> at least I thought that was the plan for f25...
15:27:36 <pbrobinson> was it all images or a case by case basis?
15:28:06 * nirik is looking for the ticket
15:28:10 <pbrobinson> eg I'd like to keep SoaS because it's still used a lot in the developing world
15:28:28 <nirik> https://fedorahosted.org/fesco/ticket/1469
15:28:50 <nirik> I guess it's unclear
15:28:52 <dgilmore> nirik: I think we should move i686 to secondary
15:29:15 <dgilmore> nirik: from the releng perspective it has never been the plan to drop i686
15:29:27 <nirik> well, with the new secondary/primary proposal, we should just make it so we reduce/drop the i686 deliverables...
15:29:44 <nirik> ie, only keep those few things like SoAS that want a i686 version.
15:29:46 <dgilmore> not sure what you mean by that statement
15:30:06 <nirik> do not make workstartion/server/cloud/atomic/whatever i686 images.
15:30:12 <dgilmore> I would like to make them all, as we do, but put them in /pub/fedora-secondary/
15:30:12 <nirik> continue making the packages as normal
15:30:25 <dgilmore> including the Labs
15:30:28 <dgilmore> and Spins
15:30:38 <nirik> well, I think we need to poke fesco, as it's unclear currently.
15:31:13 <nirik> some of the working groups specifically asked to not ship i686 isos already
15:31:16 <dgilmore> nirik: I suspect that FESCo said drop them because they have made it non release blocking and to them it was either drop or build
15:31:21 <dgilmore> not move where it goes
15:31:47 <dgilmore> nirik: the WG's also do not really follow what the secondary arches do
15:31:58 <nirik> sure.
15:32:10 <nirik> I can file a fesco ticket, or would you like to?
15:32:28 <nirik> or we could pile on the redefining secondary archs ticket... as thats related.
15:32:33 <dgilmore> I think its a matter of communication being crap, people not knowing whats going on or what could be done, so just say lets kick it out
15:33:14 <dgilmore> I think it should go with the secondary arch ticket
15:33:23 <dgilmore> its essentially what FESCo has done
15:33:23 <nirik> ok
15:33:35 <dgilmore> just they did not want to kick it out because of multilib
15:34:03 <nirik> well, IMHO, we shouldn't be shipping i686 isos in the case of working groups that asked us not to.
15:34:31 <dgilmore> I think that if they knew they could move to secondary they would have asked for that rather than removal
15:34:45 <nirik> well, then we should communicate that.
15:34:53 <dgilmore> I think it is all a bit loaded
15:35:16 <dgilmore> nirik: right. we should say to the WG's we want to move the arch to secondary status
15:35:43 <nirik> well, you do
15:35:50 <dgilmore> given how big the market share is for i686 I think we would be doing our users a massive disservice just removing it
15:35:56 * nirik personally doesn't see as much point with i686 anymore
15:35:59 <dgilmore> sure
15:36:11 <dgilmore> nirik: its about 20% of users still
15:36:22 <dgilmore> thats a big enough point to keep it
15:36:39 <nirik> it's less
15:36:45 <nirik> https://admin.fedoraproject.org/mirrormanager/statistics/2016-08-07/archs
15:36:50 <nirik> 5.4% yesterday
15:37:21 <dgilmore> nirik: that stat is bogus though
15:37:22 <nirik> but of course that isn't some magic number... but anyhow.
15:37:26 <dgilmore> it includes RHEL
15:37:35 <dgilmore> well epel
15:37:53 <nirik> yeah, so it's less.
15:37:56 <nirik> in fedora
15:38:06 <dgilmore> in fedora it is more
15:38:21 <dgilmore> mattdm was saying it was around 20% at flock
15:38:27 <masta> I think we should continue to do the i686 stuff a while longer.
15:38:34 <nirik> huh, that very much surprises me... but ok
15:38:48 <masta> but yeah, organize i686 so the WGs don't have to care
15:39:03 <nirik> well, we (releng) shouldn't decide. We should ask fesco and working groups with all the info we have what they want to do.
15:39:25 <masta> I guess so
15:39:53 <nirik> ideally it would be before alpha freeze, but oh well
15:43:11 <dgilmore> its probably a discussion that should have happened at branching time
15:44:02 <nirik> yeah, or before.
15:45:48 <dgilmore> well by branching I mean when we branched f24
15:45:53 <dgilmore> bit vague there
15:46:19 <dgilmore> so that rawhide had things as intended to be shipped in f25 as soon at it is practical
15:46:48 <nirik> right.
15:48:05 <dgilmore> #action dgilmore to reach out and communicate, proposing to drop i686 to secondary arch
15:49:05 <dgilmore> I may be wrong about the arch stats
15:49:21 <dgilmore> looking now it seems this time round mattdm did not do a arch slide
15:52:47 <dgilmore> anyway
15:52:52 <dgilmore> #endmeeting