14:29:45 <jflory7> #startmeeting Fedora Diversity Team (2016-08-09)
14:29:45 <zodbot> Meeting started Tue Aug  9 14:29:45 2016 UTC.  The chair is jflory7. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:29:45 <zodbot> The meeting name has been set to 'fedora_diversity_team_(2016-08-09)'
14:29:46 <jflory7> #meetingname diversity
14:29:46 <zodbot> The meeting name has been set to 'diversity'
14:29:58 <jflory7> #topic Roll Call / Q&A
14:30:13 <jflory7> Morning / afternoon / evening, all o/
14:30:16 <MooDoo> o/
14:30:25 <potty> Morning! o/
14:31:37 <jflory7> MooDoo, potty: Hiya! Here for the Fedora Diversity meeting or just passing salutations? :)
14:31:50 <jflory7> .hello jflory7
14:31:51 <zodbot> jflory7: jflory7 'Justin W. Flory' <me@justinwflory.com>
14:31:55 <MooDoo> jflory7: passing interest without interfering
14:32:01 * jflory7 nods
14:32:15 <potty> Here for the meeting. Just reading right now
14:32:18 <potty> .hello potty
14:32:19 <zodbot> potty: potty 'Abdel G. Martínez L.' <abdel.g.martinez.l@gmail.com>
14:32:38 <jflory7> #chair potty tatica
14:32:38 <zodbot> Current chairs: jflory7 potty tatica
14:32:48 <tatica> o/
14:32:52 <tatica> .hello tatica
14:32:53 <zodbot> tatica: tatica 'Maria Gracia Leandro Lombardo' <tatadbb@gmail.com>
14:33:48 <jflory7> We'll wait a couple more minutes for some others to arrive too - I know there's a lot of things happening all over all at once today.
14:33:53 <tatica> oi!
14:34:23 <tatica> np! that wil give me time to move that damn button the boss things is 1px too far to the left... lol
14:34:34 <jflory7> Heheh :)
14:35:03 <jflory7> If it's alright to begin with, I'd like to do a quick overview of what exactly happened / was created in the last 24 hours, so we're all on the same page
14:35:11 <jflory7> Or maybe just starting with announcements
14:36:02 <tatica> sure, go ahead jflory7
14:36:03 <potty> hi tatica
14:36:08 <Amita> hi
14:36:13 <jflory7> #chair Amita
14:36:13 <zodbot> Current chairs: Amita jflory7 potty tatica
14:36:15 <jflory7> o/
14:36:30 <jflory7> Perfect. This should be enough for us to get started!
14:36:36 <jflory7> #topic Announcements
14:36:50 <jflory7> #info === What happened in the last 24 hours ===
14:37:36 <jflory7> #info Since yesterday, the Diversity team now has a FAS group, Fedocal, Pagure group, and Pagure repo. This fits into a larger discussion we will need to have regarding the tooling we use as a team and building solutions that help us meet the needs of the community and our own agenda items.
14:37:40 <jflory7> #link https://admin.fedoraproject.org/accounts/group/view/diversity-team
14:37:45 <jflory7> #link https://apps.fedoraproject.org/calendar/diversity-team/
14:37:50 <jflory7> #link https://pagure.io/group/fedora-diversity
14:37:55 <jflory7> #link https://pagure.io/fedora-diversity
14:38:00 <jflory7> #info === Current meeting time ===
14:38:17 <tatica> yisus! that's a lot of things happening in less than 24h
14:38:26 <tatica> it should say "what happened in the last 5 hours"
14:38:46 <jflory7> #info The current meeting time in Fedocal is set for 14:30 UTC (i.e. 10:30am US EST) every 14 days. A reminder will also be sent to the mailing list one day before our meetings to help remind everyone of the meeting time.
14:38:58 <jflory7> If needed, we can always change the meeting time if this time no longer works for many people.
14:39:02 <jflory7> tatica: Heheh, just a bit :)
14:39:13 <jflory7> Okay, that's all the announcements I had in mind for sharing
14:39:24 <jflory7> Ohh! Maybe one more, actually...
14:39:31 <jflory7> #info === Diversity Panel at Flock 2016 ===
14:39:39 <jflory7> #link http://tatica.org/en/2016/08/09/flocktofedora-diversity/
14:40:17 <jflory7> #info The Diversity Panel at Flock 2016 (organized by Amita) produced a lot of interest from attendees. Special thanks to the panelists who helped form the panel and to audience members who provided helpful / useful feedback for going forward.
14:40:18 <jflory7> eof
14:40:39 * jflory7 can't think of anything else to add right now
14:42:07 <jflory7> Do we want to go ahead and jump into discussion about our tooling, or is there anything you wanted to lead, tatica?
14:42:19 * jflory7 isn't sure if there were other items tatica was wanting to share or focus on today :)
14:43:04 <tatica> not right now, lets go with today's progress
14:43:31 <tatica> I'm in need to have a brieff about the insanity jflory7 brought to the tickets, lol
14:44:28 * jflory7 nods
14:44:35 <jflory7> #topic Open discussion
14:44:55 <jflory7> Okay, so I can give an update / briefing on some of the tooling for the Diversity Team that I had in mind
14:45:26 <jflory7> Originally, all I wanted was to have a Fedocal instance so we could have a reminder for the meeting, but it ended up resulting in also requesting a FAS group for administration privileges of said Fedocal
14:45:39 <jflory7> So Fedora Infra graciously created both a FAS group and Fedocal for us
14:46:11 <jflory7> The FAS group is also a good way for us to keep a count of those who are contributing or assisting actively with diversification and inclusion efforts in the project
14:46:21 <tatica> +1
14:46:41 <jflory7> I think now that we *have* a FAS group and there was talk about making a badge, it will be very important for us to have some clearly laid-out join steps for anyone interested in becoming involved.
14:47:00 <potty> jflory7: !
14:47:02 <jflory7> #idea Having on-boarding steps for new members who want to become involved with the Diversity Team (e.g. 1,2,3 steps)
14:47:05 <jflory7> potty: go ahead!
14:47:22 <potty> jflory7: who is in charge of approving Diversity members on FAS group?
14:47:34 <jflory7> potty: Right now, that will fall to tatica as the Diversity Adviser
14:47:51 <potty> Understood :)
14:48:02 <potty> EOF
14:48:10 <tatica> lol
14:48:13 <jflory7> Unless we decide otherwise based on an on-boarding process that can be clearly followed (e.g. "has $PERSON followed these steps and is ready to be sponsored in the group?")
14:48:21 <jflory7> But we can decide on that later on, I think.
14:48:21 <tatica> I will take over the badge, I think it's important to have something to show up
14:48:27 * jflory7 nods
14:48:30 <jflory7> tatica++
14:48:39 <jflory7> #nick diversity_team
14:48:44 <tatica> I'm thinking on a panda shaking hands with a badger, cause if we use the lgbt flag, it will be about one minority
14:48:52 <tatica> I don't want the badge to be asociate with none, but all
14:49:01 <jflory7> #action diversity_team Begin working on creating on-boarding steps for the Diversity Team and bringing new members in
14:49:03 <tatica> you can open the ticket so I can take it to make the badge
14:49:20 <jflory7> #action jflory7 File a ticket for Diversity Team member in fedbadges Trac
14:49:33 <jflory7> #action tatica Create badge artwork assets for Diversity Team member badge (once filed)
14:49:39 * jflory7 nods
14:49:51 <jflory7> So, after the FAS group and Fedocal, I looked at Pagure
14:49:56 <tatica> !
14:50:03 <jflory7> tatica: Sure, go ahead!
14:50:34 <tatica> I also approved all of you who have been helping on diversity at FAS. thx jflory7 for adding them
14:50:42 <jflory7> \o/
14:50:48 <tatica> we need to discuss about our accepting members policy, for next contributors to the team
14:50:57 <jflory7> Definitely agreed.
14:51:00 <tatica> but we can just do a draft and add inputs and discuss it next meeting
14:51:34 <jflory7> Mhmm. This should definitely be one of our #1 priority tasks, I think, too.
14:51:52 <jflory7> In regards to how we keep track of our tasks / action items...
14:52:06 <jflory7> *Normally*, we would probably want a Trac instance for this, where anyone can file a ticket and put something on our own agenda that we need to be aware of
14:52:32 <tatica> I can do it
14:52:40 <jflory7> However, Fedora Infra is "sunsetting" Trac in 2017, and they will no longer create new Trac instances unless there is no other solution
14:52:52 <jflory7> They are pointing people to use Pagure whenever possible, if it fills their needs
14:53:23 <jflory7> As a ticket-based team, I think we would be able to use Pagure to fit our own needs for the community. If we can build the tool we need here, it will save us from having to worry about migration farther down the line.
14:53:29 <tatica> we can go on email
14:53:36 <tatica> our list is slow, that can bring up some movement
14:53:38 <tatica> it's ok
14:54:12 <jflory7> You mean to forgo Pagure?
14:54:41 <jflory7> As an example, a ticket I filed yesterday (and how it could be used to keep tabs on tasks):
14:54:42 <jflory7> #link https://pagure.io/fedora-diversity/issue/1
14:55:10 <tatica> that's so cute :$
14:55:56 <jflory7> The one thing about Pagure is that it also works with FAS login (and is maintained by Fedora Infra), so it's easy for anyone with FAS to log in and participate.
14:56:08 <tatica> +1
14:56:32 <jflory7> #idea Using Pagure repo for creating tickets and keeping tabs on ongoing tasks for the Diversity Team
14:56:46 <jflory7> tatica: With regards to the idea I had earlier on the Diversity Inbox...
14:56:53 <tatica> yes
14:58:50 <jflory7> There's also ways for issues / tickets filed in Pagure to be "private" tickets. I think this was also possible in Trac (with sensitive tickets), but there could be a single repository for community concerns / issues that people want to raise. They would have the option to file it publicly or privately. Should they want to share it with the whole team, they could use the repo linked above. If they only want to share it with the Diversity
14:58:50 <jflory7> Adviser (and maybe someone else, like the FPL and FCL), they could create a ticket in a repo owned by just those individuals (so nobody else would have access to private tickets).
14:58:56 <jflory7> Whoa, more text than I thought...
14:59:32 <jflory7> But the advantages of doing it this way is that we don't have to create a special tool for this purpose
14:59:39 <tatica> question
14:59:40 <jflory7> It's all something we could do, hypothetically, tomorrow
14:59:41 <jflory7> Sure!
15:00:05 <tatica> my only concern with the pagure private is, what will hapen to cases of people who don't have access to fas
15:01:03 <jflory7> That would be a limiting factor. There *might* be a way for people to email in tickets, but I'm not 100% on that. I think for the time being, there isn't a good answer for that
15:01:38 <jflory7> #idea Using Pagure "private" issues for Fedora community members reporting issues / problems in the community that they want to share privately with FPL / FCL / Diversity Adviser
15:01:49 <jflory7> #idea What about people who don't have FAS accounts?
15:02:01 <tatica> well, we could have some wranglers that can open tickets in behalf of those who can
15:02:07 * jflory7 nods
15:02:10 <tatica> or, in behalf of those who do't want their names public
15:02:13 <tatica> that can happen as well
15:02:41 * potty is reading
15:03:01 <jflory7> I think that would be a good alternative. And if it would be something we might find helpful, we could look into the possibility of filing tickets from email too. But that would be something that would likely have to be expanded or added on to Pagure, and not guaranteed it would happen
15:03:05 <bconoboy> (sorry to interrupt, is this not the time for the fedora-serverwg meeting?)
15:03:22 <nirik> bconoboy: normally yeah... we could go to fedora-meeting-2 ?
15:03:26 <jflory7> bconoboy: Oh, I thought I picked a time that didn't interfere! :(
15:03:33 <jflory7> I must have had wrong time zones or something
15:04:04 <bconoboy> nirik: if it's free, wfm- then jflory7 can continue here
15:04:09 <nirik> we can use -2, no worries.
15:04:42 <jflory7> bconoboy: Super sorry - I will take another look at Fedocal after this meeting to make sure we don't bleed over next time.
15:04:48 <jflory7> jflory7-- :P
15:05:07 <nirik> possibly we didn't update our meeting time right either.
15:05:16 <bconoboy> Okay, </interruption>
15:05:20 * jflory7 nods
15:06:05 <jflory7> tatica: I think a good action item for now would be to make sure all of the Diversity Team has logged into Pagure, and then I can add them to the Diversity Team group on there so privileges are distributed
15:06:46 <jflory7> And if we use the public Pagure for the time being, we could probably switch to a ticket-based meeting structure too, so our meetings follow a regiment of target items
15:06:56 * jflory7 likes ticket-based meetings, but would want to know what others think
15:07:22 <tatica> exactly
15:07:34 <tatica> but yet, we need something non-log- related for those who don't want to go public
15:08:45 <jflory7> tatica: Hmm, could you re-explain that bit?
15:08:54 <jflory7> Like for people who want to talk to the team but not in Meetbot?
15:09:13 <tatica> jflory7, my only concern is that 80% of people won't like their names out when the time to make public their issues come down
15:09:21 <tatica> we need a solution for it, more than that
15:09:22 <Amita> that's correct
15:09:27 <Amita> tatica, +1 on it
15:09:38 <jflory7> Ahh, I see what you're saying now
15:09:42 <tatica> for example, I kept privated several issues I experienced in the past years because it could bring eben more harrasment
15:09:53 <jflory7> No, I absolutely agree
15:09:56 <tatica> so, we need to consider than more than half of those tickets will come annonymously
15:09:59 <Amita> yes, that's what quite evident now
15:10:04 <Amita> from the discussion
15:10:12 <Amita> I never wanted it to go in public
15:10:29 <tatica> Amita, sometimes, it's imperative to make things change
15:11:47 <Amita> I am going open now
15:11:50 <Amita> as I am in this team
15:11:58 <Amita> I will have to deal with it
15:12:04 <Amita> for others as well
15:12:17 <meskarune> .hello meskarune
15:12:18 <zodbot> meskarune: meskarune 'Dolores Portalatin' <meskarune@archwomen.org>
15:12:19 <tatica> so, probably having wranglers would be great
15:12:24 <jflory7> For ticket-based discussions, if the person filing the issue wishes to remain anonymous, I see no reason why we would want to violate their trust and force their issue into the public.
15:12:25 <jflory7> #chair meskarune
15:12:25 <zodbot> Current chairs: Amita jflory7 meskarune potty tatica
15:12:29 <jflory7> meskarune: o/
15:12:56 <Amita> I can show world about the issue as example
15:13:00 <Amita> who says there is no issue
15:13:36 <jflory7> #idea Having ticket-based meetings based on tickets filed in public / private Pagure repos
15:14:37 <jflory7> #action diversity_team If not created already, please log into Pagure with your FAS account and ping in #fedora-diversity when you have done so
15:14:39 <jflory7> #link https://pagure.io/login/?next=https://pagure.io/
15:14:54 <meskarune> \o
15:16:01 <jflory7> #action jflory7 File ticket for discussing Diversity Team on-boarding
15:16:10 <tatica> yup
15:16:12 * jflory7 feels satisfied about discussion for Diversity Team tooling
15:16:29 <tatica> I saw something similar to the google diversity panel
15:16:31 <meskarune> so there is a diversity email now?
15:16:34 <tatica> let me see if I can find it quickly
15:16:38 <jflory7> Is there anything else we want to cover, or move to an open floor for any lingering discussion topics?
15:16:42 <meskarune> coudl people use that to send information anonymously?
15:17:00 <tatica> https://www.google.com/diversity/
15:17:07 <jflory7> meskarune: Well, it's something on our wishlist. The idea I mentioned was using Pagure private issues as one way for people to do that, but email may work best for anyone without FAS
15:17:12 <meskarune> or I suppose psuedo anonymously so tatica can represent their concerns
15:17:19 * jflory7 clicks
15:17:54 <meskarune> I think an email should be high priority
15:18:05 <tatica> meskarune, I think that now that I read it, I think it would be correct that any annonimous ticket should have a wrangler that knows who raised the concern
15:18:14 <tatica> so it wouldn't be 100% annonymous
15:18:24 <meskarune> tatica: yes, and then you would be able to know for sure the concern is legitament
15:18:30 <jflory7> +1
15:18:51 <meskarune> it would be good to be fair to each person invovled
15:19:57 <tatica> meskarune, exacly.. thank you for that
15:20:04 <jflory7> meskarune++
15:20:26 <meskarune> also I am wondering are you going to sepperate CoC violations with anti-diversity actions?
15:20:41 <meskarune> like say someone is doing both
15:20:53 <meskarune> do you report that to another fas group?
15:21:32 <meskarune> and if someone isn't breaking the CoC but is making another person feel excluded and silenced how would that be handled?
15:21:56 * Amita leaving now, will be on logs tomorrow
15:22:00 <meskarune> \o
15:22:04 <jflory7> Amita: Good night!
15:22:11 <tatica> meskarune, first talk, that's the best we can do
15:22:27 <tatica> just see what just happened with the Amita case right now
15:22:40 <jflory7> I imagine for something like that, they'd still want to reach the team / Diversity Adviser specifically.
15:22:40 <tatica> people tend to forget to talk and discuss prior getting crazy
15:23:20 <meskarune> tatica: I think thats good, but I think maybe having a policy in place for steps on reporting and handling these sorts of things would be awesome
15:23:55 <meskarune> that way it is clear how people can contact you and what they can expect
15:24:06 <jflory7> e.g. pointing people to the Pagure repo(s) or direct contact to tatica with information that's helpful for resolving the problem (or identifying it)
15:24:13 <jflory7> ?
15:24:17 <meskarune> setting expectations ahead of time is really important, and maybe emphasize that the CoC needs to be followed for someone to contribute to fedora
15:25:11 <meskarune> jflory7: yeah, and have some examples of how to provide detailed information about an issue maybe
15:25:18 <tatica> meskarune, +1
15:25:37 <tatica> jflory7, not everyone would feel happy with me, so we need several wranglers
15:25:42 <jflory7> #idea Creating clear guidelines for how someone contacts Diversity Team / Adviser to streamline process (with helpful information for identifying and solving the issue quickly)
15:26:03 <jflory7> #idea Improving communication that the CoC needs to be followed in order to contribute to Fedora
15:26:32 <jflory7> #idea Having multiple wranglers for issues / tickets filed by the community
15:26:38 <jflory7> All seem sound?
15:26:42 <meskarune> also what is the process for reporting CoC violations?
15:26:58 <meskarune> and is it different on various parts of fedora's infra?
15:27:02 * jflory7 notes we're in the final four minutes and /me will have a hard stop then :(
15:27:03 <bee2502> .hello bee2502
15:27:04 <zodbot> bee2502: bee2502 'Bhagyashree Padalkar' <bhagyashree.iitg@gmail.com>
15:27:07 <jflory7> #chair bee2502
15:27:08 <zodbot> Current chairs: Amita bee2502 jflory7 meskarune potty tatica
15:28:07 <jflory7> meskarune: Hmmm. That's actually a really good question. As a contributor, I don't think I've ever seen how that would be done. I would think maybe directly contacting the FPL before we had the Diversity Adviser position. If I wasn't aware we had a Diversity Adviser, I would probably default to mattdm. So improving communication about this is a major need, I think.
15:28:10 <jflory7> bee2502: Hiya!
15:28:31 <meskarune> jflory7: ++
15:28:41 <meskarune> ok, I think that should be something the diverity team can push
15:29:06 <jflory7> #idea Improving communication about how and where to report CoC violations (who to contact? what info to include? where to report relevant info? what is helpful for reviewing violations?)
15:29:13 <jflory7> meskarune: +1, for sure.
15:29:18 <tatica> we should also add a guidelines for it
15:29:26 <meskarune> tatica: yes ++
15:29:38 <tatica> when you call a fail, you also need to be polite and not be harsh on the one who did wrong
15:29:40 * mailga thinks that the council is able to decide about CoC.
15:29:45 <tatica> it's a principle of politeliness
15:30:09 <jflory7> mailga: Ah, yeah, that would also make sense.
15:30:27 <tatica> mailga, we are here to make follow the rules in a healthy environment
15:30:29 <meskarune> I mean, its possible that a first violation could just mean a warning, a second the person could be supervised and mentored, etc
15:30:37 <tatica> if we think a rule is not good, we should bring it to the council
15:30:41 <meskarune> and it depends on how blatant the violation is
15:30:56 <meskarune> there should be a process for handling violations and reporting them
15:31:00 <meskarune> and same for diversity issues
15:31:03 * jflory7 notes we're at time
15:31:24 <mailga> tatica: +1
15:31:26 <jflory7> Have to go and pick up my car from the shop in the next 15 minutes - tatica, feel free to #endmeeting when the discussion wraps up
15:31:37 <tatica> I think that first we need to list the potential cases we will deal, make a draft on each and then decide on another meeting
15:31:43 <tatica> jflory7, sure
15:31:44 * jflory7 is AFK
15:32:29 <tatica> so, do you thikn it will be ok to start a draft about the cases we might deal?
15:32:45 <tatica> it will only be like a begining until we get new cases and expand our understanding of them
15:33:08 <tatica> also draft a list of questions anyone could answer to report one case of bullying or harrasment
15:33:10 <meskarune> yeah that should be helpful, and I can give you some ideas of the things I have run into in other communities like ubuntu and arch
15:33:11 * mailga isn't in the diversity team but thinks this is a good way to start.
15:33:27 <tatica> mailga, welcome on board! you're here! you care! you're the team!
15:34:49 <meskarune> \o/
15:35:18 <mailga> tatica: I'm too many times absent in those period, so I'm not able to give any continuity. I was just guessing.
15:35:20 <meskarune> tatica: do you know if there is already a process for handling CoC violations?
15:35:30 <tatica> meskarune, I will take you and learn from those cases
15:36:04 <tatica> meskarune, no like a process itself
15:36:11 <tatica> that's our task now
15:36:14 <meskarune> ok
15:36:56 <meskarune> maybe if the IRC team and forum mods already have a process it could be integrated into a larger CoC violation process to handle issues fairly but strictly
15:38:00 <meskarune> if they don't, then the CoC stuff will help them too
15:38:24 <tatica> meskarune, I like, our task could be to organize the case to present
15:38:30 <meskarune> I think this diversity iniative is goign to really changae thigns for the better for fedorans
15:38:38 <tatica> meskarune, I really hope so
15:38:41 <meskarune> tatica: yeah :)
15:38:42 <tatica> ok, so task
15:39:29 <tatica> #action start a draft about cases we can work on to prepare members on how to adress them
15:39:35 <tatica> zodbot, never likes me
15:40:19 <tatica> #action get a meeting with the council to discuss how far is our reach into how to deal with the cases that arrive to us
15:40:45 <mailga> zodbot is not in the channel
15:40:48 <tatica> cause I have no idea how far we can help, and we need that
15:40:56 <meskarune> yeah, thats a good point
15:41:00 <tatica> he left me... he always does that
15:41:04 <meskarune> aw
15:41:12 <tatica> lol
15:41:24 <tatica> ok, I think that this has been a great meeting, getting back from flock
15:41:29 <tatica> #topic openfloor
15:41:34 <mailga> tatica: zodbot ungrateful....
15:41:46 <tatica> ok, I would like to thank everyone who did a fantastic job at Flock!
15:42:00 <tatica> I couldn't be more proud of all of you... I've only heard wonders of your inputs there
15:42:07 <tatica> so... congratulations!!!!
15:42:20 <tatica> anyone wants to add anything before I call it out?
15:43:22 <tatica> goes on 3
15:43:27 <tatica> 2
15:43:32 <tatica> 1
15:43:34 <tatica> #endmeeting