16:00:36 <geppetto> #startmeeting fpc
16:00:36 <zodbot> Meeting started Thu Aug 11 16:00:36 2016 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:36 <zodbot> The meeting name has been set to 'fpc'
16:00:36 <geppetto> #meetingname fpc
16:00:36 <zodbot> The meeting name has been set to 'fpc'
16:00:36 <geppetto> #topic Roll Call
16:00:47 <orionp> hello
16:00:49 <geppetto> #chair tibbs
16:00:49 <zodbot> Current chairs: geppetto tibbs
16:00:52 <geppetto> #chair limburgher
16:00:52 <zodbot> Current chairs: geppetto limburgher tibbs
16:04:16 <geppetto> #chair racor
16:04:16 <zodbot> Current chairs: geppetto limburgher racor tibbs
16:04:28 <tibbs> So...
16:04:46 <geppetto> La?
16:04:52 <tibbs> I talked to Xavier at Flock and his hours just haven't lined up.
16:04:59 * geppetto nods
16:05:11 <orionp> boo
16:05:23 <geppetto> #chair orionp
16:05:23 <zodbot> Current chairs: geppetto limburgher orionp racor tibbs
16:05:34 <geppetto> orionp: sorry, didn't see you there :-o
16:06:19 * geppetto remembers to send out ping, but we have 5 so we'll start in a couple of minutes
16:07:36 <mbooth> Hi
16:07:55 <geppetto> #chair mboddu
16:07:55 <zodbot> Current chairs: geppetto limburgher mboddu orionp racor tibbs
16:08:03 <geppetto> #undo
16:08:03 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1258f310>
16:08:12 <geppetto> #unmod mboddu
16:08:19 <geppetto> #chair mbooth
16:08:19 <zodbot> Current chairs: geppetto limburgher mboddu mbooth orionp racor tibbs
16:08:24 <geppetto> #unchair mboddu
16:08:24 <zodbot> Current chairs: geppetto limburgher mbooth orionp racor tibbs
16:08:28 <geppetto> ok
16:08:47 <geppetto> Not sure what my undo did ... probably removed the roll call topic, sigh
16:08:49 <geppetto> #redo
16:08:53 <geppetto> ha, no
16:09:10 <geppetto> #topic Schedule
16:09:14 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/FZWRWHLWLIXX77SODQYQBEQIQRTK7EMF/
16:09:30 <geppetto> #topic #641     Proposal to improve wiki page of cmake packaging
16:09:35 <geppetto> .fpc 641
16:09:36 <zodbot> geppetto: #641 (Proposal to improve wiki page of cmake packaging) – fpc - https://fedorahosted.org/fpc/ticket/641
16:10:25 <tibbs> I will admit to not really understanding cmake.
16:10:55 <orionp> I'm the cmake packager, so I suppose I do a bit :)
16:10:55 <geppetto> I only know the very basics
16:11:06 * geppetto hands the mic to orionp
16:11:14 <tibbs> rdieter's opinion would also be useful, I guess.
16:12:07 <tibbs> I have no problems with cleaning up the page, but I guess there's disagreement about whether the stuff in that ticket is good.
16:12:08 <orionp> yeah, the kde folks live in the cmake world
16:12:14 <rdieter> hrm, could've sworn I'd commented in the ticket before
16:12:40 <rdieter> but offhand, the rpath suggestion is bad
16:13:00 <orionp> Generally we request a draft, which seems like the place to start
16:13:27 <rdieter> the out-of-src-tree suggestion... meh, some packages work well, others don't, so maybe not a good idea to make any official recommendation there either
16:14:17 <geppetto> Yeh, people love to do drafts via. giving us a hand patch :-o
16:14:19 <rdieter> so as is, given the suggestions aren't *great* and lack of any formal draft, there's probably little/nothing to do from fpc side
16:14:53 <geppetto> #action Need a real draft
16:15:14 <geppetto> #action Out-of-src-tree suggestion won't work for all packages.
16:15:22 <tibbs> I would think that we'd recommend out of tree builds when they work, but if they work less than 80% of the time then maybe not.
16:15:34 <tibbs> I guess for rpm building it doesn't really matter.
16:15:57 <rdieter> sure, even autoconf-based projects could theoretically to out-of-tree builds
16:16:03 <rdieter> s/to/do/
16:16:15 <geppetto> yeh, it's roughly the same there
16:16:21 <geppetto> some work well, some fail
16:16:36 <tibbs> Then almost certainly not worth the efort.
16:16:42 <racor> some require VPATH builds ;)
16:16:44 <orionp> I do a lot of out of tree builds, but then I package MPI stuff which does multiple builds
16:17:11 <rdieter> orionp: <nod>, for that use-case, it's almost essential
16:17:17 <tibbs> Right, in the RPM building contezt that's really the only time you have to do it.
16:17:25 <tibbs> Otherwise it shouldn't really matter.
16:17:29 * geppetto nods ... I've used it a lot for optimized vs. debug builds
16:17:50 <geppetto> It's useful, but it requires testing
16:18:03 <geppetto> Anyway, moving on unless anyone wants to add more actions?
16:18:11 <geppetto> or data.
16:18:20 <orionp> #action - rpath sed is rejected
16:18:22 <tibbs> For the sake of keeping the guideline page clean, I'd suggest just ignoring it.  Or maybe adding a short appendix about it.
16:19:19 <orionp> I'm done
16:19:29 <geppetto> #topic #642     Clarify in the packaging guidelines that the "nobody" user is not OK to use for system daemons
16:19:32 <geppetto> .fpc 642
16:19:33 <zodbot> geppetto: #642 (Clarify in the packaging guidelines that the "nobody" user is not OK to use for system daemons) – fpc - https://fedorahosted.org/fpc/ticket/642
16:20:37 <tibbs> I was +1 in the ticket.
16:20:41 <geppetto> Yeh
16:20:56 <geppetto> I'm happy with where you want to put it too
16:20:59 <limburgher> I'm +1.  And I'm the distcc maintainer.
16:21:01 <orionp> +1 and that seems like the right location.
16:21:03 * limburgher groans
16:21:11 <geppetto> limburgher: :)
16:21:51 <tibbs> I'd think it would be safe to change a package to do it between releases.  Probably not within a release.
16:22:04 <tibbs> (where "do it" is use a proper user.
16:22:14 <limburgher> Yeah.
16:22:31 <geppetto> #chair Rathann
16:22:31 <zodbot> Current chairs: Rathann geppetto limburgher mbooth orionp racor tibbs
16:22:52 <Rathann> hi, terribly sorry for being late
16:22:58 <geppetto> No problem
16:23:25 <geppetto> Wea re on 642 atm. ... and at +4 with tibbs recommendation in the comment
16:23:27 * Rathann has an acute neck ache
16:23:32 <geppetto> :(
16:23:47 <Rathann> but painkillers started to work now
16:23:53 <Rathann> ok, let me check
16:24:01 <racor> +1
16:24:05 <mbooth> +1 from me, too
16:24:26 <Rathann> yep, +1
16:25:02 <geppetto> #action Clarify guidelines to not use "nobody" userid for daemons (+1:7, 0:0, -1:0)
16:25:11 <geppetto> #topic #643     Exceptions for bootstrapping Rust and Cargo
16:25:21 <geppetto> .fpc 643
16:25:22 <zodbot> geppetto: #643 (Exceptions for bootstrapping Rust and Cargo) – fpc - https://fedorahosted.org/fpc/ticket/643
16:25:53 <geppetto> Seems like a simple +1 here
16:26:17 <tibbs> +1
16:26:21 <limburgher> +1
16:26:42 <orionp> +1
16:27:43 <racor> +1
16:28:47 <mbooth> +1
16:31:03 <geppetto> Rathann: That's +6 want to vote for the record?
16:31:14 <Rathann> yes, +1
16:31:19 <geppetto> #action Exceptions for bootstrapping Rust and Cargo (+1:7, 0:0, -1:0)
16:31:31 <geppetto> #topic #644     Allow %systemd_ordering to be used
16:31:34 <geppetto> .fpc 644
16:31:36 <zodbot> geppetto: #644 (Allow %systemd_ordering to be used) – fpc - https://fedorahosted.org/fpc/ticket/644
16:33:21 <geppetto> Midding paragraph of last comment seems fine, although it seems weird to have uid allocation of all of systemd grouped together. Sigh.
16:33:40 <limburgher> Looks reasonable.
16:36:12 <geppetto> Anyone else +1 or want something changed first?
16:37:41 <Rathann> looks fine to me, +1
16:39:14 <mbooth> Sure +1
16:39:39 <tibbs> I've lost the context; let me see if my concern about the language was addressed.
16:41:22 <tibbs> Looks like it.  Although, there's mention of systemd UID and GID services, which we actually don't use (or at least we have no guidelines for them).
16:41:52 <geppetto> yeh
16:42:35 <tibbs> I''m +1, though I think while writing it up I'd probably remove the UID/GID bits..
16:42:46 <tibbs> We should probably look into that at some point.
16:42:50 <Rathann> s/e.g. to install UID, GID, or tmpfiles/e.g. tmpfiles/ ?
16:43:00 <geppetto> Yeh, I'm shocked nobody else has come forward
16:43:07 <tibbs> By which I mean that someone who knows what it does should tell us about it.
16:43:10 <orionp> +1, yeah, drop UID/GID for now
16:43:20 <geppetto> I thought it was a big thing on the container side to want to move away from scriptlets to allocate uid/guis
16:43:21 <limburgher> MmmHmm.
16:43:38 <geppetto> atomic too
16:44:04 <tibbs> I don't have a problem with moving away from scriptlets at all.  It could potentially solve some other problems (like install-time allocation). Maybe.
16:44:19 * geppetto nods
16:44:28 <tibbs> But... that's a separate topic.
16:45:13 <geppetto> mbooth: I think that's everyone but you is +1 without the uid/gid bits
16:45:25 <geppetto> damnit ... not you
16:45:33 * limburgher does a shot, in accordance with the "is systemd fixing more than it breaks" drinking game
16:46:03 * limburgher loves systemd, to be clear and avoid flames. :)
16:46:37 <racor> geppetto: Thank you for having missed my vote ;)
16:46:42 <geppetto> racor: It's you!
16:46:47 <geppetto> I knew there was one missing
16:46:47 <racor> 0, I am not convinced, but I apparently do not know enough about docker/containers to have a strong opinion.
16:46:53 <geppetto> I couldn't work out who it was
16:47:25 <geppetto> limburgher: Actually you didn't actually say +1, I think
16:47:34 <limburgher> +1
16:47:42 <geppetto> #action Allow %systemd_ordering to be used (+1:6, 0:1, -1:0)
16:47:51 <geppetto> ok
16:48:03 <geppetto> #topic Open Floor
16:48:15 <geppetto> I'm pretty sure none of the old tickets have moved/changed
16:48:26 <geppetto> But anyone want to talk about them, or anything else?
16:48:37 <tibbs> I obviously have a huge queue.
16:49:00 <tibbs> Hopefully I'll be able to make a dent in it over the next few days.  Sadly I came home from Flock sick.
16:49:05 <limburgher> Nothing pressing here.
16:49:07 <limburgher> Booo.
16:49:19 <limburgher> I've heard that's a thing.
16:49:26 <geppetto> tibbs: You aren't the only one ... I also heard a bunch of people spent > 24hrs traveling :-o
16:50:00 <limburgher> If, someday, I get to attend one of these things, I'm pounding vitamin C and wearing a mask.
16:50:15 <geppetto> :)
16:51:06 <geppetto> need to attend as one of those drivable video robots, like sheldon ;)
16:51:16 <geppetto> best of both worlds
16:51:37 * limburgher celebrates passing Turing test
16:51:42 <geppetto> ha
16:53:01 <geppetto> Ok, if nobody has anything I'll close in a minute or so
16:53:29 <Rathann> nothing from me today, thanks
16:54:40 <geppetto> #endmeeting