16:01:23 <geppetto> #startmeeting fpc
16:01:23 <zodbot> Meeting started Thu Aug 18 16:01:23 2016 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:23 <zodbot> The meeting name has been set to 'fpc'
16:01:23 <geppetto> #meetingname fpc
16:01:23 <zodbot> The meeting name has been set to 'fpc'
16:01:23 <geppetto> #topic Roll Call
16:01:35 * limburgher here
16:01:44 <geppetto> #chair limburgher
16:01:44 <zodbot> Current chairs: geppetto limburgher
16:01:47 <geppetto> hey
16:01:55 <limburgher> yo
16:02:03 <orionp> hello - I have to leave in 15 min
16:02:09 <geppetto> #chair orionp
16:02:09 <zodbot> Current chairs: geppetto limburgher orionp
16:02:20 <geppetto> Ok, maybe not a big problem
16:02:26 <geppetto> no real tickets
16:02:30 <limburgher> #voteonallthethings
16:03:13 <geppetto> 645 is the only thing close, and I doubt we'll vote on anything
16:03:20 <geppetto> Even if we get to 5.
16:03:23 * racor is here, but I am having networking probs (Heavy thunderstorm 1h ago)
16:03:32 <geppetto> #chair racor
16:03:32 <zodbot> Current chairs: geppetto limburgher orionp racor
16:09:15 <geppetto> Ok, going to close ... even if someone turns up soon orionp has to leave
16:09:18 <orionp> yeesh, just put the obsoletes in dnf and be done with it
16:09:57 <geppetto> Yeh, dnf (or better something that dnf requires which can be rebuilt independantly) is an obvious choice
16:10:19 <geppetto> But then I thought that about fedora-release too :)
16:10:33 <Rathann> hi
16:10:34 <Rathann> sorry
16:10:57 <geppetto> Esp. as it makes it obvious what all the other repos. should do about their packages (have a -release package, and obsolete in it)
16:11:28 <racor> Yep. The historical solution, fedora has applied, was not to care about orphans at all and leave cleaning up to the user (package-cleanup)
16:11:28 <geppetto> Rathann: No problem ... orionp has to leave in a few, so just talking about 645 and then getting lunch
16:11:35 <Rathann> oh ok
16:12:10 <geppetto> racor: Yeh, that has some advantages ... but some annoying edge cases
16:12:28 <geppetto> #chair Rathann
16:12:28 <zodbot> Current chairs: Rathann geppetto limburgher orionp racor
16:12:46 <geppetto> #topic Schedule
16:12:48 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/FOSFRX4AIDSRLESZBYXRYAOUV2WXJFPF/
16:12:52 <geppetto> #topic Open Floor
16:13:45 <Rathann> is tibbs around?
16:13:55 <tibbs> Wow, wait, is it time?
16:13:57 <tibbs> Shit.
16:14:06 <tibbs> Ther's a freaking line at my door.
16:14:16 <Rathann> LOL
16:14:24 <geppetto> #chair tibbs
16:14:24 <zodbot> Current chairs: Rathann geppetto limburgher orionp racor tibbs
16:14:39 <Rathann> so we might have quorum after all
16:14:43 <Rathann> even if orionp leaves
16:14:44 <geppetto> Ok, we can maybe have a real meeting :)
16:14:49 * geppetto nods
16:14:57 <geppetto> #topic #645  Clarify policy on obsoleting non-directly-replaced packages
16:15:01 <geppetto> .fpc 645
16:15:03 <zodbot> geppetto: #645 (Clarify policy on obsoleting non-directly-replaced packages) – fpc - https://fedorahosted.org/fpc/ticket/645
16:15:09 <orionp> I'm out of here...
16:15:09 <tibbs> Sorry.  The semester starts on Monday and things are crazy.
16:15:31 <geppetto> orionp: Ok, see you next week
16:15:34 <tibbs> I think I said all I can really say in the ticket.
16:16:28 <geppetto> Yeh, I'm somewhat torn ... on the one hand, I don't think this falls on us ... on the other it's not been fixed for years, so if we can nudge someone in the right direction that'd be cool
16:16:43 * geppetto shrugs
16:17:00 <tibbs> I think it was around FC5 that I proposed having a package that obsoleted all of the packages which have been retired.
16:17:29 <tibbs> I would characterize the reaction as being laughed out of the room, except that I don't think it was a physical room.
16:17:35 <tibbs> I guess things change in a decade.
16:17:41 <Rathann> I agree with mbooth that dnf package should obsolete dnf-langpacks
16:17:44 <Rathann> in this case
16:17:59 * geppetto nods
16:18:00 <Rathann> but I'm not opposed to adding Obsoletes to fedora-release either
16:18:07 <Rathann> as a general solution
16:18:25 <tibbs> I don't think it should be part of fedora-release, but some other package.  Which you can install or not as you wish.
16:18:45 <Rathann> hm
16:18:54 <tibbs> Having some locally maintained package removed just because Fedora retired something of the same name is kind of an issye.
16:19:06 <Rathann> right
16:19:17 <tibbs> It's not really that uncommon for someone to rebuild their own stuff when the Fedora maintainer has gone away.
16:19:30 <tibbs> Or to just pull packages from a COPR or something.
16:19:31 <geppetto> tibbs: the problem is you generally want most users to have the package installed, and thus. get the obsoletes on upgrade
16:19:44 <racor> The problem with obs/prov in a base package is: It's easy to screw up and can be very hard to get rid of mistakes and in cases obsoleted packages shall be unretired.
16:19:44 <Rathann> well if the Obsoletes are properly versioned, your local build can just have a newer version-release
16:19:46 <geppetto> although suggests from dnf/fedora-release could fix that now
16:19:47 <tibbs> geppetto: Yes, it would probably be installed by default.
16:20:00 <Rathann> but yes, I share racor's concerns
16:20:01 <tibbs> The unretirement thing is another issue.
16:20:33 <tibbs> So the issue here is people doing dnf system-upgrade and having failed deps due to packages leaving the OS, right?
16:20:54 <tibbs> And if so why doesn't, you know, dnf system-upgrade have some better way to handle that case?
16:21:09 <geppetto> :)
16:21:21 <tibbs> I mean, someone could write an interface or something to show you packages that are no longer in the distro and ask you what you want to do with them.
16:21:43 <tibbs> What I really don't understand is how this gets down to packaging guidelines at all.
16:21:55 <Rathann> and it should do that before it downloads a gigabyte of packages and bombs out because of unresolved deps
16:21:57 <tibbs> What guideline would we have?
16:22:39 <tibbs> Rathann: I guess that would be a reasonable bonus.  I don't know why it doesn't do that now; dnf should have all of the info in the repodata without needing the actual packages.
16:22:56 <tibbs> But absolutely none of that has anything to do with us.
16:23:12 <Rathann> I kind of agree
16:23:34 <tibbs> I guess a proposed guideline would be "it is allowed for one package to obsolete things which have been retired".  Except why bother writing a guideline for one single package?
16:23:53 <tibbs> FPC could just say "sure, you can have a package which obsoletes retired things if you really want".
16:24:10 <geppetto> I'm pretty sure all of us have said that :)
16:24:20 <tibbs> Well, why not vote?
16:24:23 <tibbs> Proposal:
16:24:24 <geppetto> Ha
16:24:56 <tibbs> The distribution can have a package which obsoletes retired packages if other committees decide that they want such a thing.
16:25:04 <geppetto> I'm not sure it's that useful ... and was wondering if it was more useful if we came up with a "this is how you should handle that, in our not so humble opinion"
16:25:16 <geppetto> Then maybe someone will be prodded to do it
16:25:23 <tibbs> I don't know; that gets into user interface and such.
16:25:28 * geppetto nods
16:25:37 <geppetto> +1 on your proposal fwiw
16:25:50 <tibbs> But I don't think anyone disagreed that whatever interface is going to be responsible for upgrading systems between versions shoudl handle this as well as it can.
16:26:49 <tibbs> And if users are stuck not being able to system-upgrade because of weird circular dependencies on a retired package and an obsoletes would fix that, then obviously one needs to be added.
16:27:15 <tibbs> I guess the issue is that you can't uninstall dnf-langpacks on your current system without breaking dnf, but dnf won't update the system as long as dnf-langpacks is installed.
16:27:31 <Rathann> There are at least two types of retired packages: retired due to lack of maintainer and retired due to being no longer required. In the latter case, it should be obsoleted by an appropriate closely related package.
16:28:15 <geppetto> Yeh, as tibbs said in this case the new dnf should really obsolete it
16:28:50 <geppetto> Anyone else want to vote on tibbs proposal?
16:28:55 <racor> geppetto: Really?
16:29:12 <tibbs> Hey, I'll +1 my own thing.
16:29:15 <geppetto> racor: that dnf should obsolete dnf=langpacks ... yeh, why not?
16:30:05 <racor> geppetto: Yes. May-be I misunderstood
16:30:21 <Rathann> I'm not completely sold on the benefits vs. maintenance burden of the distro-wide obsoletes package
16:30:28 <tibbs> Rathann: And that case is already covered by the existing guideline anyway.
16:30:50 <tibbs> I mean, it says "make it transparent to end users" and if it's not an exact replacement, use Obsoletes: but not Provides:.
16:30:52 <Rathann> tibbs: well, only if the retired package is replaced by something
16:30:52 <geppetto> Rathann: tibbs proposal didn't mandate it ... just made it 100% clear it was fine if someone wanted to do it
16:31:09 <racor> I understood your remark as dnf automatically "obsoletes" "discontinued/retired packages"
16:31:30 <racor> This would not be helpful, IMO.
16:31:44 <tibbs> racor: I don't think anyone here disagrees with you.
16:31:59 <geppetto> racor: Ahh, yeh, that was proposed because dnf is a core package and packaging related ... it's not the best choice, but I could kind of see the dnf maintainers using it because they control it and can solve their problem.
16:32:27 <tibbs> Though for updates there needs to be some easy way to handle the situation.  It's just that we're really not the right place to talk about it.
16:32:32 <geppetto> racor: I'm not really against it, but I think there are a bunch of better options
16:32:42 <tibbs> I basically have zero understanding of why this ticket was even filed.
16:33:32 <geppetto> My guess is that someone asked how to solve it and the reply was "FPC is the packaging people, ask them"
16:34:00 <Rathann> I agree that the guidelines don't explicitly say what to do when a retired package is not directly replaced by something
16:34:07 <tibbs> Well it was couched as "please clarify the guidelines" but I don't know what's actually unclear.
16:34:22 <Rathann> so we could clear that up
16:34:24 <tibbs> Rathann: I don't think they should.
16:34:37 <tibbs> I mean, what could we say besides "do what's reasonable"?
16:35:03 <Rathann> tibbs: the whole FPG is "do what's reasonable" ;)
16:35:11 <geppetto> My guess is they want us to say "If you want the package to be obsoleted, but nothing is really releated to it ... do XYZ"
16:35:22 <Rathann> that's my understanding as well
16:35:35 <geppetto> so they can go do XYZ and have dnf-langpacks (or whatever) disappear.
16:36:02 <Rathann> without breaking the world^W f23->f25 upgrades
16:36:04 <tibbs> I dislike guessing.
16:36:27 <tibbs> What breaks things entirely depends on the details of the situation.
16:36:54 <tibbs> A concrete proposal or draft or something would really help to have is not guess.
16:36:56 <tibbs> us
16:37:25 <tibbs> Otherwise we blow 20 minutes hoping we're answering the question that may or may not have been asked.
16:40:08 <geppetto> #action Can you write a concrete proposal, that we could vote on, so we aren't discussing trying to solve the problem problem.
16:40:12 <geppetto> Good?
16:40:22 <tibbs> Yes, please.
16:40:23 <geppetto> #undo
16:40:23 <zodbot> Removing item from minutes: ACTION by geppetto at 16:40:08 : Can you write a concrete proposal, that we could vote on, so we aren't discussing trying to solve the problem problem.
16:40:29 <geppetto> #action Can you write a concrete proposal, that we could vote on, so we aren't discussing trying to solve the wrong problem.
16:40:38 <geppetto> stupid brain typo
16:40:44 <geppetto> #topic Open Floor
16:40:47 <Rathann> :)
16:41:03 <geppetto> Ok, anything anyone wants to talk about?
16:41:21 <tibbs> I think I'm good.  My backlog is long enough as it is.
16:41:26 * geppetto nods
16:42:02 <geppetto> I'll close in a couple of minutes then ... you can get back to your pre. september :)
16:42:32 <tibbs> Students....
16:42:59 <geppetto> Will they ever learn? ;)
16:44:30 <geppetto> #endmeeting