15:00:55 <sgallagh> #startmeeting Server Working Group Weekly Meeting (2016-08-23)
15:00:55 <zodbot> Meeting started Tue Aug 23 15:00:55 2016 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:55 <zodbot> The meeting name has been set to 'server_working_group_weekly_meeting_(2016-08-23)'
15:00:55 <sgallagh> #meetingname ServerSIG
15:00:55 <zodbot> The meeting name has been set to 'serversig'
15:00:55 <sgallagh> #chair danofsatx nirik adamw mhayden jds2001 mjwolf hanthana sgallagh dperpeet
15:00:55 <zodbot> Current chairs: adamw danofsatx dperpeet hanthana jds2001 mhayden mjwolf nirik sgallagh
15:01:15 <sgallagh> #topic Roll Call
15:01:17 <mhayden> .hello mhayden
15:01:18 <zodbot> mhayden: mhayden 'Major Hayden' <major@mhtx.net>
15:01:18 <sgallagh> .hello sgallagh
15:01:19 <nirik> .hello kevin
15:01:21 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:01:23 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
15:01:24 <vvaldez> .hello vvaldez
15:01:26 <zodbot> vvaldez: vvaldez 'Vinny Valdez' <vvaldez@redhat.com>
15:01:26 <mjwolf> .hello mjwolf
15:01:29 <zodbot> mjwolf: mjwolf 'Michael Wolf' <mjwolf@us.ibm.com>
15:01:38 <adamw> .hello adamwill
15:01:39 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
15:03:29 <sgallagh> We have quorum, but I'm going to wait two more minutes for folks to filter in
15:03:57 <bconoboy_> .hello blc
15:03:58 <zodbot> bconoboy_: blc 'Brendan Conoboy' <blc@redhat.com>
15:05:12 <sgallagh> #topic Agenda
15:05:12 <sgallagh> #info Agenda Item: Open Seats
15:05:12 <sgallagh> #info Agenda Item: New Meeting Time
15:05:12 <sgallagh> #info Agenda Item: Fedora 25 Talking Points
15:05:12 <sgallagh> #info Agenda Item: Server SIG PRD
15:05:40 <sgallagh> I've got four items on the agenda for today. Anyone else?
15:06:19 <sgallagh> OK, I'll take that as "no".
15:06:23 <sgallagh> #info Agenda Item: Open Seats
15:06:31 <sgallagh> #undo
15:06:32 <zodbot> Removing item from minutes: INFO by sgallagh at 15:06:23 : Agenda Item: Open Seats
15:06:36 <sgallagh> #topic Open Seats
15:07:02 <sgallagh> As resolved in the meeting two weeks ago, there are two members of the Server Working Group that did not respond to the request to restate their interest in their seat.
15:07:26 <sgallagh> #info danofsatx and hanthana did not respond to queries to retain their seat on the Server Working Group
15:07:45 <sgallagh> Thus, we have two open seats to fill. At present, we have one clear self-nomination: smooge (Stephen Smoogen)
15:08:57 <vvaldez> I'd like to self-nominate if there are no others interested
15:09:11 <sgallagh> smooge said on the list he couldn't make it to this meeting
15:09:55 <sgallagh> WG members: How would you like to proceed? Should we vote for smooge and vvaldez today or have an open call for membership as we did in the past?
15:10:08 <sgallagh> I'm slightly in favor of just accepting them, personally.
15:10:29 <sgallagh> (In part because I know from the WhenIsGood that we actually have a possible meeting time that includes them)
15:10:31 <nirik> yeah, I'm fine with just voting/accepting today and going on
15:11:22 <sgallagh> #info Proposal: smooge and vvaldez are accepted to a char in the Server Working Group.
15:11:25 <adamw> +1 smooge - i don't know who vvaldez is (hi there, no offence :>) but if people say they're fine, fine by me
15:11:41 <sgallagh> #undo
15:11:41 <zodbot> Removing item from minutes: INFO by sgallagh at 15:11:22 : Proposal: smooge and vvaldez are accepted to a char in the Server Working Group.
15:11:49 <sgallagh> Fair point: Vinny, mind giving a self-introduction?
15:13:02 * mhayden is +1 on smooge and eager to hear from vvaldez :)
15:13:19 * nirik likewise
15:14:23 <sgallagh> vvaldez: ping?
15:14:23 <zodbot> sgallagh: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
15:14:28 <vvaldez> hi adamw and all. sure thing, I've been involved with Linux since Red Hat 6.0 or so, I've had several jobs in IT over the years, worked for Dell for 5 years supporting Linux for enterprise customers, and implementing HPCC, then I started working for Red Hat in 2007 mostly doing consuting work, I've given talks at Red Hat Summit several years in a row. More recently I've been involved with OpenStack and spoke in Tokyo. Now I'm
15:14:28 <vvaldez> Systems Engineering and will be focused on Fedora Server, modularity and everything cool and fun
15:14:33 <sgallagh> ah
15:15:51 <mjwolf> +1 smooge
15:16:27 <sgallagh> I'm also going to +1 smooge, which makes him at least official
15:16:48 <sgallagh> #agreed smooge (Stephen Smoogen) is elected to serve on the Server Working Group (+5, 0, -0)
15:17:06 <adamw> any background in fedora at all, vvaldez? not that we're in a position to be picky, but i can see the red hat logo on that parachute from here :P
15:17:15 * adamw just being snarky, will probably wind up saying +1 anyhow
15:18:10 <sgallagh> So, essentially vvaldez is working inside Red Hat on many of the things we discussed at Flock wanting Fedora Server to start doing.
15:18:26 <vvaldez> adamw: sure, I started 2 projects on fedoraproject dell-satellite-sync and dell-config-cluster but true, I've mostly been focused on our products as I've most been in consulting. I plan to be more involved directly upstream
15:18:30 <sgallagh> So regardless of whether you get a seat on this Working Group, welcome and thanks!
15:18:52 <vvaldez> sgallagh: thanks! happy to be here in any capacity
15:19:29 <adamw> sgallagh: wait, are you saying we should pick someone who actually does things with servers? this is clearly ludicrous
15:20:09 <sgallagh> As a point of full disclosure, vvaldez works on the team to which I am internally transitioning (that is allowing me to work on Fedora Server again). So we'll be working closely together.
15:21:02 <vvaldez> https://fedorahosted.org/dell-config-cluster/  and https://fedorahosted.org/dell-satellite-sync/ though Dell has now taken them both over
15:21:27 <vvaldez> in retrospect these didn't have anything specifically to do with Fedora, github or something may have been a better choice
15:22:20 <bconoboy_> using the fedora brand is always good practice :-)
15:22:22 <vvaldez> https://github.com/vvaldez
15:22:42 <vvaldez> You can see some of my playbook work here: https://github.com/vvaldez/rhc-ose
15:23:38 <vvaldez> This one is probably the most comprehensive: https://github.com/vvaldez/rhc-ose/tree/openshift-enterprise-3/rhc-ose-ansible/roles/subscription-manager
15:24:11 <sgallagh> I'm +1 vvaldez on the grounds that I fully expect him to commit actual time and effort to Fedora Server.
15:24:22 * nirik is +1 also.
15:24:34 <vvaldez> And again, not Fedora, but I was part of a 13-person community team that wrote the first edition of the OpenStack Architecture Deign Guide: http://docs.openstack.org/arch-design/
15:25:06 <vvaldez> I like documenting stuff :)
15:25:18 <adamw> sure, +1
15:27:10 <sgallagh> mjwolf, mhayden?
15:27:25 <mhayden> no objections here, +1 from me
15:27:28 <mjwolf> +1
15:27:54 <sgallagh> #agreed vvaldez (Vinnie Valdez) is elected to serve on the Server Working Group (+5, 0, -0)
15:28:04 <sgallagh> #topic New Meeting Time
15:28:18 <vvaldez> s/Vinnie/Vinny/
15:28:21 <vvaldez> :)
15:28:47 <sgallagh> vvaldez: Sorry about that
15:29:03 <sgallagh> OK, so: http://whenisgood.net/8bc83ek/results/nm9w3rx are the results of the WhenIsGood
15:29:18 <vvaldez> sgallagh: np
15:29:40 <sgallagh> mjwolf indicated to me that his response for Tuesdays can also include 3pm and 4pm Eastern, though he didn't amend his reply to show that.
15:30:36 <mjwolf> spallagh: I went into the tool and added those.  something must have gone wrong with the save
15:30:39 <sgallagh> So if we exclude linuxmodder (sorry), then Tuesdays at 4 or Thursdays remain.
15:30:40 <mjwolf> sorry aobut that
15:30:50 <sgallagh> mjwolf: I just realized I can edit it as well, so I just did.
15:31:08 <sgallagh> I removed linuxmodder's reply and updated yours and mine.
15:31:13 * nirik would prefer tuesday, but can do thursday if needed
15:31:20 <sgallagh> So Tuesday or Thursday at 4 are both available
15:31:29 <adamw> oh, sorry, i didn't fill it in. both of those work OK for me.
15:31:53 <sgallagh> #info Proposal: Server SIG meeting time moves to Tuesdays at 4pm US/Eastern (following US DST)
15:32:27 <sgallagh> +1
15:32:33 <nirik> +1 (although I hate to cow-tow to DST)
15:32:37 <mjwolf> +1 sounds fine to me
15:33:10 <sgallagh> nirik: Well, I at least wouldn't be able to make most of the year if we don't follow that DST :-/
15:33:20 <vvaldez> +1
15:34:13 <sgallagh> adamw, mhayden?
15:34:37 <adamw> sure.
15:36:01 <sgallagh> #agreed Server SIG meeting time moves to Tuesdays at 4pm US/Eastern (following US DST) (+5, 0, -0)
15:36:20 <mhayden> that works for me
15:36:25 <sgallagh> #undo
15:36:25 <zodbot> Removing item from minutes: AGREED by sgallagh at 15:36:01 : Server SIG meeting time moves to Tuesdays at 4pm US/Eastern (following US DST) (+5, 0, -0)
15:36:25 <mhayden> a much better time, actually
15:36:27 <sgallagh> #agreed Server SIG meeting time moves to Tuesdays at 4pm US/Eastern (following US DST) (+6, 0, -0)
15:36:35 * mhayden rejoices
15:36:50 <sgallagh> #info This meeting time goes into effect on 2016-08-30
15:37:02 <sgallagh> (No, I'm not going to make you sit through another one of these today)
15:37:14 <sgallagh> #topic Fedora 25 Talking Points
15:37:35 <sgallagh> So, do we have anything in particular that we want to advertise for Fedora 25?
15:37:46 <nirik> we didn't do much. ;)
15:37:56 <nirik> newer cockpit and freeipa ?
15:37:58 <sgallagh> I imagine Cockpit probably has some stuff to brag about since F24.
15:38:14 <adamw> yay, coattails!
15:38:24 <sgallagh> nirik: FreeIPA is in kind of a bind; they missed Alpha with 4.4.0
15:38:37 <sgallagh> And they didn't have a Change Proposal filed...
15:38:57 <sgallagh> I suspect they'll come to FESCo and ask about it, but I don't want to make any promises in the Talking Points before that's hashed out
15:39:47 <sgallagh> I've been somewhat out of the loop, so I don't know what else we might want to bring up.
15:40:13 <sgallagh> I suppose we could claim Node.js 6.x as "ours"
15:41:04 <sgallagh> Is that something we'd like to claim?
15:41:33 * adamw doesn't really have an opinion.
15:42:02 <sgallagh> #info Talking Point: Fedora Server 25 now ships Node.js 6.x
15:42:16 <sgallagh> Might as well have it to pad the list, I suppose
15:43:01 <sgallagh> Did we talk about the Cockpit SELinux Troubleshooter in the F24 notes?
15:43:05 <sgallagh> If not, that's a good one
15:43:25 <sgallagh> https://fedoraproject.org/wiki/Fedora_24_talking_points#Fedora_Server says no
15:43:50 <mhayden> ah, i missed that in cockpit
15:44:29 <sgallagh> #info Cockpit in Fedora 25 now has an SELinux Troubleshooter module
15:44:33 * adamw recalls hearing about it somewhere, but i guess not there.
15:44:54 <sgallagh> #info Cockpit in Fedora 25 can display host SSH keys in the system dashboard
15:46:04 <sgallagh> "(11:45:52 AM) petervo: network teams, docker volumes, docker storage, systemd timers"
15:46:35 <sgallagh> #info Cockpit in Fedora 25 will include support for network teaming, docker volume and storage management as well as the creation of systemd timer units
15:46:38 <adamw> #info DOCKAH DOCKAH DOCKAH
15:46:58 * adamw is helping
15:47:05 <sgallagh> #info Cockpit will also support multi-step (incl. 2FA) authentication in Fedora 25
15:47:14 <mhayden> #link http://dockah.dockah.dockah.com/
15:47:40 <sgallagh> ... because of course that's a real thing
15:47:42 * mhayden obviously is behind on cockpit features
15:47:57 <adamw> mhayden: i think it's scheduled to turn into skynet next thursday
15:48:09 <sgallagh> adamw: No, they had to push it back to Q2 2017
15:48:26 <sgallagh> Wanted time to increase the lethality
15:49:15 <sgallagh> #chair vvaldez smooge
15:49:15 <zodbot> Current chairs: adamw danofsatx dperpeet hanthana jds2001 mhayden mjwolf nirik sgallagh smooge vvaldez
15:49:18 <sgallagh> (forgot to do that earlier)
15:49:26 <sgallagh> #unchair danofsatx hanthana
15:49:26 <zodbot> Current chairs: adamw dperpeet jds2001 mhayden mjwolf nirik sgallagh smooge vvaldez
15:49:59 <sgallagh> #info Fedora 25 will ship with Docker 1.12
15:50:42 <sgallagh> #info Non-server-specific: Fedora 25 will remove support for weaker (1024-bit) certificate authorities
15:50:49 <sgallagh> (That one's for the Talking Points in general)
15:51:25 <sgallagh> #info FreeIPA may or may not deliver version 4.4 in Fedora 25. Needs discussion as it missed Alpha.
15:51:35 <sgallagh> Anyone have other Talking Points?
15:52:00 <mjwolf> I do not
15:52:22 <sgallagh> I wonder if we should be talking about hardware enablement stuff in Server as well?
15:52:31 <sgallagh> Support for new commercial servers, etc.?
15:53:13 <sgallagh> Well "support" in the technical sense, of course.
15:53:22 <mjwolf> how do you get access to those to ensure they work?  does this working group have a relationship with various vendors?
15:53:51 <sgallagh> mjwolf: I'd like to start seeing that happen. I feel like you and mhayden and jds2001 might be good points of contact on that.
15:54:21 <mhayden> what type of hardware are we talking about?
15:54:25 <mjwolf> ok
15:54:28 <mhayden> something like hardware compatibility?
15:54:46 <bconoboy_> we have a lot of hardware inside red hat that we can perhaps leverage if there are specific targets
15:54:53 <sgallagh> mhayden: Well, if nothing else I'd like to be able to say things like "Fedora 25 supports installing on Intel's latest <codename> servers"
15:55:04 <mhayden> ah, gotcha
15:55:05 <sgallagh> Where F24's media would not have
15:55:30 <mhayden> we have it running on Power8 ;)
15:55:42 <sgallagh> Also coo,.
15:55:44 <sgallagh> *cool
15:55:49 <mhayden> i call it "The Ocho" to irritate the engineers
15:56:06 <sgallagh> OK, let's leave that out for this release and make that a goal for F26 (to be able to talk about hardware enablement)
15:56:09 <sgallagh> mhayden++
15:56:09 <zodbot> sgallagh: Karma for mhayden changed to 1 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:56:18 <mhayden> my first cookie!
15:56:32 <sgallagh> OK, I don't think we're going to have time for the PRD discussion, so I'll take that to the list.
15:56:47 <sgallagh> #topic Server SIG PRD
15:56:50 <vvaldez> mhayden: I like that
15:57:02 <sgallagh> #info Out of time in the meeting, will be discussed on the server@lists.fp.o mailing list
15:57:06 <sgallagh> #topic Open Floor
15:57:14 <sgallagh> We have three minutes for Open Floor: go!
15:57:53 <vvaldez> I am very happy and excited to be here, please let me know where and how I can help
15:58:58 <sgallagh> I'm going to start the PRD discussion a little more formally on the mailing list. I'll start with a thread on Impacts and we'll move through the Logic Model again with everyone involved.
16:00:19 <sgallagh> Thanks for coming, everyone!
16:00:24 <sgallagh> Welcome to our newest members!
16:00:28 <sgallagh> #endmeeting