14:01:18 <tflink> #startmeeting fedora-qadevel
14:01:18 <zodbot> Meeting started Mon Sep 12 14:01:18 2016 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:18 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:01:18 <tflink> #meetingname fedora-qadevel
14:01:18 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:01:18 <tflink> #topic Roll Call
14:01:25 * jskladan yaay, meeting!
14:01:40 <tflink> jskladan: who are you and what have you done with josef?
14:01:55 <tflink> :)
14:01:58 * mkrizek is here
14:02:01 * garretraziel is here
14:02:04 * jskladan this is Meetinator2000, the allmighty meeting bot
14:02:34 * tflink is interested to see how well this meeting bot works, may be asking questions about where to get one later
14:03:25 * kparal is here
14:03:33 <tflink> ok, let's get this party started
14:03:42 <tflink> #topic Announcements and Information
14:03:59 <tflink> #info looked into using rpmdeplint instead of depcheck - mkrizek
14:03:59 <tflink> #link https://github.com/default-to-open/rpmdeplint
14:03:59 <tflink> #info figured out how to build blockerbugs css - mkrizek
14:03:59 <tflink> #link https://phab.qadevel.cloud.fedoraproject.org/T720
14:04:00 <tflink> #info latest libtaskotron and testcloud deployed on prod - mkrizek
14:04:01 <tflink> #info Dockerized Taskotron stack - jsedlak, jskladan
14:04:02 <tflink> #link https://bitbucket.org/fedoraqa/taskotron-docker
14:04:04 <tflink> #info Refined the new Trigger, waiting for review - jskladan
14:04:06 <tflink> #link https://phab.qadevel.cloud.fedoraproject.org/D963
14:04:08 <tflink> #info Implemented ResultsDB's v2.0 API + tests (working on frontend now) - jskladan
14:04:10 <tflink> #link https://bitbucket.org/fedoraqa/resultsdb/branch/feature/v20
14:04:14 <tflink> #link https://bitbucket.org/fedoraqa/resultsdb_api/branch/feature/v20
14:04:17 <tflink> #link https://bitbucket.org/fedoraqa/resultsdb_frontend/branch/feature/v20
14:04:18 <tflink> #chair jskladan kparal mkolman garretraziel
14:04:18 <zodbot> Current chairs: garretraziel jskladan kparal mkolman tflink
14:04:20 <tflink> oops
14:04:22 <tflink> #chair mkrizek
14:04:22 <zodbot> Current chairs: garretraziel jskladan kparal mkolman mkrizek tflink
14:04:37 <tflink> any questions or comments?
14:04:55 <tflink> jskladan: are you doing the frontend to resultsdb 2.0 based on the existing resultsdb_frontend?
14:05:16 <jskladan> yeah, just minimal changes to show the right data
14:05:34 <tflink> cool
14:05:35 <jskladan> the fancy changes may/will come later on, when we know what they should be :)
14:06:05 <tflink> makes sense
14:06:22 <tflink> mkrizek: did you write anything up about what you found with rpmdeplint?
14:07:21 <mkrizek> tflink: nope, just tried a few runs to see if rpmdeplint works at least the same as depcheck, looked good from what I have tried
14:07:45 <tflink> mkrizek: any thoughts on whether we should switch to using that instead of depcheck?
14:08:53 <jskladan> tflink: yes please! Depcheck needs to die! (although I have not seen the rpmdeplint in action, so just take it as a cheerleading practice from me...)
14:08:54 <mkrizek> I hope so, I need to go thtough the depcheck scenarios first though and talk to rpmdeplint guys to see if they are planning to put the package into Fedora (I suspect so)
14:09:30 <tflink> yeah, it'd be nice to not maintain that anymore. i wonder how it works
14:10:30 <tflink> on that topic, there's an urgent issue with depcheck right now: https://phab.qadevel.cloud.fedoraproject.org/T838
14:10:47 <mkrizek> seems like it's not crashing anymore
14:10:54 <tflink> it was just F25
14:10:59 <mkrizek> oh, ok
14:11:12 <tflink> otherwise I would have made more noise about it last week
14:11:26 <tflink> the potentially problematic update hadn't made it through updates-testing yet
14:11:30 <tflink> for F24, F23
14:12:01 <tflink> anyhow, that can be explored later. please feel free to take that ticket :)
14:12:15 <tflink> anything else on this topic?
14:12:54 * tflink takes that as a no
14:12:56 <tflink> #topic Docker Testing Status
14:13:16 <tflink> so, this has fallen a bit behind where it needs to be
14:13:35 <tflink> which is at least partially my fault for not getting tickets written
14:13:43 <tflink> partially/mostly/whatever
14:14:18 <tflink> did we make a decision on what kind of directory structure we wanted to use for tasks in dist-git?
14:15:00 <jskladan> I don't have the whiteboard picture, but from what I remember, but I know somebody took it
14:15:03 <kparal> not since the sketch on the whiteboard
14:15:31 <tflink> it was probably me, ill look for it
14:16:14 <tflink> yep, found it
14:16:56 * tflink will post a link to it after the meeting
14:17:13 <tflink> or do we want to get that figured out now?
14:18:24 <kparal> I'd discuss it in a ML/ticket
14:19:10 <tflink> https://tflink.fedorapeople.org/taskotron/20160809-distgit-task-location-whiteboard.jpg
14:19:18 * tflink didn't scale it at all
14:19:53 <tflink> anyhow, the other missing pieces are: trigger responding properly to docker image build fedmsgs and documentation (maybe just review)
14:20:14 <tflink> I'd like to get this figured out this week, if possible
14:20:47 <jskladan> trigger (the new one) *should* (yes, I said that) be fairly simple, depending on the information in the message, and the actual information we need
14:21:11 <tflink> one more reason to get that into dev sooner than later
14:21:18 <jskladan> I know there were some issues with linking koji builds, and the actual worker jobs, or something like that, lbrabec would know
14:21:28 <tflink> linking koji builds?
14:21:30 <jskladan> I don't really remember, as he only told me about it once, and it's some time ago
14:21:51 <tflink> he doesn't seem to be online
14:21:52 <jskladan> I know there were some issues in being able to traverse all the systems responsible for the docker build
14:22:04 <jskladan> so you can actually get all the stuff that's needed
14:22:23 <jskladan> but I really don't remember the actual things he told me
14:22:56 <tflink> jskladan: you want to poke him about it or should I?
14:23:20 <jskladan> but if the fedmsg contains the data we need (or the data is readily available, and searchable based on the contents of the fedmsg), the trigger part will be easy
14:23:22 <jskladan> I'll do it
14:23:26 <tflink> thanks
14:23:59 <tflink> #action jskladan to poke lbrabec about the issues found in using koji build messages for docker images
14:24:49 * tflink also needs to check on the state of our docs
14:25:10 <tflink> I don't remember if the docker testing docs were ever written, reviewed and put into the main repo
14:25:47 <tflink> #action tflink to check on status of docker testing docs
14:25:58 <tflink> anything else on this topic?
14:26:09 <jskladan> nothing here
14:26:23 <tflink> k, moving on
14:26:32 <tflink> #topic deploying new trigger on DEV
14:27:01 <tflink> jskladan: is there anything in particular you wanted to say about this? I assume you were the one who added it to the agenda
14:27:40 <jskladan> well, just wanted to discuss it - the code is done, to a point where it IMHO is worth doing
14:27:51 <jskladan> the Diff is there, just waiting for some love
14:27:56 <tflink> has anyone reviewed it?
14:27:57 <tflink> ah
14:28:14 <tflink> it's on my TODO list for today now that I can think :)
14:28:15 <jskladan> well, it's a bunch of code, so... you guess :D
14:28:41 <jskladan> I ran it (albeit only the stream-trigger mode) locally for some time, and it seemed to work OK
14:28:49 <jskladan> as far as I could tell
14:29:06 <jskladan> so I only wanted to talk about the next steps to make it official
14:29:10 <tflink> I'm not anticipating any problems, though so I don't have any objections to getting that done later this week
14:29:34 <tflink> mkrizek: do you have any thoughts/objections?
14:29:40 <jskladan> there's also the thing where I need to poke jsedlak hard enough to actually package the mongoquery for me
14:29:47 <jskladan> but that can be done later on
14:29:53 <mkrizek> no objections
14:30:04 <jskladan> (the package review is done, I'm just not a packager, so no can do on my own)
14:30:10 <garretraziel> mongoquery is already packaged, but not reviewed
14:30:20 <tflink> garretraziel: is anyone assigned to review it?
14:30:31 <jskladan> garretraziel: iz actually approved
14:30:56 <jskladan> https://bugzilla.redhat.com/show_bug.cgi?id=1342063
14:30:57 <tflink> does anyone have the bzid or a link handy?
14:31:03 <tflink> i spoke too soon :)
14:31:04 <garretraziel> I haven't opened request for review. jskladan did, but he need sponsorship, so we decided that I'll open it again for myself
14:31:41 <tflink> jskladan: have you poked anyone directly about sponsorship?
14:32:05 <jskladan> some people at the office, when I initially packaged it
14:32:09 <jskladan> (june?)
14:32:23 <jskladan> but it lead nowhere
14:32:50 <jskladan> bot (all three?) said they "don't have time" whatever it means
14:32:57 <garretraziel> I believe that it was sochotnicky, but he said he don't have time
14:33:33 <jskladan> I also asked some other people, but IRC is so unsearchable... Can't figure out whom
14:33:36 <jskladan> whatever
14:33:38 <tflink> jskladan: let's try poking threebean or maxamillion
14:34:20 <tflink> the list of sponsors is: https://admin.fedoraproject.org/accounts/group/members/packager/*/sponsor
14:35:01 <tflink> we can get that taken care of after the meeting though
14:35:10 <tflink> it'd be good to get jskladan sponsored
14:35:31 <jskladan> *thumbs up*
14:35:48 <tflink> it sounds like there are no objections/issues with the plan to get the new trigger into DEV later this week, though?
14:36:42 <tflink> jskladan: any thoughts on how close resultsdb 2.0 is to use in dev?
14:37:19 <jskladan> I'm fairly certain I'll have the frontend "done" by the end of the week
14:37:35 <tflink> so in the next couple of weeks?
14:37:48 <jskladan> yeah, I see no problem there
14:37:56 <jskladan> we'll just need to change all the bits that use it
14:38:08 <jskladan> which should only be resultsdb directive, though
14:38:12 <jskladan> hopefully
14:38:23 <tflink> it'll be a good test of how we've written things
14:38:44 <tflink> anything else on this topic?
14:39:02 <jskladan> on top of that, we also have the new execdb code, but I'd rather not change the whole stack at once :D
14:39:13 <tflink> break all the things!
14:39:25 <jskladan> and the new execdb will need changes in the buildbot's steps anyway
14:39:31 <tflink> is that code in the canonical repos?
14:39:53 <tflink> yeah, lets get trigger first and then worry about the rest since we need trigger for the docker image testing stuff
14:41:11 * tflink assumes that's all for this topic
14:41:20 <tflink> #topic packaging update
14:41:45 <tflink> last I checked, the taskotron package reviews were done but not quite ACK'd correctly and are effectively stalled
14:41:48 <tflink> or at least 2 of them were
14:43:22 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1346249
14:43:22 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1346243
14:43:23 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1341099
14:43:23 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1346245
14:43:34 <tflink> i suppose that labeling those would have helped
14:44:49 <tflink> in order that's reusltsdb, execdb, taskotron-trigger, resultsdb_frontend
14:45:36 <tflink> it looks like resultsdb and resultsdb_frontend are done but not acked properly and thus stuck in the process
14:45:44 <tflink> execdb and taskotron-trigger have yet to find a reviewer
14:45:57 <tflink> mkrizek: does that match your understanding?
14:46:08 <mkrizek> yep
14:46:13 * jskladan afk for a moment
14:46:27 <mkrizek> actually
14:46:37 <mkrizek> taskotron-trigger is being reviewed no?
14:46:44 <mkrizek> resultsdb_frontend needs a reviewer
14:46:59 <tflink> yeah, i had those backwards
14:47:41 <tflink> #info resultsdb and taskotron-trigger have been reviewed, seem to need a different ACK to move forwards
14:47:54 <tflink> #info execdb and resultsdb_frontend still need reviewers
14:48:24 * jskladan back
14:48:28 <tflink> mkrizek: can you poke jiri in person to get him to ACK the reviews?
14:48:38 <mkrizek> will do
14:48:41 <tflink> thanks
14:49:19 <tflink> jskladan: on a barely related note, have you done any unofficial reviews for packages?
14:49:42 <tflink> anything else on this topic?
14:50:23 * tflink takes that as a no
14:50:28 <tflink> #topic fedorahosted shutdown
14:50:52 <tflink> this doesn't affect our current projects much but we still have blockerbugs and autoqa to migrate off of fedorahosted (even if it's just for archival)
14:51:22 <tflink> IIRC, the plan was to migrate to pagure unless there was some great advantage to hosting stuff in phabricator
14:51:30 <jskladan> oh, sorry, lost track of IRC. No I have not done any reviews, tflink
14:51:38 <tflink> does anyone have objections to that rough plan?
14:51:52 <tflink> jskladan: can you start doing a few of those when you get the chance?
14:52:11 <jskladan> ad pagure: none, I don't really care where we host the repos
14:52:25 <tflink> it'd be nice to be off bitbucket, though
14:52:49 * mkrizek is ok with pagure
14:53:06 <tflink> if there are concerns or issues with that plan, please bring it up on the ML
14:53:06 <jskladan> i like BB... but as I said, if there's technical issues, with it, I don't really care. Whatever you guys think is the right choice, as long as it's git..
14:53:33 <tflink> jskladan: the only issue i have with BB is ideological since it's closed source
14:53:40 <jskladan> ad reviews: OK, I guess... But /me really wanted to not get dirty with the lengthy packaging guidelines, and stuff
14:54:11 <tflink> jskladan: you are supposed to be familiar with the packaging guidelines as a reviewer :-P
14:54:24 <tflink> and doing informal reviews is part of the normal process to become a packager
14:54:35 <tflink> #topic Open Floor
14:54:39 <jskladan> I don't want to be a reviewer, I just want this one package in fedora, and nobody did it... so unnecessary complicated...
14:54:47 <tflink> Anything else that folks wanted to bring up?
14:55:20 * jskladan has nothing
14:55:26 <mkrizek> not here
14:56:18 <tflink> I have two (hopefully) quick questions for folks:
14:56:34 <tflink> 1. Does it make sense to continue to send out minutes to the ML after meetings?
14:57:04 <tflink> 2. Is this meeting method/format continue to work for folks?
14:57:29 <jskladan> tflink: I like the minutes, At least I don't need to remember t he zodbot's archive urls
14:57:49 <kparal> meetings are good if you miss the meeting
14:57:50 <mkrizek> yes and yes for me
14:58:25 <jskladan> ad 2: it's fine. I still want to try the video-conference when we'll need to discuss things, but for the status updates, it's fine
14:58:41 <kparal> as for method, I don't have any better suggestion, and we need to sync up somehow, so it's fine by me
14:59:01 <tflink> yeah, I was thinking about trying to do a video conference thing later this week
14:59:51 <tflink> anyhow, our hour is pretty much up and the QA meeting is about to start
14:59:55 <tflink> thanks for coming everyone.
14:59:58 * tflink will send out minutes shortly
15:00:02 <tflink> #endmeeting