20:00:45 <sgallagh> #startmeeting Server Working Group Weekly Meeting (2016-09-13)
20:00:45 <zodbot> Meeting started Tue Sep 13 20:00:45 2016 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:45 <zodbot> The meeting name has been set to 'server_working_group_weekly_meeting_(2016-09-13)'
20:00:45 <sgallagh> #meetingname ServerSIG
20:00:45 <zodbot> The meeting name has been set to 'serversig'
20:00:45 <sgallagh> #chair nirik adamw mhayden jds2001 mjwolf sgallagh dperpeet smooge vvaldez
20:00:45 <zodbot> Current chairs: adamw dperpeet jds2001 mhayden mjwolf nirik sgallagh smooge vvaldez
20:00:45 <sgallagh> #topic Roll Call
20:00:45 <sgallagh> .hello sgallagh
20:00:46 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
20:01:05 <smooge> .hello smooge
20:01:06 <zodbot> smooge: smooge 'Stephen J Smoogen' <smooge@gmail.com>
20:01:09 <vvaldez> .hello vvaldez
20:01:10 <zodbot> vvaldez: vvaldez 'Vinny Valdez' <vvaldez@redhat.com>
20:01:15 <jds2001> .hello jstanley
20:01:16 <zodbot> jds2001: jstanley 'Jon Stanley' <jonstanley@gmail.com>
20:01:29 <nirik> .hello kevin
20:01:30 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
20:01:53 <adamw> .hello adamwill
20:01:54 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
20:02:52 <sgallagh> OK, we have quorum at least. Let's get started.
20:03:00 <sgallagh> #topic Agenda
20:03:10 <sgallagh> #info Agenda Item: Release-blocking media
20:03:18 <sgallagh> #info Agenda Item: PRD Discussion
20:03:21 <mhayden> .hello mhayden
20:03:22 <zodbot> mhayden: mhayden 'Major Hayden' <major@mhtx.net>
20:03:26 <sgallagh> Any other items to put on the agenda this week?
20:04:03 <danofsatx> wait, the meeting got moved to a time I can attend?
20:04:08 * danofsatx is shocked
20:04:30 <danofsatx> .hello dmossor
20:04:31 <zodbot> danofsatx: dmossor 'Dan Mossor' <danofsatx@gmail.com>
20:05:10 <sgallagh> Hello Dan, welcome back.
20:05:21 <sgallagh> Please pardon the mess while we are redecorating
20:05:32 <danofsatx> Thank ya... you should see my apartment.
20:05:52 * danofsatx is a geographical bachelor for the next 9 months
20:07:34 <sgallagh> OK, I'll take that to mean there are no other agenda items
20:07:44 <sgallagh> #topic Release-blocking media
20:07:49 <sgallagh> #link https://fedoraproject.org/wiki/Fedora_Program_Management/ReleaseBlocking/Fedora25#Server
20:08:18 <sgallagh> Does anyone feel that this list is in any way in error for Fedora 25?
20:08:52 <sgallagh> I think we had talked about not wanting to ship ix86 media in F25, but I don't know whether that's technically possible yet.
20:08:53 <nirik> looks good to me
20:09:14 <jds2001> looks good to me.
20:09:45 <adamw> ok for me.
20:09:58 <danofsatx> not blocking on ARM?
20:10:06 <adamw> i think disabling 32-bit media might be possible if we wanted to, but nirik and dgilmore would know better.
20:10:08 * danofsatx has a fuzzy memory
20:10:16 <adamw> danofsatx: minimal and Xfce are the blocking package sets for ARM.
20:10:18 <vvaldez> pardon my ignorance, but what about vagrant server image?
20:10:20 <adamw> server never has been, iirc.
20:10:37 <sgallagh> vvaldez: We don't actually have one of those today
20:10:38 <jds2001> adamw: i think that disabling 32bit is a good idea
20:10:45 <adamw> i think the logic being that no-one really runs servers on 32-bit arm.
20:10:57 <sgallagh> vvaldez: The only vagrant image in Fedora today is the Cloud one, however maintained that is.
20:10:59 <jds2001> not sure that we'd want to be chasing those issues, let alone blocking on them (which we aren't today)
20:11:04 <adamw> vvaldez: the vagrant images are all part of the cloud wg at present ( though that may be changing).
20:11:04 <danofsatx> adamw, you are likely correct.
20:11:13 <sgallagh> vvaldez: If you want to produce one for Server, I think F26 would be the right place to start doing that
20:11:27 <vvaldez> ok thanks, I would definitely be interested in that sgallagh
20:11:34 * nirik thinks people do use 32bit arm servers, but not sure it's enough to block on
20:11:52 <sgallagh> #action vvaldez to investigate creating a Fedora Server vagrant image for Fedora 26
20:11:53 <smooge> I had a second question.. wasn't there a thread in the cloud group of moving various parts to Server ?
20:11:56 <nirik> we can request the no 32bit images. I don't recall if thats possible or not.
20:12:02 <sgallagh> smooge: Not for Fedora 25
20:12:07 <sgallagh> Possibly in Fedora 26
20:12:10 <dgilmore> adamw: I want to move 32 bit to secondary namespace
20:12:18 <smooge> was that for F26 or now.. and were we supposed to also answer for he cloud items.
20:12:21 <smooge> sgallagh, ok thanks
20:12:33 <vvaldez> great, I can check with cloud wg on their existing process and see what is involved
20:12:39 <sgallagh> vvaldez++
20:12:40 <zodbot> sgallagh: Karma for vvaldez changed to 1 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
20:13:11 * dgilmore has fedora server on at least half if not more of his arm systems
20:13:11 <smooge> dgilmore, is that move for F25 or F26?
20:13:16 <dgilmore> smooge: f26
20:13:28 <dgilmore> we could do it for f25 but it is really too late
20:13:36 <smooge> ok so for F25.. then we are ok with i386 and arm not being blocking
20:13:42 <mhayden> ah, i thought we'd already pushed 32 bit to secondary...
20:13:50 <dgilmore> mhayden: nope
20:14:07 <dgilmore> smooge: 32 bit x86 by fesco degree is not release blocking period
20:14:22 <sgallagh> OK, so for Fedora 24 we just instructed Websites not to list the 32-bit x86 media on the site. Shall we just do that again this time around?
20:14:22 * danofsatx isn't entirely sure if he still has a vote
20:14:31 <smooge> yes.. but we have the ability to make it if we wanted to and we are decidng no tot
20:14:41 <dgilmore> 32 bit arm for slefish reasons I would like but I am just one guy
20:14:49 <danofsatx> but yes, I am fine with not blocking on i386 and ARM
20:14:51 <dgilmore> smooge: we are making it
20:14:59 <adamw> dgilmore: 32-bit arm we're not discussing dropping, just why it's not release-blocking.
20:15:09 <dgilmore> smooge: and afaik there is no ability to say it is release blocking
20:15:12 <adamw> dgilmore: 32-bit i386 we're discussing whether to have it at all (i think).
20:15:14 <sgallagh> danofsatx: Your seat was given to either vvaldez or me when we realigned the membership a few weeks back
20:15:15 <dgilmore> FESco rulled that it can not be
20:15:17 <adamw> maybe let's discuss one thing at a time.
20:15:33 <dgilmore> adamw: I will strongly say it must exist
20:15:36 <danofsatx> roger ball.
20:15:40 <smooge> dgilmore, then I am f'ing confused because that is what the web page says we are supposed to answer
20:15:44 <dgilmore> but I think it should be done as secondary arch
20:15:52 <smooge> do we agree that X is release blocking or not
20:15:56 <dgilmore> honestly at this point you need to be talking about f26 not f25
20:15:57 <jds2001> smooge: we're answering the blocking status
20:16:03 <jds2001> smooge: which is a column in there
20:16:17 <jds2001> right now, only x86_64 is blocking
20:16:18 <smooge> yes and dgilmore said we don't have the power to answer it
20:16:19 <sgallagh> dgilmore: The Council and websites team asked us to assure that the list is accurate today
20:16:24 <dgilmore> there is nothing to answer as to 32 bit x86 being blocking, FESCo has said it is not period
20:16:26 <jds2001> i for one am in favor of that.
20:16:52 <sgallagh> I don't think anyone disagrees that i386 should not block the release.
20:17:00 <dgilmore> I think it should exist i386 is still a significant chunk of users
20:17:03 <sgallagh> dgilmore: The question was whether we could avoid producing the media at all
20:17:51 <sgallagh> With the probably fallback plan of simply not listing said media on the getfedora.org site
20:18:00 <sgallagh> s/probably/probable/
20:18:29 <dgilmore> sgallagh: at this point I am not making changes like that to the f25 configs
20:18:49 <sgallagh> dgilmore: That's perfectly fine, thanks.
20:19:18 <sgallagh> WG members: Do we want to make an early request for F26 to drop ix86 install media entirely?
20:19:30 <mhayden> sounds reasonable to me
20:19:41 <dgilmore> sgallagh: I will stongly object to that
20:20:11 <vvaldez> do we have download numbers we could refer to to help understand the userbase?
20:20:13 <dgilmore> sgallagh: all 32 bit x86 deliverables this week will be getting moved from /pub/fedora to /pub/fedora-secondary
20:20:50 <sgallagh> dgilmore: That doesn't preclude having a generic ix86 netinstall, just that we wouldn't produce something specifically under the Fedora Server brand
20:20:56 <jds2001> dgilmore: help us understand the objection. I don't realistically think that *servers* are i386 anymore
20:21:24 <dgilmore> sgallagh: jds2001: servers in many poorer parts of the world are still 32 bit
20:21:38 <dgilmore> lots of people use 32 bit in vms for resource reasons
20:21:45 <danofsatx> jds2001: Fedora Server isn't necessarily always installed on a rackmount Xeon CPU system.
20:21:54 <nirik> There is: https://admin.fedoraproject.org/mirrormanager/statistics/2016-09-13/archs (but thats not the entire picture)
20:22:08 <sgallagh> Sure, but folks that are that specific about their resources are almost certainly not using the full Server package set either
20:22:12 <dgilmore> I would personally like to see it as a alternative delivverable for a release or two and if its not useful drop it then
20:22:50 <sgallagh> As long as it's non-blocking and not emphasized on the download page, I'm not sure I care.
20:23:11 <dgilmore> sgallagh: thats all up to marketing
20:23:16 <dgilmore> and websites
20:23:52 <nirik> the danger is that if we don't test it or block on it, it might be a pile of junk.
20:24:01 <nirik> but I'm with sgallagh.
20:24:19 <adamw> welp, i'm pretty sure we already don't test it, and we certainly don't block on it.
20:24:24 <adamw> i for one have no goddamn clue if it works at all.
20:24:42 <jds2001> is that something that we want to be putting out there?
20:24:47 <sgallagh> Proposal: The list as it currently stands is fine for Fedora 25. The getfedora.org website should not offer 32-bit x86 media for Server.
20:25:00 <jds2001> something that QA has "no goddamn clue if it works at all"? :)
20:25:13 <nirik> sgallagh: +1
20:25:16 <sgallagh> jds2001: If that was the only criterion, we'd still be on RHL 1.0 ;-)
20:25:25 <smooge> sgallagh, +1 to that proposal
20:25:45 <sgallagh> +1 to myself, for the record
20:25:47 <mhayden> sgallagh: should i move off RHL 1.0 ?
20:26:06 <smooge> mhayden, if you have a copy of RHL 1.0 you need to keep it running
20:26:11 <jds2001> sgallagh: +1
20:26:39 <vvaldez> +1
20:27:35 <vvaldez> presumably anyone running a 32-bit version could still uprade w/o needing media, we're just discussing the install media not actual repos I assume
20:27:42 <smooge> who is left to vote?
20:27:45 <sgallagh> adamw: ? mhayden?
20:27:50 <adamw> sure, fine.
20:28:10 <adamw> jds2001: we build all sorts of stuff that i have no clue if it works
20:28:24 <vvaldez> adamw: that would make a great t-shirt
20:28:38 <dgilmore> mhayden: I have a box of yellow dog linux, RHL 5.2 and RHL 6.1 I am happy to lend you to update to
20:28:52 <sgallagh> #agreed The list as it currently stands is fine for Fedora 25. The getfedora.org website should not offer 32-bit x86 media for Server. (+6, 0, -0)
20:28:55 <adamw> vvaldez: i prefer https://memegenerator.net/instance/49626302
20:29:52 <sgallagh> #topic PRD Discussion
20:30:24 <sgallagh> OK, so I don't think there's anything that would specifically benefit from an IRC discussion here yet.
20:30:28 <vvaldez> adamw: heh
20:30:46 <sgallagh> I think we need to solicit more responses and thoughts on the list and hash it out there, asynchronously.
20:31:17 <sgallagh> What this means to *you*, is that I really need someone besides me to be talking on the list about this.
20:31:44 <sgallagh> I'd really like to see us be completely done with this reinvention process before Halloween.
20:32:17 <sgallagh> So please, throw some ideas at the wall and we'll discuss them.
20:32:31 <jds2001> +1 to hashing it out on the list
20:32:33 <sgallagh> I provided a template, please follow it.
20:32:42 * danofsatx will put some thought into it in between QA testing and Dr. Who marathons
20:32:43 * jds2001 will make sure it's not an sgallagh echo chamber :D
20:32:58 <sgallagh> #action Server SIG members should start brainstorming actively on the server mailing list
20:33:42 <smooge> I have a couple of questions.. how many of these do we want to have on the table?
20:33:46 <sgallagh> Does anyone have anything on this topic that they feel would be best worked out in near-realtime today?
20:34:27 <sgallagh> smooge: I think at least three but fewer than ten, to remain focused.
20:34:30 <sgallagh> (Good question)
20:34:45 <smooge> Are we looking to have say 3 outcomes we can focus on or 400 good things we could work on before the century is out
20:34:58 <smooge> and you answered faster than I can ask questions :)
20:35:28 <sgallagh> So, maybe it would be a good idea to set a scope on this.
20:35:55 <sgallagh> Perhaps we should try to keep ourselves to outcomes we'd like to see within two years?
20:36:08 <sgallagh> And revisit them at two-year intervals?
20:36:23 <smooge> I would like to try 1 year for this first set
20:36:54 <smooge> mainly because we throw a lot of stuff at walls and if this isn't sticking we should know it by next FLOCK
20:37:06 <sgallagh> smooge: I think it might be ambitious to effect any external change that fast
20:37:20 <sgallagh> Certainly the *Outputs* we should look at a one-year plan
20:37:40 <smooge> I am not looking to effect a change but if we aren't even on outputs or below..
20:37:59 <smooge> then waiting til FLOCK2018 to reorient would be too late
20:38:31 <sgallagh> smooge: That's a fair point.
20:38:46 <smooge> anyway I am not wanting to derail this any further :)
20:39:02 <sgallagh> OK, I suppose the worst that would happen is at Flock 2017 we say "we need more time to see if this is having the desired effect"
20:39:28 <vvaldez> is Flock held annually? I've never been
20:39:36 <sgallagh> OK, so does focusing on one-year Outcomes work for everyone?
20:39:41 <sgallagh> vvaldez: Yes, annually in the summer sometiem
20:39:43 <jds2001> yep, just happened in Poland
20:39:58 <vvaldez> great thanks, in that case one-year Outcomes make sense
20:40:07 <sgallagh> It alternates continents (NA/Europe) each year
20:40:27 <sgallagh> So next year it will be back in North America somewhere
20:41:29 <sgallagh> OK, I don't think we need to vote on this, I'll just update the thread to add a constraint on the problem,
20:41:34 <sgallagh> smooge++
20:41:34 <zodbot> sgallagh: Karma for smooge changed to 10 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
20:42:14 <smooge> ok thanks. I will try to focus on a 'simple' outcome and move up from there
20:42:21 <mhayden> smooge++
20:42:21 <zodbot> mhayden: Karma for smooge changed to 11 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
20:42:39 <sgallagh> smooge: Thanks very much.
20:43:14 <sgallagh> General comment: Don't worry too much about getting it "right". This is a brainstorming activity. Throw a bunch of ideas out and we'll work as a group to find the wheat.
20:44:39 <sgallagh> #info We will focus on Outcomes that we expect to be able to have an effect on within one year (targeted at Flock 2017)
20:44:47 <smooge> ok
20:45:12 <sgallagh> #info The best way to have a good idea is to have lots of ideas
20:45:42 <smooge> yep
20:46:13 <sgallagh> #info Outcome brainstorming will happen on the Server mailing list. All are encouraged to participate.
20:46:40 <sgallagh> #topic Open Floor
20:46:51 <sgallagh> Anyone have anything for Open Floor this week?
20:46:58 <sgallagh> If not, I'll give you fifteen minutes of your life back
20:47:18 * jds2001 accepts 15 minuts of his life back
20:47:54 <smooge> 13 minutes
20:48:01 <smooge> 12
20:48:08 <sgallagh> #endmeeting